Comment 44 for bug 253422

Matías (matiasnfrias) wrote :

Problem solved here (SPDIF not tested). Just adding "options snd-hda-intel model=targa-2ch-dig" to my "/etc/modprobe.d/alsa-base.conf" configuration file. A little detail; now, headphones and speakers shares the same volume control. I'm using Ubuntu 9.04, in a LG E500 model GP02B6 (Core2Duo T7100 1.8 GHz, with Intel ALC883). I've tried "auto" and "3stack", but nothing happened. I used /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz for reference.

Here some extra info:

matias@matias-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC883
Codec: LSI ID 1040

matias@matias-laptop:~$ aplay -l
**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC883 Analog [ALC883 Analog]
  Subdispositivos: 0/1
  Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 1: ALC883 Digital [ALC883 Digital]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

http://ubuntuforums.org/showthread.php?t=616845
http://ubuntuforums.org/showthread.php?t=314383

Thanks! I hope this helps someone.
Matías.

PD: Sorry, my english... sucks.