Ubuntu

Please include RaLink RT2860 driver

Reported by Pac Shady on 2008-04-02
242
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
Mandriva
Fix Released
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Update:

"I managed to get the drivers from http://www.ralinktech.com/ralink/Home/Support/Linux.html for the RT2860 to work for this card under Kubuntu Hardy 64bit. Since lodging this bug report they have updated the drivers to work with the current kernel. Is it possible to incorporate this driver into Ubuntu's modules, if not for Hardy then at least for Intrepid?"

=====

The RaLink RT2790 card doesn't work. The rt2x00 serialmonkey drivers don't cover this card. There are (apparently) drivers for Linux on RaLink's website that cover this card, but they don't compile on the 2.6.24 kernel. Ndiswrapper seems to accept the Windows drivers for it and detects its presence, but the card still fails to work as a network interface (at least in the 64bit version, haven't tested ndiswrapper yet in 32bit).

This card has failed for me in Kubuntu Gutsy 64bit, Hardy Beta 64bit, and Hardy Beta 32bit.

Pac Shady (pacshady) wrote :

OK, I managed to get the card to SORT OF work using the Windows driver in ndiswrapper. The card is detectable, wicd can see the networks available, etc. but the network won't connect.

On two occasions I DID get it to work however, so long as the connection was active (ie. a restart would kill it and the card wouldn't work again). Firstly, one has to be able to have access to an ethernet. Secondly, the card needs to be set up with ndiswrapper, and fail the connection. Then, plug the wired cable in and connect to the ethernet using wicd. Then immediately after try to connect to the wireless again. This MAY work, but only once. Making a new user and trying it again seems to allow one to replicate it, at least once (haven't been able to replicate it more than once so far).

Besides these two individual occasions, this card is almost paperweight-like in it's usefulness so far. The capacity is definitely there for it to work, due to it's ability to SEE networks, but so long as it can't reliably connect it's broken.

Pac Shady (pacshady) wrote :
Download full text (5.0 KiB)

Here's some of the outputs of various commands:

sudo lspci -vv
...
02:00.0 Network controller: RaLink Unknown device 0781
        Subsystem: RaLink Unknown device 2790
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f6000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME+
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [70] Express Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <128ns, L1 <2us
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 512 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 0
                Link: Latency L0s <512ns, L1 <64us
                Link: ASPM Disabled RCB 128 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x1
...

ndiswrapper -l
rt2860 : driver installed
        device (1814:0781) present

sudo iwlist scan
...
wlan0 Scan completed :
          Cell 01 - Address: 00:18:4D:D5:1A:A1
                    ESSID:"NETGEAR"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:100/100 Signal level:-27 dBm Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

iwconfig
...
wlan0 IEEE 802.11g ESSID:off/any
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Bit Rate:144 Mb/s Tx-Power:20 dBm Sensitivity=0/3
          RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ifconfig
...
wlan0 Link encap:Ethernet HWaddr 00:15:af:91:7f:da
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
        ...

Read more...

Pac Shady (pacshady) wrote :

Output for lshw:

sudo lshw -C network
  *-network
       description: Wireless interface
       product: RaLink
       vendor: RaLink
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 00:15:af:91:7f:da
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+rt2860 driverversion=1.52+Ralink Technology, Corp.,11 latency=0 link=no module=ndiswrapper multicast=yes wireless=IEEE 802.11g
  *-network
       description: Ethernet interface
       product: RTL8101E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 01
       serial: 00:40:d0:e5:f6:7b
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.2LK duplex=full ip=192.168.0.6 latency=0 link=yes module=r8169 multicast=yes port=twisted pair speed=100MB/s

Pac Shady (pacshady) wrote :

There are new drivers available at RaLink's site which compile on Hardy's kernel. However, after testing them this morning, they don't work properly. Similar issue as with the ndiswrapper drivers mentioned above, the card can scan the network but not connect to anything.

An update on the Windows drivers with ndiswrapper. I discovered it worked on another network, so after some tweaking on my network at home I managed to get it working. However, for the fact that the current settings are now identical to the previous settings, and the fact that I managed to get it working initially under the exact same circumstances it failed to work under before, I consider the bandaid patch of using ndiswrapper drivers to be UNSTABLE. Also, the range of the wireless seems to be less than I think it should be (I'm currently getting between 40-50% strength with this laptop, whereas my ASUS A6Jc which is 2 years old is getting 80-90% in the same position, and the range was greater under Windows Vista [*shudder*]).

Pac Shady (pacshady) wrote :

Complete lspci -vvnn output

Pac Shady (pacshady) wrote :

dmesg output

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux the kernel for Hardy Heron.

Pac Shady (pacshady) wrote :

I managed to get the drivers from http://www.ralinktech.com/ralink/Home/Support/Linux.html for the RT2860 to work for this card under Kubuntu Hardy 64bit. Since lodging this bug report they have updated the drivers to work with the current kernel. Is it possible to incorporate this driver into Ubuntu's modules, if not for Hardy then at least for Intrepid?

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux:
status: Unknown → Confirmed

Hi Pac,

I've also marked bug 216084 as a duplicate of this report as it's also requesting for the rt2860 drivers to be included. I'll try to bring this to the attention of the kernel team to consider. I'm also going to modify the title and bug description a bit to better reflect this request. Hope that is ok with you. Thanks.

description: updated
krutoileshii (krutoileshii) wrote :

Also the newest driver form Ralink won't compile under 2.6.26 series kernel. after digging around and the net got it to compile but lost the WPA/WPA2/WEP or any other incription support.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jason Scurtu (solard3ity) wrote :

Here is a patched source that will compile under Ubuntu with kernel 2.6.26 +up
Tested with ubuntu intrepid.. and works with networkmanager!!

Changes between original from Ralink and this Source;

* Driver will compile with kernel 2.6.26 and up
* File RT2860STA.dat will not be put in /etc/Wireless/RT2860STA
* Wierd tftboot file wont be placed in / "root directory"
* Networkmanager is enabled
* Driver wont trash logs that much anymore

Install Build-Essentials
in the Directory just "sudo make && make install " to compile

I will test teh patched version and see if it works.
Also
for 2.6.27 kernel i will try this over next couple of days

2008/9/1 Jason Scurtu <email address hidden>

> Here is a patched source that will compile under Ubuntu with kernel 2.6.26
> +up
> Tested with ubuntu intrepid.. and works with networkmanager!!
>
>
> Changes between original from Ralink and this Source;
>
> * Driver will compile with kernel 2.6.26 and up
> * File RT2860STA.dat will not be put in /etc/Wireless/RT2860STA
> * Wierd tftboot file wont be placed in / "root directory"
> * Networkmanager is enabled
> * Driver wont trash logs that much anymore
>
> Install Build-Essentials
> in the Directory just "sudo make && make install " to compile
>
>
> ** Attachment added: "Patched source"
>
> http://launchpadlibrarian.net/17216054/2008_0708_RT2860_Linux_STA_v1.7.0.0-adapted.tgz
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Jason Scurtu (solard3ity) wrote :

Forgot to inculde this!
If you tried to compile the Ralink driver before or used ndiswrapper, you should do some steps before compiling the patched version.

Stop networkmanager:

sudo /etc/init.d/networkmanager stop

sudo ifconfig ra0 down ## Or wlan0 instead of ra0 if ndiswrapper was used
sudo modprobe -r rt2860sta ## or ndiswrapper instead of rt2860sta

Remove old config file as User, not root:

rm -fr ~/.gconf/system/networking/wireless/networks/*

Restart, and you should be able to log in a new network..

krutoileshii (krutoileshii) wrote :

Jason

tried the patched source to see if it will compile on the 2.26.27 kernel.
so far it doesn't. attached is the message i get (intrepid alpha 3)

Let me know if you need anything else.

Also thanks for the help.

Let me know if you got any more thoughts. on this.

2008/9/2 Jason Scurtu <email address hidden>

> Forgot to inculde this!
> If you tried to compile the Ralink driver before or used ndiswrapper, you
> should do some steps before compiling the patched version.
>
> Stop networkmanager:
>
> sudo /etc/init.d/networkmanager stop
>
> sudo ifconfig ra0 down ## Or wlan0 instead of ra0 if
> ndiswrapper was used
> sudo modprobe -r rt2860sta ## or ndiswrapper instead of rt2860sta
>
> Remove old config file as User, not root:
>
> rm -fr ~/.gconf/system/networking/wireless/networks/*
>
> Restart, and you should be able to log in a new network..
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Giovanni Masucci (gio-grifis) wrote :

it seems mandriva resolved this problem:
* Sat Aug 30 2008 Herton Ronaldo Krzesinski <email address hidden> 1.7.0.0-2mdv2009.0
  + Revision: 277121
  - Add patch to allow build with kernel 2.6.27
ftp://fr2.rpmfind.net/linux/Mandriva/devel/cooker/sparcv9//media/contrib/release/dkms-rt2860-1.7.0.0-2mdv2009.0.noarch.rpm
It would be really cool if intrepid would support these drivers out of the box, since they are needed by a lot of user. Especially on new netbooks, like the EEEPC 901/1000, which need that driver to have wifi working.

krutoileshii (krutoileshii) wrote :

Hey where can i get the source for the RPM?

2008/9/7 Giovanni Masucci <email address hidden>

> it seems mandriva resolved this problem:
> * Sat Aug 30 2008 Herton Ronaldo Krzesinski <email address hidden>
> 1.7.0.0-2mdv2009.0
> + Revision: 277121
> - Add patch to allow build with kernel 2.6.27
>
> ftp://fr2.rpmfind.net/linux/Mandriva/devel/cooker/sparcv9//media/contrib/release/dkms-rt2860-1.7.0.0-2mdv2009.0.noarch.rpm
> It would be really cool if intrepid would support these drivers out of the
> box, since they are needed by a lot of user. Especially on new netbooks,
> like the EEEPC 901/1000, which need that driver to have wifi working.
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Giovanni Masucci (gio-grifis) wrote :

cant' find sources anywhere...however I think that sources are in the rpm I've linked...should be a src rpm (noarch).

Giovanni Masucci (gio-grifis) wrote :

Ok I've been doing some testing with this...here's what I did:
svn co http://svn.mandriva.com/svn/packages/cooker/dkms-rt2860/releases/1.7.0.0/2mdv2009.0/
I entered in the SOURCES folder, unzipped the drivers and applied mandriva's patches.
make and make install went fine and now I can modprobe the driver module with:
sudo modprobe rt2860sta
and if I go to "System/Hardware drivers", I see rt2860sta driver "in use".
Now the bad news:
Network Manager is unable to see a wireless connection, and only show me eth0...
any idea on this?

Dimitrios Symeonidis (azimout) wrote :

Well, the first thing you want to check is whether the interface is created by udev:
run ifconfig and iwconfig and see if you have a wireless interface.
- if it's not there, look at the kernel log (dmesg) for any errors right after you modprobe the module
- if it's there, you might need to do a "sudo ifconfig wlan0 up" (or whatever interface name you have instead of wlan0)

Giovanni Masucci (gio-grifis) wrote :

ifconfig doesn't show anything.
iwconfig shows: ra0 RT2860 Wireless ESSID:"" Nickname:""
          Mode:Auto Frequency=2.412 GHz
          Link Quality=10/100 Signal level:0 dBm Noise level:-143 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
dmesg after modprobe shows:
[ 1237.324406] === pAd = f8fe1000, size = 580572 ===
[ 1237.324411]
[ 1237.324439] <-- RTMPAllocAdapterBlock, Status=0
[ 1237.324536] rt2860 0000:01:00.0: setting latency timer to 64

Giovanni Masucci (gio-grifis) wrote :

I have to add an other thing...
ifconfig before showed:

eth0 info about eth0

lo info about lo

now, after reboot I have also:

ra0 Link encap:Ethernet HWaddr 00:15:af:e4:fd:e2
          inet6 addr: fe80::215:afff:fee4:fde2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:369 errors:0 dropped:0 overruns:0 frame:0
          TX packets:619 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:44741 (44.7 KB) TX bytes:0 (0.0 B)
          Interrupt:19

eth0 is my ethernet device, so ra0 should be wireless...
still sudo ifconfig ra0 up has no effect

Dimitrios Symeonidis (azimout) wrote :

ok, so ra0 is your wireless interface.
the rest should work now.
if it doesn't, it's not related to this bug report, and i don't want to turn this bug report into a wireless networking support forum thread...

Giovanni Masucci (gio-grifis) wrote :

I'm sorry to have given the impression to being looking for help, using this bug report as a forum support thread... I was rather trying to be helpful reporting my experience. Let me just add that the drivers work if I boot intrepid with 2.6.24 hardy kernel...of course I'm using the same configuration. This makes me think that something is wrong at kernel level or that there are still some problems with those drivers and 2.6.27 but maybe I'm wrong. Hope other testers are luckier than me and that this is really a problem of my configuration.
Have a nice day.
Giovanni

Giovanni Masucci (gio-grifis) wrote :

Finally, wireless works. I've built the kernel driver from Eric Anholt (the xorg developer) git repository.
I don't know what patches he applied, we should ask him!
No problem so far...network manager works ok, even with wpa.
You can test it by doing:
sudo apt-get install git-core
git clone git://git.anholt.net/git/rt2860
cd rt2860/
make
sudo make install
sudo modprobe rt2860sta

and here's a link to Eric's blog, in case someone has questions.

http://anholt.livejournal.com/39165.html?view=110589#t110589

Hope it helps...

Adam McDaniel (adamrmcd) wrote :

There is a known issue where rt2860 does not support both WEP and WPA in a single compiled module. (There is a config option to enable one or the other, but not both, for some dumb reason.)

Asus has released a patch to one blogger who complained about this, but AFAIK it's not on any Xandros repositories yet. See: http://www.itwriting.com/blog/778-fixing-wi-fi-on-asus-eee-pc-901-with-linux.html

I had a look at Eric's repository that you just posted, Giovanni. This WEP/WPA patch is not yet included.
I can post a comment to let him know about it.

(The Asus patch provides the config option EEEPC_SPECIAL_SETTING. Not a very intuitive name :)

krutoileshii (krutoileshii) wrote :

Anyone care to post a patched version with WPA enabled?

2008/9/8 Adam McDaniel <email address hidden>

> There is a known issue where rt2860 does not support both WEP and WPA in
> a single compiled module. (There is a config option to enable one or the
> other, but not both, for some dumb reason.)
>
> Asus has released a patch to one blogger who complained about this, but
> AFAIK it's not on any Xandros repositories yet. See:
> http://www.itwriting.com/blog/778-fixing-wi-fi-on-asus-eee-pc-901-with-
> linux.html<http://www.itwriting.com/blog/778-fixing-wi-fi-on-asus-eee-pc-901-with-linux.html>
>
> I had a look at Eric's repository that you just posted, Giovanni. This
> WEP/WPA patch is not yet included.
> I can post a comment to let him know about it.
>
> (The Asus patch provides the config option EEEPC_SPECIAL_SETTING. Not a
> very intuitive name :)
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Stéphane Graber (stgraber) wrote :

I have been asked to try packaging a patched upstream code for that driver, I took the code from git clone git://anongit.anholt.net/git/rt2860 and uploaded the result to my PPA: https://launchpad.net/~stgraber/+archive

I used cdbs for the packaging, we'd need a clean orig.tar.gz before considering inclusion in Intrepid's current kernel (and an UVFe too). Anyway, the package in my PPA is clean and seems to work almost perfectly on current Intrepid.
It has so far been tested successfully with WPA2+AES and roaming (WDS) seems to be working too.

Note: I don't know the code and at first sight it seems far from clean, I had to hack the Makefile to have it generate files in the right place.

Hope it helps.

Stéphane

Stéphane Graber (stgraber) wrote :

Of course by cdbs I meant cdbs+dkms ... (there definitely are too much 4 letters acronyms)
So the module will automatically update with the kernel (it's the way we are supposed to package kernel modules in Intrepid).

krutoileshii (krutoileshii) wrote :

what are the dependencies for this one. it keeps telling me that dkms is not
sattisfied

2008/9/8 Stéphane Graber <email address hidden>

> Of course by cdbs I meant cdbs+dkms ... (there definitely are too much 4
> letters acronyms)
> So the module will automatically update with the kernel (it's the way we
> are supposed to package kernel modules in Intrepid).
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Stéphane Graber (stgraber) wrote :

On Tue, 2008-09-09 at 04:35 +0000, krutoileshii wrote:
> what are the dependencies for this one. it keeps telling me that dkms is not
> sattisfied

It depends on dkms, if you are installing it by adding the repository to
your sources.list that shouldn't be a problem as apt-get will handle the
depends.
If you are trying to install the package directly using dpkg or gdebi,
you'll need to then run "apt-get -f install" to install the missing
dependencies.

Stéphane

Jason Scurtu (solard3ity) wrote :

Thanks guys for this, I was just about >||< that close to replace my Ralink against a Intel IPW.. guess i'll wait and see where this is all going.. The ralink drivers seem to be realy tricky and not that well programmed..

@ Stéphane does your driver only support WPA, or also WEP?
Will this driver be able to reach the Intrepid release and be official?

Bruno Lambert (bruno.lambert) wrote :

I tested the driver with Stéphane and it work well. It's stable for now (been connected since more than 12 hours with any problem)

Stéphane Graber (stgraber) wrote :

On Tue, 2008-09-09 at 08:28 +0000, Jason Scurtu wrote:
> Thanks guys for this, I was just about >||< that close to replace my
> Ralink against a Intel IPW.. guess i'll wait and see where this is all
> going.. The ralink drivers seem to be realy tricky and not that well
> programmed..
>
> @ Stéphane does your driver only support WPA, or also WEP?
> Will this driver be able to reach the Intrepid release and be official?

Bruno tested with WPA, we don't have a WEP accesspoint around.
The decision of whether to include that module is now up to the kernel
team, we are past the Feature Freeze so I'm not sure how it works for
the kernel but a freeze exception may be needed in order to include it.

Stéphane

Giovanni Masucci (gio-grifis) wrote :

From what I've understood we need a vanilla tar.gz from ralink and the separate patches used by Eric to consider official inclusion in Intrepid, am I correct?
So here's a clean Ralink tar.gz. Note that this version is from 15/07 and already has the patch to have both WEP and WPA (Thanks Adam!).
http://www.itwriting.com/DPO_RT28xx_60_LinuxSTA_V1.7.0.0_2008_07_15.tgz
It should already have the "EEEPC_SPECIAL_SETTING" option set, so we just need to add Eric's patches and we are set with these drivers. =)
Does anybody has the list of the patches added by Eric?

Giovanni Masucci (gio-grifis) wrote :

Ok, /me thinks to see the light at the end of the tunnel.
I've used the tarball provided in my last post and some patches.
Works for me with wpa and now should also work with WEP:
Here are the patches:

Giovanni Masucci (gio-grifis) wrote :
Giovanni Masucci (gio-grifis) wrote :
Giovanni Masucci (gio-grifis) wrote :

Please somebody tests the 15/07 tarball + these 3 patches (2+the makefile fix. We have to thank Mandriva for them)...if it works for everyone we are ready and can ask to the kernel team...I think :)

Tim Gardner (timg-tpi) on 2009-01-22
Changed in linux:
status: Triaged → Fix Released
128 comments hidden view all 208 comments
chrisbuchholz (chrisbuchholz) wrote :

I tried to compile the kernel with the driver, and it worked.

I'm not sure what part of what I did made it work, but here's the steps I took:

aptitude purge rt2860-source
aptitude install rt2860-source
m-a prepare
m-a a-i rt2860-source ( I also tried with "m-a a-i rt2860" but neither worked - it said it couldn't find the deb file, but somehow in the process my wifi card suddenly turned on by itself, so I've done something right)

You need to have the module-assistant package installed, by the way.

krutoileshii (krutoileshii) wrote :

sudo dpkg-reconfigure rt2860-source was all i needed after a kernel upgrade

2009/1/28 ChrisBuchholz <email address hidden>

> I tried to compile the kernel with the driver, and it worked.
>
> I'm not sure what part of what I did made it work, but here's the steps
> I took:
>
> aptitude purge rt2860-source
> aptitude install rt2860-source
> m-a prepare
> m-a a-i rt2860-source ( I also tried with "m-a a-i rt2860" but neither
> worked - it said it couldn't find the deb file, but somehow in the process
> my wifi card suddenly turned on by itself, so I've done something right)
>
> You need to have the module-assistant package installed, by the way.
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Giovanni Masucci (gio-grifis) wrote :

I just want to add that this driver entered the linux kernel in 2.6.29 (under the staging drivers section) so, if jaunty ships 2.6.29, we'll get this driver for free (well, ubuntu devs just need to enable it in make menuconfig), with a lot of new features (better gem and kms for intel cards, new drivers and so on) and fixes...

Alex Krastelev (alex-netrc) wrote :

Tested a clean "vanilla" install of Jaunty Alpha 3 on eee 901 with all automatic updates installed as of today.
(kernel "2.6.28-6-generic #16-Ubuntu SMP Mon Jan 26 20:16:00 UTC 2009 i686 GNU/Linux"). I did not install any extra drivers.

- The driver is present and works just fine on eee 901

- The driver complains in kernel messages about missing RT2860STA.dat, but works just fine without this file.
# dmesg | grep 2860
...
[ 30.597458] --> Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
I do not even have /etc/Wireless folder and wireless works fine.

- For some reason the ra0 interface was NOT automatically seen by gnome network manager at first.
"Wireless" tab in System-->Preferences-->Network connections was empty.
Only after manual "sudo modprobe rt2860sta" and "iwlist ra0 scanning" the gnome-network-manager recognized it (?).
After that, wireless works in Gnome after every reboot (no need for modprobe or iwlist).

krutoileshii (krutoileshii) wrote :

forgot to mention that not using an eee
got a sparklank card instead.

2009/1/30 Alex Krastelev <email address hidden>

> Tested a clean "vanilla" install of Jaunty Alpha 3 on eee 901 with all
> automatic updates installed as of today.
> (kernel "2.6.28-6-generic #16-Ubuntu SMP Mon Jan 26 20:16:00 UTC 2009 i686
> GNU/Linux"). I did not install any extra drivers.
>
> - The driver is present and works just fine on eee 901
>
> - The driver complains in kernel messages about missing RT2860STA.dat, but
> works just fine without this file.
> # dmesg | grep 2860
> ...
> [ 30.597458] --> Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
> I do not even have /etc/Wireless folder and wireless works fine.
>
> - For some reason the ra0 interface was NOT automatically seen by gnome
> network manager at first.
> "Wireless" tab in System-->Preferences-->Network connections was empty.
> Only after manual "sudo modprobe rt2860sta" and "iwlist ra0 scanning" the
> gnome-network-manager recognized it (?).
> After that, wireless works in Gnome after every reboot (no need for
> modprobe or iwlist).
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Kyle Jones (mutiny32) wrote :
Download full text (3.7 KiB)

2860 chipset on an Encore Electronics ENLWI-N PCI card.

The latest Jaunty kernel as of writing (2.6.28-9) x86 recognizes this card and seems to function semi-properly.

I cannot connect to my 802.11N AP with WPA2 security though. It can associate with the AP, but not authenticate properly. Here is some kernel log output:

Mar 16 10:57:44 dell-desktop kernel: [ 4115.044274] RTMPSetPhyMode: channel is out of range, use first channel=1
Mar 16 10:57:44 dell-desktop kernel: [ 4115.045298] MCS Set = ff ff 00 00 01
Mar 16 10:57:44 dell-desktop kernel: [ 4115.046856] <==== RTMPInitialize, Status=0
Mar 16 10:57:44 dell-desktop kernel: [ 4115.046919] 0x1300 = 00064300
Mar 16 10:57:49 dell-desktop kernel: [ 4120.066100] ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 244
Mar 16 10:57:55 dell-desktop kernel: [ 4125.724012] ra0: no IPv6 routers present
Mar 16 10:58:10 dell-desktop kernel: [ 4140.081219] ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 244
Mar 16 10:58:10 dell-desktop kernel: [ 4140.081520] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
Mar 16 10:58:25 dell-desktop kernel: [ 4155.097085] ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 244
Mar 16 10:58:25 dell-desktop kernel: [ 4155.097354] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)

And some entries from the daemon log:

Mar 16 11:11:16 dell-desktop NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
Mar 16 11:11:16 dell-desktop NetworkManager: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
Mar 16 11:11:16 dell-desktop NetworkManager: <info> Activation (ra0) Stage 2 of 5 (Device Configure) complete.
Mar 16 11:11:16 dell-desktop NetworkManager: <info> Config: set interface ap_scan to 1
Mar 16 11:11:16 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: disconnected -> scanning
Mar 16 11:11:21 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: scanning -> associating
Mar 16 11:11:31 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: associating -> disconnected
Mar 16 11:11:31 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: disconnected -> scanning
Mar 16 11:11:36 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: scanning -> associating
Mar 16 11:11:46 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: associating -> disconnected
Mar 16 11:11:46 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: disconnected -> scanning
Mar 16 11:11:47 dell-desktop NetworkManager: <info> ra0: link timed out.
Mar 16 11:11:51 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: scanning -> associating
Mar 16 11:12:01 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: associating -> disconnected
Mar 16 11:12:01 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: disconnected -> scanning
Mar 16 11:12:06 dell-desktop NetworkManager: <info> (ra0): supplicant connection state: scanning -> associating
Mar 16 11:12:16 dell-...

Read more...

Asus Eee Box B202 with RaLink 2790 on Ubuntu 8.10 with kernel 2.6.27-14-generic and the package by Stephane Graber works. Thank you very much!

Troy Ready (troyready) wrote :

Since the 802.11n/WPA2 issue I (and others) are experiencing is separate from the issue of including the driver, I have opened a new bug for it: 344022 (RaLink RT2860 won't connect to 802.11n WPA2 networks).

I think the issue of including it is definitely closed.

Dean Loros (autocrosser) wrote :

I'm connecting to a WPA/WPA2 network with my Encore PCI card---I don't know if this has something in it to help you guys, but I created a /etc/Wireless/RT2860STA/RT2860STA.dat as per the info that comes with the driver---I edited the RT2860STA.dat file (again supplied with the driver info) to the configuration I needed--the card now connects @ 270Mb/s with a N-only network with WPA/WPA2....I'll send my file to anyone that wants it--also you would need/want the stock info & .dat file to compare to edit to your needs.....autocrosser1 at gmail.com (subject line it as: RT2860 please...thanks)

Jim Louvau (jlouvau) wrote :

Well, I got this working a while back on all of my various rt2860 cards with WPA(2) using Adam's DKMS dirver. Nothing else I tried ever worked across all of my machines. Unfortunately, it seems it wasn't Adam's stuff that made it into the kernel/Jaunty beta release since I'm back to WPA(2) being completely borked. For once it'd be nice if egos and politics could be put aside by whomever and the WORKING driver be included. If Intel (and I'm not a big fan of theirs for various reasons) would make a mini-PCI (not e) "N" card, I'd be on it in a second. They seem to be the only wireless manufacturer out there that can release a driver that does, or can be gotten working within a reasonable ammount of time. Broadcom is a PITA and so proprietary it hurts. RALink and Atheros can't seem to get a stable driver that works with all of the protocols across all of their chipsets (before I've sold the old hardware anyway) to save their lives. Sorry for the rant, but look at the age of this thread. And here we go again. If I ever install anything where RA* stuff works out of the box I think I'll have a heart attack.

Jim Louvau (jlouvau) wrote :

News flash! Adam's 1.7.1.1 DKMS package still works and WPA/WPA2 work fine with it (without having to screw around with an obscure and supposedly un-needed dat file). I deleted the current kernel module and installed the trusty 1.7.1.1 and presto, everything's just peachy once again. Oh well, at least I have something to use until the fixes get put back in .. maybe by 9.10 (ever the optimist).

Michael Schurter (schmichael) wrote :

rt2860 not working in Jaunty using standard kernel linux-image-2.6.28-11-generic version 2.6.28-11.41

Tried installing Stephane's ppa2 packages on a whim, rebooted, and still nothing.

Is there anything else I should try? Any way I can help? The comment thread is kind of epic, and I'm having a hard time figuring out what the current state is in Jaunty.

Troy Ready (troyready) wrote :

Michael: The 2.6.28 kernel that comes with Jaunty has the 1.8.0.0 rt2860sta driver included (as part of the kernel's staging drivers). It appears that everyone has reported success with this driver connecting to WEP networks, but little success with WPA networks. The 1.7.1.1 driver, attached to this bug report, has given some people more luck with WPA networks (but still doesn't work for my WPA2 network).

Adam McDaniel (adamrmcd) wrote :

Troy... FWIW I've ported rt2860sta v1.7.1.1 to the v1.8 branch in the upstream kernel staging driver.

I've supplied a patch to Greg KH, labelling this upgrade as v1.8.1.1. This version works for me on my 901 with WPA, WPA2 and WEP encryption.

The patch itself is only available via the linux-next.git repository, and not yet standard in the main kernel itself AFAICT.

The patch can be accessed here:
http://git.kernel.org/?p=linux/kernel/git/sfr/linux-next.git;a=commitdiff;h=ed291e8051ee418de7ccd3507c1e783323fd1c35

Note, If ubuntu doesn't include this with Jaunty's final release, I will be applying this patch to my Netbook Jaunty kernel, TBA...see http://www.array.org/ubuntu .. I'll post an announcement there within the next few weeks.

krutoileshii (krutoileshii) wrote :

No luck here.either. Also i couldn't find the firmware with the default
install on Jaunty

2009/4/12 Adam McDaniel <email address hidden>

> Troy... FWIW I've ported rt2860sta v1.7.1.1 to the v1.8 branch in the
> upstream kernel staging driver.
>
> I've supplied a patch to Greg KH, labelling this upgrade as v1.8.1.1.
> This version works for me on my 901 with WPA, WPA2 and WEP encryption.
>
> The patch itself is only available via the linux-next.git repository,
> and not yet standard in the main kernel itself AFAICT.
>
> The patch can be accessed here:
>
> http://git.kernel.org/?p=linux/kernel/git/sfr/linux-next.git;a=commitdiff;h=ed291e8051ee418de7ccd3507c1e783323fd1c35
>
> Note, If ubuntu doesn't include this with Jaunty's final release, I will
> be applying this patch to my Netbook Jaunty kernel, TBA...see
> http://www.array.org/ubuntu .. I'll post an announcement there within
> the next few weeks.
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Jack Deslippe (jdeslip) wrote :

I have eee 901 and just installed jaunty UNR and am having a lot of trouble connecting to wpa (works 1 out of every 10 attempts or so).

Adam, can you package your new working wifi driver in separate .deb like you did in the past?

Jack Deslippe (jdeslip) wrote :

WPA still is a problem on my eee 901 with the final release of jaunty. Adam - will it be fixed in your kernel?

Adam McDaniel (adamrmcd) wrote :

On 28/04/09 01:57 PM, jdeslip wrote:
> WPA still is a problem on my eee 901 with the final release of jaunty.
> Adam - will it be fixed in your kernel?

Yes, the rt2860 driver is upgraded to v1.8.1.1 in my netbook kernels,
WPA/WPA2 encryption is working for me on my 901. The kernel is available
today for download, however, the site isn't yet updated.. (that's next on
my list:)

If you want to try it today, use the repository path

  deb http://www.array.org/ubuntu jaunty main

Then install either the 'linux-netbook' or 'linux-netbook-eeepc' packages.
This will set you up with either

  2.6.28-12-netbook (or)
  2.6.28-12-netbook-eeepc

Complete instructions and details will be made available at
http://www.array.org/ubuntu as soon as I debug my perl/mysql code :P

Jack Deslippe (jdeslip) wrote :

Adam. Thanks for your hard work. However, I just installed your linux-netbook-eeepc package (and headers) on my jaunty eeepc 901 and then rebooted, but WPA did not work. If anything it now takes more network manager cycles to connect than it used to. Is it possible the old driver is still being used somehow?

Matthieu Baerts (matttbe) wrote :

Hi everybody,

I post this comment because I have a new bug with the new kernel (2.6.30-2generic (x86_64)) on Ubuntu Karmic.
So the kernel doesn't recognise my wireless card. And if I try "rt2860-source_1.8.0.0-0ubuntu1~ppa2_all.deb" (by Stéphane Graber) I have an error output :

============================
Adding Module to DKMS build system
Doing initial module build

Error! Bad return status for module build on kernel: 2.6.30-2generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/rt2860/1.8.0.0/build/ for more information.
Installing initial module

Error! Could not locate rt2860sta.ko for module rt2860 in the DKMS tree.
You must run a dkms build for kernel 2.6.30-2-generic (x86_64) first.
Done.
============================

(you can found "make.log" in attachment)

I suppose that the reason is that actual Ralink drivers (1.8.0.0) doesn't support this new kernel. But I'm not a specialist ;-).
I see that there are new drivers : http://www.ralinktech.com/ralink/Home/Support/Linux.html (2.1.1.0) but not new firmware. These new drivers are maybe a solution for eeepc's wireless card ? You can found the changelog here : http://www.ralinktech.com.tw/data/drivers/ReleaseNote-RT2860.txt

Do you want I try to compile this new drivers?

Thanks for your help !

krutoileshii (krutoileshii) wrote :

The 1.8 driver does not support kernels above 2.8 there is a new driver 2.1
i think that was released by ralink.
However i had little success with getting stephane's drive to work out of
the box in the first place.
Try the ralink driver form their website and see if it will compile for you.

2009/5/6 Matthieu Baerts <email address hidden>

> Hi everybody,
>
> I post this comment because I have a new bug with the new kernel
> (2.6.30-2generic (x86_64)) on Ubuntu Karmic.
> So the kernel doesn't recognise my wireless card. And if I try
> "rt2860-source_1.8.0.0-0ubuntu1~ppa2_all.deb" (by Stéphane Graber) I have an
> error output :
>
> ============================
> Adding Module to DKMS build system
> Doing initial module build
>
> Error! Bad return status for module build on kernel: 2.6.30-2generic
> (x86_64)
> Consult the make.log in the build directory
> /var/lib/dkms/rt2860/1.8.0.0/build/ for more information.
> Installing initial module
>
> Error! Could not locate rt2860sta.ko for module rt2860 in the DKMS tree.
> You must run a dkms build for kernel 2.6.30-2-generic (x86_64) first.
> Done.
> ============================
>
> (you can found "make.log" in attachment)
>
> I suppose that the reason is that actual Ralink drivers (1.8.0.0) doesn't
> support this new kernel. But I'm not a specialist ;-).
> I see that there are new drivers :
> http://www.ralinktech.com/ralink/Home/Support/Linux.html (2.1.1.0) but not
> new firmware. These new drivers are maybe a solution for eeepc's wireless
> card ? You can found the changelog here :
> http://www.ralinktech.com.tw/data/drivers/ReleaseNote-RT2860.txt
>
> Do you want I try to compile this new drivers?
>
>
> Thanks for your help !
>
> ** Attachment added: "make.log"
> http://launchpadlibrarian.net/26413214/make.log
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Matthieu Baerts (matttbe) wrote :

Bad news...
Unfortunately, this drivers don't work.
I have removed Stéphane Graber's package, I have compiled ralink's drivers (2.1.1.0) (two times : one with 'HAS_WPA_SUPPLICANT=n' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n' (in os/linux/config.mk) and the second with 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y') and apply a 'modprobe rt2860sta' but I can't connect to a WPA2 connexion.
In fact, I can see some routers with WICD. I can't change the WPA2 encryption because I'm not at home now and I'm not the administrator. I come back tomorrow (to test with WEP encryption).

PS : Maybe Stéphane has changed something in the config files but what ?

Matthieu Baerts (matttbe) wrote :

Sorry for this second mail...
Finally, after a reboot, it works.
Drivers are compiled with 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
If you need something more, I can help you !

krutoileshii (krutoileshii) wrote :

No i can get the ralink drivers to work myself. My concern is that they
closed the bug without having a working driver. Stephan's driver only works
for some machines.
BTW, if you install Stephan's driver now, it will be updated and will be
working going forward( at least that's what i have found out. however once
we move to 2.6.29 kernel it will stop compiling. new one however should
compile just fine.

I would really love to have it work out of the box as would a lot of other
people. just need to figure out what's causing it. what was removed from the
original driver that's causing this problem.

2009/5/7 Matthieu Baerts <email address hidden>

> Sorry for this second mail...
> Finally, after a reboot, it works.
> Drivers are compiled with 'HAS_WPA_SUPPLICANT=y' and
> 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
> If you need something more, I can help you !
>
> --
> Please include RaLink RT2860 driver
> https://bugs.launchpad.net/bugs/210725
> You received this bug notification because you are a direct subscriber
> of the bug.
>

David Parrish (daveparrish) wrote :

Thanks to Matthieu Baerts instruction I was able to compile and install a new version of the RaLink RA2860 driver which allowed me connect via WPA2 encryption. I'm using Ubuntu 9.04 and my computer is an ACER Extensa 4630Z.

I was unable to connect to any WPA or WPA2 wireless networks out of the box.

For more information about what I did check out this Ubuntu thread: http://ubuntuforums.org/showpost.php?p=7239633&postcount=26

Pac Shady (pacshady) wrote :

As the original reporter of this problem, I'd like to say that after a fresh install of Jaunty this card seems to work 100% out of the box, at least on my system. Thank you everyone for your reports, and thanks to the guys at Canonical who packaged the drivers for Ubuntu :). Hopefully for everyone else who is still having problems, things will be sorted out soon!

Jisakiel (jisakiel) wrote :

The staging driver is still not present as of 2.6.30-4-generic (2.6.30-4.5 from karmic on a jaunty install), although its firmware is present on linux-firmware-1.11 (/lib/firmware/rt2860.bin), which doesn't make that much sense to me.

However 2.1.1.0 compiled just fine on mentioned 2.6.30-4, and with it my WPA+TKIP works fine (and it is also able to suspend / resume just as well). Haven't tried on other configs yet (WPA2+AES, WPA+TTLS+PAP as in Eduroam).

Unfortunately, it still does not work with Eduroam. (802.1x+PEAP+MSCHAPv2)

#modinfo rt2860sta
filename: /lib/modules/2.6.28-11-generic/kernel/drivers/net/wireless/rt2860sta.ko
version: 2.1.1.0
license: GPL
srcversion: 144906C5DE08A9365720B3A

Matthieu Baerts (matttbe) wrote :

I can connect to an Eduroam network (UCL - Belgium).
I use Wcid with the encryption PEAP with TKIP.

FilipeCorreia (fcorreia) wrote :

I'm having trouble connecting to eduroam. I'm using the kernel from array.org.
This setup should be working outside the box? I'm figuring there may still be an issue here somewhere (or, I'm doing something wrong...)

Here's an excerpt of my NetworkManager log:

<info> Activation (ra0/wireless): connection 'eduroam' has security, and secrets exist. No new secrets needed.
<info> Config: added 'ssid' value 'eduroam'
<info> Config: added 'scan_ssid' value '1'
<info> Config: added 'key_mgmt' value 'WPA-EAP'
<info> Config: added 'proto' value 'WPA RSN'
<info> Config: added 'pairwise' value 'TKIP CCMP'
<info> Config: added 'group' value 'WEP40 WEP104 TKIP CCMP'
<info> Config: added 'password' value '<omitted>'
<info> Config: added 'eap' value 'PEAP'
<info> Config: added 'fragment_size' value '1300'
<info> Config: added 'phase1' value 'peapver=1'
<info> Config: added 'phase2' value 'auth=MSCHAPV2'
<info> Config: added 'ca_cert' value 'blob://-org-freedesktop-NetworkManagerSettings-5-ca_cert'
<info> Config: added 'identity' value '<email address hidden>'
<info> Config: added 'anonymous_identity' value '<email address hidden>'
<info> Activation (ra0) Stage 2 of 5 (Device Configure) complete.
<info> Config: set interface ap_scan to 2
<info> (ra0): supplicant connection state: disconnected -> scanning
<info> (ra0): supplicant connection state: scanning -> associating
<info> Activation (ra0/wireless): association took too long.
<info> (ra0): device state change: 5 -> 6
<info> Activation (ra0/wireless): asking for new secrets
<info> (ra0): supplicant connection state: associating -> disconnected
<info> (ra0): supplicant connection state: disconnected -> scanning
<info> ra0: link timed out.

And what I get running modinfo:

$ modinfo rt2860sta
filename: /lib/modules/2.6.28-12-netbook-eeepc/kernel/drivers/staging/rt2860/rt2860sta.ko
version: 1.8.1.1
license: GPL
srcversion: F8A8B7D56002B0571161D46
alias: pci:v00001A3Bd00001059sv*sd*bc*sc*i*
alias: pci:v00001814d00000781sv*sd*bc*sc*i*
alias: pci:v00001814d00000701sv*sd*bc*sc*i*
alias: pci:v00001814d00000681sv*sd*bc*sc*i*
alias: pci:v00001814d00000601sv*sd*bc*sc*i*
depends:
vermagic: 2.6.28-12-netbook-eeepc SMP mod_unload modversions 586
parm: mac:rt28xx: wireless mac addr (charp)

Matthieu Baerts (matttbe) wrote :

Hello,

I'm on Ubuntu Karmic and I can't load the new kernel 2.6.31-*. It seems that it's a problem with my ralink wifi card (RT2860).
I have included an attachment (a part of the kern.log) with the end of the loading.

The last drivers released by Ralink are on the version 2.1.2.0 (05/21/2009 - http://www.ralinktech.com/ralink/Home/Support/Linux.html ).

If you need something more, don't be shy to call me !

krutoileshii (krutoileshii) wrote :

the fix is pretty simple all you have to do is make sure that the RT2860STA.dat file is in /eyc/Wireless/RT2860STA/ folder. and restart the interface

krutoileshii (krutoileshii) wrote :

THis should fix the WPA and WPA2 problems

Kyle Jones (mutiny32) wrote :
Changed in linux:
status: Confirmed → Unknown
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
1 comments hidden view all 208 comments
Robin J Banfield (rjbanfield) wrote :

Am I to take this fix released to mean that the Linksys WMP600N will finally work OOB?

Ari (ari-reads) wrote :

Robin: wmp600n does work out of the box... but only for an hour or so, even when in wireless G mode with no encryption, it's quite pathetic.

Connections drop and the system message log gets flooded with messages from the buggy driver.

Turns out that Karmic's version of the ralink driver is very old (1.8.0.1); the vendor already issued 2.2.0.0, but it is not trivial to make it work with karmic's kernel. So far I couldn't.

See this petition:

https://bugs.launchpad.net/bugs/460436

Jason (jkollars73) wrote :

I found a very good procedure that works perfectly with my Asus eee 1000 netbook. I followed the instructions word-for-word and the wireless works perfectly now. I hope it helps with a solution to getting the module included in updates for Ubuntu, especially the NBR version.

Jason (jkollars73) wrote :

Oops, I forgot to include the link. This works perfectly for my Asus eee1000. http://ubuntuforums.org/showthread.php?t=1476007

deborah aho (ibadebi) on 2010-08-04
Changed in linux (Ubuntu):
status: Fix Released → In Progress
Matthieu Baerts (matttbe) wrote :

Just to note that there is another bug with this ralink card on Maverick => bug #594866
So I think the status can be changed to 'Fix released'

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in mandriva:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 208 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.