Cisco Aironet stopped working in Hardy

Bug #189398 reported by joenix on 2008-02-05
100
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Mandriva)
Unknown
Medium
linux (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Adam Buchbinder

Bug Description

Since upgrading my install to Hardy Alpha 4, my wireless network card has stopped functioning.

My wireless card is a Cisco Aironet 340 pcmcia card, handled by the module airo_cs:

$ pccardctl ident
Socket 0:
  product info: "Cisco Systems", "340 Series Wireless LAN Adapter", "", ""
  manfid: 0x015f, 0x0007
  function: 6 (network)

If the card is present during boot, boot hangs, giving this message:

padlock: VIA Padlock not detected
Error inserting padlock_aes (/lib/modules/2.6.24-5-generic/kernel/drivers/crypto/padlock-aes.ko): No such device

If I insert the card after boot, or try to load the module padlock_aes, I get the same message.

I have tried booting using kernel versions 2.6.22-10 through 2.6.22-14, all of which worked fine. Only 2.6.24-5 hangs.

marcogoni (cogoni) wrote :

I can totally confirm this behavior for a cisco aironet mp350 in my thinkpad X31.
The kernel 2.6.24-5 hangs exactly at the same point as joenix.
I observe the same symptom in the Debian experimental 2.6.24, so it's maybe
an upstream regression. I'll compile a vanilla kernel tomorrow to check this.

Changed in linux:
status: New → Confirmed
Samuel J Sarette (lunarcloud) wrote :

my cisco AIRONET Wireless Communications PC4800 gives me the same results using hardy.

marcogoni (cogoni) wrote :

Today I upgraded the system to 2.6.24-8 and the problem persists.
Is anybody working on this or maybe this is a dupe of something else?
Please, somebody has to do something, this is a showstopper for many people!

Thanks!

marcogoni (cogoni) wrote :

Hi, I bypassed the problem in a crude way.
Since the problem comes from the padlock_aes module that of course does not find any hardware on my pc, I went in the /lib/modules/2.6.24-xxx/modules.alias and I commented out the first two occurrences of AES that link to padlock and geode hardware.
So, the airo driver works perfectly now and the boot process is smooth as usual. Somebody should modify the configuration in a way that aes_generic or something like that is used on normal hardware.

Hope it works for you too!
marco

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
Alain Robillard (arentoine) wrote :

Samething for my Cisco Aironet 340 pcmcia card with my old Armada m300 (no message reporting a problem). Previous kernel versions all work fine.

Thanks

darkharmonics (pimptastic1) wrote :

"Hi, I bypassed the problem in a crude way.
Since the problem comes from the padlock_aes module that of course does not find any hardware on my pc, I went in the /lib/modules/2.6.24-xxx/modules.alias and I commented out the first two occurrences of AES that link to padlock and geode hardware.
So, the airo driver works perfectly now and the boot process is smooth as usual. Somebody should modify the configuration in a way that aes_generic or something like that is used on normal hardware.

Hope it works for you too!"

This worked perfectly for me! Boots up much quicker and the card works too! :)

Thomas Hood (jdthood) wrote :

The workaround worked for me too, as I reported in #220606.

Thomas R. N. Jansson (tjansson) wrote :

I can confirm this on my Thinkpad X30. Not only did my Wireless (MPI350) not work but also my sound card (82801CA-ICH3) wasn't work either and the boot process was hanging for 2 minutes before proceding because of the padlock_aes problem.

The fix about comment out the lines with padlock_aes in /lib/modules/2.6.24-16-generic/modules.alias worked for me as well. This is really a show stopper - even though I saw that there was something strange with padlock_aes it took some time to find this page an realise that this was also the solution to my sound and wireless problems.

Kind regards
Thomas Jansson

chef (adotei) wrote :

After fiddling about with modprobe, airo.ko and God knows what, I finally stumbled across this workaround. And it works perfectly well :). Thanks.

Fred L (fender83) wrote :

I fixed it this way, which should still work even if the kernel gets updated (I think). Add the following lines to your /etc/modprobe.d/blacklist file:

# these aes modules break the airo driver
blacklist padlock_aes
blacklist geode_aes

This fixed wireless on my Cisco Aironet 350 and eliminated the hang during boot.

  • unnamed Edit (1.1 KiB, text/html; charset=ISO-8859-1)

Hi,
Fred's solution is of course the best and I have been using it for some
weeks...
I just forgot to post it before! Sorry.

On Sat, Apr 26, 2008 at 7:36 AM, Fred L <email address hidden> wrote:

> I fixed it this way, which should still work even if the kernel gets
> updated (I think). Add the following lines to your
> /etc/modprobe.d/blacklist file:
>
> # these aes modules break the airo driver
> blacklist padlock_aes
> blacklist geode_aes
>
> This fixed wireless on my Cisco Aironet 350 and eliminated the hang
> during boot.
>
> --
> Cisco Aironet stopped working in Hardy
> https://bugs.launchpad.net/bugs/189398
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Daniel S (dan.seti) wrote :

Hi
Works for me as well on Thinkpad T40 with airo card.
tested using either Fred L and marcogoni methods.

Thank you.

foxhop (foxhop) wrote :

Yes Fred L's solution worked for me, ibm thinkpad t23 with cisco aironet 350 wireless pcmica adaptor. Also the ubuntu irc chatroom helped me find this page. Thanks ubuntu team for the great support! I wonder if the ubuntu image will be correct for this hardware... ubuntu 8.04

andy8co (tinfoiltop) wrote :

fixed with blacklist
compaq armada m300 with cisco aironet 350

Jim Cauthen (jimcauthen) wrote :

Fixed with Fred's blacklist suggestion: Thinkpad T41

ronny (ronny-standtke) wrote :

I just run into the same bug on a Lenovo ThinkCentre with (output of lspci):
03:06.0 Network controller: AIRONET Wireless Communications PC4800 (rev 01)

Also fixed with Fred's blacklist suggestion, thanks!

Lance Albertson (lance-osuosl) wrote :

I can confirm that the blacklist addition fixes my issues with the aironet driver as well! Inspiron 4150

gotee12 (gotee12) wrote :

Thanx Fred L! Fixed my sound/wireless issues on my thinkpad R40...

Thomas Dreibholz (dreibh) wrote :

I can confirm the problem for Dell desktop PCs equipped with Cisco AIRNONET 350 PCI cards (AIRONET Wireless Communications PC4800 network controller, as reported by lspci). After setting:
blacklist padlock-aes
blacklist geode-aes
in /etc/modprobe.d/blacklist, the system works. Otherwise, it hangs during startup.

The problem still consists in the latest version of Hardy (upgraded from Gutsy today - July 08 2008 - via Internet repositories).

Ozgur (ozgur-yavuzcetin) wrote :

I have T30 and AIRONET wireless card. Right after I had upgraded to Hardy the boot took a lot of time and the wireless didn't work. So I tried /lib/modules/2.6.24-xxx/modules.alias and I commented out the first two occurrences of AES that link to padlock and geode hardware as reported above. It worked...! Until the updates were installed and after that it stopped working again. Then I commented them back in the modules.alias and re-booted but this didn't help. Finally I tried Fred's solution:

# these aes modules break the airo driver
blacklist padlock_aes
blacklist geode_aes

And then the booting worked smoothly and the wireless card worked just fine. Thanks to all.

Obrouni (nick-fisk) wrote :

Confirmed on a Compaq M300 and Presario 900 with a Cisco Wireless PCMCIA card

Chris C (chrisc-abshernw) wrote :

Works great with 2.6.24-19 upgraded from Gutsy on a Thinkpad T40 with an internal Aironet card.

Changed in linux:
status: Unknown → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Leann, I can confirm that the bug is no longer present in 2.6.26-5-generic, if that helps. Also, bug 209342 appears to be a duplicate of this one; please upgrade the importance here from 'Medium' to 'High', as the other bug was marked.

Thomas Hood (jdthood) wrote :

The aironet card on my ThinkPad T30 works fine with the new kernel.

$ uname -a
Linux timulak 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

$ lspci -s 02:02.0 -v
02:02.0 Network controller: AIRONET Wireless Communications Cisco Aironet Wireless 802.11b
 Subsystem: AIRONET Wireless Communications Unknown device 5000
 Flags: bus master, fast devsel, latency 64, IRQ 11
 I/O ports at 8000 [size=256]
 Memory at d0200000 (32-bit, non-prefetchable) [size=16K]
 Memory at d0400000 (32-bit, non-prefetchable) [size=4M]
 [virtual] Expansion ROM at d0800000 [disabled] [size=2M]
 Capabilities: <access denied>

Thomas Hood <email address hidden> writes:
> The aironet card on my ThinkPad T30 works fine with the new kernel.

But did you have the problem before?

JFC (ubuntu-inax) wrote :

I did a fresh install of Intrepid Ibex 8.10 beta 5 on my IBM Thinkpad X31 and I don't have any problem with the WIFI (Cisco aironet 802.11B).
I don't need to blacklist the modules anymore (has I had to do with Hardy).

jfc@jfc-x31:~$ uname -r
2.6.27-2-generic
jfc@jfc-x31:~$ lspci -s 02:02.0 -v
02:02.0 Network controller: AIRONET Wireless Communications Cisco Aironet Wireless 802.11b
Subsystem: AIRONET Wireless Communications Device 5000
Flags: bus master, fast devsel, latency 64, IRQ 11
I/O ports at 8000 [size=256]
Memory at c0200000 (32-bit, non-prefetchable) [size=16K]
Memory at c0400000 (32-bit, non-prefetchable) [size=4M]
[virtual] Expansion ROM at c0800000 [disabled] [size=2M]
Capabilities: <access denied>
Kernel driver in use: airo
Kernel modules: airo

Andrew Melo (andrew-melo) wrote :

with:
Linux amelo-laptop 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

I don't get the hang on boot, I merely get the suspend/restart bug now.

thanks!

Andrew Melo (andrew-melo) wrote :

the bug is 238961, btw

Thanks for all the testing and updates everyone. I'm marking this "Fix Released" for Intrepid. If you see any regressions regarding this issue prior to Intrepid's final release, please reopen by setting the status back to "New". Thanks.

Changed in linux:
status: Triaged → Fix Released
Christophe Dumez (hydr0g3n) wrote :

I have tested alpha6 using the LiveCD and I get this error in daemon.log :
Sep 19 21:37:35 ubuntu modprobe: WARNING: Error inserting padlock_aes (/lib/modules/2.6.27-3-generic/kernel/drivers/crypto/padlock-aes.ko): No such device

chef (adotei) wrote :

This bug has reappeared for me in Intrepid Beta since I updated today 10/10/08. It doesn't exhibit the long boot up time associated with the previous bug. However, Intrepid doesn't detect the wireless card and rather states in network-manager that "device is unmanaged".

My wireless card worked with Gutsy but as with everyone else, didn't work with Hardy until I used the blacklist solution. In testing earlier versions of Intrepid (Alphas), I didn't experience this problem. My wireless card worked fine until I updated and did a partial upgrade today. The last time I did an upgrade before this was about 4 days ago but that didn't break my Cisco AIRNONET 340 wireless.

The upgrade installed the 2.6.27-7 kernel. My wireless card worked fine with 2.6.27-5 until the upgrade. Now booting up using either one doesn't solve the problem.

Changed in linux:
status: Fix Released → New
Ola Lindberg (olalindberg) wrote :

I just updated to the latest Ibex (2.6.27-7-generic) on my Thinkpad T40 (AIRONET Wireless Communications Cisco Aironet Wireless 802.11b) today and my WLAN still works. I'm not sure if it is a Aironet 340 or not though.

chef (adotei) wrote :

I found out that although network-manager doesn't show my wireless network connected and states "device unmanaged", it is actually working. This bug has been filed under another number. The link to it is given below.

https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/191889

The link below also seems to suggest a way of working around the problem but I haven't tried it out as my wireless is working.

http://ubuntuforums.org/showthread.php?t=940364&highlight=nm-applet

I guess this is unrelated to the bug under this section and thus I will change its status back to "Fix Released".

Changed in linux:
status: New → Fix Released

I am using Cisco Aironet 350 under Ubuntu 8.10 for Thinkpad T41. After a "Suspend", the wireless doesn't work anymore.

The "lsmod" shows the driver is loaded.

I also blacklisted "padlock_aes" and "geode_aes" in blacklist file.

I don't get any output from " lspci -s 02:02.0 -v ".

Any help is highly appreciated

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

I haven't seen this bug on any of the vanilla kernel versions I've tested. I'm unable to attempt to backport the fix to Hardy without doing a git bisect on a tree that contains at least one bad and at least one good version. If anyone would like to report that the problem is reproducible with a particular upstream kernel version, I'd be happy to try to isolate the bad diff and make the fix backportable to Hardy. As it stands now, I've upgraded to Intrepid, so this issue no longer affects me.

rgonnering (roger-gonnering) wrote :

I have an IBM T22 and a Cisco 350. I upgraded from 7.10 to 8.04. wireless was working fine before the upgrade and didn't work after the upgrade. Immediately after the upgrade the directory /proc/driver/aironet/ was empty and the LEDs on the Cisco were OFF. I added the following lines to my /etc/modprobe.d/blacklist file and rebooted:

   blacklist padlock_aes
   blacklist geode_aes

After rebooting, there was now a eth1 directory in /proc/driver/aironet/, with the contents:
APList BSSList Config SSID Stats StatsDelta Status WepKey

The LEDs on the Cisco card were also ON. eth1 shows up in iwconfig and ifconfig. The problem now is that it I can't get an IP address. dhclient returns No DHCPOFFERS received.

Anyone have any suggestions?

mira (meerajpatel) wrote :

I had the similar problem happened just today and i really need help with it. If some body knows anything, please let me know. I tried to install wireless driver on my Ubuntu 8.04 since it is not able to configure the internal wireless card, i tried to use Trendnet TEW-424ub and my booting hangs with this wornning.

Error inserting padlock_aes (/lib/modules/2.6.24-5-generic/kernel/drivers/crypto/padlock-aes.ko): No such device

and its been long time since booting is hanged. i wanted to follow the help that is listed in some answer but to do that or just delete what i have done, i have to be able to finish booting and access my files. I have lots of other data of my thesis on it and I really can't loose it. so please if anybody knows how i can get back to my files, please let me know.

I don't know if this helps, because I don't understand it. After I upgraded
the Ubuntu version, the wireless didn't work. I tried a bunch of stuff and
nothing helped. Then I plugged it into a ethernet cable. The wired link
worked fine. I then powered down and when I next powered up, wireless was
working again. This has happened each time, after 2 upgrades.

Ubuntu magic.

On Sat, May 30, 2009 at 6:17 PM, mira <email address hidden> wrote:

> I had the similar problem happened just today and i really need help
> with it. If some body knows anything, please let me know. I tried to
> install wireless driver on my Ubuntu 8.04 since it is not able to
> configure the internal wireless card, i tried to use Trendnet TEW-424ub
> and my booting hangs with this wornning.
>
> Error inserting padlock_aes
> (/lib/modules/2.6.24-5-generic/kernel/drivers/crypto/padlock-aes.ko): No
> such device
>
> and its been long time since booting is hanged. i wanted to follow the
> help that is listed in some answer but to do that or just delete what i
> have done, i have to be able to finish booting and access my files. I
> have lots of other data of my thesis on it and I really can't loose it.
> so please if anybody knows how i can get back to my files, please let me
> know.
>
> --
> Cisco Aironet stopped working in Hardy
> https://bugs.launchpad.net/bugs/189398
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Fix Released
> Status in “linux” source package in Mandriva: Confirmed
>
> Bug description:
> Since upgrading my install to Hardy Alpha 4, my wireless network card has
> stopped functioning.
>
> My wireless card is a Cisco Aironet 340 pcmcia card, handled by the module
> airo_cs:
>
> $ pccardctl ident
> Socket 0:
> product info: "Cisco Systems", "340 Series Wireless LAN Adapter", "", ""
> manfid: 0x015f, 0x0007
> function: 6 (network)
>
>
> If the card is present during boot, boot hangs, giving this message:
>
> padlock: VIA Padlock not detected
> Error inserting padlock_aes
> (/lib/modules/2.6.24-5-generic/kernel/drivers/crypto/padlock-aes.ko): No
> such device
>
> If I insert the card after boot, or try to load the module padlock_aes, I
> get the same message.
>
> I have tried booting using kernel versions 2.6.22-10 through 2.6.22-14, all
> of which worked fine. Only 2.6.24-5 hangs.
>

mira <email address hidden> writes:
> I had the similar problem happened just today and i really need help
> with it. If some body knows anything, please let me know. I tried to
> install wireless driver on my Ubuntu 8.04 since it is not able to
> configure the internal wireless card, i tried to use Trendnet TEW-424ub
> and my booting hangs with this wornning.
>
> Error inserting padlock_aes
> (/lib/modules/2.6.24-5-generic/kernel/drivers/crypto/padlock-aes.ko): No
> such device

This doesn't look like the same problem. You should file a new bug
report.

Perry

Frull (frull-ozon) wrote :

maulana@linux-box:~$ lspci
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
02:01.0 Ethernet controller: Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
02:02.0 Network controller: AIRONET Wireless Communications Cisco Aironet Wireless 802.11b

How about that, can any body fix it for me, please step by step couse am newbee on linux

Changed in linux (Mandriva):
status: Confirmed → Invalid
Computool (computool) wrote :

I have just installed Hardy Heron 8.04, onto an NEC Versa C150 Laptop. (wanted EMC2)
I am new to Linux. I have been using it for just 1 week now. (Spent most of that time trying to fix problems)

'Painfully Slow to Install' was the first problem ( swapfile solution applied).

The Cisco Aironet 350 WiFi Lan and Ali 1545? Sound card both were not working.
I had failed to google a solution that worked (or made any sense), until I stumbled upon the AES edit to the modules.alias file, which I discovered after running the System>Admin>Hardware Test, and wondered what 'Launchpad' was.

Edited file as suggested, re-booted, and Hey presto, quicker boot, sound at last, and 'Enable wireless' has finally appeared in the Network Control menu.

Many Many, thanks to that man!

AJJ

Samuel J Sarette (lunarcloud) wrote :

If you are new to Linux, then you ought to be using the latest version of Ubuntu, Lucid Lynx or 10.04, it is also a "long-term support" release. You'll thank yourself by using an up-to-date version.

Computool (computool) wrote :

Hi Samuel,

Thanks for the suggestion, but PDF manual for EMC2 does not recommend using any version other than 8.04, and EMC2 is why I turned to Ubuntu.

AJJ

Changed in linux (Mandriva):
status: Invalid → Unknown
Changed in linux (Mandriva):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.