IBM T40 breaks under Hardy with 2.6.24 kernel

Bug #209342 reported by Perry E. Metzger on 2008-03-30
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Hardy
High
Unassigned
Intrepid
High
Unassigned

Bug Description

I upgraded an IBM T40 laptop to Hardy. The machine goes quite nuts with a 2.6.24 kernel -- booting the old 2.6.22 kernel works more or less fine. Symptoms include a long hang during hardware probes and failure to properly initialize a bunch of the hardware thereafter.

I just realized, I should have said an IBM Thinkpad T40. I'm not
entirely sure what sort of machine information will be needed by
whomever will be helping to debug this -- just tell me what commands
to run and I'll post the output here. (Please specify if you need me
to be running the broken kernel when I run said commands.)

Perry

Hi Perry,

Are you able to at least make it through the boot process to be able to grab some log information? If so, can you attach the following (be sure to attach each as a separate file and not as a tarball).

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies .

If you are unable to completely finish booting to grab the above files, care to try booting with the "quiet" and "splash" boot options removed and take a digital photo of your screen to capture the errors you see. Thanks.

Changed in linux:
status: New → Incomplete

Leann Ogasawara <email address hidden> writes:
> Are you able to at least make it through the boot process to be able to
> grab some log information?

Yes, I can do that.

> If so, can you attach the following (be sure to attach each as a
> separate file and not as a tarball).

Will do right now.

> * cat /proc/version_signature > version.log
> * dmesg > dmesg.log
> * sudo lspci -vvnn > lspci-vvnn.log

Perry

By the way, things have improved slightly. With the absolutely latest Hardy kernel, boot still hangs for quite a while before succeeding and sound is still dead, but the ethernet now comes up. The wireless is still dead, though.

description: updated

I note that the bug report is still listed as "incomplete" although it has been some days since I posted the requested information. The clock is also ticking on auto-deleting the bug report. Is there something else I need to add before the report will be considered complete? I'd hate to have report of a real problem removed for lack of some information that is still considered needed.

pongtawat (pongtawat) wrote :

I have the same problem here with Thinkpad T40 and kernel 2.6.24-16-generic.
Please tell me if I could be any help.

pongtawat (pongtawat) wrote :

pongtawat <email address hidden> writes:
> I have the same problem here with Thinkpad T40 and kernel 2.6.24-16-generic.
> Please tell me if I could be any help.

I would guess that if you go through the bug report and dump and
upload the same information I uploaded it would be of help to the
people who might fix the bug.

--
Perry E. Metzger <email address hidden>

pongtawat (pongtawat) wrote :
pongtawat (pongtawat) wrote :
pongtawat (pongtawat) wrote :

FYI, Gutsy 2.6.22 kernel seems to work fine.

pongtawat <email address hidden> writes:
> FYI, Gutsy 2.6.22 kernel seems to work fine.

That is my experience too. If I boot an old kernel, I have no problem
at all. This is absolutely a regression against Gutsy.

Perry

pongtawat (pongtawat) wrote :

RC is out, so it is likely that you and me are left to stay with 2.6.22 kernel :(

pongtawat <email address hidden> writes:
> RC is out, so it is likely that you and me are left to stay with 2.6.22
> kernel :(

I can't understand why this bug report is being ignored.

Perry

Hi Perry,

Sorry for the delayed response. I really do apologize if you felt you were being ignored. Everyone is just extremely busy right now since we are so close the to the final Hardy release. We definitely appreciate your patience. I'm reassigning to the kernel team to take a closer look. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Incomplete → Triaged
Kevin Sumner (kevinsumner) wrote :

I have this same problem my IBM T40 with the stock Hardy kernel. It happened first after upgrading from Gutsy, and on a clean install from Hardy DVD.

I did the following until this can be officially rectified.
[snip]
sudo bash
wget http://security.ubuntu.com/ubuntu/pool/main/l/linux-source-2.6.22/linux-image-2.6.22-14-generic_2.6.22-14.52_i386.deb
dpkg -i linux-image-2.6.22-14-generic_2.6.22-14.52_i386.deb
sed -i -e 's%^default .*%default 2%' /boot/grub/menu.lst
update-grub
[/snip]

Then rebooted.

I'll attach the previously requested outputs in moments.

Kevin Sumner (kevinsumner) wrote :
Kevin Sumner (kevinsumner) wrote :
Kevin Sumner (kevinsumner) wrote :
Ola Lindberg (olalindberg) wrote :

Having the same problems. It worked by installing 2.6.22 though. I'll attach output from both 2.6.22 and 2.6.24.

Thanks in advance!

Klaus Layer (klaus-layer) wrote :

Same here on a Thinkpad T40. After a fresh install of kubuntu 8.04 sound does not work.

8301 (8301-comhem) wrote :

Thinkpad T40

Sound got lost with upgrade and 5 min boot time, something failures in the first 12 % when booting.

Hi Guys,

Just to see if it makes a difference, care to test the Intrepid Ibex 8.10 kernel? It was most recently rebased with the upstream 2.6.25 kernel and is currently available in the following PPA:

https://edge.launchpad.net/~kernel-ppa/+archive

If you are not familiar with how to install packages from a PPA basically do the following:

Create the file /etc/apt/sources.list.d/kernel-ppa.list to include the following two lines:

deb http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main

Then run the command:

sudo apt-get update

You should then be able to install the linux-image-2.6.25 kernel package. After you've finished testing you can remove the kernel-ppa.list file and run 'sudo apt-get update' once more to restore your system. Please let us know your results. Thanks.

Ola Lindberg (olalindberg) wrote :

Seems to work fine with the 2.6.25 kernel! No long boot up time, sound works and WLAN works.

I attach the log files (as above).

Ola Lindberg (olalindberg) wrote :
Ola Lindberg (olalindberg) wrote :
Kevin Sumner (kevinsumner) wrote :

My T40 has left my hands for the moment, but I have an R40 exhibiting the same symptoms. I'll give it a try on that later tonight or tomorrow and post results.

Leann Ogasawara <email address hidden> writes:
> Just to see if it makes a difference, care to test the Intrepid Ibex
> 8.10 kernel?
[instructions on how to test elided]
> Please let us know your results. Thanks.

This appears to fix my problems with my T40 -- at the very least, boot
proceeded normally (which it did not with the 2.6.24 kernel), sound is
working, and the wireless card is working.

Is there hope to get the 2.6.24 kernel working as well as the 2.6.25
kernel is working?

Perry

Changed in linux:
status: Triaged → Fix Released
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged

Hi Everyone,

Thanks for testing and the feedback. I'm glad at least the Intrepid kernel is working for you. Now the tricky part is to narrow down the exact patch(es) which resolved this issue. There are a vast amount of changes between the 2.6.24 and 2.6.25 kernels. Is anyone here familiar with (and willing to perform) a git bisect to try and isolate the fix? This is typically not something we expect you as bug reporters to know how to do. However it is helpful to the kernel team, especially since you would be able to confirm the fix. We could then try to get this into Hardy's 8.04.1 point release. I'll post some links to some docs which may help if you're interested. But again, this is completely at your own comfort level:

http://www.kernel.org/doc/local/git-quick.html#bisect
https://help.ubuntu.com/community/Kernel/Compile

Also note, that for the bisect you'll have to switch the meanings of "good" and "bad" as the bisection searches for the patch which caused a regression, not the patch which fixes an issue.

Additionally, you can grab the Intrepid kernel source git tree from by performing:

git clone git://kernel.ubuntu.com/ubuntu/ubuntu-intrepid.git

Hope that helps. Thanks.

kevku (kevku) wrote :

IBM T40p bootup is very slow and sound doesn't work.

kevku (kevku) wrote :
kevku (kevku) wrote :
kevku (kevku) wrote :
kevku (kevku) wrote :

system freezes for about 2-3 minutes at the last picture.

I'm experiencing the same problem; I suppose it's too late for 8.04.1.

I see the instructions for using git bisect to track down the bug, but since it's present in (so far as I know) all versions of Hardy but none of Intrepid, I don't see how I could possibly do a git bisect across the two trees (ubuntu-hardy.git and ubuntu-intrepid.git). If you have more detailed instructions, I'd be willing to attempt to track down the offending commit. I haven't worked with git before, but I'm willing to take some time to work on this.

I'm building 2.6.25-1.2 from the intrepid sources now to make sure that works for me. (The copy that was in the PPA is no longer there.) I'll post a follow-up if that doesn't fix sound, wireless and that long wait on startup. The offending copy currently running is 2.6.24-19.36.

Adam Wood (adamwood) wrote :

Adam: Have you tried a vanilla kernel? I just grabbed the intrepid sources and looking at the tags that exist it should be possible to bisect from a version of the vanilla kernel that shows the problem and the ubuntu tagged release that works.

Just an idea but if 2.6.22 works, 2.6.24 doesn't and 2.6.26 does work again, running bisect twice. First on 2.6.22-2.6.24 to find when the problem arises, then from 2.6.24-2.6.26 to find the fix should really narrow down the problem.

I'd help with this one but I don't have the hardware to test it on.

After seeing symptoms identical to those described both here and in bug 189398, and using the fix there, I'm concluding that this is a dupe. Please upgrade the severity of that bug to 'High', as this one was marked.

(I haven't gotten a chance to try out vanilla kernels; this is my only machine, and downtime is kind of hard to come by. But with the fix in place, the wireless and sound drivers load, and there's no long pause at boot, so at least there's a workaround.)

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers