[Dell XPS L321X] The touchpad doesn't work unless the cursor is moved slowly.

Bug #1816947 reported by opensas on 2019-02-21
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libinput
Fix Released
Unknown
libinput (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned

Bug Description

The touchpad doesn't work unless the cursor is moved slowly.

WORKAROUND: Execute at a terminal:
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: xorg 1:7.7+19ubuntu8
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu19
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperVersion: 1.402
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Feb 21 02:56:45 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller [1028:052e]
LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190203)
MachineType: Dell Inc. Dell System XPS L321X
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd quiet splash --- maybe-ubiquity
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/27/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd12/27/2011:svnDellInc.:pnDellSystemXPSL321X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.family: HuronRiver System
dmi.product.name: Dell System XPS L321X
dmi.product.sku: System SKUNumber
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.3.2-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20180925-2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperVersion: 1.394
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
DistUpgraded: Fresh install
DistroCodename: bionic
DistroRelease: Ubuntu 18.04
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller [1028:052e]
LiveMediaBuild: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
MachineType: Dell Inc. Dell System XPS L321X
Package: libinput (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd quiet splash --- maybe-ubiquity
ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
Tags: bionic ubuntu
Uname: Linux 4.18.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/27/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd12/27/2011:svnDellInc.:pnDellSystemXPSL321X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.family: HuronRiver System
dmi.product.name: Dell System XPS L321X
dmi.product.sku: System SKUNumber
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.95-1~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.2-0ubuntu1~18.04.2
version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.2-0ubuntu1~18.04.2
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

opensas (opensas) wrote :
Daniel van Vugt (vanvugt) wrote :

Could you please:

1. Attach a copy of your /var/log/apt/history.log

2. Tell us the date of the upgrade when you think the problem started.

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in libinput (Ubuntu):
status: New → Incomplete
summary: - Touchpad not working after last apt-get upgrade
+ [Dell XPS L321X] Touchpad not working after last apt-get upgrade

Thanks a lot for your prompt reply, I hope someone can put some effort into into it.

It happened last week, when I upgraded pop os! from 17.10 to 18.04 issuing do-release-upgrade

Now I have the following kernel:

$ uname -a
Linux pop-os 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29 16:28:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

But as I told, I can reproduce the same issue from the current daily image of ubuntu.

tags: added: apport-collected bionic
description: updated

apport information

opensas (opensas) wrote : DpkgLog.txt

apport information

opensas (opensas) wrote : Lspci.txt

apport information

opensas (opensas) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

opensas (opensas) wrote : UdevDb.txt

apport information

apport information

apport information

opensas (opensas) wrote : xinput.txt

apport information

I just ran

$ apport-collect -p xserver-xorg-input-synaptics 1816947

from the popos! machine.

the first files I sent were from the live-session of the latest ubuntu daily image

Daniel van Vugt (vanvugt) wrote :

The problem is not related to xserver-xorg-input-synaptics so please don't use that in the data collection.

Your Xorg logs show you are using the default libinput driver instead.

Changed in libinput (Ubuntu):
status: Incomplete → New
Changed in linux (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: cosmic
description: updated
tags: added: bios-outdated-a08 regression-potential
description: updated

opensas, please advise to all of the following:

1) When discussing this issue, please keep it to only one machine (the Dell XPS 13 L321X, not multiple) and Ubuntu (not popos! or some other unsupported distro, unofficial flavor, etc.).

2) Regarding this issue with the Dell XPS 13 L321X, is this reproducible in a live environment of Ubuntu 18.04 via https://wiki.ubuntu.com/BionicBeaver ?

3) Do you know which package, that after when updated, this problem is reproducible in?

Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
tags: removed: bionic cosmic
opensas (opensas) wrote :

Thanks a lot for your time & effort

1) the issue only happend in my dell xps 13 machine. ok, I'll just stick to ubuntu versions (I don't have any installed, but I can try with live-cd, or I can install one to a different partition if that helps

2) downloading https://www.ubuntu.com/download/desktop/thank-you?version=18.04.2&architecture=amd64 right now

3) not sure how can I help with that, from what daniel told (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1816947/comments/18):

---

The problem is not related to xserver-xorg-input-synaptics so please don't use that in the data collection.

Your Xorg logs show you are using the default libinput driver instead.

---

the problem should be with libinput

what shall I run in the livece instead of `apport-collect -p xserver-xorg-input-synaptics 1816947` to help you gather the data?

once again, thanks a lot for your time

apport information

tags: added: bionic
description: updated

apport information

opensas (opensas) wrote : Lspci.txt

apport information

opensas (opensas) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

opensas (opensas) wrote : UdevDb.txt

apport information

apport information

opensas (opensas) wrote : Xrandr.txt

apport information

apport information

all this was sent from ubuntu bionic livecd

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 4.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 7 14:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
ubuntu@ubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

opensas:

1) To advise, you don't have to apport-collect any further unless specifically requested to do so.

2) Does the touchpad work in the live environment of 18.04 without using any WORKAROUND?

opensas (opensas) wrote :

1) ok, sorry

2) I can confirm that the touchpad DOES NOT work in the live environment of 18.04, it shows the same behaviour (only works if the cursor is moved slowly) as in the latest ubuntu daily build (and as in my machine with pop os)

opensas:

To confirm the regression point, could you please test a live environment of https://wiki.ubuntu.com/ArtfulAardvark/ReleaseNotes and advise to the results?

description: updated
opensas (opensas) wrote :

sure, as soon as I get back home I'll do it ;-)

opensas (opensas) wrote :

I can confirm that the touchpad DOES work as expected in ubuntu 17.10

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 4.13.0-21-generic #24-Ubuntu SMP Mon Dec 18 17:29:16 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

So it is indeed a regression introduced somewhere between 17.10 and 18.04

Hope that helps

Just let me know if there's anything else I can do

opensas:

To further narrow the regression, in Ubuntu 18.04 or higher, if you install kernel 4.13.3 from https://wiki.ubuntu.com/Kernel/MainlineBuilds does the touchpad work again?

tags: added: regression-release
removed: regression-potential
opensas (opensas) wrote :

I've just installed ubuntu 18.04.2 to a new partition, and then installed the following packages:

https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13.3/linux-headers-4.13.3-041303-generic_4.13.3-041303.201709200606_amd64.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13.3/linux-image-4.13.3-041303-generic_4.13.3-041303.201709200606_amd64.deb

sas@bionic:~$ uname -a
Linux bionic 4.13.3-041303-generic #201709200606 SMP Wed Sep 20 10:12:46 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I can confirm that the bug IS NOT PRESENT using this kernel, with kernel version 4.13.3 the touchpad works ok.

opensas, the next step is to fully commit bisect from 4.13.13 to 4.15.

This will allow for a direct review of the offending commit for either reverting, or further improvements. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ? This article was written for folks who don't know anything about linux, so it's easy to follow.

Please note, finding adjacent kernel versions, or providing a commit without testing it and reverting it is not fully commit bisecting.

Also, the kernel release names are irrelevant for the purposes of bisecting.

It is most helpful that after the bad commit (not kernel version) has been confirmed via testing, you then mark this report Status Confirmed.

Thank you for your help.

Changed in libinput (Ubuntu):
status: New → Invalid
tags: added: needs-bisect- needs-upstream-testing
opensas (opensas) wrote :

I'm trying to pinpoint the kernel version in which the bug appeared.

So, following the bisection guide, I checked the releases of the artful linux source package (https://launchpad.net/ubuntu/artful/+source/linux)

From my previous tests, artcul livecd worked ok, and it reported kernel 4.13.0-21

I tried installing the previous release to that version: (I couldn't find the 4.31.0-21 version)

linux-headers-4.13.0-19_4.13.0-19.22_all.deb
linux-headers-4.13.0-19-generic_4.13.0-19.22_amd64.deb
linux-image-4.13.0-19-generic_4.13.0-19.22_amd64.deb

(downloaded from https://launchpad.net/ubuntu/+source/linux/4.13.0-19.22)

I installed them with sudo dpkg -i *.deb

I assumed they should work ok, because they are before a version that worked ok, but they present the same bug. Every other version I tried like this did the same.

Then I tried with several versions from the upstream kernels (from https://wiki.ubuntu.com/Kernel/MainlineBuilds) an they all worked fine, even the msot recent ones. So this must be a bug introduces by ubuntu.

I'm kind of stuck. I'd like to be able to reproduce the working kernel from artful livecd and then start bisecting from there.

Any other clue you could give me?

Daniel van Vugt (vanvugt) wrote :

Maybe go back a little further to a 4.12 or 4.11 version. If they still don't work then that's an indication the "fix" might have been in a patch that only existed in artful.

Daniel van Vugt (vanvugt) wrote :

Also, if you haven't already please try much newer kernels too. Like 4.20 or 5.0.

opensas (opensas) wrote :

All right, I took your advice and tested several older kernels:

linux-headers-4.10.0-19_4.10.0-19.21_all.deb
linux-headers-4.10.0-19-generic_4.10.0-19.21_amd64.deb
linux-headers-4.10.0-26_4.10.0-26.30_all.deb
linux-headers-4.10.0-26-generic_4.10.0-26.30_amd64.deb
linux-headers-4.11.0-13_4.11.0-13.19_all.deb
linux-headers-4.11.0-13-generic_4.11.0-13.19_amd64.deb
linux-headers-4.12.0-13_4.12.0-13.14_all.deb
linux-headers-4.12.0-13-generic_4.12.0-13.14_amd64.deb
linux-image-4.10.0-19-generic_4.10.0-19.21_amd64.deb
linux-image-4.10.0-26-generic_4.10.0-26.30_amd64.deb
linux-image-4.11.0-13-generic_4.11.0-13.19_amd64.deb
linux-image-4.12.0-13-generic_4.12.0-13.14_amd64.deb

I installed all these deb files, and booted with them, and the bug is STILL present.

It seems like I can't reproduce the working kernel of the artful livecd.

Any idea about how should I proceed?

you should've installed linux-image-extra for 4.13.0-19.22, testing without it doesn't prove a thing

opensas (opensas) wrote :

1) I tried with all these:

4.10.0-041000_4.10.0
4.11.0-041100_4.11.0
4.12.0-041200_4.12.0
4.17.0-041700_4.17.0
4.18.0-041800_4.18.0
4.19.0-041900_4.19.0

they all work fine

2) I'll give it a try, but I had troubles installing a working ubuntu kernel version to start looking for the version that introduces the bug, see: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1816947/comments/43

Timo Aaltonen (tjaalton) wrote :

Yes, in #43 you said that you tested 4.13.0-19.22 but didn't seem to install the package with the drivers (linux-image-extra). If you do, does it work like the live version did?

Download full text (5.6 KiB)

Thanks for the tip (I didn't know which packages to include), I'll give it
a try asap

On Wed, Feb 27, 2019 at 12:20 PM Timo Aaltonen <email address hidden> wrote:

> Yes, in #43 you said that you tested 4.13.0-19.22 but didn't seem to
> install the package with the drivers (linux-image-extra). If you do,
> does it work like the live version did?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1816947
>
> Title:
> [Dell XPS L321X] Touchpad not working after last apt-get upgrade
>
> Status in libinput package in Ubuntu:
> Invalid
> Status in linux package in Ubuntu:
> Incomplete
>
> Bug description:
> The touchpad doesn't work unless the cursor is moved slowly.
>
> WORKAROUND: Execute at a terminal:
> sudo modprobe -r psmouse
> sudo modprobe psmouse proto=imps
>
> ProblemType: Bug
> DistroRelease: Ubuntu 19.04
> Package: xorg 1:7.7+19ubuntu8
> ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
> Uname: Linux 4.18.0-11-generic x86_64
> ApportVersion: 2.20.10-0ubuntu19
> Architecture: amd64
> BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
> CasperVersion: 1.402
> CompositorRunning: None
> CurrentDesktop: ubuntu:GNOME
> Date: Thu Feb 21 02:56:45 2019
> DistUpgraded: Fresh install
> DistroCodename: disco
> DistroVariant: ubuntu
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Dell 2nd Generation Core Processor Family Integrated
> Graphics Controller [1028:052e]
> LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190203)
> MachineType: Dell Inc. Dell System XPS L321X
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=C.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper
> initrd=/casper/initrd quiet splash --- maybe-ubiquity
> SourcePackage: xorg
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 12/27/2011
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A01
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.chassis.version: 0.1
> dmi.modalias:
> dmi:bvnDellInc.:bvrA01:bd12/27/2011:svnDellInc.:pnDellSystemXPSL321X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
> dmi.product.family: HuronRiver System
> dmi.product.name: Dell System XPS L321X
> dmi.product.sku: System SKUNumber
> dmi.sys.vendor: Dell Inc.
> version.compiz: compiz N/A
> version.libdrm2: libdrm2 2.4.97-1
> version.libgl1-mesa-dri: libgl1-mesa-dri 18.3.2-1ubuntu1
> version.libgl1-mesa-glx: libgl1-mesa-glx N/A
> version.xserver-xorg-core: xserver-xorg-core 2:1.20.3-1ubuntu1
> version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
> version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.0-1
> version.xserver-xorg-video-intel: xserver-xorg-video-intel
> 2:2.99.917+git20180925-2
> version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:...

Read more...

Download full text (4.6 KiB)

I installed the following deb files:

linux-headers-4.13.0-19_4.13.0-19.22_all.deb
linux-headers-4.13.0-19-generic_4.13.0-19.22_amd64.deb
linux-image-4.13.0-19-generic_4.13.0-19.22_amd64.deb
linux-image-extra-4.13.0-19-generic_4.13.0-19.22_amd64.deb

Now I'm running

$ uname -a
Linux bionic 4.13.0-19-generic #22-Ubuntu SMP Mon Dec 4 11:58:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

and the bug IS STILL present.

Any other idea?

BTW, perhaps this might help:

$ lsmod
Module Size Used by
ccm 20480 3
rfcomm 77824 4
bnep 20480 2
snd_hda_codec_hdmi 49152 1
snd_hda_codec_realtek 94208 1
snd_hda_codec_generic 73728 1 snd_hda_codec_realtek
intel_rapl 20480 0
x86_pkg_temp_thermal 16384 0
intel_powerclamp 16384 0
coretemp 16384 0
kvm_intel 200704 0
hid_generic 16384 0
joydev 20480 0
kvm 581632 1 kvm_intel
irqbypass 16384 1 kvm
crct10dif_pclmul 16384 0
crc32_pclmul 16384 0
ghash_clmulni_intel 16384 0
pcbc 16384 0
dell_laptop 20480 0
snd_hda_intel 40960 3
aesni_intel 188416 2
snd_hda_codec 126976 4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
aes_x86_64 20480 1 aesni_intel
crypto_simd 16384 1 aesni_intel
snd_hda_core 81920 5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep 20480 1 snd_hda_codec
glue_helper 16384 1 aesni_intel
snd_pcm 98304 4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
cryptd 24576 3 crypto_simd,ghash_clmulni_intel,aesni_intel
intel_cstate 20480 0
intel_rapl_perf 16384 0
arc4 16384 2
snd_seq_midi 16384 0
iwldvm 229376 0
snd_seq_midi_event 16384 1 snd_seq_midi
mac80211 778240 1 iwldvm
snd_rawmidi 32768 1 snd_seq_midi
btusb 45056 0
btrtl 16384 1 btusb
wmi_bmof 16384 0
snd_seq 65536 2 snd_seq_midi_event,snd_seq_midi
btbcm 16384 1 btusb
iwlwifi 249856 1 iwldvm
input_leds 16384 0
dell_wmi 16384 0
dell_smbios 16384 2 dell_wmi,dell_laptop
dcdbas 16384 1 dell_smbios
sparse_keymap 16384 1 dell_wmi
btintel 16384 1 btusb
serio_raw 16384 0
bluetooth 540672 31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
uvcvideo 90112 0
snd_timer 32768 2 snd_seq,snd_pcm
videobuf2_vmalloc 16384 1 uvcvideo
usbhid 49152 0
videobuf2_memops 16384 1 videobuf2_vmalloc
hid 118784 2 hid_generic,usbhid
ecdh_generic 24576 1 bluetooth
snd 81920 17 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_cod...

Read more...

Kai-Heng Feng (kaihengfeng) wrote :

Please attach dmesg when it works and when it doesn't work.

yoshiki2 (yoshiki2) wrote :

Hello.
I have the same laptop.. It malfunctions all the time. The touchpad has to be used slowly or it freezes. and I am unable to drag and select/move text..
I can see there was a simillar bug to this..
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1048258
Some interesting information about these drivers.. project sputnik?
https://bartongeorge.io/2012/06/20/sputnik-update-touchpad-driver-now-available/
Let me know If i can help with something else.. thanks

yoshiki2, it will help immensely if you use Ubuntu with the computer the problem is reproducible with and file a new report via a terminal to provide necessary debugging logs:
ubuntu-bug linux

Please feel free to subscribe me to it.

yoshiki2 (yoshiki2) wrote :
Download full text (3.5 KiB)

fredo@fredo-Dell-System-XPS-L321X:~$ sudo libinput measure touchpad-pressure
Using CyPS/2 Cypress Trackpad: /dev/input/event5

Ready for recording data.
Pressure range used: 30:25
Palm pressure range used: 130
Place a single finger on the touchpad to measure pressure values.
Ctrl+C to exit

Sequence 1115 pressure: min: 61 max: 129 avg: 103 median: 108 tags: down
Sequence 1116 pressure: min: 36 max: 189 avg: 127 median: 130 tags: down palm
Sequence 1117 pressure: min: 60 max: 139 avg: 118 median: 116 tags: down palm
Sequence 1118 pressure: min: 8 max: 119 avg: 92 median: 96 tags: down
Sequence 1119 pressure: min: 12 max: 131 avg: 103 median: 109 tags: down palm
Sequence 1120 pressure: min: 12 max: 126 avg: 69 median: 63 tags: down
Sequence 1121 pressure: min: 9 max: 11 avg: 10 median: 10 tags:
Sequence 1122 pressure: min: 8 max: 15 avg: 12 median: 13 tags:
Sequence 1123 pressure: min: 9 max: 43 avg: 25 median: 22 tags: down
Sequence 1124 pressure: min: 19 max: 217 avg: 132 median: 141 tags: down palm
Sequence 1125 pressure: min: 18 max: 213 avg: 113 median: 115 tags: down palm
Sequence 1126 pressure: min: 239 max: 239 avg: 239 median: 239 tags: down palm
Sequence 1127 pressure: min: 34 max: 227 avg: 129 median: 125 tags: down palm
Sequence 1128 pressure: min: 13 max: 133 avg: 102 median: 102 tags: down palm
Sequence 1129 pressure: min: 10 max: 82 avg: 57 median: 59 tags: down
Sequence 1130 pressure: min: 21 max: 95 avg: 64 median: 65 tags: down
Sequence 1131 pressure: min: 56 max: 207 avg: 146 median: 150 tags: down palm
Sequence 1132 pressure: min: 54 max: 103 avg: 79 median: 75 tags: down
Sequence 1133 pressure: min: 57 max: 157 avg: 118 median: 120 tags: down palm
Sequence 1134 pressure: min: 38 max: 138 avg: 94 median: 93 tags: down palm
Sequence 1135 pressure: min: 57 max: 155 avg: 110 median: 104 tags: down palm
Sequence 1136 pressure: min: 52 max: 152 avg: 96 median: 93 tags: down palm
Sequence 1137 pressure: min: 17 max: 227 avg: 122 median: 123 tags: down palm
Sequence 1138 pressure: min: 65 max: 178 avg: 110 median: 105 tags: down palm
Sequence 1139 pressure: min: 58 max: 111 avg: 100 median: 105 tags: down
Sequence 1140 pressure: min: 61 max: 172 avg: 115 median: 114 tags: down palm
Sequence 1141 pressure: min: 31 max: 131 avg: 91 median: 99 tags: down palm
Sequence 1142 pressure: min: 54 max: 168 avg: 132 median: 141 tags: down palm
Sequence 1143 pressure: min: 18 max: 222 avg: 125 median: 131 tags: down palm
Sequence 1144 pressure: min: 67 max: 255 avg: 169 median: 169 tags: down palm
Sequence 1145 pressure: min: 62 max: 135 avg: 107 median: 109 tags: down palm
Sequence 1146 pressure: min: 46 max: 140 avg: 97 median: 101 tags: down palm
Sequence 1147 pressure: min: 35 max: 145 avg: 114 median: 117 tags: down palm
Sequence 1148 pressure: min: 40 max: 106 avg: 91 median: 93 tags: down
Sequence 1149 pressure: min: 53 max: 135 avg: 112 median: 113 tags: down palm
Sequence 1150 pressure: min: 51 max: 131 avg: 101 median: 103 tags: down palm
Sequence 1151 pressure: min: 9 max: 217 avg: 102 median: 100 tags: down palm
Sequence 1152 pressure: min: 9 max: 10 avg: 9...

Read more...

yoshiki2 (yoshiki2) wrote :

fredo@fredo-Dell-System-XPS-L321X:~$ dmesg|grep -i "ps/2"
[ 1.006927] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[ 1.010735] mousedev: PS/2 mouse device common for all mice
[ 2.667559] input: CyPS/2 Cypress Trackpad as /devices/platform/i8042/serio1/input/input6
fredo@fredo-Dell-System-XPS-L321X:~$

I believe the problem is in libinput.. for some reason it detects my finger as a palm..

Daniel van Vugt (vanvugt) wrote :
summary: - [Dell XPS L321X] Touchpad not working after last apt-get upgrade
+ [Dell XPS L321X] The touchpad doesn't work unless the cursor is moved
+ slowly.
Changed in libinput (Ubuntu):
status: Invalid → New
status: New → Confirmed
Changed in libinput:
status: Unknown → New
guy sansom (gooie) wrote :

Any solution pending on this? I have same fault - as expected I guess.
Have just rebuilt PC from old Ubuntu 16.04LTS to 18.04LTS and Trackpad has developed same problem.
Confirming I'm on DELL XPS13 L321X
 - Trackpad only works sporadically, short distances, if very light touch and moving slowly++
 - Cannot click and drag anything
 - Cannot highlight text
PS: I'm virtually coding illiterate but will do whatever I can to assist if needed
Is there something I can download and overwrite as a fix?
If so, please spell out coding syntax required to complete
Cheers guys. (Linux noob)

yoshiki2 (yoshiki2) wrote :

The only way to fix this is using libinput 13.
You might need to compile it, and those new drivers would fix it.
I tried libinput on fedora 30.
I do not know how to update/build libinput, though. (i am using linux mint debian for now).
Can someone give us instructions?

Changed in libinput:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.