Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)

Bug #1554613 reported by Thomas Bonfort on 2016-03-08
344
This bug affects 103 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
High
Unassigned

Bug Description

*** Temporary workaround ***
Install Kernel from the following location:
- http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/

OR
Perform the following:
- $ apt-add-repository "deb http://ppa.launchpad.net/canonical-kernel-team/ppa/ubuntu yakkety main"
- $ echo -en "Package: *\nPin: release o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority: -1\n" >> /etc/apt/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
- $ apt update
- $ apt install linux-image-extra-4.6.0-6-generic linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic
```
There was a typo in instructions (/etc/preferences.d should have been /etc/apt/preferences.d).
As result you might have upgraded Linux META packages and therefor you won't receive proper upgrades of Xenial native Linux packages (hoping they will ever contain the fix).
I suggest you move /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety to /etc/apt/preferences.d/ and downgrade related packages:
$ apt update
$ apt install linux-headers-generic/xenial-updates linux-tools-generic/xenial-updates linux-image-generic/xenial-updates
```
***

Please inspect duplicate reports for more details:
    Bug #1522922
    Bug #1535048
    Bug #1552304
    Bug #1555158
    Bug #1561729
    Bug #1565234
    Bug #1568599
    Bug #1573392

does not affect 4.4.0-8
affects 4.4.0-9 to 4.4.0-22

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-generic 4.4.0.11.12
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
CurrentDesktop: KDE
Date: Tue Mar 8 09:57:12 2016
HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
InstallationDate: Installed on 2016-01-07 (61 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 0c45:670c Microdia
 Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 13 9350
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-8-generic root=UUID=757547b8-d0e4-4eb8-8afd-920b743f99a4 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-8-generic N/A
 linux-backports-modules-4.4.0-8-generic N/A
 linux-firmware 1.156
SourcePackage: linux
UpgradeStatus: Upgraded to xenial on 2016-02-28 (9 days ago)
dmi.bios.date: 01/08/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.2.3
dmi.board.name: 07TYC2
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.2.3:bd01/08/2016:svnDellInc.:pnXPS139350:pvr:rvnDellInc.:rn07TYC2:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 13 9350
dmi.sys.vendor: Dell Inc.

Thomas Bonfort (thomas-bonfort) wrote :

Thomas Bonfort, thank you for reporting this and helping make Ubuntu better.

In order to allow additional upstream developers to examine the issue, at your earliest convenience, could you please test the latest upstream kernel available from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D ? Please keep in mind the following:
1) The one to test is at the very top line at the top of the page (not the daily folder).
2) The release names are irrelevant.
3) The folder time stamps aren't indicative of when the kernel actually was released upstream.
4) Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds .

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Also, you don't need to apport-collect further unless specifically requested to do so.

Once testing of the latest upstream kernel is complete, please mark this report Status Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-1.2.3
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
tags: added: regression-release
Thomas Bonfort (thomas-bonfort) wrote :

I have tested 4.5.0-040500rc7-generic which is affected. I've added the kernel-bug-exists-upstream-4.5-rc7 tag, let me know if that what you were expecting from me.

tags: added: kernel-bug-exists-upstream-4.5-rc7
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thomas Bonfort, the next step is to fully commit bisect from kernel 4.4.0-8 to 4.4.0-9 in order to identify the last good kernel commit, followed immediately by the first bad one. This will allow for a more expedited analysis of the root cause of your issue. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

After the offending commit (not kernel version) has been identified, then please mark this report Status Confirmed.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: needs-bisect
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Thomas Bonfort (thomas-bonfort) wrote :

I'm unable to run the bisection. The first bisect step between Ubuntu-4.4.0-8.23 and Ubuntu-4.4.0-9.24 from git://kernel.ubuntu.com/ubuntu/ubuntu-xenial.git outputs "Bisecting: a merge base must be tested" and leaves me in a state where I have no debian/ subdir to allow me to launch the build

pranith (bobby-prani) wrote :

I think this bug is caused by the backported i915 driver in 4.4.0-9 which is being loaded as i915_bpo.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thomas Bonfort, have you had a chance to review the section https://wiki.ubuntu.com/Kernel/KernelBisection#Bisecting:_a_merge_base_must_be_tested ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Thomas Bonfort (thomas-bonfort) wrote :
Download full text (3.4 KiB)

Christopher,
Yes I have read that section but it is not useful as selecting between bad/good is already the required workflow. The issue is that the documentation refers to using the packaging scripts in the debian/ subdir, which is not present and/or usable in the intermediate bisecting steps.
I'm currently testing using this workflow, please advise if it is the correct one:

make mrproper && git clean -d -f && git checkout debian
git bisect good/bad/skip
cp /boot/config-4.4.0-8-generic .config
make oldconfig
make-kpkg --rootcmd=fakeroot --append-to-version "-04-deadbeef" --initrd --us --uc kernel_image -j4
#install and test kernel

here is my current bisect log. note that I have to skip many commits as they fail to compile:

git bisect start '--' 'drivers/gpu/' 'include/drm/' 'include/uapi/drm/' 'ubuntu/i915'
# good: [463f21c6a2dcc90e06dbc2eb2341640ae5c43c28] UBUNTU: Ubuntu-4.4.0-8.23
git bisect good 463f21c6a2dcc90e06dbc2eb2341640ae5c43c28
# bad: [b8723f286caa9218ebda0c47a435d1b52b8dfaf4] UBUNTU: Ubuntu-4.4.0-9.24
git bisect bad b8723f286caa9218ebda0c47a435d1b52b8dfaf4
# good: [1cb8570bf04ab12a03c31c397a4d158f24895d9c] Linux 4.4.2
git bisect good 1cb8570bf04ab12a03c31c397a4d158f24895d9c
# skip: [19ed21af1bffa667745926f2b8b28a0505cca0be] drm: Add "prefix" parameter to drm_rect_debug_print()
git bisect skip 19ed21af1bffa667745926f2b8b28a0505cca0be
# skip: [a9b3cdd235bf966b4cddab82d61dc941a74e3a74] UBUNTU: SAUCE: Backport I915_PARAM_HAS_EXEC_SOFTPIN and EXEC_OBJECT_PINNED
git bisect skip a9b3cdd235bf966b4cddab82d61dc941a74e3a74
# skip: [8bfcd31065a60ffba9e600fafd62bbd90ff0895a] drm/atomic: Add encoder_mask to crtc_state, v3.
git bisect skip 8bfcd31065a60ffba9e600fafd62bbd90ff0895a
# skip: [693a63075524374165196137ca4b952a6afd5265] drm/i915/kbl: Add Kabylake GT4 PCI ID
git bisect skip 693a63075524374165196137ca4b952a6afd5265
# good: [34f091b3d14dadd9ef8d1f8a678656aed759fe33] UBUNTU: SAUCE: radeon: r100: Silence 'may be used uninitialized' warnings
git bisect good 34f091b3d14dadd9ef8d1f8a678656aed759fe33
# skip: [abfd1387464d2e764989d8fbaea78b0b7af89142] drm/i915: Set connector_state->connector using the helper.
git bisect skip abfd1387464d2e764989d8fbaea78b0b7af89142
# skip: [975bc60948107bce995ae5d18e0755dc5f2abf53] drm: fix potential dangling else problems in for_each_ macros
git bisect skip 975bc60948107bce995ae5d18e0755dc5f2abf53
# good: [98e1eef7fa2b711e0946d22a3c2659458582e807] drm/i915/skl: Disable coarse power gating up until F0
git bisect good 98e1eef7fa2b711e0946d22a3c2659458582e807
# skip: [1f955e92dc87f484048109bc1d434fa59221c5dd] drm/atomic: add connector mask to drm_crtc_state.
git bisect skip 1f955e92dc87f484048109bc1d434fa59221c5dd
# skip: [7d5329085d3e64b6b04a9de1c86f5074bac26cc9] drm/i915: Update connector_mask during readout, v2.
git bisect skip 7d5329085d3e64b6b04a9de1c86f5074bac26cc9
# skip: [8167675659a93004ae99d7b3aa90e1134352a836] drm: Implement drm_modeset_lock_all_ctx()
git bisect skip 8167675659a93004ae99d7b3aa90e1134352a836
# skip: [8ba5c26373f1e4341f2cbd198ddeb41644adf9b6] drm/atomic: Do not unset crtc when an encoder is stolen
git bisect skip 8ba5c26373f1e4341f2cbd198ddeb41644adf9b6
# skip: [197b480eac049b43e26cad...

Read more...

Thomas Bonfort (thomas-bonfort) wrote :

I have tested 4.0.0-13 which does not seem to exhibit the flickering present from 4.0.0-9 to 4.0.0-12. It does however now present tearing artifacts when switching focus between windows, see https://www.dropbox.com/s/opirfyzklathw3i/VID_20160316_112021.m4v?dl=0 for a screengrab.

After a couple of hours using 4.0.0.13 the flickering has re-appeared.

description: updated
Download full text (9.7 KiB)

I have finished bisecting the commits and the switch from i915 to i915_bpo seems to be the culprit. There are quite a few candidates but that's because all those skipped commits failed to build/compile.

Note that on the first flicker after booting, this message appears in dmesg:

[drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]] *ERROR* CPU pipe A FIFO underrun

Here is the log of the bisect:

git bisect start '--' 'drivers/gpu/' 'include/drm/' 'include/uapi/drm/' 'ubuntu/i915'
# good: [463f21c6a2dcc90e06dbc2eb2341640ae5c43c28] UBUNTU: Ubuntu-4.4.0-8.23
git bisect good 463f21c6a2dcc90e06dbc2eb2341640ae5c43c28
# bad: [b8723f286caa9218ebda0c47a435d1b52b8dfaf4] UBUNTU: Ubuntu-4.4.0-9.24
git bisect bad b8723f286caa9218ebda0c47a435d1b52b8dfaf4
# good: [1cb8570bf04ab12a03c31c397a4d158f24895d9c] Linux 4.4.2
git bisect good 1cb8570bf04ab12a03c31c397a4d158f24895d9c
# skip: [19ed21af1bffa667745926f2b8b28a0505cca0be] drm: Add "prefix" parameter to drm_rect_debug_print()
git bisect skip 19ed21af1bffa667745926f2b8b28a0505cca0be
# skip: [a9b3cdd235bf966b4cddab82d61dc941a74e3a74] UBUNTU: SAUCE: Backport I915_PARAM_HAS_EXEC_SOFTPIN and EXEC_OBJECT_PINNED
git bisect skip a9b3cdd235bf966b4cddab82d61dc941a74e3a74
# skip: [8bfcd31065a60ffba9e600fafd62bbd90ff0895a] drm/atomic: Add encoder_mask to crtc_state, v3.
git bisect skip 8bfcd31065a60ffba9e600fafd62bbd90ff0895a
# skip: [693a63075524374165196137ca4b952a6afd5265] drm/i915/kbl: Add Kabylake GT4 PCI ID
git bisect skip 693a63075524374165196137ca4b952a6afd5265
# good: [34f091b3d14dadd9ef8d1f8a678656aed759fe33] UBUNTU: SAUCE: radeon: r100: Silence 'may be used uninitialized' warnings
git bisect good 34f091b3d14dadd9ef8d1f8a678656aed759fe33
# skip: [abfd1387464d2e764989d8fbaea78b0b7af89142] drm/i915: Set connector_state->connector using the helper.
git bisect skip abfd1387464d2e764989d8fbaea78b0b7af89142
# skip: [975bc60948107bce995ae5d18e0755dc5f2abf53] drm: fix potential dangling else problems in for_each_ macros
git bisect skip 975bc60948107bce995ae5d18e0755dc5f2abf53
# good: [98e1eef7fa2b711e0946d22a3c2659458582e807] drm/i915/skl: Disable coarse power gating up until F0
git bisect good 98e1eef7fa2b711e0946d22a3c2659458582e807
# ski...

Read more...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
tags: added: bisect-done
removed: needs-bisect

introduced in LP: #1540390

4.5.0-040500 is still affected

tags: added: kernel-bug-exists-upstream-4.5
removed: kernel-bug-exists-upstream-4.5-rc7

also present in 4.5.0-994-generic_4.5.0-994.201603152201 from drm-intel-nightly

Thomas Bonfort. the issue you are reporting is an upstream one. Could you please report this problem following the 1.1 - DRM Kernel instructions verbatim at https://01.org/linuxgraphics/documentation/how-report-bugs ?

Please provide a direct URL to your post when it becomes available so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
16 comments hidden view all 155 comments

I'm experiencing what seems to be random flickering (not related to hiding cursor as seen on #93945).

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1554613 contains my bisection of the issue.

[359d2243117a79599435141fda0047d01ef324e8] drm/i915: Update DRIVER_DATE to 20160314
from drm-intel-next still exhibits the issue

I've bisected this down with relative confidence (had to mark commits from 4.3 as artificially good as the system was not usable with this older version of the kernel):

921ec285a6589cf3beb7f56a70744f75b09349f8 is the first bad commit
commit 921ec285a6589cf3beb7f56a70744f75b09349f8
Author: Rodrigo Vivi <email address hidden>
Date: Wed Nov 18 11:21:12 2015 -0800

Here is the full bisect log:

git bisect start '--' 'drivers/gpu/drm/i915' 'include/drm/' 'include/uapi/drm/'
# bad: [359d2243117a79599435141fda0047d01ef324e8] drm/i915: Update DRIVER_DATE to 20160314
git bisect bad 359d2243117a79599435141fda0047d01ef324e8
# good: [1cb8570bf04ab12a03c31c397a4d158f24895d9c] Linux 4.4.2
git bisect good 1cb8570bf04ab12a03c31c397a4d158f24895d9c
# good: [afd2ff9b7e1b367172f18ba7f693dfb62bdcb2dc] Linux 4.4
git bisect good afd2ff9b7e1b367172f18ba7f693dfb62bdcb2dc
# bad: [2a33d93486f247924e46b5402b8ffb43d1b9b38c] drm/i915/bios: add support for MIPI sequence block v3
git bisect bad 2a33d93486f247924e46b5402b8ffb43d1b9b38c
# bad: [013d37520af735fd55f78e33edf55cc6fb3858eb] drm/i915: Introduce bdw_{update,enable,disable}_pipe_irq()
git bisect bad 013d37520af735fd55f78e33edf55cc6fb3858eb
# good: [b1a14c6e40413f833dadc1d23b43c530f4b8e381] drm/i915: refactor stepping info retrieval
git bisect good b1a14c6e40413f833dadc1d23b43c530f4b8e381
# good: [78e0d2e3477aa3e8bdac70698ddd2aad020016d1] drm/i915: Store DVO SRCDIM register offset under intel_dvo_device
git bisect good 78e0d2e3477aa3e8bdac70698ddd2aad020016d1
# good: [a6d09186fa27dea720ddd668a814cb6e4f78d53b] drm/i915: Stuff rotation params into view union
git bisect good a6d09186fa27dea720ddd668a814cb6e4f78d53b
# good: [ca1a95334ddaf624c1b0424113fe9b8100da1614] drm/i915: Remove duplicated dpcd write on hsw_psr_enable_sink.
git bisect good ca1a95334ddaf624c1b0424113fe9b8100da1614
# bad: [9bbc8258ae5914af1986561767d971417cee7a28] drm/i915: Check for underruns after crtc disable
git bisect bad 9bbc8258ae5914af1986561767d971417cee7a28
# bad: [05eec3c2709d8966cbfcc7cd395f37889c492678] drm/i915: Remove PSR Perf Counter for SKL+
git bisect bad 05eec3c2709d8966cbfcc7cd395f37889c492678
# bad: [bb929cbc1f58c72eaf7981281dbb024ad92ef24d] drm/i915: PSR: Mask LPSP hw tracking back again.
git bisect bad bb929cbc1f58c72eaf7981281dbb024ad92ef24d
# bad: [921ec285a6589cf3beb7f56a70744f75b09349f8] drm/i915: PSR: Let's rely more on frontbuffer tracking.
git bisect bad 921ec285a6589cf3beb7f56a70744f75b09349f8
# first bad commit: [921ec285a6589cf3beb7f56a70744f75b09349f8] drm/i915: PSR: Let's rely more on frontbuffer tracking.

16 comments hidden view all 155 comments

Stille present with 4.4.0-16 , and after updating BIOS to latest 1.3.3 version

description: updated
tags: added: latest-bios-1.3.2
removed: latest-bios-1.2.3
1 comments hidden view all 155 comments

sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
1.3.3
03/01/2016

tags: added: latest-bios-1.3.3
removed: latest-bios-1.3.2
Eugene San (eugenesan) wrote :

I would like to add few observations:

1. Seems like the issue is Power Management related since I've never experienced it with AC adapter connected and sometimes almost instantly after disconnecting it, the flickering is started.

2. Sometimes first "flick" after reboot or PM change is accompanied with "[drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]] *ERROR* CPU pipe A FIFO underrun"

3. My dmesg is not as clean as the one provided by original reporter. It filled with quite a few bug/dump reports of i915 driver. Attaching my dmesg.log.

4. Once in a while, I find the computer in state which seems like a hardware "hang" but I suspect it's an i915 driver fault since sometimes after a prolonged wait the computer finally wakes up and later I find the errors mentioned in 3. Note those hangs can happen even if the computer is powered from AC and no automatic suspend is configured.

Seems like upstream bug report didn't get the attention it deserves, any ideas on how to assist with this bug(s) resolution?

Eugene San (eugenesan) wrote :

For me, the flickering happens with or without AC. And First flicker always ends up having the FIFO error message being printed.

I do confirm that behavior

Thomas Bonfort <email address hidden> schrieb am Sa., 2. Apr. 2016,
18:05:

> For me, the flickering happens with or without AC. And First flicker
> always ends up having the FIFO error message being printed.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1561729).
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> screen flickering on XPS13 9350
>
> Status in linux package in Ubuntu:
> Triaged
>
> Bug description:
> see LP: #1552304
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-16
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:670c Microdia
> Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: Dell Inc. XPS 13 9350
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-8-generic
> root=UUID=757547b8-d0e4-4eb8-8afd-920b743f99a4 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-4.4.0-8-generic N/A
> linux-backports-modules-4.4.0-8-generic N/A
> linux-firmware 1.156
> SourcePackage: linux
> UpgradeStatus: Upgraded to xenial on 2016-02-28 (9 days ago)
> dmi.bios.date: 01/08/2016
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.2.3
> dmi.board.name: 07TYC2
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A01
> dmi.chassis.type: 9
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias:
> dmi:bvnDellInc.:bvr1.2.3:bd01/08/2016:svnDellInc.:pnXPS139350:pvr:rvnDellInc.:rn07TYC2:rvrA01:cvnDellInc.:ct9:cvr:
> dmi.product.name: XPS 13 9350
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1554613/+subscriptions
>

I am still not 100% sure but after a day with this kernel: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc1-wily/ I can report the following:

1. No flickering
2. No more kernel dumps/bugs reports
3. No more i915 warnings
4. No more suspend issues
5. No more Dell WMI events errors
6. Not that it wasn't great but battery life seems to be improved (might be a placebo effect)

Looks like Linux 4.4 is just not ready for Skylake and backporting all the fixes is going to be hell for both maintainers and users.
If I were in position, I would push for Kernel 4.6 as an official kernel variant for 16.04 (before 16.04.1).

I just hope Dell will create enough momentum for those issues to be resolved soon, after all it's their flagship device with official Ubuntu support.

No change with 4.6-rc1-wily for me

Daniel Basten (axhm3a) wrote :

as mentioned in #1561729:

kernel 4.6rc1 also did not fixed the issue for me

6 comments hidden view all 155 comments

Could someone at Intel please assign this to offending commit committer Rodrigo Vivi (or request he assign himself)?

Unfortunately, bugzilla won't allow one to either assign him or CC as per error message:
Assignee:
rodrigo.vivi AT intel DOT com did not match anything

Also, this seems strange one cannot assign him given Intel's documentation states to report here as per https://01.org/linuxgraphics/documentation/how-report-bugs , but yet bugzilla cannot reach the appropriate developer?

Despite this, increasing importance, given it's bisected, reproducible for a few folks as reported downstream, and reproducible in latest drm-intel-nightly.

5 comments hidden view all 155 comments
Timo Aaltonen (tjaalton) wrote :

i915_bpo is tracking 4.6, and 4.4.0-17 has essentially the same driver as 4.6-rc1. Does reverting that commit fix it? Also, you could try booting with 'i915.enable_psr=1' to actually use PSR, which should be stable on SKL now, assuming X is using the intel driver.

with 4.4.0-16: flickers with or without i915.enable_psr=1 , and with or without reverting rodrigo's commit found by bisection
with 4.4.0-17: X does not start , I'm left with a blank screen. happens with or without i915.enable_psr

failed X startup with 4.4.0-17. Let me know if you want more info.

dmesg of failed startup with 4.4.0-17

3 comments hidden view all 155 comments

(In reply to Christopher M. Penalver from comment #2)
> Could someone at Intel please assign this to offending commit committer
> Rodrigo Vivi (or request he assign himself)?
>
> Unfortunately, bugzilla won't allow one to either assign him or CC as per
> error message:
> Assignee:
> rodrigo.vivi AT intel DOT com did not match anything

Done now, it's just that he's registered here with another email address. Writing just parts of the name will show up alternatives.

Changed in linux:
importance: Unknown → High
status: Unknown → In Progress
3 comments hidden view all 155 comments

Created attachment 122707
revert of bisected commit...

Hi there,

First of all please accept my apologies for using different emails here and in the commits. But besides the auto-complete with only my name as Jani suggested I'm always open for direct emails.

So, there are 2 separated tests that I'd like you to to perform:

1. Apply the attached patch and let me know if the issue goes away.

2. Without applying any patch boot with i915.enable_psr=2.

Thanks,
Rodrigo.

Rodrigo:
I have already tried reverting that commit (in ubuntu's mainline kernel, i.e. in their backported i915_bpo module) but the flickering still occurs.
I may have messed up my bisect: from memory, b1a14c6e40413f8 78e0d2e3477aa3e8bdac a6d09186fa27dea7 ca1a95334ddaf624c1b0424 may have been marked wrongly as "good" as at least the last two of them did not allow me boot up the computer.
I will try psr=2 and let you know.

3 comments hidden view all 155 comments

you didn't install linux-image-extra, which has most of the drivers, including i915..

Timo: with -extra installed I can now boot up successfully. The flickering still occurs with enable_psr=0, 1 and 2 . It seems to occur more frequently when set to 0

Timo Aaltonen (tjaalton) wrote :

0 is the default, PSR isn't enabled (yet)

Changed in linux:
status: In Progress → Incomplete
tags: added: cherry-pick
Changed in linux:
status: Incomplete → Fix Released
Eugene San (eugenesan) on 2016-04-30
summary: - screen flickering on XPS13 9350
+ screen flickering on XPS13 9350/9550
Eugene San (eugenesan) on 2016-04-30
summary: - screen flickering on XPS13 9350/9550
+ Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
Eugene San (eugenesan) on 2016-04-30
description: updated
description: updated
tags: added: needs-reverse-bisect
tags: added: kernel-da-key
Eugene San (eugenesan) on 2016-05-13
description: updated
description: updated
77 comments hidden view all 155 comments
Eugene San (eugenesan) wrote :

@kmstoilov Please make sure you've updated computer's firmware to 1.3.3.

Brad Buran (bburan) wrote :

I have a XPS 13 9350. Screen flicker bug is still present.

~ ❯❯❯ uname -r
4.4.0-22-generic

Computer's BIOS is on 1.3.3.

Download full text (3.3 KiB)

Easy workaround: turn bluetooth on
Learned from http://en.community.dell.com/techcenter/os-applications/f/4613/p/19680410/20909083#20909083

LC

No dia 13/05/2016, às 18:30, Brad Buran <email address hidden> escreveu:

> I have a XPS 13 9350. Screen flicker bug is still present.
>
> ~ ❯❯❯ uname -r
> 4.4.0-22-generic
>
> Computer's BIOS is on 1.3.3.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1565234).
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>
> Status in Linux:
> Fix Released
> Status in linux package in Ubuntu:
> Triaged
>
> Bug description:
>
> *** Temporary workaround ***
> Install Kernel from one of the following locations:
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.10-xenial/
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc7-yakkety/
> ***
>
> Please inspect duplicate reports for more details:
> Bug #1522922
> Bug #1535048
> Bug #1552304
> Bug #1555158
> Bug #1561729
> Bug #1565234
> Bug #1568599
> Bug #1573392
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-22
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:670c Microdia
> Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: Dell Inc. XPS 13 9350
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-8-generic root=UUID=757547b8-d0e4-4eb8-8afd-920b743f99a4 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-4.4.0-8-generic N/A
> linux-backports-modules-4.4.0-8-generic N/A
> linux-firmware 1.156
> SourcePackage: linux
> UpgradeStatus: Upgraded to xenial on 2016-02-28 (9 days ago)
> dmi.bios.date: 01/08/2016
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.2.3
> dmi.board.name: 07TYC2
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A01
> dmi.chassis.type: 9
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr1.2.3:bd01/08/2016:svnDellInc.:pnXPS139350:pvr:rvnDellInc.:rn07TYC2:rvrA01:cvnDellInc.:ct9:cvr:
> dmi.product.name: XPS 13 9350
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/1554613/+subscriptions

---
Luís Correia
Universidade de Lisboa - Faculdade de Ciências
Departamento de Informática
Campo Grande, 1749-016 ...

Read more...

Jeremy LaCroix (j-jlacroix) wrote :

@Brad, are you using Ubuntu MATE by chance? I've long suspected that the MATE desktop environment (or at least Ubuntu MATE) has its own flickering issue that is not related at all.

Kostadin Stoilov (kmstoilov) wrote :

@eugenesan I have the XPS 15 9550 with the latest bios, which is 1.2.0 in my case.

I'm using Unity.

On Fri, May 13, 2016 at 10:53 AM, Jeremy LaCroix <<email address hidden>
> wrote:

> @Brad, are you using Ubuntu MATE by chance? I've long suspected that the
> MATE desktop environment (or at least Ubuntu MATE) has its own
> flickering issue that is not related at all.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>
> Status in Linux:
> Fix Released
> Status in linux package in Ubuntu:
> Triaged
>
> Bug description:
>
> *** Temporary workaround ***
> Install Kernel from one of the following locations:
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.10-xenial/
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc7-yakkety/
> ***
>
> Please inspect duplicate reports for more details:
> Bug #1522922
> Bug #1535048
> Bug #1552304
> Bug #1555158
> Bug #1561729
> Bug #1565234
> Bug #1568599
> Bug #1573392
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-22
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:670c Microdia
> Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: Dell Inc. XPS 13 9350
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-8-generic
> root=UUID=757547b8-d0e4-4eb8-8afd-920b743f99a4 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-4.4.0-8-generic N/A
> linux-backports-modules-4.4.0-8-generic N/A
> linux-firmware 1.156
> SourcePackage: linux
> UpgradeStatus: Upgraded to xenial on 2016-02-28 (9 days ago)
> dmi.bios.date: 01/08/2016
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.2.3
> dmi.board.name: 07TYC2
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A01
> dmi.chassis.type: 9
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias:
> dmi:bvnDellInc.:bvr1.2.3:bd01/08/2016:svnDellInc.:pnXPS139350:pvr:rvnDellInc.:rn07TYC2:rvrA01:cvnDellInc.:ct9:cvr:
> dmi.product.name: XPS 13 9350
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/1554613/+subscriptions
>

I've installed the following Mainline PPA kernel on today's Ubuntu MATE 16.10

  * http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc7-yakkety/

All screen flicker is gone. Just running Ubuntu MATE 16.10, without this kernel upgrade, the flicker was still present.

My system:

Machine: System: Intel (portable) product: SharkBay Platform v: 0.1
           Mobo: Topstar model: WhiteTip Mountain1 Fab2 v: Fab2
           Bios: American Megatrends v: 5.6.5 date: 03/17/2015
CPU: Dual core Intel Core i3-5010U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2100 MHz 1: 2000 MHz 2: 2001 MHz 3: 2000 MHz
           4: 2000 MHz
Graphics: Card: Intel HD Graphics 5500
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 11.2.1

Eugene San (eugenesan) on 2016-05-19
description: updated
description: updated
Eugene San (eugenesan) on 2016-05-19
description: updated
description: updated
description: updated
Kostadin Stoilov (kmstoilov) wrote :

Amazingly, Bluetooth ON/OFF seems to have an effect on this bug. I have been running with Bluetooth constantly ON for the past couple of days and have seen no flicker at all. As soon as I turn off Bluetooth a flicker occurs after a couple of minutes. I also copied the firmware file from the Windows drivers for the Dell Wireless 1830 card as Bluetooth wasn't finding any devices without it. I am not 100% sure, but I think before adding the bluetooth firmware I got flicker with Bluetooth ON as well. You can get the firmware file from this thread - https://bbs.archlinux.org/viewtopic.php?id=204739

I am running an XPS 9550 with an i7-6700HQ.

I had this problem with a Dell desktop; It was especially bad with the second monitor, which blanked out every time it lost focus. I can confirm that

- $ apt-add-repository "deb http://ppa.launchpad.net/canonical-kernel-team/ppa/ubuntu yakkety main"
- $ echo -en "Package: *\nPin: release o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority: -1\n" >> /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
- $ apt update
- $ apt install linux-image-extra-4.6.0-6-generic linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic

after having created the directory /etc/preferences.d manually, and so upgrading to the yakkety kernel, fixed the issue.

Can anyone please post the instruction to revert this and go back to normal Xenial kernel release when the bug is fixed there? Thanks!

Thiago Martins (martinx) wrote :

Still present on latest Xenial... :-(

Eugene San (eugenesan) on 2016-05-21
description: updated
Eugene San (eugenesan) wrote :

@romano-giannetti and anyone who followed the instructions referenced in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1554613/comments/125,
There was a typo in instructions, please read bug description for details and fix.

description: updated
Vasya Pupkin (shadowlmd) wrote :

I have flickering problem in Chrome on my ASUS UX301LA laptop. The funny thing is that latest kernel (4.6) doesn't fix anything.

@Vasya: seems a different problem. The flickering which this bug is referring to is application-independent, and visible in the full screen(s).

ArTaX (marco-zannoni) wrote :

I want to share my experience: I have a Dell XPS 13 9350 QHD SSD: 512GB RAM: 16GB. Bios 1.3.3.
I installed plain Ubuntu 16.04 erasing all Windows partitions. I did not apply any workaround (I read about this bug).
I do NOT experience this bug.

In the meantime I stambled upon these link, according to which TLP causes screen flickers:
https://ubuntu-mate.community/t/solved-screen-flickering-only-when-on-battery-skylake-16-04/5201/21

I don't know if it is the same problem, but you may try to disable/remove TLP.

I have this bug with Ubuntu only.
Linux mint 18 beta cinnamon (based on Ubuntu 16.04) does not have that that problem.
Maybe the Mint team have found a fix that could also be used on Ubuntu.

I don't know if Ubuntu uses different kernel than Mint.

I can help with testing Linux Mint 18 beta on different kernels if you want, so I can see if I get the same problem as Ubuntu with the Intel graphics card, but only if someone can tell me what i should test, and how to do it, because I have never done that before, but I want to find out if there is just the kernel Linux Mint 18 uses that is not affected or there is a fix on Linux Mint that Ubuntu does not have, because if there is a fix, then I think we also can use it on Ubuntu.

Still no problems with Linux Mint 18 beta, and I found out that Linux Mint 18 use the same kernel and driver as Ubuntu 16.04, so why does everything work in Linux Mint 18 Beta when not in Ubuntu 16.04?

I have the same card and I have the same problem with Ubuntu earlier as this bug is for, but after I installed Linux Mint instead of Ubuntu then I can't see any problems with graphics.

I don't know if I can help, but here is some files from my computer with logs and information that I hope can be used to fix the bug in Ubuntu.

Here is the output of:

lsb_release -a
Distributor ID: LinuxMint
Description: Linux Mint 18 Sarah
Release: 18
Codename: sarah

uname -a

Linux alexstrand7-HP-Pavilion-g6-Notebook-PC 4.4.0-24-generic #43-Ubuntu SMP Wed Jun 8 19:27:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Kenichi Ito (ken-i54k) wrote :

It seems that the screen flicker problem fixed in 4.4.0-24 .
Anyone else?

Environment:
XPS 13 9350
Ubuntu 16.04
kernel 4.4.0-24-generic
Bluetooth off

Giacomo Russo (giako87) wrote :

Same environment as in #136, I confirm that there's no flickering anymore.

Eugene San (eugenesan) wrote :

Confirming #136.

Environment (on 2 machines):
Machine: XPS 13 9350 FHD Display
Distro: Ubuntu 16.04
Kernel: 4.4.0-24-generic
Bluetooth: off and on
Firmware: 1.3.3 and 1.4.3
DE: Unity and GnomeFlashback
Power: On battery and on AC
Screen: eDP (Built-In) or/and DP1 (External TB3/USBC->HDMI)

Kenichi Ito (ken-i54k) on 2016-06-27
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Kostadin Stoilov (kmstoilov) wrote :

I can also confirm #136. Screen flickering has been gone on an XPS 9550 with BIOS 1.2.0 since upgrading to 4.4.0-24-generic.

Thiago Martins (martinx) wrote :

I'm on 4.4.0-28-generic (Xenial), problem still here.

A good website to test it, is TradingView:

https://www.tradingview.com/chart/7ipqeH3N/

Google Chrome window flickers a lot! Especially if you really use the above website, by login in, clicking on its functions, pop-up windows and etc...

Hardware is a Macbook Pro, end-2015.

Anmar Oueja (anmar) wrote :
Download full text (4.1 KiB)

Chrome flickers... but FF doesn't for me. Are you sure it isn't the browser.

On Thu, Jul 7, 2016 at 7:58 PM, Thiago Martins <email address hidden>
wrote:

> I'm on 4.4.0-28-generic (Xenial), problem still here.
>
> A good website to test it, is TradingView:
>
> https://www.tradingview.com/chart/7ipqeH3N/
>
> Google Chrome window flickers a lot! Especially if you really use the
> above website, by login in, clicking on its functions, pop-up windows
> and etc...
>
> Hardware is a Macbook Pro, end-2015.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1552304).
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>
> Status in Linux:
> Fix Released
> Status in linux package in Ubuntu:
> Fix Released
>
> Bug description:
> *** Temporary workaround ***
> Install Kernel from the following location:
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/
>
> OR
> Perform the following:
> - $ apt-add-repository "deb
> http://ppa.launchpad.net/canonical-kernel-team/ppa/ubuntu yakkety main"
> - $ echo -en "Package: *\nPin: release
> o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority: -1\n" >>
> /etc/apt/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
> - $ apt update
> - $ apt install linux-image-extra-4.6.0-6-generic
> linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic
> ```
> There was a typo in instructions (/etc/preferences.d should have been
> /etc/apt/preferences.d).
> As result you might have upgraded Linux META packages and therefor you
> won't receive proper upgrades of Xenial native Linux packages (hoping they
> will ever contain the fix).
> I suggest you move
> /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety to
> /etc/apt/preferences.d/ and downgrade related packages:
> $ apt update
> $ apt install linux-headers-generic/xenial-updates
> linux-tools-generic/xenial-updates linux-image-generic/xenial-updates
> ```
> ***
>
> Please inspect duplicate reports for more details:
> Bug #1522922
> Bug #1535048
> Bug #1552304
> Bug #1555158
> Bug #1561729
> Bug #1565234
> Bug #1568599
> Bug #1573392
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-22
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:670c Microdia
> Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linu...

Read more...

Thiago Martins (martinx) wrote :

Anmar,

I am 100% sure that it is not the browser, please guys, watch this:

https://www.youtube.com/watch?v=BC287yYPfTA

This BUG is not fixed. Or maybe, what I'm seeing here is a different bug.

On Ubuntu 16.10, things looks a little bit better but, Chrome still flickers.

Ubuntu 14.04 is fine. While 16.04 and 16.10 are just terrible.

Anmar Oueja (anmar) wrote :
Download full text (4.3 KiB)

Yikes. In your case it isn't the browser for sure. I read somewhere that
the adaptive brightness control might be a culprit but don't count on that
being true unless confirmed.

On Thu, Oct 6, 2016 at 11:38 AM, Thiago Martins <email address hidden>
wrote:

> Anmar,
>
> I am 100% sure that it is not the browser, please guys, watch this:
>
> https://www.youtube.com/watch?v=BC287yYPfTA
>
> This BUG is not fixed. Or maybe, what I'm seeing here is a different
> bug.
>
> On Ubuntu 16.10, things looks a little bit better but, Chrome still
> flickers.
>
> Ubuntu 14.04 is fine. While 16.04 and 16.10 are just terrible.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1552304).
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>
> Status in Linux:
> Fix Released
> Status in linux package in Ubuntu:
> Fix Released
>
> Bug description:
> *** Temporary workaround ***
> Install Kernel from the following location:
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/
>
> OR
> Perform the following:
> - $ apt-add-repository "deb http://ppa.launchpad.net/
> canonical-kernel-team/ppa/ubuntu yakkety main"
> - $ echo -en "Package: *\nPin: release o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority:
> -1\n" >> /etc/apt/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
> - $ apt update
> - $ apt install linux-image-extra-4.6.0-6-generic
> linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic
> ```
> There was a typo in instructions (/etc/preferences.d should have been
> /etc/apt/preferences.d).
> As result you might have upgraded Linux META packages and therefor you
> won't receive proper upgrades of Xenial native Linux packages (hoping they
> will ever contain the fix).
> I suggest you move /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
> to /etc/apt/preferences.d/ and downgrade related packages:
> $ apt update
> $ apt install linux-headers-generic/xenial-updates
> linux-tools-generic/xenial-updates linux-image-generic/xenial-updates
> ```
> ***
>
> Please inspect duplicate reports for more details:
> Bug #1522922
> Bug #1535048
> Bug #1552304
> Bug #1555158
> Bug #1561729
> Bug #1565234
> Bug #1568599
> Bug #1573392
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-22
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:...

Read more...

Lorenzo Bettini (bettini) wrote :

At least for my DELL 3800, current kernel in Ubuntu Xenial, 4.4.0-38.57, fixes the flickering

Sukttarb (n-kb0) wrote :

On my Dell XPS 13-9350, I had been running 4.4.0-38.57 for two weeks and continued to experience screen flash while using google-chrome-beta until updating this morning to 54.0.2840.50-1. No more flash. Halleluja!

Anmar Oueja (anmar) wrote :
Download full text (4.2 KiB)

Guys, there is an entry on the Chromium site talking about xorg modesetting
vs intel xorg driver. By installing modesetting module and getting rid of
the intel driver, the flicker was gone completely on Ubuntu 16.04.

https://bugs.chromium.org/p/chromium/issues/detail?id=606152#c73

On Thu, Oct 6, 2016 at 10:27 AM, Sukttarb <email address hidden>
wrote:

> On my Dell XPS 13-9350, I had been running 4.4.0-38.57 for two weeks and
> continued to experience screen flash while using google-chrome-beta
> until updating this morning to 54.0.2840.50-1. No more flash. Halleluja!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1552304).
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>
> Status in Linux:
> Fix Released
> Status in linux package in Ubuntu:
> Fix Released
>
> Bug description:
> *** Temporary workaround ***
> Install Kernel from the following location:
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/
>
> OR
> Perform the following:
> - $ apt-add-repository "deb http://ppa.launchpad.net/
> canonical-kernel-team/ppa/ubuntu yakkety main"
> - $ echo -en "Package: *\nPin: release o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority:
> -1\n" >> /etc/apt/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
> - $ apt update
> - $ apt install linux-image-extra-4.6.0-6-generic
> linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic
> ```
> There was a typo in instructions (/etc/preferences.d should have been
> /etc/apt/preferences.d).
> As result you might have upgraded Linux META packages and therefor you
> won't receive proper upgrades of Xenial native Linux packages (hoping they
> will ever contain the fix).
> I suggest you move /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
> to /etc/apt/preferences.d/ and downgrade related packages:
> $ apt update
> $ apt install linux-headers-generic/xenial-updates
> linux-tools-generic/xenial-updates linux-image-generic/xenial-updates
> ```
> ***
>
> Please inspect duplicate reports for more details:
> Bug #1522922
> Bug #1535048
> Bug #1552304
> Bug #1555158
> Bug #1561729
> Bug #1565234
> Bug #1568599
> Bug #1573392
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-22
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:670c Microdia
> Bus 001 Device 002: ID...

Read more...

John Smith (atesting) wrote :

I'm having this same issue on a Dell 7537 running Ubuntu 16.10 (kernel 4.8).

The flickering that occurs is a rapid change in the brightness of the screen, in a random, persistently manner (it never stops).
Not so often the screen goes all white and quickly returns to normal.

It's interesting to mention that on Ubuntu 16.04 (kernel 4.4) the bug appears to be fixed, as the flickering does not occur.

Michel-Ekimia (michel.ekimia) wrote :

I can happily confirm that this does not occur anymore on Ubuntu 16.04 ( kernel 4.4) .

tags: removed: kernel-da-key needs-reverse-bisect

Just started noticing this(?) bug (matches symptoms) on my system 3 or 4 days ago. Using Linux Mint:

System: Host: vtpoet-Lenovo-Yoga-2-11 Kernel: 4.8.0-040800-generic x86_64 (64 bit) Desktop: Cinnamon 3.2.7
           Distro: Linux Mint 18.1 Serena
Machine: System: LENOVO (portable) product: 20428 v: Lenovo Yoga 2 11
           Mobo: LENOVO model: VIUU4 v: 31900058WIN Bios: LENOVO v: AACN21WW date: 01/30/2015
CPU: Dual core Intel Core i3-4012Y (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 1500 MHz 1: 1500 MHz 2: 1500 MHz 3: 1499 MHz 4: 1500 MHz
Graphics: Card: Intel Device 0a1e
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell GLX Version: 3.0 Mesa 12.0.6

Have tried kernels:

4.4x
4.8x
4.10x
4.11x

Doesn't affect TTY.

Same here. I upgraded from Xubuntu 16.04 to 17.04 maybe a month ago and that finally fixed my screen flickering issue, but it has now returned. I have been seeing it again at least couple of days now.

Running kernel 4.10.0-21-generic on Asus Zenbook laptop with Intel Skylake.

Brad Buran (bburan) wrote :
Download full text (4.1 KiB)

Same here. It appears to have reappeared using the XPS9350.
4.10.0-21-generic. Flickering is intermittent (e.g., once a day) and
goes away if I resize the window I'm currently using.

On Sat, May 27, 2017 at 8:02 AM, Mikko Rytkönen <email address hidden> wrote:
> Same here. I upgraded from Xubuntu 16.04 to 17.04 maybe a month ago and
> that finally fixed my screen flickering issue, but it has now returned.
> I have been seeing it again at least couple of days now.
>
> Running kernel 4.10.0-21-generic on Asus Zenbook laptop with Intel
> Skylake.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1554613
>
> Title:
> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>
> Status in Linux:
> Fix Released
> Status in linux package in Ubuntu:
> Fix Released
>
> Bug description:
> *** Temporary workaround ***
> Install Kernel from the following location:
> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/
>
> OR
> Perform the following:
> - $ apt-add-repository "deb http://ppa.launchpad.net/canonical-kernel-team/ppa/ubuntu yakkety main"
> - $ echo -en "Package: *\nPin: release o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority: -1\n" >> /etc/apt/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
> - $ apt update
> - $ apt install linux-image-extra-4.6.0-6-generic linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic
> ```
> There was a typo in instructions (/etc/preferences.d should have been /etc/apt/preferences.d).
> As result you might have upgraded Linux META packages and therefor you won't receive proper upgrades of Xenial native Linux packages (hoping they will ever contain the fix).
> I suggest you move /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety to /etc/apt/preferences.d/ and downgrade related packages:
> $ apt update
> $ apt install linux-headers-generic/xenial-updates linux-tools-generic/xenial-updates linux-image-generic/xenial-updates
> ```
> ***
>
> Please inspect duplicate reports for more details:
> Bug #1522922
> Bug #1535048
> Bug #1552304
> Bug #1555158
> Bug #1561729
> Bug #1565234
> Bug #1568599
> Bug #1573392
>
> does not affect 4.4.0-8
> affects 4.4.0-9 to 4.4.0-22
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-generic 4.4.0.11.12
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
> CurrentDesktop: KDE
> Date: Tue Mar 8 09:57:12 2016
> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
> InstallationDate: Installed on 2016-01-07 (61 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 0c45:670c Microdia
> Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.
> Bus 001 Device 001: ID 1d6b:0002 Li...

Read more...

Anmar Oueja (anmar) wrote :
Download full text (8.1 KiB)

Have you guys tried uninstalling the Intel Xorg driver so you default
to kernel mode settings. That solved a lot of flicker issues for me.

$ sudo dpkg --purge install xserver-xorg-video-intel

On Tue, May 30, 2017 at 12:02 PM, Brad Buran <email address hidden> wrote:
> Same here. It appears to have reappeared using the XPS9350.
> 4.10.0-21-generic. Flickering is intermittent (e.g., once a day) and
> goes away if I resize the window I'm currently using.
>
> On Sat, May 27, 2017 at 8:02 AM, Mikko Rytkönen <email address hidden> wrote:
>> Same here. I upgraded from Xubuntu 16.04 to 17.04 maybe a month ago and
>> that finally fixed my screen flickering issue, but it has now returned.
>> I have been seeing it again at least couple of days now.
>>
>> Running kernel 4.10.0-21-generic on Asus Zenbook laptop with Intel
>> Skylake.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1554613
>>
>> Title:
>> Screen flickers on XPS 13 9350/9550 (Intel Skylake/Broadwell GPU)
>>
>> Status in Linux:
>> Fix Released
>> Status in linux package in Ubuntu:
>> Fix Released
>>
>> Bug description:
>> *** Temporary workaround ***
>> Install Kernel from the following location:
>> - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/
>>
>> OR
>> Perform the following:
>> - $ apt-add-repository "deb http://ppa.launchpad.net/canonical-kernel-team/ppa/ubuntu yakkety main"
>> - $ echo -en "Package: *\nPin: release o=LP-PPA-canonical-kernel-team-ppa\nPin-Priority: -1\n" >> /etc/apt/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety
>> - $ apt update
>> - $ apt install linux-image-extra-4.6.0-6-generic linux-headers-4.6.0-6-generic linux-tools-4.6.0-6-generic
>> ```
>> There was a typo in instructions (/etc/preferences.d should have been /etc/apt/preferences.d).
>> As result you might have upgraded Linux META packages and therefor you won't receive proper upgrades of Xenial native Linux packages (hoping they will ever contain the fix).
>> I suggest you move /etc/preferences.d/canonical-kernel-team-ubuntu-ppa-yakkety to /etc/apt/preferences.d/ and downgrade related packages:
>> $ apt update
>> $ apt install linux-headers-generic/xenial-updates linux-tools-generic/xenial-updates linux-image-generic/xenial-updates
>> ```
>> ***
>>
>> Please inspect duplicate reports for more details:
>> Bug #1522922
>> Bug #1535048
>> Bug #1552304
>> Bug #1555158
>> Bug #1561729
>> Bug #1565234
>> Bug #1568599
>> Bug #1573392
>>
>> does not affect 4.4.0-8
>> affects 4.4.0-9 to 4.4.0-22
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 16.04
>> Package: linux-image-generic 4.4.0.11.12
>> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
>> Uname: Linux 4.4.0-8-generic x86_64
>> ApportVersion: 2.20-0ubuntu3
>> Architecture: amd64
>> AudioDevicesInUse:
>> USER PID ACCESS COMMAND
>> /dev/snd/controlC0: tbonfort 1498 F.... pulseaudio
>> CurrentDesktop: KDE
>> Date: Tue Mar 8 09:57:12 2016
>> HibernationDevice: RESUME=UUID=3248e0d7-0dac-4ccc-8982-b5ac5ce6ed5e
>> ...

Read more...

Kẏra (thekyriarchy) wrote :
cement_head (andor-udel) wrote :

I also am experiencing this bug on 16.04.3 LTS

i7 7500U Kaby Lake HD 620 using Intel Driver.

Gustavo L (gustavo-lapido) wrote :

Flickering still going on my Dell Inspiron N4050

Linux N4050 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:printing-9.20160110ubuntu0.2-amd64:printing-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:27 memory:f6800000-f6bfffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff

Displaying first 40 and last 40 comments. View all 155 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.