Ubuntu

Docking station audio I/O support for Thinkpad X230 tablet

Reported by David Henningsson on 2012-07-20
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson

Bug Description

This bug is used for tracking purposes. Please do not triage.

Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
tags: added: blocks-hwcert-enablement
David Henningsson (diwic) wrote :

Accepted by upstream and will come through upstream stable.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in linux (Ubuntu):
importance: Undecided → Medium
darthvader (sarmbruster) wrote :

Audio currentl y does not work on a Thinkpad X230 (not the tablet!) via docking station. I've installed the mainline kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2012-08-01-quantal/ and there is no sound on the docking station. Is your patch contained in this kernel. (sorry for the potentially dumb question, I'm by far not well informed about the kernel deployment process here).

David Henningsson (diwic) wrote :

@darthvader, I don't know, but I think it should be. Please file a separate bug with this command "ubuntu-bug audio" as your machine is different from this bug's machine. Thanks!

madbiologist (me-again) wrote :

@darthvader - That model needs a separate patch, which has just landed upstream in the 3.6 kernel and should be available in 3.6-rc2:

author Felix Kaechele
Mon, 6 Aug 2012 21:02:01 +0000 (23:02 +0200)
committer Takashi Iwai
Tue, 7 Aug 2012 06:02:49 +0000 (08:02 +0200)
commit c8415a48fcb7a29889f4405d38c57db351e4b50a
tree 47b1a3aa82a329a5e8f5b52ad8db9951887a7326
parent 8dfaa573918afa34c8eaf8b2120b2e38cc4f651f

ALSA: hda - add dock support for Thinkpad X230

As with the ThinkPad Models X230 Tablet and T530 the X230 needs a qurik to
correctly set up the pins for the dock port.

Signed-off-by: Felix Kaechele
Cc: <email address hidden> [v3.2+]
Signed-off-by: Takashi Iwai

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-10.10

---------------
linux (3.5.0-10.10) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * rebase to v3.5.1

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_AFS_FSCACHE=y
    - LP: #728977

  [ Tim Gardner ]

  * SAUCE: firmware: Remove emi62 files duplicated in linux-firmware
  * SAUCE: firmware: Remove tehuti files duplicated in linux-firmware

  [ Upstream Kernel Changes ]

  * overlayfs: copy up i_uid/i_gid from the underlying inode
    - LP: #944386
  * hwmon: (applesmc) Shorten minimum wait time
    - LP: #1034449
  * hwmon: (applesmc) Decode and act on read/write status codes
    - LP: #1034449

  [ Upstream Kernel Changes ]

  * rebase to v3.5.1
    - LP: #1026953
    - LP: #1025377
 -- Leann Ogasawara <email address hidden> Sun, 12 Aug 2012 13:16:43 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-30.47). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Luis Henriques (henrix) wrote :

Since the commit for this issue came in via a stable upstream release, I'm tagging it as verified.

tags: added: verification-done-precise
removed: verification-needed-precise
Tyler Moore (twmoore) wrote :

I just installed the latest linux release on precise-proposed, and it did not fix the problem. The version it installed is 3.2.0.30.32, not 47, so I'm not sure if the newer release actually fixes the problem. However, I don't know how to actually install 3.2.0.30.47.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Donjan Rodic (bryonak) wrote :

Confirming that 3.2.0-31.50 produces sound from an Ultrabase Series 3 with a X230 (not tablet), correctly handling pluggin in/out of both the Ultrabase and the Thinkpad. (mine isn't a tablet, but 3.2.0-30.32 didn't work with respect to audio from the dock)

However there is a very strange effect: when plugged into the Ultrabase, every time I do a "GUI highlight" (select an indicator, hover over a menu item, switch windows), there is a cracking static-like noise from the headphones. This is independent of the mouse used, and selecting an indicator and browsing left/right with the keyboard has the same effect, just like alt+tabbing. Simply writing as I do now also causes a very weak static noise, but it's barely audible.
The explanation of "dodgy wiring" within the Ultrabase AFAICT makes little sense because of how the error occurs. I've tried every sensible port combination of USB mouse+keyboard and audio jack on Thinkpad and dock: it consistently produces noise when the headphones are plugged into the dock.
Using the audio jack on the Thinkpad itself causes no such noises, i.e. it's absolutely quiet and the music is perfectly clear.

Should I file a separate bug for the non-tablet X230? And do we get an ETA on when the X230 specific fix by Felix Kaechele is going to land in the LTS release?

Stefan Freyr (stefan-freyr) wrote :

I'm having this same problem on my Lenovo T430 and Ultrabase Series 3.

No audio from the dock jack.

I've also commented on bug 893611 since that's also related but I'm a little confused whether I should be commenting on all of these bugs that I find that don't use the exact same model of laptop as I do or whether I should create a new bug for my exact configuration.

Fabian Schäfer (uo-li) wrote :

Same as Stefan, I've filed the following bug:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1064497

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers