[HDA-Intel - HDA Intel PCH, playback] ThinkPad Mini Dock Series 3 no sound on 3.5 mm TRS socket

Bug #1064497 reported by uo on 2012-10-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Rolf Leggewie

Bug Description

Same Problem as:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/893611
or
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1026953

Seems my Model needs to be added to the table:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/893611/comments/12

Workaround via /etc/modprobe.d/alsa-base.conf brings no change, neither does kernel update to 3.2.0-30.48.

Keep up the good work!

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic-pae 3.2.28
Uname: Linux 3.2.0-31-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC3202 Analog [ALC3202 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: claudia 1694 F.... pulseaudio
 /dev/snd/pcmC0D0c: claudia 1694 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2530000 irq 45'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,17aa21f3,00100203 HDA:80862806,80860101,00100000'
   Controls : 36
   Simple ctrls : 13
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Oct 9 17:53:36 2012
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release i386 (20120817.3)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Eingebautes Audio - HDA Intel PCH
Symptom_Type: Only some of outputs are working
Title: [HDA-Intel - HDA Intel PCH, playback] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/25/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G1ET41WW (1.16 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2344CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG1ET41WW(1.16):bd05/25/2012:svnLENOVO:pn2344CTO:pvrThinkPadT430:rvnLENOVO:rn2344CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2344CTO
dmi.product.version: ThinkPad T430
dmi.sys.vendor: LENOVO
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2012-10-09T15:38:41.282970

uo (uo-li) wrote :
Stefan Freyr (stefan-freyr) wrote :

Probably a duplicate of bug 1060372.

uo (uo-li) wrote :

@Stefan
Possible, although I am using
LENOVO ThinkPad Mini Dock Series 3 U,
not the Ultrabase.

uo (uo-li) wrote :

Thx @Raymond!

Unfortunately I am no good with git and don't have much time to learn it at the moment.
Could somebody patch it for me?
I will try to compile and will happily test it asap of course.

Raymond (superquad-vortex2) wrote :

ALC269/270/275/276/280/282
======
  laptop-amic Laptops with analog-mic input
  laptop-dmic Laptops with digital-mic input
  alc269-dmic Enable ALC269(VA) digital mic workaround
  alc271-dmic Enable ALC271X digital mic workaround
  inv-dmic Inverted internal mic workaround
  lenovo-dock Enables docking station I/O for some Lenovos

Raymond (superquad-vortex2) wrote :

try model=lenovo-dock

or

Codec: Realtek ALC3202
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x10ec0269
Subsystem Id: 0x17aa21f3
Revision Id: 0x100203
No Modem Function Group found

       SND_PCI_QUIRK(0x17aa, 0x21ca, "Thinkpad L412", ALC269_FIXUP_SKU_IGNORE),
        SND_PCI_QUIRK(0x17aa, 0x21e9, "Thinkpad Edge 15", ALC269_FIXUP_SKU_IGNORE),
        SND_PCI_QUIRK(0x17aa, 0x21f6, "Thinkpad T530", ALC269_FIXUP_LENOVO_DOCK),
+ SND_PCI_QUIRK(0x17aa, 0x21f3, "Thinkpad T430", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x21fb, "Thinkpad T430s", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x2203, "Thinkpad X230 Tablet", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x3bf8, "Quanta FL1", ALC269_FIXUP_QUANTA_MUTE),
        SND_PCI_QUIRK(0x17aa, 0x3bf8, "Lenovo Ideapd", ALC269_FIXUP_PCM_44K),

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Orcinus (mannfeld) wrote :

@ Raymond: "try model=lenovo-dock" worked on my TP430 connected to Mini Dock series 3!
Thank you very much! Now I've got hard rocking sound on my external hifi system! :-)

Rolf Leggewie (r0lf) wrote :

does this ever occur in trusty or later?

Changed in alsa-driver (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
uo (uo-li) wrote :

I'll probably only be able to check at the end of July as this is at my Mum's place... Sorry!

uo (uo-li) wrote :

Problem is gone, even back in 12.04, probably with the HWE-Stack update.
I think this can be closed.

Rolf Leggewie (r0lf) wrote :

Thank you for reporting back.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers