Ubuntu

eclipse: tooltips unreadable

Reported by Pavel Rojtberg on 2010-03-17
474
This bug affects 100 people
Affects Status Importance Assigned to Milestone
light-themes
Unknown
Unknown
eclipse (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned
light-themes (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: light-themes

the tooltip that appears when you hover with the mouse over some code uses black font on black background..

ProblemType: Bug
Architecture: i386
Date: Wed Mar 17 16:39:00 2010
DistroRelease: Ubuntu 10.04
Package: light-themes 0.1.5.8
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: light-themes
Uname: Linux 2.6.32-16-generic i686

Pavel Rojtberg (rojtberg) wrote :
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Could you provide a screenshot of the problem? It would help us understand the problem better. [not everyone has eclipse installed]

Changed in light-themes (Ubuntu):
status: New → Incomplete

I confirm this bug. I use Ubuntu 9.10 and eclipse 3.5.2.
There is workaround:
export GDK_NATIVE_WINDOWS=1
See: http://ubuntuforums.org/showthread.php?t=1305012

Pavel Rojtberg (rojtberg) wrote :

@adam:
no this is a theming issue. I am already using NATIVE_WINDOWS.

Vish (vish) on 2010-03-19
Changed in light-themes (Ubuntu):
status: Incomplete → New
Jonas Schwabe (jonas-schwabe) wrote :

The problem appears not only with the new themes, new wave or other themes that were available and working with eclipse during the last release does not work as expected now. Are you sure this is a bug in the light-themes package?

Vish (vish) wrote :

Confirming bug from dups

Changed in light-themes (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Slug (slugzero) wrote :

Looks like there is no way to configure this in the preferences, however the following works for me to set the tooltip background in Eclipse CDT to the familiar yellow from Human:

Modify or add the following lines in
eclipse_workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings/org.eclipse.cdt.ui.prefs

sourceHoverBackgroundColor=245,245,181
sourceHoverBackgroundColor.SystemDefault=false

Klaus Purer (klausi) wrote :

@Slug: This works for me only once after starting Eclipse, hovering over another variable or method shows the black in black tooltip again.

mathieg2 (graeme-salsaholics) wrote :

Found a better workaround. None of the suggested ones worked for me.

In ubuntu,

right click on desktop,
click change desktop background,
click theme,
click customise,
click colours
Change background colour back to yellow, and foreground colour to black.

mathieg2 (graeme-salsaholics) wrote :

Cant find an edit button - but Its the tooltip background colour you set to yellow.

You can also do:

System > Preferences > Appearance
Click Customize ...
Select the Colors tab
Set the background color for Tooltips to #F6F88B
Set the foreground color for Tooltips to #000000

And restart Eclipse after that.

Alexey Kotlyarov (koterpillar) wrote :

Isn't it Eclipse's fault to draw tooltip text black, when it should be white as per theme?

Alexey Kotlyarov (koterpillar) wrote :

For non-C development, there are other files setting it:
alex@flower2:~/projects/.metadata$ find . -name *.prefs | xargs grep sourceHoverBackgroundColor
./.plugins/org.eclipse.core.runtime/.settings/org.eclipse.cdt.ui.prefs:sourceHoverBackgroundColor=245,245,181
./.plugins/org.eclipse.core.runtime/.settings/org.eclipse.cdt.ui.prefs:sourceHoverBackgroundColor.SystemDefault=false
./.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ruby.ui.prefs:sourceHoverBackgroundColor=0,0,0
./.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ruby.ui.prefs:sourceHoverBackgroundColor.SystemDefault=true
./.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ui.prefs:sourceHoverBackgroundColor.SystemDefault=true
./.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ui.prefs:sourceHoverBackgroundColor=0,0,0

And the last two (Ruby and DLTK) get reset after shutting down Eclipse, even though I've set it to the same as CDT.

Vincenzo Pii (vinc-pii) wrote :

I can confirm this bug, and want to thank Slug (comment #7) for that not-intrusive workaround that solved the issue without changing the whole system aspect settings!

Philipp Wendler (philw85) wrote :

This bug should definitely be fixed. While the normal text on the tooltip was white for me and there readable (although very ugly IMO), additional content of the tooltip like icons and especially links are not visible well (see attachment). Changing the tooltip colors of the theme works for me. In my opinion, the tooltips of a light theme should not be black anyway but yellow like the users are accustomed to.

Damien Lecan (dlecan) wrote :

Duplicates bug #572209 ?

cfriedt (chrisfriedt) wrote :

In reply to comment #12

It is not eclipse's fault, per se. Eclipse uses several different text colours according to the syntax highlighting of the editor being used. If it were eclipse's "fault", then Eclipse would be responsible to check every single possible conflict of colours and dynamically re-configure the theme, which is completely ridiculous, and invalidates the entire point of eclipse managing its own syntax highlighting.

It should actually be gtk's responsibility to recognize when applications specify custom text colours / themes. In those cases, gtk should _not_ apply the default text colour / font / etc, but rather those specified by the application. Only when an application does not specify custom text colours / fonts / etc, should gtk resort to the default text colour / font / etc.

It is Eclipse's fault IMHO. GTK theme specifies that:
- editor text should be drawn using background color A and foreground
color B.
- tooltips should be drawn using background color C and foreground color
D.
It guarantees that A and B, as well as C and D, are distinguishable.

Eclipse makes an incorrect assumption that if it mixes all the colors
together, D will be fine on A.

GTK can do nothing to prevent Eclipse from using the theme's colors (see
http://bugs.launchpad.net/bugs/554600 for another example).

Charles Kozler (ckozleriii) wrote :

I can confirm this too. Also, I do not think this is specific to just eclipse and may be a more higher level thing as Pidgin reacts the same way:

http://ubuntuforums.org/showthread.php?t=1305012

Charles Kozler (ckozleriii) wrote :

Comment #9 worked properly. I am using Eclipse's PHP editor and the suggestions above did not work. Also, editing the theme "tooltips" color selection from black to white fixed hte issue pidgin as well.

Vinay Pai (vinay.pai) wrote :

I'm editing using PHP mode. When I set the sourceHoverBackgroundColor property in org.eclipse.dltk.ui.prefs it sometimes works right after I restart eclipse then reverts to black, and gets set back to 0,0,0 in the file. #9 worked for me for now though.

wdesmet (kromagg) wrote :

I'd just like to add that a secondary problem is the javadoc display. This also uses a black background, with white text. The problem being that links are using dark blue, which is unreadable on pure black.

Confirm #22 - I also can achieve a temporary fix, but it does seem to revert when I change the file I'm editing.
The only permanent solution is the Workaround that is #9 (i.e. changing default colour scheme for tooltips).

BigBadBassMan (d-reiche) wrote :

in reply to #18:

This has absolutely nothing to do with eclipse!
If an application developer wants to use custom fg and bg colors, he/she will have a reason to do so, rather than using the system defined ones. (And if it is simply, because he/she wants his/her app to look the same, no matter what theme/distro is used, that should also be respected!)

In such a case, the gtk has to repsect the applications settings, rather than enforcing some system defined defaults!
Maybe there is not function in gtk te let an application tell the toolkit to use the default colors? That is not a fault of Eclispe either. If an application specifies colors, those should be respected, not overriden!
Also, the whole mess with GDK_NATIVE_WINDOWS is ridiculous. Why isn't the some sort of compatibility API, if the developers decide to change the API between minor releases?
I had to set this flag for flash too, because some flash apps where not usable. And it took ages to find out that it was GDK not flash that was faulty, and where to apply the fix...

Alexey Kotlyarov (koterpillar) wrote :

Eclipse *can* override all colors (see comment #7), but only for C. And
the problem is, by default it overrides the foreground color but not the
background, therefore the mess.

So a solution will be to either respect all theme colors, or none (and
end up with something like the notebook crapware:
http://www.fcenter.ru/img/article/notebooks/Lenovo_IdeaPad_Y550P/152311.jpg)

BigBadBassMan (d-reiche) wrote :

nope, this happens also for the PHP and JAVA flavours of Eclipse.
besides that, changing the theme to something other than Ambiance or Radiance solves the problem.

So, is it a bad theme-ing decision to use dark backgrounds,
or the eclispe folks, who have not considered that the backgroundcolor may be dark, and forgot to set the foreground color explicitely?

Anyway, it is not user friendly, to tell folks to use a different theme, when their most used application is barely usable.

The problem with manually changing the colors is: eclipse may work, but you break tooltips in other apps!
For me, eclipse showed TTs with black text on light background, whereas Firefox tried to render background and text of Tooltips in light colors - same as above but the other way around. Only reason was to switch to a different theme.

Alexey Kotlyarov (koterpillar) wrote :

> nope, this happens also for the PHP and JAVA flavours of Eclipse.
And Ruby, but for all those the fix from #7 does not work.

> For me, eclipse showed TTs with black text on light background,
> whereas Firefox tried to render background and text of Tooltips in
> light colors - same as above but the other way around. Only reason
> was to switch to a different theme.
I have changed the tooltips to be dark on light, this works everywhere.

Vadim Dmitriev (dmgloss) wrote :

Fixed in latest eclipse 3.6 RC2: https://bugs.eclipse.org/309907

NormInNorman (nsmelton) wrote :

I had the same problem as BigBadBassMan. Unfortunately I'm using ZendStudio so I can't update to Eclipse 3.6 until Zend does. My fix was to change tooltips to text=black and blackgorund=#808080, which is halfway between black and white. Now in both Zend Studio AND Firefox I can read the tooltips. To me it looks bad, but at least I can use it.

Niels Thykier (niels-thykier) wrote :

Vadim Dmitriev wrote:
> Fixed in latest eclipse 3.6 RC2: https://bugs.eclipse.org/309907
>

Hi

I have tried to backport this to the eclipse in Ubuntu and have uploaded
modified versions of eclipse to the team PPA[1].

If you decide to test if this patch work, please remember to test with a
"clean" eclipse (rename ~/.eclipse and create a new workspace for the
test). This is especially true for all of who have deployed a workaround.

~Niels

[1] https://launchpad.net/~eclipse-team/+archive/debian-package

Tried the 3.6RC2 of Eclipse and the problem is _not_ fixed.

Niels Thykier (niels-thykier) wrote :

Michele Costantino Soccio wrote:
> Tried the 3.6RC2 of Eclipse and the problem is _not_ fixed.
>

Hi

If you downloaded that 3.6RC2 from eclipse.org, then please report your
result directly to the upstream bug so they are aware of it and can
revise their solution. There is a link to it in this report.

~Niels

NB: Just for clarification, the packages I uploaded to the PPA mentioned
in my previous post is a patched 3.5.2 and not 3.6 - if you used those,
please test the 3.6RC2 from eclipse.org before posting on the upstreams
bug tracker.

Alexey Kotlyarov (koterpillar) wrote :

The PPA package fixed Javadoc and Java tooltips, but changed nothing for Ruby (DLTK).

Benjamin Drung (bdrung) on 2010-06-05
Changed in eclipse (Ubuntu):
status: New → Triaged
Benjamin Drung (bdrung) on 2010-06-05
Changed in eclipse (Ubuntu):
importance: Undecided → Low
Niels Thykier (niels-thykier) wrote :

@Alexey Kotlyarov

Hi

We recently uploaded a new package to the PPA with another patch; does that fix the Ruby/DLTK issue? If not then we need to forward this issue upstream.

~Niels

Changed in eclipse (Ubuntu):
status: Triaged → Incomplete
Alexey Kotlyarov (koterpillar) wrote :

Pardon, where is the package? I don't see any updates on https://launchpad.net/~eclipse-team/+archive/debian-package...

Changeing tooltips color in Apereance corects that.
Maybe themes would be updated soon, not such a killer bug, maybe would be ok to duplicate themes with different tooltips colors.
same for community themes.

Niels Thykier (niels-thykier) wrote :

Hi

We have committed the two patches and they will be a part of the new upload.

@Alexey Kotlyarov

The "new" packages are the ones uploaded on "2010-06-05" (I uploaded a few days before I posted here). I suspect that the second patch will not fix the Ruby/DLTK issue and we will have to file a bug against it upstream.

~Niels

Changed in eclipse (Ubuntu):
status: Incomplete → Fix Committed
jollyr0ger (jollyr0ger) wrote :

Where we'll can downdload that package? Tnx

Niels Thykier (niels-thykier) wrote :

Hi

You can either fetch it from the PPA at [1] or wait for us to upload it. For the Maverick release, it will probably be stalled until after the weekend.

For Lucid (10.04) there is no more changes expected; we may be able to get that uploaded already tomorrow.

~Niels

[1] https://launchpad.net/~eclipse-team/+archive/debian-package

Benjamin Drung (bdrung) wrote :

Attached the uploaded SRU debdiff for lucid.

Changed in eclipse (Ubuntu Lucid):
status: New → Fix Committed

Accepted eclipse into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Daniele Dellafiore (ildella) wrote :

I have another example of colors messing up with Ubuntu 10.04 and Eclipse 3.6 with Aptana 2
In the Aptana HTML editor, the content assist does not take the correct color.

The content assist windows is supposed to take the "input boxes" colors from the appearance theme editor. But as long as the background is correctly white and change color accordingly to the theme editor, the font foreground should be black but is white instead.
Other Eclipse content assist works right.

It seems to me problem is closer to GTK or OpenJDK, what do you think?

Niels Thykier (niels-thykier) wrote :

Hi

Ubuntu does not have eclipse 3.6 at the present time nor does Ubuntu ship this plugin, so I cannot do anything to fix your particular issue. Though I am interested in seeing it fixed since eclipse 3.6 is likely to the default in the release after Maverick.
  I suggest you file a bug upstream against the Aptana HTML editor; feel free to link the bug to this bug so we can track it (others might also be interested in the progress as well).

The past cases of this issue has been that SWT or/and a particular plugin used its own colors instead of fetching the theme colours by default. You may want to point the Aptana developers to [1] (also linked from this bug).

~Niels

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=309907

Nikke (nmellegard) wrote :

I'm experiencing the same problem with DavMail (http://sourceforge.net/projects/davmail/) and its popups from the tray icon. The window type of the popup is reported as "Tooltip".
I'm guessing that the Eclipse patch won't fix this problem? Is it maybe an underlying SWT problem?

Using:
Ubuntu Lucid, all updates as of June 28 2010
Sun Java SDK/JRE version 6.20dlj-1ubuntu3
libswt-gtk-3.5-java version 3.5.1-versiondump-2ubuntu2

All the best
N

Niels Thykier (niels-thykier) wrote :

@Nikke

The problem could be SWT[1], it could also be in davmail. However, please keep in mind that these patches only affects eclipse! The SWT from libswt-gtk-3.5-java is from a completely different source package and has (to the best of my knowledge) not been updated.

It would be logical to assume that since I am co-maintainer of eclipse that I also had something to do with libswt-gtk-3.5-java, but I do not. For various reasons, swt-gtk is not team maintained in Debian and therefore I cannot really touch it[2]. It does not prevent anyone from updating it in Ubuntu, but I have a feeling that nobody has done so.

~Niels

[1] Which is quite possible since there was an "SWT" patch for this kind of issue. Though it does not fix all of this kind of issues.

[2] All my work is done in Debian and Ubuntu pulls it from there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.2-4

---------------
eclipse (3.5.2-4) unstable; urgency=low

  [ Niels Thykier ]
  * Added menu entry for the Debian menu.
  * Moved a lot of arch-indep plugins into eclipse-platform-data.
  * Backported fix for poor tooltip colors with certain themes.
    (Closes: #582302, LP: #540332)
  * Backported fix for hover text visability problem.
  * Corrected a format issue in debian/copyright.
  * Removed depends on cvs for eclipse-plugin-cvs, it is not needed.
    (LP: #592508)
  * Removed Depends on JRE for libequinox-osgi-java.
  * Added patch to use sat4j 2.2 instead of 2.1 (Closes: #586978)
  * Added recommends on eclipse-pde for eclipse-platform.
    (LP: #593260)
  * Added patch to install the o.e.equinox.concurrent plugin in
    eclipse-platform (Closes: #585178)
  * Bumped (Build-)Depends on libhamcrest-java to 1.1-8 to avoid
    being affected by a regression in libhamcrest-java 1.1-7.

  [ Adnan Hodzic ]
  * Added debian/patches/fix-bashism.patch (Closes: #581099)

  [ Yulia Novozhilova ]
  * Added the Maven POMs for libequinox-osgi.java (LP: #598039)
  * Added a Build-Depends dependency on maven-repo-helper and maven-ant-helper
  * Added missing recommends on libservlet2.5-java for libequinox-osgi-java.

  [ Benjamin Drung ]
  * Bump Standards-Version to 3.9.0 (no changes required).
 -- Benjamin Drung <email address hidden> Mon, 28 Jun 2010 22:25:42 +0200

Changed in eclipse (Ubuntu):
status: Fix Committed → Fix Released
Nikke (nmellegard) wrote :

@Niels

Thanks for the clarification, and sorry if I'm posting this in the wrong place:
The bug report which is related to the problem with libswt (affecting other java applications than eclipse) can be found here: https://bugs.launchpad.net/ubuntu/+source/swt-gtk/+bug/583944

Best regards
Nikke

Martin Pitt (pitti) wrote :

Anyone who can test this update in lucid-proposed?

Pavel Rojtberg (rojtberg) wrote :

works. Tooltips are as in eclipse 3.6 - but some things are still poorly readable (attachment)

Martin Pitt (pitti) wrote :

Thanks. Definitively an improvement, so marking verified.

Changed in light-themes (Ubuntu):
status: Confirmed → Invalid
Changed in light-themes (Ubuntu Lucid):
status: New → Invalid
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.2-2ubuntu4.2

---------------
eclipse (3.5.2-2ubuntu4.2) lucid-proposed; urgency=low

  * Backported fix for poor tooltip colors with certain themes. (LP: #540332)
  * Backported fix for hover text visability problem.
 -- Niels Thykier <email address hidden> Fri, 25 Jun 2010 00:43:37 +0200

Changed in eclipse (Ubuntu Lucid):
status: Fix Committed → Fix Released

If you're still seeing this on Ubuntu 10.04 and Eclipse 3.6: Check the System > Preferences > Appearance > Theme > Colours > tooltip setting. The default color scheme of the 'Radiance' theme for tooltips is white text on black background (which came unexpected to me given that Radiance is a very light theme)

getaceres (getaceres) wrote :

I'm using the updated light themes from Maverick on Lucid but the problem persists. Even changing the tooltip background color there's another problem: The inactive selection is too light and also has white text in Eclipse (which is strange given that the text is black in Nautilus). It's annoying to open an autocomplete popup and get the selected option almost invisible. I've tested with Shiki Colors and the inactive selection puts the text black correctly so I don't know what's the difference between Ambiance and Shiki in this case.

Jonas Ådahl (jadahl) wrote :

This is still an issue for CDT editors. The workaround in comment #7 works (for me), but default behavior is unreadable tooltip text. Running version 3.5.2-2ubuntu4.2.

cfriedt (chrisfriedt) wrote :

Someone has probably already mentioned this, but there is a way to fix the tooltip issue by going through preferences with the CDT (and Java) editors.

Window -> Preferences -> C / C++ -> Editor

Adjust the last entry, "Source hover background", in "Appearance color options". Do not use the system default. I use #F6F68D.

JAlcala (jalcalav) wrote :

In my case it was better to uncheck "Use mixed fonts and colors for labels":

Window -> Preferences -> General -> Appearance -> Uncheck "Use mixed fonts and colors for labels".

Solved this and other similar problems.

Hope this helps.

Sérgio Faria (sergio91pt) wrote :

This still happens on the declaration view (java), where only keywords (like public, super,..) are visible.
Anybody knows the setting to change this? No matter what i do, seems to change nothing lol

I'm still having this issue on natty, anyone else noticed this?

Géza Búza (medve) wrote :

Yes, I have it too. I tried every workaround, but noting worked for me.

martin (mbvlist) wrote :

@Spinus: I also have this issue. I changed the theme (black on light orange), which looks sort-of OK in other applications too.

balo (vbalazs) wrote :

it also affects oneiric.
#7 solved the problem.

agnul (sucrabu) wrote :

Still happens on Eclipse 3.7 and ubuntu 10.10 with the added bonus that with unity you can no longer change the tooltip colors unless you install some third party stuff.

I solved the problem copying the "Radiance" theme to my .themes folder under a new name and changing colors there as suggested on http://askubuntu.com/questions/70599/how-to-change-tooltip-background-color-in-unity/70665#70665 (and for reasons that escape me I could only choose the new theme using gnome-tweak-tool)

Nick Andrik (andrikos) wrote :

An easy way to fix this is to install gnome-color-chooser .
Open it, go to Specific -> Tooltips and put black foreground over pale yellow background

Xiaojun Ma (damage3025) wrote :

Hi, all.

I reported a new bug for 12.04:
https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/1047353

I'm not sure whether 10.04's Eclipse works out-of-the-box now.
But certainly not for that of 12.04.

Having workarounds is not enough.
We need root fix like patching the eclipse package in Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.