unity held back if ubuntu-desktop is not installed during upgrade from raring to saucy (upgrade fails)

Bug #1241420 reported by MatatTHC on 2013-10-18
428
This bug affects 70 people
Affects Status Importance Assigned to Milestone
libunity
Fix Released
Medium
Steve Langasek
libunity (Ubuntu)
Medium
Steve Langasek
Saucy
High
Steve Langasek

Bug Description

[SRU justification]
Users who have unity installed but not the ubuntu-desktop task will not be able to upgrade using ubuntu-release-upgrader; and those who upgrade using apt will have the unity desktop removed. We want users to get a correct upgrade from raring to saucy.

[Test case]
1. On a minimal installation of Ubuntu Raring install unity (without ubuntu-desktop)
2. Edit /etc/apt/sources.list to point to saucy.
3. Run: apt-get dist-upgrade
4. Observe that unity is marked for removal.
5. Enable saucy-proposed.
6. Run: apt-get dist-upgrade
7. Observe that unity is now marked for upgrade instead of removal.
8. Run the dist-upgrade tests in jenkins and confirm that they still work.

[Regression potential]
Minimal: we are adding an additional Breaks: against a package not shipping in saucy that is meant to be removed on upgrade. While this could permute apt's upgrade calculation in unexpected ways, this is unlikely.

ACTUAL RESULT:
The system cannot upgrade because unity is removed due to the following resolution:

Investigating (0) libunity-core-6.0-8 [ amd64 ] < none -> 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs )
Broken libunity-core-6.0-8:amd64 Conflicts on unity-common [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome )
  Considering unity-common:amd64 3 as a solution to libunity-core-6.0-8:amd64 2
  Holding Back libunity-core-6.0-8:amd64 rather than change unity-common:amd64
[...]
Investigating (0) unity [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 -> 7.1.2+13.10.20131014.1-0ubuntu1 > ( gnome )
Broken unity:amd64 Depends on libunity-core-6.0-8 [ amd64 ] < none -> 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs ) (= 7.1.2+13.10.20131014.1-0ubuntu1)
  Considering libunity-core-6.0-8:amd64 2 as a solution to unity:amd64 0
  Removing unity:amd64 rather than change libunity-core-6.0-8:amd64

Original Report

/var/log/dist-upgrade/main.log

2013-10-18 10:25:25,166 DEBUG blacklist expr 'unity$' matches 'unity'
2013-10-18 10:25:25,166 DEBUG The package 'unity' is marked for removal but it's in the removal blacklist
2013-10-18 10:25:59,444 ERROR Dist-upgrade failed: 'The package 'unity' is marked for removal but it is in the removal blacklist.'

I have not installed the xorg-edgers ppa (only gnome3 from gnome3-team).

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubuntu-release-upgrader-core 1:0.192.13
ProcVersionSignature: Ubuntu 3.8.0-31.46-generic 3.8.13.8
Uname: Linux 3.8.0-31-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
CrashDB: ubuntu
Date: Fri Oct 18 10:26:09 2013
InstallationDate: Installed on 2011-11-09 (708 days ago)
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to raring on 2013-10-18 (0 days ago)
VarLogDistupgradeTermlog:

MatatTHC (matatthc) wrote :
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Elias Martenson (lokedhs) wrote :

I have same same problem, and I'm attaching apt.log in case this can help tracking down this bug.

summary: - Unable to upgrade to 13.10 ( Could not calculate the upgrade)
+ unity held back if ubuntu-desktop is not installed during upgrade from
+ raring to saucy
summary: unity held back if ubuntu-desktop is not installed during upgrade from
- raring to saucy
+ raring to saucy (upgrade fails)
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
assignee: nobody → Canonical Foundations Team (canonical-foundations)
description: updated
Steve Langasek (vorlon) wrote :

This is reproducible as well with 'apt-get dist-upgrade'; ubuntu-release-upgrader simply bails instead of letting a "wrong" upgrade path be calculated, but the removal of unity is reproducible with simple apt-get.

We can hint more strongly to apt that unity should be upgraded and unity-common should be removed by adding an additional Breaks: unity-common (<< 7.1.2) from another unity package lower in the stack - such as libunity9.

affects: ubuntu-release-upgrader (Ubuntu) → libunity (Ubuntu)
Changed in libunity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Steve Langasek (vorlon)
Steve Langasek (vorlon) on 2013-10-18
description: updated
Changed in libunity (Ubuntu Saucy):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Steve Langasek (vorlon)
Changed in libunity (Ubuntu):
importance: Critical → Medium
status: Triaged → In Progress

Hello MatatTHC, or anyone else affected,

Accepted libunity into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libunity/7.1.2+13.10.20131010-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libunity (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I followed the test case and confirm that using the new version of libunity resolves the issue.

tags: added: verification-done-saucy
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.2+13.10.20131010-0ubuntu2

---------------
libunity (7.1.2+13.10.20131010-0ubuntu2) saucy; urgency=low

  * Declare a Breaks: against unity-common (<< 7.1.2) to help apt calculate
    the upgrade from raring properly. LP: #1241420.
 -- Steve Langasek <email address hidden> Fri, 18 Oct 2013 11:11:35 -0700

Changed in libunity (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.2+13.10.20131010-0ubuntu2

---------------
libunity (7.1.2+13.10.20131010-0ubuntu2) saucy; urgency=low

  * Declare a Breaks: against unity-common (<< 7.1.2) to help apt calculate
    the upgrade from raring properly. LP: #1241420.
 -- Steve Langasek <email address hidden> Fri, 18 Oct 2013 11:11:35 -0700

Changed in libunity (Ubuntu):
status: In Progress → Fix Released
Download full text (4.1 KiB)

I'm not running Ubuntu tho... I'm running Kubuntu right now
On Oct 18, 2013 3:50 PM, "Launchpad Bug Tracker" <email address hidden>
wrote:

> This bug was fixed in the package libunity -
> 7.1.2+13.10.20131010-0ubuntu2
>
> ---------------
> libunity (7.1.2+13.10.20131010-0ubuntu2) saucy; urgency=low
>
> * Declare a Breaks: against unity-common (<< 7.1.2) to help apt calculate
> the upgrade from raring properly. LP: #1241420.
> -- Steve Langasek <email address hidden> Fri, 18 Oct 2013
> 11:11:35 -0700
>
> ** Changed in: libunity (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1241234).
> https://bugs.launchpad.net/bugs/1241420
>
> Title:
> unity held back if ubuntu-desktop is not installed during upgrade from
> raring to saucy (upgrade fails)
>
> Status in “libunity” package in Ubuntu:
> Fix Released
> Status in “libunity” source package in Saucy:
> Fix Released
>
> Bug description:
> [SRU justification]
> Users who have unity installed but not the ubuntu-desktop task will not
> be able to upgrade using ubuntu-release-upgrader; and those who upgrade
> using apt will have the unity desktop removed. We want users to get a
> correct upgrade from raring to saucy.
>
> [Test case]
> 1. On a minimal installation of Ubuntu Raring install unity (without
> ubuntu-desktop)
> 2. Edit /etc/apt/sources.list to point to saucy.
> 3. Run: apt-get dist-upgrade
> 4. Observe that unity is marked for removal.
> 5. Enable saucy-proposed.
> 6. Run: apt-get dist-upgrade
> 7. Observe that unity is now marked for upgrade instead of removal.
> 8. Run the dist-upgrade tests in jenkins and confirm that they still
> work.
>
> [Regression potential]
> Minimal: we are adding an additional Breaks: against a package not
> shipping in saucy that is meant to be removed on upgrade. While this could
> permute apt's upgrade calculation in unexpected ways, this is unlikely.
>
> ACTUAL RESULT:
> The system cannot upgrade because unity is removed due to the following
> resolution:
>
> Investigating (0) libunity-core-6.0-8 [ amd64 ] < none ->
> 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs )
> Broken libunity-core-6.0-8:amd64 Conflicts on unity-common [ amd64 ] <
> 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome )
> Considering unity-common:amd64 3 as a solution to
> libunity-core-6.0-8:amd64 2
> Holding Back libunity-core-6.0-8:amd64 rather than change
> unity-common:amd64
> [...]
> Investigating (0) unity [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 ->
> 7.1.2+13.10.20131014.1-0ubuntu1 > ( gnome )
> Broken unity:amd64 Depends on libunity-core-6.0-8 [ amd64 ] < none ->
> 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs ) (=
> 7.1.2+13.10.20131014.1-0ubuntu1)
> Considering libunity-core-6.0-8:amd64 2 as a solution to unity:amd64 0
> Removing unity:amd64 rather than change libunity-core-6.0-8:amd64
>
> Original Report
>
> /var/log/dist-upgrade/main.log
>
> 2013-10-18 10:25:25,166 DEBUG blacklist expr 'unity$' matches 'unity'
> 2013-10-18 10:25:25,166 DEBUG The package 'unity' is marked for removal
> but i...

Read more...

Download full text (7.9 KiB)

And I'm running Xubuntu on the system where the upgrade failed

-----Oorspronkelijk bericht-----
From: Christopher Costa
Sent: Saturday, October 19, 2013 3:49 AM
To: <email address hidden>
Subject: Re: [Bug 1241420] Re: unity held back if ubuntu-desktop is
notinstalled during upgrade from raring to saucy (upgrade fails)

I'm not running Ubuntu tho... I'm running Kubuntu right now
On Oct 18, 2013 3:50 PM, "Launchpad Bug Tracker"
<email address hidden>
wrote:

> This bug was fixed in the package libunity -
> 7.1.2+13.10.20131010-0ubuntu2
>
> ---------------
> libunity (7.1.2+13.10.20131010-0ubuntu2) saucy; urgency=low
>
> * Declare a Breaks: against unity-common (<< 7.1.2) to help apt
> calculate
> the upgrade from raring properly. LP: #1241420.
> -- Steve Langasek <email address hidden> Fri, 18 Oct 2013
> 11:11:35 -0700
>
> ** Changed in: libunity (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1241234).
> https://bugs.launchpad.net/bugs/1241420
>
> Title:
> unity held back if ubuntu-desktop is not installed during upgrade from
> raring to saucy (upgrade fails)
>
> Status in “libunity” package in Ubuntu:
> Fix Released
> Status in “libunity” source package in Saucy:
> Fix Released
>
> Bug description:
> [SRU justification]
> Users who have unity installed but not the ubuntu-desktop task will not
> be able to upgrade using ubuntu-release-upgrader; and those who upgrade
> using apt will have the unity desktop removed. We want users to get a
> correct upgrade from raring to saucy.
>
> [Test case]
> 1. On a minimal installation of Ubuntu Raring install unity (without
> ubuntu-desktop)
> 2. Edit /etc/apt/sources.list to point to saucy.
> 3. Run: apt-get dist-upgrade
> 4. Observe that unity is marked for removal.
> 5. Enable saucy-proposed.
> 6. Run: apt-get dist-upgrade
> 7. Observe that unity is now marked for upgrade instead of removal.
> 8. Run the dist-upgrade tests in jenkins and confirm that they still
> work.
>
> [Regression potential]
> Minimal: we are adding an additional Breaks: against a package not
> shipping in saucy that is meant to be removed on upgrade. While this
> could
> permute apt's upgrade calculation in unexpected ways, this is unlikely.
>
> ACTUAL RESULT:
> The system cannot upgrade because unity is removed due to the following
> resolution:
>
> Investigating (0) libunity-core-6.0-8 [ amd64 ] < none ->
> 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs )
> Broken libunity-core-6.0-8:amd64 Conflicts on unity-common [ amd64 ] <
> 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome )
> Considering unity-common:amd64 3 as a solution to
> libunity-core-6.0-8:amd64 2
> Holding Back libunity-core-6.0-8:amd64 rather than change
> unity-common:amd64
> [...]
> Investigating (0) unity [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 ->
> 7.1.2+13.10.20131014.1-0ubuntu1 > ( gnome )
> Broken unity:amd64 Depends on libunity-core-6.0-8 [ amd64 ] < none ->
> 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs ) (=
> 7.1.2+13.10.20131014.1-0ubuntu1)
> Considering libunity-core-6...

Read more...

Download full text (12.0 KiB)

I got it running on Kubuntu finally
I had to do a -f to the command
do-devel-release-kubuntu -f was the command for me I think
On Oct 21, 2013 11:05 AM, "Dirk Broer" <email address hidden> wrote:

> And I'm running Xubuntu on the system where the upgrade failed
>
> -----Oorspronkelijk bericht-----
> From: Christopher Costa
> Sent: Saturday, October 19, 2013 3:49 AM
> To: <email address hidden>
> Subject: Re: [Bug 1241420] Re: unity held back if ubuntu-desktop is
> notinstalled during upgrade from raring to saucy (upgrade fails)
>
> I'm not running Ubuntu tho... I'm running Kubuntu right now
> On Oct 18, 2013 3:50 PM, "Launchpad Bug Tracker"
> <email address hidden>
> wrote:
>
> > This bug was fixed in the package libunity -
> > 7.1.2+13.10.20131010-0ubuntu2
> >
> > ---------------
> > libunity (7.1.2+13.10.20131010-0ubuntu2) saucy; urgency=low
> >
> > * Declare a Breaks: against unity-common (<< 7.1.2) to help apt
> > calculate
> > the upgrade from raring properly. LP: #1241420.
> > -- Steve Langasek <email address hidden> Fri, 18 Oct 2013
> > 11:11:35 -0700
> >
> > ** Changed in: libunity (Ubuntu)
> > Status: In Progress => Fix Released
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1241234).
> > https://bugs.launchpad.net/bugs/1241420
> >
> > Title:
> > unity held back if ubuntu-desktop is not installed during upgrade from
> > raring to saucy (upgrade fails)
> >
> > Status in “libunity” package in Ubuntu:
> > Fix Released
> > Status in “libunity” source package in Saucy:
> > Fix Released
> >
> > Bug description:
> > [SRU justification]
> > Users who have unity installed but not the ubuntu-desktop task will not
> > be able to upgrade using ubuntu-release-upgrader; and those who upgrade
> > using apt will have the unity desktop removed. We want users to get a
> > correct upgrade from raring to saucy.
> >
> > [Test case]
> > 1. On a minimal installation of Ubuntu Raring install unity (without
> > ubuntu-desktop)
> > 2. Edit /etc/apt/sources.list to point to saucy.
> > 3. Run: apt-get dist-upgrade
> > 4. Observe that unity is marked for removal.
> > 5. Enable saucy-proposed.
> > 6. Run: apt-get dist-upgrade
> > 7. Observe that unity is now marked for upgrade instead of removal.
> > 8. Run the dist-upgrade tests in jenkins and confirm that they still
> > work.
> >
> > [Regression potential]
> > Minimal: we are adding an additional Breaks: against a package not
> > shipping in saucy that is meant to be removed on upgrade. While this
> > could
> > permute apt's upgrade calculation in unexpected ways, this is unlikely.
> >
> > ACTUAL RESULT:
> > The system cannot upgrade because unity is removed due to the following
> > resolution:
> >
> > Investigating (0) libunity-core-6.0-8 [ amd64 ] < none ->
> > 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs )
> > Broken libunity-core-6.0-8:amd64 Conflicts on unity-common [ amd64 ] <
> > 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome )
> > Considering unity-common:amd64 3 as a solution to
> > libunity-core-6.0-8:amd64 2
> > Holding Back libunity-core-6.0-8:amd64 rather than ...

Changed in libunity:
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.