Evince and Okular do not show all the pages in some PostScript documents

Bug #550440 reported by Roman Yepishev on 2010-03-28
54
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evince
Unknown
Medium
libspectre
Invalid
Medium
libspectre (Ubuntu)
Low
Unassigned

Bug Description

LATEST PACKAGE TESTED:
libspectre1 0.2.6-1

WORKAROUND:
Convert the affected PostScript document into a PDF by using the command "ps2pdf".

Binary package hint: evince

While attempting to view multi-page PS document I am given only one page.
No warnings are printed to the terminal.

gs shows all the pages properly.

The document that causes this behavior is attached. It can be downloaded from http://citeseerx.ist.psu.edu/viewdoc/summary?doi=10.1.1.72.605 as well.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: evince 2.29.92-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic i686
Architecture: i386
CheckboxSubmission: b16b943d4712f4613c50f12b0ffe0cc5
CheckboxSystem: 1fd1d69a420d7665c5bbb30cf0881c53
Date: Sun Mar 28 22:10:03 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/evince
KernLog: Mar 28 21:47:43 buzz kernel: [39851.304791] type=1505 audit(1269802063.007:17): operation="profile_load" pid=30720 name="libvirt-0b2b9b75-3141-f051-6eb1-f3279b63013e"
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.utf8
SourcePackage: evince

Roman Yepishev (rye) wrote :
madbiologist (me-again) wrote :

This file seems to be corrupt:

~/Downloads$ pdfinfo 10.1.1.72.605.ps
Error: May not be a PDF file (continuing anyway)
Error: PDF file is damaged - attempting to reconstruct xref table...
Error: Couldn't find trailer dictionary
Error: Couldn't read xref table

Embedded in the file is the following:

%%Revision: $Header: psnup.trl,v 2.2 94/06/14 14:39:34 rxkmh Locked 0%
%%Creator: psnup, Copyright (C) 1994 M. Herbert <email address hidden>
%% psnup comes with ABSOLUTELY NO WARRANTY. This is free software,
%% and you are welcome to redistribute it under certain conditions;
%% see the file COPYING for details on warranty and these conditions.

Pedro Villavicencio (pedro) wrote :

yes the file is corrupted, there's nothing we can do about that.

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Roman Yepishev (rye) wrote :

Unfortunately I have to disagree about pdfinfo usage. The file is in PostScript, not PDF.
And if you run

$ gs 10.1.1.72.605.ps

You will see that all pages are readable.

Changed in evince (Ubuntu):
status: Invalid → New
importance: Low → Undecided
madbiologist (me-again) wrote :

psnup seems to be part of the psutils package.

Changed in evince (Ubuntu):
status: New → Confirmed
Timmy Shih Jun Yee (shijun) wrote :

bug 32193 seems to be related.

Changed in evince:
status: Unknown → New

Could you try to update your evince and tell us if the problem is still there?

the latest version now is 2.30

thanks

Roman Yepishev (rye) wrote :

This is still broken. Attaching the screenshot.

Timmy Shih Jun Yee (shijun) wrote :

There's a couple of files I had Evince read that have all pages shown correctly. The other files I collected from various related bug reports only have their last pages shown. This was done on Karmic (9.10).

I've attached the working files in good-ps-documents.zip and the non-working ones in bad-ps-documents.zip.

Timmy Shih Jun Yee (shijun) wrote :
Timmy Shih Jun Yee (shijun) wrote :

I've just loaded the same files into Evince on Lucid, and I'm getting the same results.

madbiologist (me-again) wrote :

Does this help? - https://bugs.freedesktop.org/show_bug.cgi?id=27830

The symptom is a bit different to the original report here so it might not help.

Timmy Shih Jun Yee (shijun) wrote :

I opened the bad PS files and was able to see all the pages in print preview, so I think it's the same bug. I'll have to try the version in the git master to confirm that it's been fixed. Thanks!

Changed in evince (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Timmy Shih Jun Yee (shijun) wrote :

This bug is probably related to bug 552990, and according to the comments there, it's been fixed in Maverick. After I install Maverick, I'll try out Evince to see out if this bug's been fixed.

If someone else can confirm that this has been fixed in Maverick, please mark as fixed. Thanks!

Timmy Shih Jun Yee (shijun) wrote :

I've confirmed that opening the bad PS files with Okular exhibits the same behavior (i.e. only the last page is shown). This means that this is a libspectre bug and will be marked as such.

Also, I've tried Evince in Maverick with those files, and the bug still exists.

Changed in evince (Ubuntu):
status: Triaged → Invalid
affects: evince (Ubuntu) → libspectre (Ubuntu)
Changed in libspectre (Ubuntu):
status: Invalid → Confirmed
summary: - Evince does not show all the pages in PS document
+ Evince does not show all the pages in some PostScript documents
summary: - Evince does not show all the pages in some PostScript documents
+ Evince and Okular do not show all the pages in some PostScript documents

There are some multi-page PostScript documents, when opened in Evince or Okular, that are only shown the last page. However, when using print preview, all pages are shown correctly. These files are in bad-ps-documents.zip.

Multi-page PostScript documents that render fine with libspectre are in good-ps-documents.zip.

These documents were tested with libspectre 0.2.6.

This bug has been first reported on Launchpad:
https://bugs.launchpad.net/ubuntu/+source/libspectre/+bug/550440

I am unable to attach bad-ps-documents.zip because Bugzilla said it's too large. It is available on Launchpad.

Timmy Shih Jun Yee (shijun) wrote :

I've forwarded this bug upstream:
http://bugs.freedesktop.org/show_bug.cgi?id=29749

description: updated
Changed in evince:
status: New → Confirmed

Looks like another case of bug #17241 -- Carlos?

Yes, we don't support documents without Page comments.

*** This bug has been marked as a duplicate of bug 17241 ***

Changed in libspectre:
importance: Unknown → Medium
Changed in evince:
importance: Unknown → Medium
Changed in libspectre:
importance: Medium → Unknown
Changed in libspectre:
importance: Unknown → Medium
Changed in libspectre:
status: Unknown → Invalid
Changed in evince:
status: Confirmed → Unknown

One of the documents (multipageessai5.ps) has the comment Page defined, but still only renders the last page. For that document, the bug does not seem duplicated to me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.