Ubuntu

BCM4312 not supported by "Additional drivers". B43 is proposed, fails w/o useful message, "Not supported low-power chip"

Reported by Fabián Rodríguez on 2010-10-05
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Jockey
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
jockey (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

After a fresh Maverick RC install, Jockeygtk (System > Administration > Additional Drivers) proposes to install either b43 or STA drivers for the BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01) wireless adapter in a Dell Inspiron 910 (Mini 9), BIOS is A00.

The attached error message appears, repeated attempts to enable the driver then fail.

Attempting to install from commnand line shows the actual problem:

magicfab@910:~$ sudo apt-get install firmware-b43-installer
[sudo] password for magicfab:
Reading package lists... Done
Building dependency tree
Reading state information... Done
firmware-b43-installer is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error processing firmware-b43-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

As a workaround you can:
sudo apt-get remove --purge firmware-b43-installer

and then use the STA driver instead.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: jockey-gtk 0.5.10-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: wl
.var.log.jockey.log:

Architecture: i386
Date: Tue Oct 5 08:29:51 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
MachineType: Dell Inc. Inspiron 910
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=4b58b2d3-3c3e-4f37-9175-c27ce81120af ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: jockey
dmi.bios.date: 08/05/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0F29
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd08/05/2008:svnDellInc.:pnInspiron910:pvrA00:rvnDellInc.:rnCN0F29:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 910
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Fabián Rodríguez (magicfab) wrote :
description: updated
summary: - "Additional drivers" propose b43, fails w/o useful message
+ "Additional drivers" proposes b43, fails w/o useful message
summary: - "Additional drivers" proposes b43, fails w/o useful message
+ "Additional drivers" proposes b43, fails w/o useful message, "Not
+ supported low-power chip"

I do confirm to have the exact same problem on my mini 9 and that Fabian's work around solved it.

Changed in dell:
status: New → Confirmed
Changed in jockey:
status: New → Confirmed
Changed in jockey (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Tony Espy (awe) wrote :

Marked Dell task as Invalid. This project is used for tracking hardware enablement work for factory pre-installed images.

Changed in dell:
status: Confirmed → Invalid
Fabián Rodríguez (magicfab) wrote :

This has been added to the release notes in Maverick.

Michael Vogt (mvo) wrote :

I uploaded a version of jockey to the proposed queue that disbled b43-fwcutter. The wl driver seems to yield better results. The alternative is to teach jockey about the individual pci-ids, there is firmware-b43-lpphy-installer and firmware-b43-installer and jockey currently always installs the later.

Changed in jockey (Ubuntu):
status: Confirmed → Fix Committed
Adrian Perez (adrianperez-deb) wrote :

Is this really the best solution? I mean for instance, the sta driver has given me problems in the past, it also wasn't supporting monitor mode. There's no way you could add the device id, since I mean it was working on lucid 2.6.32.

Fabián Rodríguez (magicfab) wrote :

Bug #462153 is about the same issue, affecting BCM4312 chipsets. IMO B43 should not be proposed alongside STA, only STA should for this particular chipset.

summary: - "Additional drivers" proposes b43, fails w/o useful message, "Not
- supported low-power chip"
+ BCM4312 - "Additional drivers" proposes b43, fails w/o useful message,
+ "Not supported low-power chip"
summary: - BCM4312 - "Additional drivers" proposes b43, fails w/o useful message,
- "Not supported low-power chip"
+ BCM4312 not supported by "Additional drivers". B43 is proposed, fails
+ w/o useful message, "Not supported low-power chip"
Fabián Rodríguez (magicfab) wrote :

SOrry, I meant to write Bug #462143 is about this same issue in Lucid. I'll gladly stand corrected.

Changed in ubuntu-release-notes:
status: New → Fix Committed
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Michael,

I just thought about this again, and while disabling the b43 driver would have made sense in maverick, doing so in an SRU isn't really the best thing IMHO. People will see this right after installation (where updates aren't installed yet?) or even on the live CD. Also, when installing with network, ubiquity can now install the wl driver automatically, without confusion.

So for an SRU it might be better to just filter out the broken product IDs from b43 instead?

Martin Pitt (pitti) wrote :

Closing upstream task, the b43 handler is only in the Ubuntu package.

Changed in jockey:
status: Confirmed → Invalid
tags: added: verification-needed

Accepted jockey into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

psypher (psypher246) wrote :

Hi Martin,

I am running stock Maverick on the Dell Mini 9. Just installed and ran latest updates.

I just tried this. Enabled proposed, updated and upgraded. Jockey was one of the upgraded pkgs. But i still get this error:

Setting up firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error processing firmware-b43-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Whats next?

Marcelo (marceloramone-gmail) wrote :

I can not install wi-fi driver...

marcelo@marcelo-Inspiron-1545:~$ sudo apt-get install firmware-b43-installer
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  b43-fwcutter
Se instalarán los siguientes paquetes NUEVOS:
  b43-fwcutter firmware-b43-installer
0 actualizados, 2 se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 0B/21,6kB de archivos.
Se utilizarán 131kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Seleccionando el paquete b43-fwcutter previamente no seleccionado.
(Leyendo la base de datos ... 00%
126409 ficheros y directorios instalados actualmente.)
Desempaquetando b43-fwcutter (de .../b43-fwcutter_1%3a013-2_i386.deb) ...
Seleccionando el paquete firmware-b43-installer previamente no seleccionado.
Desempaquetando firmware-b43-installer (de .../firmware-b43-installer_4.150.10.5-4_all.deb) ...
Procesando disparadores para man-db ...
Configurando b43-fwcutter (1:013-2) ...
Configurando firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error al procesar firmware-b43-installer (--configure):
 el subproceso script post-installation instalado devolvió el código de salida de error 1
Se encontraron errores al procesar:
 firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
marcelo@marcelo-Inspiron-1545:~$

Hello Psypher,

psypher [2010-10-13 8:53 -0000]:
> I just tried this. Enabled proposed, updated and upgraded. Jockey was
> one of the upgraded pkgs. But i still get this error:

That's not sufficient I'm afraid, since the wrong package is
installed. You need to uninstall the firmware-b43-installer package
and reinstall the (correct) driver package from Jockey, which should
now be firmware-b43-lpphy-installer.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

psypher (psypher246) wrote :

Hi Martin, sorry missed that. Worked like a charm. Connected to our WPA2 Enterprise with PEAP AP and sems good. Hoping next ubuntu jockey will, for the 1st time, properly install these drivers.

Thanks for the help

Martin Pitt (pitti) on 2010-10-14
tags: added: verification-done
removed: verification-needed
philipvs (philipvs) wrote :

Still not working - SystemError: installArchives() failed

Martin Pitt (pitti) wrote :

philipvs, can you please attach /var/log/jockey.log?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.10-0ubuntu5.1

---------------
jockey (0.5.10-0ubuntu5.1) maverick-proposed; urgency=low

  * Change B43Handler to deal with the various firmware-b43*installer
    packages. This requires adding a modalias file for
    firmware-b43-lpphy-installer (LP: #655111)
 -- Michael Vogt <email address hidden> Mon, 11 Oct 2010 13:46:50 +0200

Changed in jockey (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-10-18
Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Simon741 (simon-okko) wrote :

Strange thing happening here: I've installed Ubuntu 10.10 a first time on my new MBP 7.1. Wireless worked out of the box (although was a bit unstable).

After having played around a bit, I re-installed everything, this time connecting it to the internet (ethernet) during the install, and activating the "download updates during install" option. With that activated, the wireless didn't work any more and I was unable to install either of the two drivers. The above proposed work-around didn't work.

I installed the system a third time, again connecting it to the internet and downloading the updates during the install. The same happened again.

Now I've installed it a forth time, this time without connecting to the internet. This time again, everything works out of the box (STA driver).

Can anyone reproduce this?

psypher (psypher246) wrote :

I'm willing to try. Need to reinstall anyway to put usr on sdcard. Have you updated now once it was installed? If so does it still work?

Fabián Rodríguez (magicfab) wrote :

Sorry I could not test this before today. Vanilla install, updated, picked STA and everything worked as expected. Thank you!

Ubfan (ubfan1) wrote :

Has anyone tried the b43-open firmware with this LP chip?
http://wireless.kernel.org/en/users/Drivers/b43 claims it's partially supported:

14e4:4315 partially supported 2.6.33 and later (PIO mode) BCM4312 b/g LP b43/wl

I just copy in a b43-open directory to /lib/firmware with the 3 files in it and my 14e4:4312 wireless works with the b43 driver.
I don't enable any additional hardware drivers for Broadcom.

Ajay (atallam) wrote :

I had quite the pain with this whole phenomenon.
I couldn't get the add'l drivers to work even with proposed-updates being enabled.
someone in trying to help me recommended against, then removed, fwcutter & lpphy, in favor of bcmwl-kernel-source. I had trouble getting this to compile, but somehow during the 2.6.35-23 kernel upgrade it built the wl driver successfully. (Yes i installed the kernel headers, even source pkg! to no avail with .32-25 or .35-22)
I tested with an open and WPA2 access point no problem. Before i could get this (STA) or the other to work, i was using the blacklisted builtin driver, but that only worked for an hour and then the computer had to be rebooted. i've been up now for almost 3 hrs. Someone told me this driver is slower, and doesn't work with WPA. The latter is definitely untrue, haven't had a chance to check for the former yet.
I also spent some time on the broadcom website for the STA/hybrid driver (http://www.broadcom.com/support/802.11/linux_sta.php), as well as the aforementioned http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware in my quest..
this was quite the pain! it "just worked" and perfectly, with 10.04.

Giorgio Solari (glsolari) wrote :

Hi Simon741,

I did a reinstallation of Ubunutu 10.10 without selecting "Download updates during installation". Then the "additional drivers" manager shows me two options of drivers, the b43 and the STA. I did select the STA, and now mi wireless card is working.

Mi laptop is a Dell Latitude E6400. A good practice is to have a dedicated filesystem for "/home", this let you re-install the OS without the need of backup and restore your files.

Regards,

GSV

At mine the problem is partly solved.

1. I installed firmware-b43-installer
2. Broadcom B43 wireless driver and STA are disabled
3. I installed wicd

I use wicd to link wlan. To connect with cable or mobile I use Network Manager.
When connected with wicd applications start offline and must turn them on manually.

matjaz (matjazjevsnik) on 2013-11-07
Changed in jockey (Ubuntu):
assignee: nobody → matjaz (matjazjevsnik)
Changed in jockey (Ubuntu):
assignee: matjaz (matjazjevsnik) → nobody
Changed in somerville:
status: New → Invalid
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306116

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions