Comment 23 for bug 655111

Ajay (atallam) wrote :

I had quite the pain with this whole phenomenon.
I couldn't get the add'l drivers to work even with proposed-updates being enabled.
someone in trying to help me recommended against, then removed, fwcutter & lpphy, in favor of bcmwl-kernel-source. I had trouble getting this to compile, but somehow during the 2.6.35-23 kernel upgrade it built the wl driver successfully. (Yes i installed the kernel headers, even source pkg! to no avail with .32-25 or .35-22)
I tested with an open and WPA2 access point no problem. Before i could get this (STA) or the other to work, i was using the blacklisted builtin driver, but that only worked for an hour and then the computer had to be rebooted. i've been up now for almost 3 hrs. Someone told me this driver is slower, and doesn't work with WPA. The latter is definitely untrue, haven't had a chance to check for the former yet.
I also spent some time on the broadcom website for the STA/hybrid driver (http://www.broadcom.com/support/802.11/linux_sta.php), as well as the aforementioned http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware in my quest..
this was quite the pain! it "just worked" and perfectly, with 10.04.