[SRU]Wrong keyboard layout active after booting into desktop

Bug #1240198 reported by Daniel Kessel on 2013-10-15
This bug affects 305 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
High
Aron Xu
Trusty
High
Aron Xu

Bug Description

[Impact]

When first boot into Unity desktop, English keyboard layout is active while all other parts of the system language settings are set to another language (e.g. German).

The bug is properly addressed in newer upstream releases in Vivid, but the changes is too intrusive and not suitable for being back ported in SRU. And changing the default to use system keyboard layout solves the problem.

[Test Case]

1. Set the system language to something other than English, e.g. German.
2. Create a new user, log in to the Unity desktop of the new user.
3. Check the keyboard layout, it should be German instead of English.

[Regression Potential]

Since this changes the default value of the keyboard layout settings by using system defined as default, it avoids using ibus's built-in keyboard layout related functionality, so that this could be a regression for users rely on this certain behavior (e.g. use English keyboard while want to keep the system language settings to German), but such behavior is not expected for normal usage.

Related branches

lp:~hennekn/ubuntu/trusty/ibus/bug-1240198
On hold for merging into lp:ubuntu/trusty/ibus
Aron Xu (community): Needs Fixing on 2014-07-26
Ubuntu branches: Pending requested 2014-05-23
lp:~mniess/ubuntu/trusty/ibus/fix-lp1240198
Jamie Strandboge: Needs Fixing on 2014-08-11
Aron Xu (community): Approve on 2014-07-27
lp:~brunonova/ubuntu/trusty/ibus/lp1240198
Aron Xu: Approve on 2014-12-02
lp:~brunonova/ubuntu/trusty/ibus/lp1240198_2
Aron Xu: Approve on 2015-12-09
Ubuntu Development Team: Pending requested 2015-11-20
Daniel Kessel (dkessel) wrote :
Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
Daniel Kessel (dkessel) wrote :

If there is any command I could type before using the "switch to vterm to fix keyboard layout" fix to help triage this, that will be no problem.

Changed in indicator-keyboard (Ubuntu):
importance: Undecided → High

Same problem here. Workaround helps as described.

Ricardo Graça (devius) wrote :

Does the keyboard layout indicator (on the Unity bar) show the correct (german in your case) layout although the keyboard actually behaves like it's an english one?

Ricardo Graça (devius) wrote :

Stupid question, you already answered it in the bug report.

Another "fix" is going to the indicator and clicking on the correct layout. Might be slightly faster than switching to one of the virtual terminals.

Danillo (danillo) wrote :

I got the same problem but the workaround I'm using is go to input settings, add another random keyboard layout and remove it right away. I'll try the other one.

Vince Marsters (vincemarsters) wrote :

I get the same on a fresh install with English (UK) as my primary language.

Aleš Pospíchal (ales-s) wrote :

I can also confirm that this bug also affects new installations. I installed Ubuntu 13.10 with Netboot and today experienced same as with my upgraded laptop from Raring.

Ludovic COLO (ludovic-colo) wrote :

I can also confirm this bug on my laptop using Ubuntu13.10, even though it started some days after the upgrade (maybe one or two weeks). I want french as default keyboard layout and it starts with the english layout. The french layout is ticked in the keyboard menu even though it is not the one used currently after a reboot. To click on it sets the keyboard to french layout as desired.

Ludovic COLO (ludovic-colo) wrote :

I don't know if that can help you, but I found a solution to my problem (comment #9). I uninstalled IBus from the Software Centre and it did the trick.

Rubeosis (faspie) wrote :

confirmed on 13.10 after fresh installation (german keyboard layout)

John Revill (jprevill) wrote :

Uninstalling IBus, as suggested in comment #10, also fixes the problem for me.

Confirmed for trusty. Happens for both desktop and LightDM

tags: added: trusty
TimoW (es-uomikim) wrote :

Yes, it also affects trusty. I use my local keyboard layout as default and english is even not among the keyboard layouts list but it still defaults to english.

1 comments hidden view all 118 comments
stagelll (gedefr) wrote :

Same bug here: 14.04 with fresh install. The English layout keeps coming back every two or three sessions, although I erased it from my keyboard's layout list.

I've used the workaround that I found here http://askubuntu.com/questions/378959/keyboard-layout-changes-after-reboot ("brunces" answer at the bottom of the page). That is to add a bash script to the startup applications, that puts the system to the default layout of my chosing. It's not pretty, but it works.

Patrick Then (patrickthen) wrote :

I still get it in Trusty, as well.
Upgraded from 13.10, where I had it, too.
It's not happening everytime, but fairly frequently.

Sorry guys, but considering that it's been there for half a year and 14.04 is supposed to be LTS, this is getting ridicoulus.

zubozrout (zubozrout) wrote :

Yep, confirmed, I first encountered it in Saucy, then it was somehow magically solved and now in a new installation of Trusty it occurs again.

Martin Jurča (mato-jurca) wrote :

Here's an easy fix:
1) open terminal
2) run ibus-setup
3) open the extra settings (the last tab)
4) check the "use system keyboard layout" checkbox

Now, how about you guys (yes, you, Canonical) make this the default settings? All I know about it is that it (probably) stores its config in gconf, but I cannot find it, so I cannot give you a patch.

gg2014 (gg2014) wrote :

@mato-jurca. Solved it for me to.

Just installed 14.04 today and this drove me nuts (after the first reboot or upgrade, dont know).
So thanks a lot.

Found on dconf-editor under desktop.ibus.general the key engines-order, and despite not having english as one of my input methods, the first value on this key was 'xkb:us::eng'. Removed that and the problem was resolved.
Don't know if that's the real cause nor why english was first if it wasn't even supposed to be there.

John Belton (jbelton1950) wrote :

I've just installed dconf-editor as it wasn't installed and the "engines-order" is empty, just showing empty square brackets.. I have never used anything like this so I'm not sure if it is valid to add anything in there. It may be because it wasn't installed but I'm not sure about using it to try and correct this.

Martin Jurča (mato-jurca) wrote :

@jbelton1950

I found the dconf property to configure (for those who don't want to use ibus-setup or want to fix this distro-scale).

Open dconf-editor and open the desktop.ibus.general folder. Make sure the "use-system-keyboard-layout" property is enabled. This will resolve the conflict between ibus and your keyboard settings.

Editing the "engines-order" and "preload-engines" won't do much help as these (supposedly) are re-generated on each login.

1 comments hidden view all 118 comments

@mato-jurca

Indeed I found out after some system reboots that the the "engine-order" returned to the original state.
I setted the "use system keyboard layout" option as described and now everything is working fine.

Didn't understand why the "engine-order" gets regenerated every time. It seems to me like a configuration the should be consistent among system reboots, not to mention it's a really annoying bug that the average user does not have the ability or will to fix it manually. Sure is easy for developers and advanced users, but still, only after we know what to do to fix it.

Martin Jurča (mato-jurca) wrote :

@7hi4g0

If you don't want the engine-order be re-generated, you need to disable the preload-engine-mode flag (set it to 0).

(obnoxious bitter comment start)
Damn... looks like I begin to know about this issue more than the Canonical.
(obnoxious bitter comment end)

John Belton (jbelton1950) wrote :

I think I know the feeling, perhaps Canonical think it is too trivial to sort, but the thing that gets me is the wrong keyboard layout is not selected on every boot but does happen apparently at random!!!
John

Hendrik Knackstedt (hennekn) wrote :

This is definitely not an indicator problem but seems to affect ibus. I added the appropriate package so developers get notified.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus (Ubuntu):
status: New → Confirmed
Hendrik Knackstedt (hennekn) wrote :

Can anybody confirm that changing use-system-keyboard-layout fixed the problem?

John Belton (jbelton1950) wrote :

I thought it had but the problem recurred a couple of days later, in fact it reverted to the US keyboard layout this morning but switched to the UK keyboard layout (as indicated by the icons) after clicking it. I assume it would be the same what ever keyboard layout was set in the Languages menu.

waffen (mlacunza) wrote :

I can confirm, many restarts and the problems dissapears with that fix. Im using Ubuntu 14.04 64bits Languages: ES and EN

Hendrik Knackstedt (hennekn) wrote :

Ok, I just checked the sources to confirm: With Ubuntu 13.10 the new dconf settings were introduced with the default value of the setting mentioned above set to "False". So this probably is the cause for this bug and also for bug #1246272 I suppose.

I'm trying to build a patch for this but I'm pretty new to creating patches for Ubuntu so please be patient. In the meantime you can just apply the setting manually as mentioned above.

Matthias Niess (mniess) wrote :

@hennekn
I can confirm that changing the ibus-setting solves this for me, too. I'll help with builing a fixed package (got a little experience with that now). What exact package (and file) is responsible?

Matthias Niess (mniess) wrote :

I just created a patched package (see linked branch above).

StatnMap (seb44550) on 2014-06-20
summary: - wrong keyboard layout active after booting into desktop, after upgrade
- to saucy
+ wrong keyboard layout active after booting into desktop (since saucy)
Changed in ibus (Ubuntu):
importance: Undecided → High
summary: - wrong keyboard layout active after booting into desktop (since saucy)
+ Wrong keyboard layout active after booting into desktop

I proposed a fix for this bug for merging. Anything more I need to do? I haven't received a single comment on the merge proposal (which is 4weeks+ old now).

Jochen Fahrner (jofa) wrote :

It looks like Canonical is not interested in fixing essential bugs. This and some other essential bugs (nvidia driver problem, brcm driver problem) caused me to switch to native Debian with Gnome 3. And I was very astonished that Debian does not suffer from all these bugs, because both systems are based on Gnome 3. So it must be Canonical modifications that break the system, but no one at Canonical feels responsible for all these bugs. Instead they wait for someone upstream to fix these bugs.

John Belton (jbelton1950) wrote :

I tried the proposed fix a while back and the problem hasn't returned on my system, I had assumed the fix had been pushed through. As for the Gnome 3 set up, I was using the Unity version on bot my Desktop and my Laptop but the problem only affected the Laptop, so maybe it is a combination of the hardware as well as the software. The Laptop is a Dell Vostro 1510 with some extra ram (4GiB) and a 250GiB harddrive. Maybe the fix doesnt work for all hardware as it seems to be something that resets the defaults in some circumstances.
John

Matthias Niess (mniess) wrote :

@jbelton1950: The problem occured when a default setting for ibus was changed. The fix just reverts the setting to the old default.

Changed in indicator-keyboard (Ubuntu):
status: Confirmed → Triaged
Changed in ibus (Ubuntu):
status: Confirmed → Triaged
no longer affects: indicator-keyboard

Hi:

I was experiencing the same issue with my Ubunty Trusty Tahr. A workaround that worked for me was this:

1- Access the Language Support from the System Settings.
2- Select "None" in the Keyboard input method system (default is IBUS).

I restarted twice and the issue was fixed. Not sure about the potential consequences of disabling this option though; I found what the IBUS feature was (https://help.ubuntu.com/community/ibus) but did not understand it completely.

Hopefully this may work for someone else. It'll be appreciate it if someone with more knowledge can tell me what does this feature do specifically and if this might affect the computer's behaviour or functionality.

Regards!

tags: added: patch
Aron Xu (happyaron) on 2014-12-01
Changed in ibus (Ubuntu):
status: Triaged → Fix Released
Changed in indicator-keyboard (Ubuntu):
status: Triaged → Won't Fix
Changed in indicator-keyboard (Ubuntu Trusty):
status: New → Won't Fix
Aron Xu (happyaron) on 2014-12-01
summary: - Wrong keyboard layout active after booting into desktop
+ [SRU]Wrong keyboard layout active after booting into desktop
Aron Xu (happyaron) on 2014-12-02
description: updated
Changed in ibus (Ubuntu Trusty):
status: New → In Progress
Aron Xu (happyaron) on 2014-12-02
Changed in ibus (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: iso-testing
tags: added: verification-needed
Colin Law (colin-law) on 2014-12-25
tags: added: verification-done
removed: verification-needed
38 comments hidden view all 118 comments
Colin Law (colin-law) wrote :

@pwd3270 did ibus 1.5.5-1ubuntu3.1 not fix it (see comment #70)?

John Belton (jbelton1950) wrote :

It has reappeared again today, I checked and the system settings "advised me" that it was not completely installed which is very odd since I always do the install whenever I update an install (back in April last year) and running it downloaded one dictionary but reinstalled several that were not downloaded but must have been on the system. This didn't change the keyboard layout until I selected it from the option on the top bar. I'm not sure why the language selection should have been affected though I didn't reboot after resetting my layout choice.
I don't know if this behaviour is related but seems one hell of a coincidence!

Bruno Nova (brunonova) wrote :

According to the previous comments, the fix for Trusty is apparently not working.
So the verification-done tag should probably be replaced by verification-failed!

I had tested the fix in a virtual machine, but I noticed that use-system-keyboard-layout was still false after installing it (reported by ibus-setup and gsettings).
As I commented in the merge request (https://code.launchpad.net/~brunonova/ubuntu/trusty/ibus/lp1240198/+merge/241742), the line I added to "debian/ibus.install" is missing from the fix. That line installs the file gschema override that sets use-system-keyboard-layout=true.
If the fix is indeed not working, this is probably the reason why it's failing.

Bruno Nova (brunonova) on 2015-01-29
tags: added: verification-needed
removed: verification-done

On 29.1.2015 14:30, Bruno Nova wrote:
> ** Tags removed: verification-done
> ** Tags added: verification-needed
>

GUI for kbd is screwed up since ubuntu 12
workaround is command ( eg for alt gr international):

setxkbmap -rules evdev -model evdev -layout us -variant altgr-intl

Bruno Nova (brunonova) wrote :

Has the proposed package fixed the issue or not?
FM33 reported in comment #71 that it fixed it, but in comment #74 he says that it wasn't fixed after all, I think.

I haven't tested it, but I don't think the proposed package will fix the issue.
From the diffs, it's missing one important change from my merge request: the line added to "debian/ibus.install" that makes the file "data/dconf/10_ibus.gschema.override" be installed, which is the file that fixes this. Unless there's something else going on.
Could an Ubuntu developer look into this?

Aron Xu (happyaron) wrote :

The fix is uploaded but stuck in trusty-proposed, still need SRU/archive admins to let that approved to trusty-updates.

Brian Murray (brian-murray) wrote :

For the SRU / archive admins to move the package from -proposed to -updates the bug report in the SRU must first be verified which this bug is not.

Bruno Nova (brunonova) wrote :

When I was asking if it fixed the issue, I was referring to the "affected users".

The bug was marked "verification-done" in comment #71 by FM33.
However, e later said in comment #74: "Reproduced again this morning (...)".
Comment #75 also says: "This problem has reappeared yesterday (...)".
They didn't remove the verification tag, so I set it to "verification-needed".
I'm now changing it to "verification-failed". If I misinterpreted the comments, please change it back.

@Aron (or someone else), please recheck my merge request (https://code.launchpad.net/~brunonova/ubuntu/trusty/ibus/lp1240198/+merge/241742).
The commit in trusty-proposed is missing the important change in "debian/ibus.install". Please add that change to trusty-proposed, adapting it if necessary.

tags: added: verification-failed
removed: verification-needed
Matthias Niess (mniess) wrote :

I can definately verify (for at least 100 machines) that changing the settings DOES work. What I can't verify is that this patch modifies the default setting (or updates existing installations). If anyone can verify this, please do so. This is such an annoying bug that I need to fix on every single non-US Ubuntu installation by changing the ibus-setting

Andrew Rendle (andrew-andrewr) wrote :

FWIW, I have installed the ibus package from trusty-proposed (version 1.5.5-1ubuntu3.1) and this bug is still present.

Matthias Niess (mniess) wrote :

@andrew Installing the package won't fix the bug for your current user. It will change the default for newly created users. If you want to fix it for your current user you just need to change the setting "by hand" by opening "ibus-setup" and checking the setting to "Use system keyboard layout".

Matthias Niess (mniess) wrote :

@andrew-andrewr If you want to confirm whether the bug is fixed, create a new user and verify if the setting is checked.

Aron Xu (happyaron) on 2015-08-20
Changed in ibus (Ubuntu Trusty):
status: Fix Committed → Triaged
assignee: nobody → Aron Xu (happyaron)
Changed in indicator-keyboard (Ubuntu):
importance: High → Undecided
Changed in ibus (Ubuntu Trusty):
importance: Undecided → High
no longer affects: indicator-keyboard (Ubuntu Trusty)
no longer affects: indicator-keyboard (Ubuntu)
Kazlu (kazlu444-4) wrote :

Also happened to me in Xubuntu 14.04, Kubuntu 15.04 and Linux Mint 17. Occurs on several computers with several keyboards but not all of them : I have an eeepc which embedded keyboard causes no problem, but some external keyboards are set in US layout at boot. Very annoying to enter my password at login...

I worked around this by executing "setxkbmap -fr" at startup, but the problem is still there at login.

Kazlu (kazlu444-4) wrote :

edit: Sorry, force of habit, I am not running "setxkbmap -fr" but "setxkbmap fr" at startup.

Matthias Niess (mniess) wrote :

How to test if the proposed package fixes this:

1. Install proposed package
2. create new user
3. login as the new user
4. run dconf read /desktop/ibus/general/use-system-keyboard-layout

The result should be 'true'. I don't have a machine with 14.04 anymore so I can't test this. Please folks, lets finally get this fixed. For all non-english users this is a major annoyance.

Paul Hoell (hoellp) wrote :

I tried the steps to test the proposed package, but the dconf key is not available on my system and thus has no output. The system language and keyboard are set to German in both cases.

Matthias Niess (mniess) wrote :

@hoellp can you run "ibus-setup" and check the "Erweitert" (Advanced) tab?

Matthias Niess (mniess) wrote :

I confirmed with @hoellp that the packages in proposed are not working. They are not reverting the dconf setting for newly created users.

Coeur Noir (gerald-maruccia-e) wrote :

Bug still existing in Ubuntu 15.10 → https://forum.ubuntu-fr.org/viewtopic.php?pid=20947601#p20947601

I also met it with many 14.04 installation - running ibus-setup and setting "use system keyboard layout" in advanced tab was and still is the workaround.

Coeur Noir (gerald-maruccia-e) wrote :

And not only under Unity environment but also other "flavors" (Lubuntu, Xubuntu…) and other ubuntu based distro like elementaryOS.

Rolf Leggewie (r0lf) wrote :

Reopening

Changed in ibus (Ubuntu):
status: Fix Released → Confirmed
Michel Kleidt (kleidt) wrote :

Perhaps I can add some clues which hopefully will help to solve this problem:

1) Restart of ibus change the keyboard layout always to US, while the indicator still shows the configured layout.
- Configure a non US layout like German [DE].
- The Keyboard indicator shows the correct "De"
- The Keyboard has the correct German layout (QWERTZ)
- Open a terminal and type in "ibus restart"
- The Keyboard indicator still shows "De"
- But the Keyboard has now US layout (QWERTY)
Shouldn't the ibus restart preserve the keyboard layout?

2) Since the last major release ibus has a new command line option: "--restart" or "-R". This option is missing in the current man page (I use Ubuntu 15.10), but if you run "ibus-daemon -h" you get:
-R, --restart restart panel and config processes when they die.

3) I didn't find out where and how idbus-daemon is actually started, but assuming
- the daemon is started with restarting option
- the daemon dies during startup and automatically restarts
- that the automatic restart also change silently the keyboard layout
In this case we would have US layout after startup, but the indicator will show the configured keyboard layout.

jamie (jgwild) wrote :

I did a fresh install of Ubuntu 15.10 on the whole drive. During the install I selected English UK and the GB keyboard layout. After the install only the US keyboard layout was in the text entry list. I added "English UK" and made it the default which fixed the problem. Afterwards I deleted the US layout but the problem returned. Adding US layout as second choice seems to help but I just re-booted this laptop and it has reverted to US again.
Also the keyboard will randomly stop working and only by logging out and back in will fix it.

I'm running two Ubuntu 14.04 machines with a UK keyboard layout. This problem affects one of them but not the other - not sure why.

On the affected machine EVERY TIME I accept a system update, the keyboard layout is broken. I can fix it by uninstalling ibus and rebooting, but on the next system update, the problem comes back. On the other machine, I can apply updates without incident.

Another problem is, if the user's password contains the affected keys, they will not be able to log in. It will look to them as if the upgrade has reset their password. They may look on the web for help, but they will not think to look for problems with swapped keys. If they are lucky, they may find my posting http://askubuntu.com/questions/695167/cannot-log-in-after-software-upgrade-ibus-issue. If not, they will probably get out the rescue disk and reinstall. This does nothing for the reputation of Linux as a replacement for Windows.

To add to the confusion, the first login after the upgrade will work, because the change is only applied after that. On the second and subsequent logins, they need to substitute some characters when they type their password.

To sum up, it appears that this only breaks some machines, which is why there has not been a huge fuss, but those machines that it breaks get broken repeatedly, and in some cases the symptoms make the problem look much more serious than it is, causing the user to do work that is disruptive and unnecessary.

Matthias Niess (mniess) wrote :

We already figured out how this was introduced and how to fix it. We just need someone to actually create the fix.

The ibus package changed the default setting of desktop.ibus.general.use-system-keyboard-layout from true to false. Ever since this dconf setting was introduced, we had this error.

For existing installations you need to change this manually either with dconf-editor or ibus-setup.

For fresh installs we need to patch the package to revert this setting back to its old default.

Wouter Van Eenoo (wouter205) wrote :

I don't know if this has already been mentioned, but I'll add this to the bug report because it can be a workaround:

If you have chosen to login automaticaly, logoff and in the logon screen you'll notice the keyboard has changed (icon next to clock). Now just change it back to your preference and upon next reboot the keyboard-layout will be to your preference (as is the case with ubuntu 14.04.3 x64 I've found).

Aron Xu (happyaron) wrote :

Uploaded to trusty-proposed.

Changed in ibus (Ubuntu Trusty):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.5.11-1ubuntu2

---------------
ibus (1.5.11-1ubuntu2) xenial; urgency=medium

  * debian/ibus.gsettings-override:
    - Use system keyboard layout by default (LP: #1240198).

 -- Iain Lane <email address hidden> Tue, 19 Jan 2016 13:35:18 +0000

Changed in ibus (Ubuntu):
status: Confirmed → Fix Released

Hello Daniel, or anyone else affected,

Accepted ibus into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ibus/1.5.5-1ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ibus (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Bruno Nova (brunonova) wrote :

I tested the ibus packages (version 1.5.5-1ubuntu3.2) in a Ubuntu 14.04.3 Live session inside VirtualBox.

Before upgrading the packages, the command:
$ gsettings get org.freedesktop.ibus.general use-system-keoard-layout
returned "false".
After upgrading, it returns "true". "ibus-setup" also displays that the setting is enabled.

This setting at "true" should mean the issue is fixed.
But testing if this really fixes "Wrong keyboard layout active after booting" is difficult since the bug is very random, and in my computer I already set that setting to "true" manually.

I'll mark this as verification-done.
But other people should test this as well (I am the one who sent the fix).
If the fix doesn't work for you, please set the bug as verification-failed (but try rebooting first).

tags: added: verification-done
removed: verification-needed
Matthias Niess (mniess) wrote :

@brunonova I did the same test with the same result. As to whether the setting really fixes the bug: I can confirm that for at least 50 machines of a client.

Bruno Nova (brunonova) wrote :

@mniess Great! :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.5.5-1ubuntu3.2

---------------
ibus (1.5.5-1ubuntu3.2) trusty; urgency=medium

  * Move the gsettings override to debian/ibus.gsettings-override so that it
    is installed by dh_installgsettings. (LP: #1240198)

 -- Iain Lane <email address hidden> Tue, 19 Jan 2016 13:27:04 +0000

Changed in ibus (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ibus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

 i cannot change keyboard layout

Changed in ibus (Ubuntu):
assignee: nobody → shamelessshark (shameless-shark)
Changed in ibus (Ubuntu):
assignee: shamelessshark (shameless-shark) → Aron Xu (happyaron)
kdureidy (kdureidy-k) wrote :

It is still not fixed, I use Ubuntu 16.04, and when the computer accidentally shutdown, due to electricity cut, or battery dead on laptop, I face this issue again!

Matthias Niess (mniess) wrote :

That's another bug then, the cause of this issue is definately fixed. If you experience something similar, please open a new bug.

Run "do-release-upgrade" on one machine yesterday. Resulting Ubuntu 14.04.4 LTS

Keyboard indicator on top of screen shows "FI" but keyboard is english.

Changing keyboard indicator on screen from FI => En and then EN => FI did not fixed keyboard.

"setxkbmap fi" fixes keyboard to be correct (finnish).

ibus-setup shows that "Käytä järjestelmän näppäimistäasettelua" (that is "use system keyboard layout") is selected.

when after "setxkbmap fi" keyboard is correct
I change keyboard indicator on top of screen
from FI => En and back EN => FI

keyboard is english again.

In other words keyboard indicator always changes keyboard to english

"setxkbmap fi" fixes that.

that fix seems to have preserved to boot. keyboard is correct after boot when I have logged in.

/ Kari Hurtta

Audun Gangsto (audun-m) wrote :

This also affects me on Ubuntu 16.04 fresh install

I've set this in /etc/default/keyboard:
XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT="altgr-intl"
XKBOPTIONS=""

BACKSPACE="guess"

And the keyboard layout is most definitively not us/altgr-intl

I had this problem also on another laptop with Trusty Tahr 14.04 a few years ago and it caused me to move to Debian. Now i tried Ubuntu again, and the problem is still here (but not on debian).

AlexAD (alex-ad) wrote :

This problem keeps coming back my Keyboard is correct for a while then it starts acting like a US even though it set as a UK. The desktop shows it as a UK keyboard and it is a UK keyboard, but somewhere this is being overridden as a US one. Can we get the fixed again, and can we work out why it keeps breaking, perhaps adding it to a automated regression test.

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS=""

Displaying first 40 and last 40 comments. View all 118 comments or add a comment.