Ubuntu

use system keyboard layout setting by default

Reported by Rolf Leggewie on 2009-08-01
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ibus

the current default for "ibus preferences - advanced - keyboard layout - use system keyboard layout" is off. I think the sane default in this case is on.

Loïc Martin (loic-martin3) wrote :

Same bug in an up-to-date Karmic. It would be pretty confusing for any non-en locale user, since the layout of their keyboard isn't respected by default by IBUS.

Changed in ibus (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) on 2009-09-23
Changed in ibus (Ubuntu):
importance: Undecided → Medium
iGEL (igel) wrote :

I think, this setting should be enabled by default and removed from the options dialog. Why should anybody want to change this? Keep it nice and simple, according to the Gnome philosophy.

iGEL (igel) wrote :

No, disabled is the correct state. The option is hard to understand, but you need to *disable* it, if you want to use a non English keyboard layout!

Remove it from the options dialog. Anyone who want to change this can use the gconf-editor.

Loïc Martin (loic-martin3) wrote :

iGEL, I'm using a non English keyboard layout, and only by enabling this option am I able to input using my session (and system) locale. With the option disabled, it reverts to a default en_US. So the option makes sense enabled.

As for suggesting users use the gconf-editors, the tool isn't geared to non techies, while changing the session layout back to an en_US is common for lambda users that learnt to use their own language input with an en_US keyboard (in their home country for example) but are now using a different layout, one corresponding to the foreign language of the country they're in. Some substitutions are possible for simple IM like pinyin, but more complex ones (character based) depend heavily on learnt habits that wouldn't easily translate into another layout (for those people).

Karl Lattimer (karl-qdh) on 2010-11-03
Changed in ibus (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
Rolf Leggewie (r0lf) wrote :

Karl, are you sure you understand the meaning of assigning this ticket to yourself? What do you intend to do and in what timeframe?

Karl Lattimer (karl-qdh) wrote :

@Rolf, I'm working a lot on ibus related things and this seemed like low hanging fruit. I'm mostly doing indicator work on ayatana.

Rolf Leggewie (r0lf) wrote :

ping Karl

Changed in ibus (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → nobody
Lalo Martins (lalo.martins) wrote :

I don't know if it's the same bug or a new one, but since in Saucy ibus is more tightly integrated, this becomes more important; but beyond that, it's actually not possible (as far as I can see) to change that setting manually! So my input methods are rendered essentially useless…

Rolf Leggewie (r0lf) on 2013-10-14
Changed in ibus (Ubuntu):
importance: Medium → Critical
milestone: none → ubuntu-13.10
Changed in ibus (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates
Changed in ibus (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Released
Hervé Fache (rvfh) wrote :

Just upgraded to Trusty from Saucy and saw my keyboard was behaving wrong. I noticed the new IBus icon and found out by chance that it was this deciding for me what layout I should use.

Could this not be an opt-in? The look'n'feel of this applet is horrible and I don't understand the point of it, can I uninstall it at all?

tags: added: trusty
Rolf Leggewie (r0lf) wrote :

no explanation was given why this was set to "fix released" so I will revert that change

Changed in ibus (Ubuntu):
milestone: saucy-updates → ubuntu-14.04-beta-2
status: Fix Released → Triaged
Aron Xu (happyaron) on 2014-03-04
Changed in ibus (Ubuntu):
importance: Critical → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers