HP LaserJet 1000/1005/1018/1020/P1005/P1006/... (on USB) stopped working in 11.04, worked in 10.04

Bug #783389 reported by Nagy Mátyás on 2011-05-16
122
This bug affects 20 people
Affects Status Importance Assigned to Milestone
foo2zjs
Undecided
auto-mirlo6
foo2zjs (Ubuntu)
High
Unassigned
Natty
High
Unassigned
hannah-foo2zjs (Ubuntu)
Undecided
rolf peter ligniez
Natty
Undecided
Unassigned

Bug Description

Binary package hint: nautilus

Ubuntu 11.04= not print(HP1020 laserjet; driver install). Under 10.04 no problem.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nautilus 1:2.32.2.1-0ubuntu13
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon May 16 11:42:34 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=hu_HU:en
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Nagy Mátyás (nm50505) wrote :
affects: nautilus (Ubuntu) → cupsys (Ubuntu)
affects: cupsys (Ubuntu) → cups (Ubuntu)
ferux@mail.ru (ferux) on 2011-05-26
tags: added: x86-64
tags: added: amd64
removed: x86-64
summary: - not print 11.04 (USB port; HP1020 laserjet); driver install
+ HP LaserJet 1020 (on USB) stopped working in 11.04, worked in 10.04
affects: cups (Ubuntu) → foo2zjs (Ubuntu)
Changed in foo2zjs (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in foo2zjs (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
Download full text (3.2 KiB)

The problem seems to be caused by some kind of war between software projects. There are two packages taking care of the automatic firmware upload into the cheap HP LaserJet printers: HPLIP and foo2zjs. Both packages do not ship the firmware files itself, because they are proprietary.

HPLIP has one plugin package with all proprietary software pieces used by different HP printers, including the firmware files. This package is downloaded if a printer which needs it is detected (using hp-plugin), but the user is asked before the download happens. This package contains also the UDEV rules and the firmware uploader scripts, as these software pieces do not make sense without the firmware files themselves.

foo2zjs contains all scripts and UDEV rules in its base package which is shipped with the distro. It comes with a script named getweb which allows to download the proprietary files (firmware or color profiles) for a given printer. With the firmware file once downloaded, it gets automatically uploaded by the firmware uploader script.

Problems occur when one downloads the firmware file with both HPLIP's and foo2zjs' methods. Then one has two copies of the firmware file which are tried to upload concurrently. This leads to a crash of the printer. This problem is discussed in bug 732450.

It seems that the author of foo2zjs is either angry about HPLIP's way to download and install a big package of proprietary files when only the firmware is actually needed or he simply wants to prevent the concurrent upload when one sees his radical approach: In the firmware uploader script (/usr/sbin/hplj1000) which is run triggered by UDEV rules, even if no firmware file is downloaded for it, he simply deletes HPLIP's UDEV rule for the firmware upload using these lines:

#
# Remove HPLIP proprietary rules!
#
model=` echo "$MODEL" | tr 'A-Z' 'a-z' `
rm -f /etc/udev/rules.d/*hpmud*laserjet_${model}*
rm -f /etc/udev/rules.d/*hpmud_support.rules

This is a radical violation against the etiquette of living together of software projects.

I have wasted several hours of searching on my system and discussing on IRC, fearing that we have a severe problem in our UDEV subsystem and not finding the problem's cause some weeks ago. Now, as I looked into the /usr/sbin/hplj1000 file to prepare for a patch to upload the firmware without using the usblp kernel module (we have decided to deprecate it today) I have found these lines.

I was really upset about this behavior.

The author of foo2zjs has broken the out-of-the-box printing experience of all users of Natty with these printers. The main intention of an author of a printer driver is to allow users to use their printers as easy as possible. And if he dislikes the way how other driver authors solve this problem he should not make the users suffering under the expression of his angriness.

I will patch out these lines now and issue that as an SRU (Stable Release Update) for Natty.

I think that this problem is urgent, therefore I have set the bug's priority to "High" and I will do the SRU before doing the fix for Oneiric, as Oneiric also needs additional work as there the usblp kernel module got deprecated and blacklisted...

Read more...

Changed in foo2zjs (Ubuntu Natty):
status: Triaged → In Progress
Till Kamppeter (till-kamppeter) wrote :

The corrected package for Natty is now uploaded to the -proposed queue and as soon as it gets approved, please test it. Instructions how to do so will be posted here then.

A debdiff of the changes is attached.

Till Kamppeter (till-kamppeter) wrote :

To reproduce the problem:

Connect an HP printer which needs firmware, a LaserJet 100, 1005, 1018, 1020, P1005, P1006, ...

Let all automatic setup work being done, especially accept the download and installation of the proprietary plugin for HPLIP.

If the plugin download does not happen, run the command

sudo hp-plugin -i

in a terminal and accept the download. If it tells you that the plugin is already installed, accept the re-install. In the end you will hear the printer making noise. It got its firmware.

Now run

ls /etc/udev/rules.d/86-hpmud-hp_laserjet_*

in a terminal window. There should be a file corresponding to your printer model.

Now turn off and turn on the printer again and wait until it stops blinking and making noise. It should make noise twice. If it makes noise only once, the firmware did not get loaded. Alternatively, you can try to print

Run again

ls /etc/udev/rules.d/86-hpmud-hp_laserjet_*

the file corresponding to your printer, and only this file, has disappeared.

Turn off and turn on the printer again and wait until it stops blinking and making noise. Now it makes noise only once and you cannot print. The firmware is not loaded.

How to test the new package:

As soon as the new package gets available, folow the instructions in the comment announcing it.

After having installed the new package, recover the UDEV rules of HPLIP by re-installing the plugin. Do this by running the command

sudo hp-plugin -i

in a terminal window. Accept the re-installation and the download of the plugin. In the end yourr printer makes noise again as it receives its firmware.

Turn off and turn on the printer again and wait until it stops blinking and making noise. It should make noise twice. Try to print. It should work.

Repeat the previous step several times. Your printer should always receive its firmware and be able to print and the command

ls /etc/udev/rules.d/86-hpmud-hp_laserjet_*

should always show your printer's file.

Changed in foo2zjs (Ubuntu Natty):
status: In Progress → Fix Committed
summary: - HP LaserJet 1020 (on USB) stopped working in 11.04, worked in 10.04
+ HP LaserJet 1000/1005/1018/1020/P1005/P1006/... (on USB) stopped working
+ in 11.04, worked in 10.04

Accepted foo2zjs into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in foo2zjs (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package foo2zjs - 20110210dfsg-1ubuntu3

---------------
foo2zjs (20110210dfsg-1ubuntu3) oneiric; urgency=low

  * debian/patches/95-udev-firmware-script-no-hplip-rules-removal.patch:
    Removed the lines in the UDEV script for the automatic firmware upload into
    the printer which remove the UDEV rules files for HPLIP's automatic
    firmware upload. NO WARS BETWEEN FREE SOFTWARE PROJECTS! (LP: #783389).
 -- Till Kamppeter <email address hidden> Wed, 8 Jun 2011 13:30:00 +0200

Changed in foo2zjs (Ubuntu):
status: Fix Committed → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Everyone who suffers the problem on Oneiric, as soon as the update of foo2zjs has happened on your system, please follow the instructions of comment #4 to get your printer printing.

Everone on Natty, please test the package of -proposed following the installation instructions of comment #5 and the testing instructions of comment #4. Thanks.

Hendy Irawan (ceefour) wrote :

Printer sharing also doesn't work, I'm not sure if it's due to this bug or another.

How to reproduce:
1. On the host computer directly connected to the LaserJet, apply the fixes as per comment #4, #5, #7 above.
2. Verify that the host computer can print to the LaserJet successfully.
3. On the host computer, enable print sharing. (System > Administration > Printing > Server > Settings > Publish shared printers connected to this system) and share the LaserJet if it's not shared yet.
4. On another computer, enable shared printer discovery (System > Administration > Printing > Server > Settings > Show printers shared by other systems). HP LaserJet should show up in a few seconds.
5. Print through that other computer to that LaserJet, it fails.

When the LaserJet printer is inspected on the client computer, the Device URI says "file:///dev/null"

A workaround is to add printer manually, and select Network Printer > Internet Printing Protocol (ipp), then configure : (for example)
Host: 192.168.66.7
Queue: /printers/HP-LaserJet-P1005

This works, but is not practical for many number of computers.

Till Kamppeter (till-kamppeter) wrote :

Hendy Irawan, this must be an independnet bug. If you have a second printer, try setting it up on the machine where you have set up your LaserJet and check whether it gets shared to your second computer correctly. My LaserJet 1020 gets shared correctly. Report a separate bug on this. Attach the /etc/cups/cupsd.conf files of both client and server and the /etc/cups/printers.conf file of the server to that bug. Attach the files separately and uncompressed. Thanks.

Hendy Irawan, as you have confirmed that printing works (at least on your server) with the fixed package, I mark this bug as "verification done" now.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package foo2zjs - 20110210dfsg-1ubuntu2.1

---------------
foo2zjs (20110210dfsg-1ubuntu2.1) natty-proposed; urgency=low

  * debian/patches/95-udev-firmware-script-no-hplip-rules-removal.patch:
    Removed the lines in the UDEV script for the automatic firmware upload into
    the printer which remove the UDEV rules files for HPLIP's automatic
    firmware upload. NO WARS BETWEEN FREE SOFTWARE PROJECTS! (LP: #783389).
 -- Till Kamppeter <email address hidden> Wed, 8 Jun 2011 13:30:00 +0200

Changed in foo2zjs (Ubuntu Natty):
status: Fix Committed → Fix Released
Worik (worik-stanton) wrote :

I have hplip installed and *not* foo2zjs. My P1005 printer stopped working after "upgrading" to 11.04. So this is not the only problem.

I aptitude remove hplip; aptitude install foo2zjs
Killed the hp ssytray and deleted my printers

Added the P1005 again using the recommended drivers and there is no test page as requested but it appears in print queue then disappears.

Worik

Savvas Radevic (medigeek) wrote :

"it appears in print queue then disappears" -- I had the same problem. I ran "sudo hp-plugin" in order to fix it. Of course, you need hplip package (and preferably hplip-gui too)

affects: foo2zjs (Ubuntu) → hannah-foo2zjs (Ubuntu)
Changed in hannah-foo2zjs (Ubuntu):
assignee: nobody → rolf peter ligniez (peterligniez)
affects: hannah-foo2zjs (Ubuntu) → foo2zjs (Ubuntu)
Changed in hannah-foo2zjs (Ubuntu):
assignee: nobody → rolf peter ligniez (peterligniez)
Changed in foo2zjs (Ubuntu):
assignee: rolf peter ligniez (peterligniez) → nobody

rolf peter ligniez, if you think that also the Ubuntu package hannah-foo2zjs needs to be fixed, open a new task instead of changing an existing, already completed task. I have done so now and moved also your assignment to the new task. Also please tell in a comment what is wrong with hannah-foo2zjs.

problem solved.

I have used Sudo HP HELP

2011/7/3 Till Kamppeter <email address hidden>

> rolf peter ligniez, if you think that also the Ubuntu package hannah-
> foo2zjs needs to be fixed, open a new task instead of changing an
> existing, already completed task. I have done so now and moved also your
> assignment to the new task. Also please tell in a comment what is wrong
> with hannah-foo2zjs.
>
> ** Package changed: hannah-foo2zjs (Ubuntu) => foo2zjs (Ubuntu)
>
> ** Also affects: hannah-foo2zjs (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: hannah-foo2zjs (Ubuntu)
> Assignee: (unassigned) => rolf peter ligniez (peterligniez)
>
> ** Changed in: foo2zjs (Ubuntu)
> Assignee: rolf peter ligniez (peterligniez) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (783462).
> https://bugs.launchpad.net/bugs/783389
>
> Title:
> HP LaserJet 1000/1005/1018/1020/P1005/P1006/... (on USB) stopped
> working in 11.04, worked in 10.04
>
> Status in foo2zjs: a linux printer driver for ZjStream protocol:
> New
> Status in “foo2zjs” package in Ubuntu:
> Fix Released
> Status in “hannah-foo2zjs” package in Ubuntu:
> New
> Status in “foo2zjs” source package in Natty:
> Fix Released
> Status in “hannah-foo2zjs” source package in Natty:
> New
>
> Bug description:
> Binary package hint: nautilus
>
> Ubuntu 11.04= not print(HP1020 laserjet; driver install). Under 10.04
> no problem.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: nautilus 1:2.32.2.1-0ubuntu13
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Mon May 16 11:42:34 2011
> ExecutablePath: /usr/bin/nautilus
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)
> ProcEnviron:
> LANGUAGE=hu_HU:en
> LANG=hu_HU.UTF-8
> SHELL=/bin/bash
> SourcePackage: nautilus
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/foo2zjs/+bug/783389/+subscriptions
>

*Mon fils jacques Geffroy ( <email address hidden> a trouvé la méthode:

1)
Installer HPLIP (si pas déja installé).
Pour cela=
Dérouler le menu Applications de Gnome,
                 choisir 'Ajouter/Supprimer'

Dans la case 'Recherche' en haut à droite, taper HPLIP.
S'il est déja coché, passer à l'étape 2), sinon, installer HPLIP.

2) Dans le menu 'Applications', Accessoires, lancer le Terminal (ligne de
commande).
Taper 'sudo hp-setup' (sans les guillemets) (ou copier-coller si tu
veux...)
                       dans le Terminal
                 puis enfoncer la touche 'ENTER'.
            *********************************************************
Le firmware vient d'être téléchargé et installé au bon endroit
automatiquement.
Il ne reste plus qu'à répondre aux questions...
Si déja prérempli, juste valider après vérif rapide de chaque page.
C'est tout.*

Bonne utilisation par les utilisateurs de HP sur Linux.

2011/7/26 Launchpad Bug Tracker <email address hidden>

> ** Branch linked: lp:debian/foo2zjs
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (783462).
> https://bugs.launchpad.net/bugs/783389
>
> Title:
> HP LaserJet 1000/1005/1018/1020/P1005/P1006/... (on USB) stopped
> working in 11.04, worked in 10.04
>
> Status in foo2zjs: a linux printer driver for ZjStream protocol:
> New
> Status in “foo2zjs” package in Ubuntu:
> Fix Released
> Status in “hannah-foo2zjs” package in Ubuntu:
> New
> Status in “foo2zjs” source package in Natty:
> Fix Released
> Status in “hannah-foo2zjs” source package in Natty:
> New
>
> Bug description:
> Binary package hint: nautilus
>
> Ubuntu 11.04= not print(HP1020 laserjet; driver install). Under 10.04
> no problem.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: nautilus 1:2.32.2.1-0ubuntu13
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Mon May 16 11:42:34 2011
> ExecutablePath: /usr/bin/nautilus
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)
> ProcEnviron:
> LANGUAGE=hu_HU:en
> LANG=hu_HU.UTF-8
> SHELL=/bin/bash
> SourcePackage: nautilus
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/foo2zjs/+bug/783389/+subscriptions
>

Changed in hannah-foo2zjs (Ubuntu Natty):
status: New → Confirmed
Changed in hannah-foo2zjs (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2013-05-18
Changed in hannah-foo2zjs (Ubuntu Natty):
status: Confirmed → Invalid
tags: removed: natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.