Gnome-terminal paste keyboard shortcut does not work - menu not shown

Bug #630383 reported by Paul Natsuo Kishimoto on 2010-09-04
288
This bug affects 53 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Medium
gnome-terminal (Ubuntu)
Medium
Michael Terry
Maverick
Medium
Unassigned
libdbusmenu (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: gnome-terminal

TEST CASE:
1. login to your desktop.
2. start gnome-terminal.
3. copy some text and try to paste it in gnome-terminal with ctrl+shift+v.
4. if won't paste.
5. now install the proposed version of gnome-terminal.
6. see ctrl+shift+v works.

Expected: the keyboard shortcut for "Paste" (set in Edit → Keyboard Shortcuts...) pastes text from the clipboard into gnome-terminal.

Observed: the shortcut has no effect.

Other information:
 * Shift+Insert pastes from the clipboard, but is not listed anywhere as a shortcut.
 * Changing the shortcut from the default (Shift+Ctrl+V) to other key combinations does not help.
 * The keyboard shortcut for "Copy" works properly — either as the default (Shift+Ctrl+C) or with another combination.
 * I created a fresh user account, logged in, started gnome-terminal, and observed the same behaviour.

When this occurs, the dbusmenu is not shown. This is reproducible when gnome-terminal is launched immediately after logging in.

$ lsb_release -rd && apt-cache policy gnome-terminal
Description: Ubuntu maverick (development branch)
Release: 10.10
gnome-terminal:
  Installed: 2.31.91-0ubuntu1
  Candidate: 2.31.91-0ubuntu1
  Version table:
 *** 2.31.91-0ubuntu1 0
        500 http://ubuntu.media.mit.edu/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-terminal 2.31.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Sat Sep 4 14:43:45 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Beta i386 (20100902.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-terminal

Related branches

Paul Natsuo Kishimoto (khaeru) wrote :
Adam Collard (adam-collard) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in gnome-terminal (Ubuntu):
status: New → Incomplete
Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
Rick Silva (silvari) wrote :

I'm experiencing this with the Maverick (10.10) Release Candidate for Netbooks. With the default 'terminal' app available via applications. Running it 'Live' from USB stick (i.e. not installed)

Not only does Shift+Ctrl+V fail to paste, but Shift+Ctrl+C fails to copy the selected text.

Use of the Edit menu options for Copy and Paste does work.
Use of Ctrl+Ins and Shift+Ins also does work for Copy and Paste.

But for as long as I've been using Ubuntu, Shift+Ctrl+C and Shift+Ctrl+V have been the default key combinations for the Copy and Paste functions in gnome-terminal. People have probably gotten used to this, and might find it confusing to find them no longer working in Maverick.

Rick Silva (silvari) wrote :

ubuntu@ubuntu:~$ lsb_release -rd && apt-cache policy gnome-terminal
Description: Ubuntu maverick (development branch)
Release: 10.10
gnome-terminal:
  Installed: 2.32.0-0ubuntu1
  Candidate: 2.32.0-0ubuntu1
  Version table:
 *** 2.32.0-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

LaserJock (laserjock) wrote :

I can confirm Paul's experience. Copy (shift-ctrl-c) works fine but Paste (shift-ctrl-v or any other shortcut I put in there for that matter) doesn't work. Shift-insert does work as does pasting from the menu.

I am using up-to-date Maverick and this has started fairly recently ( I think perhaps with the final Gnome release but I'm not 100% sure).

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed
Tobias Wolf (towolf) wrote :

Shift-Insert pastes PRIMARY selection, not CLIPBOARD. I use both and they differ.

Paul Natsuo Kishimoto (khaeru) wrote :

I should note that this is occurring on Ubuntu Netbook Edition. I can't reproduce the problem when I log into the Ubuntu Desktop session on the same machine, or on a non-UNE installation.

I am also experiencing problems with keyboard shortcuts for other applications, so this may be a Mutter/Unity issue, not one with gnome-terminal specifically.

Does this match anyone else's experience?

Tobias Wolf (towolf) wrote :

I have a hunch that this is related to the indicator-appmenu machination. Is everybody using appmenu, i.e., the global menu, here?

Ryan Lines (hardran3) wrote :

Also affected. I am using appmenu, and in fact I was linked to this bug report from here:
 https://bugs.launchpad.net/ubuntu/+source/appmenu-gtk/+bug/630292

LaserJock (laserjock) wrote :

I have the appmenu indicator installed but am not using it. I am running a regular Desktop session but I do have Unity installed.

I confirm that ctrl-shift-v does not paste on my netbook running maverick with unity. I'll check a desktop when I can.

Chris Coulson (chrisccoulson) wrote :

This is really bugging me. Will take a look at it today

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)

I confirm that my desktop running maverick does not display this bug.
i.e. I assume that Unity is the problem.

This does also not work on my box Ubuntu 10.10.

John Mahoney (jmahoney) wrote :

Hi, I have this issue and it is on Unity Ubuntu 10.10 using the gnome-terminal.
I filed this bug under Unity and it was marked as a Duplicate to here.

Now this bug is being ignored and marked at low since it is only being seen by people running Unity.

1. Can this bug be moved back to Unity instead of Gnome-terminal where it will receive proper attention.

2. I feel this bug is much worse than low priority. I am not aware of Ubuntu's bug policy, but would guess that a key feature of the most fundamental application any Unix os runs should be considered higher priority.

I am starting to wonder if I am the only person using Unity or maybe no one using it cares about the terminal. A netbook with a terminal to ssh into a powerful server makes a pretty strong weapon. It is too bad the terminal is trying to be replaced out of fear...excuse my random rant, but seriously this is a deal breaker for a computer IMO. The terminal is broken it, does not get more fundamental than that.

--
John

Tobias Wolf (towolf) wrote :

John, over all that verbosity you have overlooked that this is not a Unity issue. I and others above don’t have Unity installed at all.
It’s probably related to dbusmenu of appmenu-gtk.

On Mon, Oct 18, 2010 at 2:45 AM, Tobias Wolf <email address hidden>wrote:

> John, over all that verbosity you have overlooked that this is not a Unity
> issue. I and others above don’t have Unity installed at all.
> It’s probably related to dbusmenu of appmenu-gtk.
>
>
HAHA... That was a very polite way to respond.
 I apologize for misinterpreting your comment.

My rant still stands about unity and ignoring the terminal, but I am wasting
my breathe and wasting it in the wrong place.

cheers,
John

The priority is appropriate. It can easily be worked around (right-click, paste), It does not absolutely limit the functionality of the application. See the low section in https://wiki.ubuntu.com/Bugs/Importance

Tobias Wolf (towolf) wrote :

To balance things out we could keep the priority but tag this bug as »embarrassing regression«.

Julian Taylor (jtaylor) wrote :

It it severely increases the time needed for copy pasting on the terminal with a touchpad.

For me this is very annoying, I would like to see this having a higher priority.

As a workaround I now use xfce4-terminal instead of gnome-terminal on UNE.

On Wed, Oct 20, 2010 at 7:06 AM, Julian Taylor <email address hidden>wrote:

> It it severely increases the time needed for copy pasting on the
> terminal with a touchpad.
>
> For me this is very annoying, I would like to see this having a higher
> priority.
>
>
> As a workaround I now use xfce4-terminal instead of gnome-terminal on
> UNE.
>
>

Yeah I installed Guake and set it to automatically start at boot and
gnome-terminal paste works fine on first open. As has been stated the bug
"goes away" after you open and close gnome-terminal once.

--
John

Having the same issue, its very annoying, investigating other terminals..

in natty works properly

On So, 2010-11-14 at 09:13 +0000, Pavol Klačanský wrote:
> in natty works properly

Not here.

Daniel Sager (buuh) wrote :

I am working a lot with the terminal while being used to frequently use the paste shortcut. Hence this is the most annoying bug I experienced so far in Ubuntu. In my opinion the priority is nowhere near "low", this issue needs to be addressed asap!

Bilal Akhtar (bilalakhtar) wrote :

I noticed one thing with this behavior:

The first time, the keyboard shotrcut doesn't work. But once I use the menu and then after that the shortcut works for as long as the window is open. But if I close the gnome-terminal window and reopen it, the problem begins again for 1 more time.

I will look into fixing this and assist chris.

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Triaged
Bilal Akhtar (bilalakhtar) wrote :

20:58 < bilalakhtar> chrisccoulson: there? are you working on bug #630383? or can I take it?
20:58 < ubottu> Launchpad bug 630383 in gnome-terminal (Ubuntu) "Gnome-terminal paste keyboard shortcut does not
                work" [Low,Triaged] https://launchpad.net/bugs/630383
20:58 < chrisccoulson> bilalakhtar, feel free to take it, i didn't get time to look at it yet
20:58 < bilalakhtar> thanks chrisccoulson

Changed in gnome-terminal (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → Bilal Akhtar (bilalakhtar)
Version7x (version7x) wrote :

Interestingly enough, I had absolutely no issue on Maverick until last week when I installed Unity along side. I had been using it without issue for over a month and then it broke immediately on installation of Unity.

I've also noticed that the "highlight[copy], middle click[paste]" funtionality (or double button click on dual button mice) has also stopped working.

Chris Gross (gross-cw) wrote :

I'm having this problem, too. I use the shortcut religiously, so I do hope this is fixed very soon.

saidimu apale (saidimu) wrote :

Uninstalling Unity fixed the issue for me. The shortcuts on gnome-terminal now work as they used to before.

On Mon, Dec 13, 2010 at 3:54 PM, saidimu apale
<email address hidden> wrote:
> Uninstalling Unity fixed the issue for me. The shortcuts on gnome-
> terminal now work as they used to before.

Can you uninstall Unity on netbook remix?

--
John

I'm seeing these symptoms on a 10.10 desktop installation that does _not_ have Unity installed.

The problem started within the last few days, so it is probably related to some update that was recently pushed out.

I use those key combinations many dozens of times a day, so for me, this bug is a big deal. I'm willing to help with testing of a fix.

John Dykstra (jdykstra72) wrote :

Addendum to my previous comment:

The usual keyboard equivalents for copy/paste are also not working for me in gedit. I suspect something pretty fundamental in GNOME is broken, and that some developers are having a bad day.

I get the same behaviour with UNE 10.10, 2D Netbook Interface, Unity installed but not used.
This also appears when using the Network Manager (ssid/password dialog, edit connections...).

Extremely annoying indeed,
++Alex

confirming that this bug is definitely related to unity integration; I uninstalled unity & most of gnome, and the keyboard shortcuts work fine running under xfce.

Chris Gross (gross-cw) wrote :

I do not have unity installed, and I still have this issue.

Muharem Hrnjadovic (al-maisan) wrote :

This was working fine on maverick for me and only stopped working after installing natty (I am using the classic/gnome desktop FWIW). This is a real pain in the neck. Please fix asap.

I believe this is related to having the menu shown. I was having the same problem, turned on the menu so it was visible, and then tried pasting again, and the problem seems to be fixed. I've even closed and reopened the terminal, and it seems fixed. Perhaps it will return after a reboot?

I confirm what mlissner said, and I'm able to reproduce the problem. The copy/paste action fails when the menu is not shown.

This is highly reproducible with these steps:
- Log into Unity
- Immediately launch gnome-terminal (launcher panel, shortcut on the desktop, keyboard shortcut)

Result:
Most of the time, but not always, the first instance of gnome-terminal doesn't have a menu.

If I open other terminals (new windows) then the menu is displayed for these instances but when I switch back to the one opened first, the menu is not shown.

Adding a task for libdbusmenu

summary: - Gnome-terminal paste keyboard shortcut does not work
+ Gnome-terminal paste keyboard shortcut does not work - menu not shown
description: updated
Changed in gnome-terminal (Ubuntu):
importance: Low → Medium
Jerry Ablan (lucifurious) wrote :

Just my $0.02 on this.

When I first start terminal, Shift-Ctrl-C/V do not work, Shift-Insert does. If I open up keyboard shortcuts and close the dialog (WITHOUT CHANGING ANYTHING), the shortcuts begin to work.

It's like the initial loading of shortcuts is goofed or skipped until you go into the keyboard shortcuts dialog.

Thanks!

Muharem Hrnjadovic (al-maisan) wrote :

FWIW, I just installed alpha2 and Shift-Ctrl-V works under the classic gnome desktop

Tobias Wolf (towolf) wrote :

But not if you add the appmenu to the panel.

Leigh Honeywell (hypatia) wrote :

I ran into this in a fresh install of 32-bit 10.10 with both the netbook and regular Gnome desktops. Shift-insert does seem to work.

Bilal Akhtar (bilalakhtar) wrote :

Unable to fix this one, sorry. Someone else?

Changed in gnome-terminal (Ubuntu):
assignee: Bilal Akhtar (bilalakhtar) → nobody
Michael Terry (mterry) wrote :

I started looking at this a bit. The only upstream bug I can find that sounds similar is https://bugzilla.gnome.org/show_bug.cgi?id=600876 which talks about the same issue on Fedora 11, back at the end of 2009. But the maintainers couldn't reproduce.

Michael Terry (mterry) wrote :

Here's some testing I did in a fresh Ubuntu 10.10:

In all situations, the copy keyboard shortcut and both the copy and paste menu items seemed to work. It was only the paste keyboard shortcut that was noticeably buggy.

With indicator-applet-appmenu in gnome-panel:
 * Always can hit this bug with first gnome-terminal opened
 * Unless there is something in the clipboard before I open the first gnome-terminal; then everything is fine (I don't hit this bug)

Without indicator-applet-appmenu in gnome-panel:
 * Same behavior as above (first gnome-terminal always has bug, unless something is in clipboard already)
 * However, as soon as I open the Edit menu (without even selecting an item), Paste via the shortcut starts working again. Copy still worked before the open.

Without indicator*-appmenu and appmenu-gtk even installed, everything worked fine. With just appmenu-gtk installed and no indicator*-appmenu installed, the bug is back. So this seems clearly to be an appmenu-gtk bug. I'm going to move this bug to that package.

Michael Terry (mterry) wrote :

In latest 11.04 nightly, situation is the same except that indicator-applet-appmenu now also fixes itself now when the Edit menu is opened.

Michael Terry (mterry) wrote :

OK, more info! I now believe this is actually a gnome-terminal bug that appmenu-gtk merely exacerbates. You can reproduce on stock gnome-terminal by:
1) Logging into a fresh session
2) Open a gnome-terminal
3) Click on the Edit menu
4) Now try to copy some text and paste it. It will copy, but not paste

This is because when the Edit menu is activated, if no content is in the clipboard, gnome-terminal will disable pasting. But it doesn't notice when you do put content into the clipboard. Normally this isn't a problem since pasting starts enabled and you normally don't open the Edit menu before there is content in the clipboard. But appmenu-gtk forces a fake activation of the Edit menu (for its own, valid reasons) that causes pasting to be disabled on startup.

So I'm working on an upstream and a distro patch.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: Triaged → In Progress
Michael Terry (mterry) on 2011-03-07
Changed in libdbusmenu (Ubuntu):
status: New → Invalid
Michael Terry (mterry) on 2011-03-07
tags: added: patch-forwarded-upstream
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 2.32.1-0ubuntu3

---------------
gnome-terminal (2.32.1-0ubuntu3) natty; urgency=low

  * debian/patches/21_watch_clipboard.patch:
    - Watch clipboard contents to set Edit->Paste sensitivity appropriately.
      LP: #630383
 -- Michael Terry <email address hidden> Mon, 07 Mar 2011 10:38:22 -0500

Changed in gnome-terminal (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-terminal:
importance: Unknown → Medium
status: Unknown → New
Omer Akram (om26er) on 2011-03-13
description: updated
Changed in libdbusmenu (Ubuntu Maverick):
status: New → Invalid
Changed in gnome-terminal (Ubuntu Maverick):
status: New → In Progress
importance: Undecided → Medium
Dustin Kirkland  (kirkland) wrote :

Okay, I have fixed up the merge proposed branch, and uploaded to maverick-proposed.

Please update the description of the bug with SRU testing details:
 * https://wiki.ubuntu.com/StableReleaseUpdates

Thanks,
Dustin

I have already update it. with a test case.

On Mon, Mar 14, 2011 at 10:06 PM, Dustin Kirkland <<email address hidden>
> wrote:

> Okay, I have fixed up the merge proposed branch, and uploaded to
> maverick-proposed.
>
> Please update the description of the bug with SRU testing details:
> * https://wiki.ubuntu.com/StableReleaseUpdates
>
> Thanks,
> Dustin
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/630383
>
> Title:
> Gnome-terminal paste keyboard shortcut does not work - menu not shown
>
> Status in GNOME Terminal:
> New
> Status in “gnome-terminal” package in Ubuntu:
> Fix Released
> Status in “libdbusmenu” package in Ubuntu:
> Invalid
> Status in “gnome-terminal” source package in Maverick:
> In Progress
> Status in “libdbusmenu” source package in Maverick:
> Invalid
>
> Bug description:
> Binary package hint: gnome-terminal
>
> TEST CASE:
> 1. login to your desktop.
> 2. start gnome-terminal.
> 3. copy some text and try to paste it in gnome-terminal with ctrl+shift+v.
> 4. if won't paste.
> 5. now install the proposed version of gnome-terminal.
> 6. see ctrl+shift+v works.
>
>
> Expected: the keyboard shortcut for "Paste" (set in Edit → Keyboard
> Shortcuts...) pastes text from the clipboard into gnome-terminal.
>
> Observed: the shortcut has no effect.
>
> Other information:
> * Shift+Insert pastes from the clipboard, but is not listed anywhere as a
> shortcut.
> * Changing the shortcut from the default (Shift+Ctrl+V) to other key
> combinations does not help.
> * The keyboard shortcut for "Copy" works properly — either as the default
> (Shift+Ctrl+C) or with another combination.
> * I created a fresh user account, logged in, started gnome-terminal, and
> observed the same behaviour.
>
> When this occurs, the dbusmenu is not shown. This is reproducible when
> gnome-terminal is launched immediately after logging in.
>
> $ lsb_release -rd && apt-cache policy gnome-terminal
> Description: Ubuntu maverick (development branch)
> Release: 10.10
> gnome-terminal:
> Installed: 2.31.91-0ubuntu1
> Candidate: 2.31.91-0ubuntu1
> Version table:
> *** 2.31.91-0ubuntu1 0
> 500 http://ubuntu.media.mit.edu/ubuntu/ maverick/main i386
> Packages
> 100 /var/lib/dpkg/status
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: gnome-terminal 2.31.91-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic i686
> Architecture: i386
> Date: Sat Sep 4 14:43:45 2010
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Beta i386
> (20100902.1)
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: gnome-terminal
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gnome-terminal/+bug/630383/+subscribe
>

Changed in gnome-terminal:
status: New → Fix Released

Accepted gnome-terminal into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-terminal (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed

The update for Maverick (2.32.0-0ubuntu1.1) seems to fix this issue - thanks :)

Martin Pitt (pitti) on 2011-04-08
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 2.32.0-0ubuntu1.1

---------------
gnome-terminal (2.32.0-0ubuntu1.1) maverick-proposed; urgency=low

  * debian/patches/21_watch_clipboard.patch:
    - Watch clipboard contents for paste shorkey to work. (LP: #630383)
 -- Omer Akram <email address hidden> Sun, 13 Mar 2011 20:20:13 +0500

Changed in gnome-terminal (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.