Comment 47 for bug 630383

Michael Terry (mterry) wrote :

Here's some testing I did in a fresh Ubuntu 10.10:

In all situations, the copy keyboard shortcut and both the copy and paste menu items seemed to work. It was only the paste keyboard shortcut that was noticeably buggy.

With indicator-applet-appmenu in gnome-panel:
 * Always can hit this bug with first gnome-terminal opened
 * Unless there is something in the clipboard before I open the first gnome-terminal; then everything is fine (I don't hit this bug)

Without indicator-applet-appmenu in gnome-panel:
 * Same behavior as above (first gnome-terminal always has bug, unless something is in clipboard already)
 * However, as soon as I open the Edit menu (without even selecting an item), Paste via the shortcut starts working again. Copy still worked before the open.

Without indicator*-appmenu and appmenu-gtk even installed, everything worked fine. With just appmenu-gtk installed and no indicator*-appmenu installed, the bug is back. So this seems clearly to be an appmenu-gtk bug. I'm going to move this bug to that package.