Paste in global application menu is not active whilst using gnome-terminal

Bug #630292 reported by Adam Guthrie on 2010-09-04
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Fix Released
Low
Cody Russell
appmenu-gtk (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-terminal

Although I have text on my clipboard, the paste option is disabled in the edit global menu. This means the keyboard shortcut does not also work. Right-click -> paste does work however.

Steps to reproduce:

1, Open gedit and type "Test"
2, Control + C to copy to clipboard
3, Open gnome-terminal and attempt to Edit -> Paste or Shift + Control + V

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-terminal 2.31.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Sat Sep 4 16:58:47 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gnome-terminal

Adam Guthrie (therigu) wrote :
Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
Adam Guthrie (therigu) wrote :

Investigating this further this seems to be a problem with the global application menu. Disabling this by commenting out

export UBUNTU_MENUPROXY="libappmenu.so"

in /etc/X11/Xsession.d/80appmenu and logging out and back in fixes the issue for that session.

summary: - Paste in global menu is not active
+ Paste in global application menu is not active whilst using gnome-
+ terminal
tags: added: app-menu
Adam Guthrie (therigu) wrote :

I've investigated a little further. gnome-terminal connects a callback to the "activate" signal on the Edit menu:

  action = gtk_action_group_get_action (action_group, "Edit");
  g_signal_connect (action, "activate",
                    G_CALLBACK (edit_menu_activate_callback), window);

When not using the application menu (UBUNTU_MENUPROXY= ), this callback is fired whenever the Edit menu is opened.

However, when using the application menu, this callback is fired once when the terminal window opens and not when the Edit menu is opened.

This callback checks the clipboard and activates paste, hence this would seem to be the cause of this problem.

David Barth (dbarth) wrote :

Thanks for investigating the issue at the code level. Actually, the latest set of fixes we're landing should fix the problem hopefully in the following hours.

Keeping the bug open for now.

David Barth (dbarth) wrote :

@ted: assigning to you, but that should be fixed by your recent changes in a few hours.

Changed in indicator-appmenu:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Low
milestone: none → ubuntu-10.10
status: New → Confirmed
Adam Guthrie (therigu) wrote :

I've just dist-upgraded and retried my test case (above) and it still doesn't work.

Ted Gould (ted) on 2010-09-23
affects: indicator-appmenu → appmenu-gtk
Changed in appmenu-gtk:
assignee: Ted Gould (ted) → Cody Russell (bratsche)
milestone: ubuntu-10.10 → none
Cody Russell (bratsche) on 2010-09-23
Changed in appmenu-gtk:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2010-09-23
affects: gnome-terminal (Ubuntu) → appmenu-gtk (Ubuntu)
Changed in appmenu-gtk:
status: In Progress → Fix Committed
Changed in appmenu-gtk (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.1.9-0ubuntu2

---------------
appmenu-gtk (0.1.9-0ubuntu2) maverick; urgency=low

  * Backport upstream fix:
    - Paste in global application menu is not active whilst using
      gnome-terminal (LP: #630292)
 -- Didier Roche <email address hidden> Thu, 23 Sep 2010 21:08:40 +0200

Changed in appmenu-gtk (Ubuntu):
status: Fix Committed → Fix Released
Adam Guthrie (therigu) wrote :

Just upgraded and retested. Now `paste` is active in the edit menu but clicking it (or indeed shift+ctrl+v) doesn't do anything! Right-click > paste still works correctly.

Cody Russell (bratsche) on 2010-09-30
Changed in appmenu-gtk:
status: Fix Committed → Fix Released
Adam Guthrie (therigu) wrote :

This doesn't appear fixed to me - paste is now active but doesn't work.

I'm running appmenu-gtk 0.1.9-0ubuntu4

I think there's a separate bug about Ctrl-Shift-V not working, there may
be a deeper underlying common issue.

Mark

Didier Roche (didrocks) wrote :

right, this is bug #630383 for your information.

xtrip (xtrip) wrote :

This answer helped me to investigate a known problem with wxwidgets apps like truecrypt, audacity, filezilla, boinc, and pgadmin3.

Menu "file" disepear after an upgrade from lucid to maverick. (an example from this bug report)
https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/647410

I've commented out
# export UBUNTU_MENUPROXY="libappmenu.so"

in

sudo gedit /etc/X11/Xsession.d/80appmenu

and now all work fine !

My question is: In the future would it possible to make more fine verification of old variable/scipts that affect general env ?

Regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers