Setting static IP in Network Settings doesn't produce correct data

Bug #185854 reported by Thomas N on 2008-01-25
188
Affects Status Importance Assigned to Milestone
GST
Fix Released
Critical
gnome-system-tools (Debian)
Fix Released
Unknown
gnome-system-tools (Ubuntu)
High
Unassigned
Declined for Hardy by Pedro Villavicencio

Bug Description

When I changed to a static IP adress the network connection didn't work. If I manually did a 'ifup eth0' it was OK though. Looking at /etc/network/interfaces I can see that I'm missing the 'auto eth0'-row.

My system is Hardy Heron 8.04 devel up-to-date as of 080125.

This is what I got:

iface eth0 inet static
address 130.x.x.x
netmask 255.255.255.0
gateway 130.x.x.x

This is what it should be:

auto eth0
iface eth0 inet static
address 130.x.x.x
netmask 255.255.255.0
gateway 130.x.x.x

After fiddling some more with network-admin I have found another problem, the DNS tab doesn't work. If you unlock and perhaps add a DNS-server nothing happens to resolv.conf. Even if I save my settings to a location and apply it nothing happens.

Caroline Ford (secretlondon) wrote :

Is this still a problem with the current version of Hardy?

Changed in gnome-system-tools:
status: New → Incomplete
Stéphane Maniaci (stephh) wrote :

Still it is.

Shawn vega (svega85-gmail) wrote :

I think i'm having the same / similar problem because when i set it to a static ip it won't connect to the network and when i type ifconfig it says it has a inet6 address so i think when we type an ipaddress it automaticly converts it to ip6 when the router only knows ip4 and i think that's the problem.

Shawn vega (svega85-gmail) wrote :

marking confirmed because i believe i have the same problem

Changed in gnome-system-tools:
status: Incomplete → Confirmed
Jesse Gilles (jesse-gilles) wrote :

I can also confirm this bug in hardy beta. Unchecking and rechecking the the box next to the network interface works around the problem (auth eth0 shows up in /etc/network/interfaces then).

Jesse Gilles (jesse-gilles) wrote :

Whoops, correction: meant to write "auto eth0", not auth.

Stéphane Maniaci (stephh) wrote :

I can confirm this too. Find a workaround checking, unchecking, writing different gateways then coming back to the good one and it works. Kind of luck.

Changed in gnome-system-tools:
importance: Undecided → High
Serge Maneuf (lsmaneuf-orange) wrote :

I can confirm too. I have to manually add "auto eth0" in /etc/network/interfaces

Jesse Gilles (jesse-gilles) wrote :

Why was this bug declined for Hardy?

tuharsky (tuharsky) wrote :

The bug is here from the Gutsy. See #172529

thebrotherofasis (libardoab) wrote :

I am experiencing the same problem. Does adding "auto eth0" in /etc/network/interfaces solve the problem permanently? or must one always restart the daemon by typing "ifup eth0" every time the computer restarts?

  • unnamed Edit (966 bytes, text/html; charset=ISO-8859-1)

Adding "auto eth0" will resolve it permanently.

On Tue, Apr 1, 2008 at 7:04 PM, thebrotherofasis <email address hidden>
wrote:

> I am experiencing the same problem. Does adding "auto eth0" in
> /etc/network/interfaces solve the problem permanently? or must one
> always restart the daemon by typing "ifup eth0" every time the computer
> restarts?
>
> --
> Setting static IP in Network Settings doesn't produce correct data
> https://bugs.launchpad.net/bugs/185854
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Chow Loong Jin (hyperair) wrote :

Happens here for me too, but with wlan0 and DHCP instead. Adding "auto wlan0" fixes the issue.

Frédéric Petit (fraiddo) wrote :

i'm on hardy beta and it is impossible to be in static ip address.

Carlos Renê (slipttees) wrote :
  • unnamed Edit (780 bytes, text/html; charset=ISO-8859-1)

add "auto eth0" in the /etc/network/interface primary interface session!

2008/4/7 Frédéric Petit <email address hidden>:

> i'm on hardy beta and it is impossible to be in static ip address.
>
> --
> Setting static IP in Network Settings doesn't produce correct data
> https://bugs.launchpad.net/bugs/185854
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Sitsofe Wheeler (sitsofe) wrote :

Might be related to bug #178775 ...

Rizlaw (rizlaw) wrote :

I have been using a clean install of Hardy Beta since its release and all current updates. I, too, have the same problem: i.e. there is no way to set a static ip address and make it work. The only thing that works is to leave the default "Enable Roaming" mode checked.

Chow Loong Jin (hyperair) wrote :

Well considering this is a confirmed, high priority bug, I don't understand why it still isn't fixed when Ubuntu Hardy is going to be released in another 12 days.

Kjell Braden (afflux) wrote :

I've created a patch that fixes the data produced, so that the interface will be up after booting. However, after changing the settings using network-admin, the interface doesn't get updated (ie. configured but not with the given IP and therefore has no connection). ifup -a or disabling and reenabling the interface in the dialog also fixes this. As it is incomplete, I'll attach the patch, not a debdiff.

Chow Loong Jin (hyperair) wrote :

Ah. Thanks for the patch. I'll get a debdiff with it in as soon as I can. If all goes well I'll upload it to my PPA (http://edge.launchpad.net/~hyperair/+archive as well.

Avijit Pathania (foulplay) wrote :

I have noticed another oddity. After disabling the Enable Roaming and setting the interfaces with 'auto eth0', the option to connect to PPTP VPN is no longer present when right clicking on the network icon located in the top right corner.

So to have the ability to connect/disconnect vpn via the network icon I have to have Enable Roaming checked. Seems a lot more is dependent on Enabling Roaming.

Just thought I'd pipe this in for awareness.

Chow Loong Jin (hyperair) wrote :

"Enable roaming mode" basically removes any device configuration from /etc/network/interfaces and allows NetworkManager to take care of it. Disabling roaming mode will take control away from NetworkManager. So you will be unable to connect via system tray icon. This is perfectly expected behaviour.

Chow Loong Jin (hyperair) wrote :

I've generated a debdiff, a deb, and tested it on my computer. After using it to add the interface normally, I found it to add "auto <iface>" at the bottom, but the configuration for iface is in somewhere in the middle. While that's not exactly desirable, it has the desired effect.

Sitsofe Wheeler (sitsofe) wrote :

(VPN not being available when roaming is turned off sound like bug #5364 )

James Westby (james-w) wrote :

Hi,

The patch looks pretty sensible to me. I haven't had a chance to
look in detail at it yet, I'll do that tomorrow. Thanks for coming
up with it.

If this is going to go in at this stage I think it would be good to
have an idea of the testing that has been done. I would appreciate
it if some people would test the patch and record the things that
were tested, e.g. moving between roaming and not etc.

Thanks,

James

I tested deb provided by hyperair (big thanks) and however it has wrong depencies (cairo2 version doesn't fit with Hardy), but --force-all cures/b0rks any problems :) Anyway, it would be strange if cairo would affect this :)

So I tested in various situations and shortly - it works and I don't even experience bug what Kjell Braden saw - everything updates just normally.

I tested several situations:
1. Open network-admin, roaming mode is on, /etc/network/interfaces has only lo entry
2. Press unblock, auth stuff
3. Double click on Wired interface
4. Check out 'Enable roaming mode' checkbox and configure interface according to your needs
5. Click OK
6. Vola! /etc/network/interfaces has auto eth0 (under interface configuration, but who cares for now) and interface is up and running

After this, I run second test:
1. Open network admin, roaming mode is disabled, /etc/network/interfaces has address you configured before
2. Press unblock auth stuff
3. Double click on Wired Interface
4. Change address to new one
5. Click OK
6. Vola! /etc/network/interfaces has new ip with still auto eth0 enabled AND new address is up and running (not like bug expierenced by Kjell Braden, as far as I understood)

I will do additional line of tests, but this bug seems to be fixed by this patch. Thanks to Kjell for fix and hyperair for deb!

Sitsofe Wheeler (sitsofe) wrote :

(Additionally in other distros NetworkManager can set up static interfaces: http://bugzilla.gnome.org/show_bug.cgi?id=518189 )

If you will read comments on bug mentioned above, you will see that NM static interface configuration is purely SUSE/Redhat thing, as they use service system to control services/settings. It's totally ignores other distro configurations (Debian, Gentoo, etc.). So it is just not the "standard way of doing things" (tm). G-s-t, however, has system backends for each sytem.

NM should keep their stuff integrated with network-admin, not compete, because we need one blessed tool of configuring network.

There are dublicates for this bug (which I could find in a list given by Sitsofe Wheeler):
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/214614
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/204412
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/202605
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/201090

Interesting, that most people think that NM and even NM applet is which does manual IP configuration. Talk about real confusion here.

Count. about testing:
It is interesting that there is some other bug - or implications of same bug - which can be triaged like this:

1. Open network-admin, you have manually configured IP address
2. Unblock, auth. stuff
3. Uncheck Wired Interface checkbox
4. It reappears!
5. /etc/network/interfaces auto eth0 line is gone
6. Uncheck checkbox again
7. It stays clean!
8. /etc/network/interfaces auto eth0 line is still gone (as intended)
9. Check checkbox for Wired Interface
10. It stays checked as intended, and auto eth0 reappears in /etc/network/interfaces, however now it has at least 5 empty lines between interface configuration and auto eth0 (cosmetic bug, but strange anyway).

It is not dangerous as this bug, but something very very fishy happens there and this feels like can be triggered from something else.

Also notice that this behavior is for both - standard and patched debs, so patch still must go in, at least to fix default behaviour. This could be easily separated bug.

Chow Loong Jin (hyperair) wrote :

@Peteris Krisjanis: I don't think my debs have wrong dependencies.. I had no problems on my system. Plus, I didn't modify the dependencies of the package. It was a direct backport, just added a patch, nothing else. Perhaps you should update your system fully. The version of the libcairo2 package on my system is 1.6.0-0ubuntu1, obtained from Ubuntu's repositories. The dependency is (>= 1.6.0).

Anyway, I believe we should really get this over and done with ASAP, so that it can enter Hardy. I'm still confused as to why a certain someone declined for Hardy. Seems pretty serious to me. Either way there's nothing more I can do as of now so I'll raise it in the #ubuntu irc channels tomorrow.

Kjell Braden (afflux) wrote :

Additionally, I experienced the same behaviour (the checkbox one) as Peteris explained. Since I'm totally unfamiliar with g-s-t and NM, I don't know where to look and whether it's a different issue and so on and I think someone from the desktop team should review those changes.

hyperair, my apologies, I didn't have updated system, libcairo 1.6.0 rolled in last several days :)

hyperair, getting it in Hardy practically means bombing #ubuntu-devel with requests, but James Westby promised to take a look at it tomorrow, so probably best is just test your deb till death and provide test results here so anyone could be sure this fix doesn't 'unfix' anything else :)

Cheers man, thanks for the work.

Chow Loong Jin (hyperair) wrote :

@Peteris Krisjanis: No worries. I intend to bombard the irc channels until someone takes notice. Also, credits should go to Kjell Braden, he's the one who provided me a patch so I could package it in the first place.

Saivann Carignan (oxmosys) wrote :

I successfully built and tested the patch. I attach an updated debdiff with a comment in changelog to thanks Kjell Braden. We'll need main sponsors to review and upload this patch, so I subscribe them to the bug. Thanks for this great work!

Daniel Holbach (dholbach) wrote :

Sébastien: can you please take a look at it?

Sebastien Bacher (seb128) wrote :

I've pinged upstream about the change,

<garnacho> seb128: I'd rather do that in connection_save() so it works for non wifi/ethernet interfaces
<garnacho> but yeah, makes sense :)

He'll get a fix upstream we should likely backport this one rather than use the current version

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.22.0-0ubuntu8

---------------
gnome-system-tools (2.22.0-0ubuntu8) hardy; urgency=low

  * debian/control.in,
    debian/gnome-system-tools.manpages,
    debian/menu,
    debian/patches/00list,
    debian/patches/11_shares_admin_not_listed_under_gnome.dpatch,
    debian rules:
    - install shares-admin again since it has been requested by several users
      and some derivative distributions, it'll also make easier to edit
      previous shares for users upgrading and having some configured,
      don't install the nautilus integration and not list
      the menu item under GNOME though (lp: #208480)
  * debian/patches/90_from_svn_correctly_configure_interface.dpatch:
    - change from svn, correctly configure the network interfaces,
      thanks to the different people who worked on the issue (lp: #185854)

 -- Sebastien Bacher <email address hidden> Mon, 14 Apr 2008 14:31:56 +0200

Changed in gnome-system-tools:
status: Confirmed → Fix Released
Changed in gst:
status: Unknown → Fix Released
Jered Hofker (jlhofker) wrote :

Just a note:

I ran into this issue today with a fresh (and fully updated) install of Hardy.

Upon further investigation, /etc/network/interfaces had "auto eth0" about two lines underneath the end of my static settings. I moved "auto eth0" back above the connection where it belongs, .../networking restart, and now things are working fine.

'auto eth0' can be everywhere in /etc/network/interfaces (for example, mine always appears under static config without causing any problems), it should work anyway. So probably it was some other cause why it didn't work.

Jered Hofker (jlhofker) wrote :

Ah, I didn't realize that. Sorry for the mistake!

I wonder what caused it, then. Curious. Guess I'll post back if I find anything out!

Thanks!

Changed in gnome-system-tools:
status: Unknown → New
Charlie Kravetz (charlie-tca) wrote :

this bug appears to be back in Xubuntu Intrepid Alpha 6. Using network manager, I can not add a static connection, thus can not obtain an internet connection. The OK button is greyed out as soon as I uncheck DHCP(automatic). If this should be fixed already, perhaps this is a regression?

James Westby (james-w) wrote :

Hi Charlie,

Did you launch network-admin from the System menu, or did you choose
"Edit Connections..." from the context menu of network-manager's status
icon?

If it's the latter then it's actually a network-manager problem, as it now
provides that interface.

Thanks,

James

Charlie Kravetz (charlie-tca) wrote :

James,

I'm sorry, this bug came up searching for network-manager bugs.

I did choose "Edit Connections..." from the network-manager. Does that mean I need to file a bug report against Network Manager itself?

James Westby (james-w) wrote :

On Thu, 2008-09-18 at 23:38 +0000, Charlie Kravetz wrote:
> James,
>
> I'm sorry, this bug came up searching for network-manager bugs.
>

No problem, it has recently changed, so it's hard to know.

> I did choose "Edit Connections..." from the network-manager. Does that
> mean I need to file a bug report against Network Manager itself?

Yes please, network-manager-gnome is the correct package I think.

Thanks,

James

Changed in gnome-system-tools:
status: New → Fix Released
Changed in gst:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.