panels change their position between logins

Bug #15442 reported by Christoph Georgi on 2005-04-13
138
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Confirmed
High
gnome-panel (Ubuntu)
Low
Unassigned

Bug Description

I changed the positioning of the default panels as follows:
* Top Panel to the top of the desktop (as it is default)
* Bottom Panel to the top of the desktop, but below the Top Panel

After logging in again, the Bottom Panel is above the Top Panel at the top of
the screen, not anymore below the screen. After changing the positions again and
logging in, the bottom panel gets loaded above the top panel again.
Saving the current setup at logout does not change this behaviour.

I suppose this is a problem with the timing of the panels at bootup, as the
first panel that gets loaded is positioned at the top, the second panel that is
loaded is positioned below it.
When adding a third panel and positioning it at the top but below the other two,
it remails the lowest panel after logging in.

http://bugzilla.gnome.org/show_bug.cgi?id=126990: http://bugzilla.gnome.org/show_bug.cgi?id=126990

Sebastien Bacher (seb128) wrote :

right, there is a bug open about this on the GNOME bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=126990

Phil Bull (philbull) wrote :

Thanks for the report.

Do you still have this issue with Dapper?

Changed in gnome-panel:
status: Unconfirmed → Needs Info
Changed in gnome-panel:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

No reply, bug closed. Feel free to reopen if that's still a problem for you

Changed in gnome-panel:
assignee: seb128 → desktop-bugs
status: Needs Info → Rejected
claudio@ubuntu (claudio.ubuntu) wrote :
Download full text (4.6 KiB)

I would like to reopen this bug as it remains on feisty (also present in edgy). I have this problem on all my machines (2 x86 laptops and 1 x64 desktop). The original poster described exactly my problem. I attach a screenshot of my setup. Feel free to contact me if testing is needed.

Thanks,

Claudio

claudio@sydney:~$ dpkg -l |grep ^ii | grep -i gnome |awk '{print $2,$3}'
abiword-plugins-gnome 2.4.6-1.1ubuntu2
app-install-data 0.3.30
bug-buddy 2.18.1-0ubuntu1
capplets-data 2.18.1-0ubuntu2
compiz-gnome 0.3.6-1ubuntu13
contact-lookup-applet 0.15-1build2
deskbar-applet 2.18.1-0ubuntu2
eog 2.18.1-0ubuntu1
evolution-webcal 2.10.0-0ubuntu1
file-roller 2.18.1-0ubuntu1
firefox-gnome-support 2.0.0.3+1-0ubuntu2
gconf2 2.18.0.1-0ubuntu1
gconf2-common 2.18.0.1-0ubuntu1
gdm 2.18.1-0ubuntu1
glade-gnome-3 3.2.0-0ubuntu1
gnochm 0.9.9-0ubuntu1
gnome-about 2.18.1-0ubuntu1
gnome-accessibility-themes 2.18.1-0ubuntu1
gnome-app-install 0.3.30
gnome-applets 2.18.0-0ubuntu1
gnome-applets-data 2.18.0-0ubuntu1
gnome-btdownload 0.0.25-1ubuntu1
gnome-cards-data 2.18.1-0ubuntu1
gnome-common 2.18.0-0ubuntu1
gnome-control-center 2.18.1-0ubuntu2
gnome-cups-manager 0.31-3ubuntu5
gnome-desktop-data 2.18.1-0ubuntu1
gnome-doc-utils 0.10.3-0ubuntu1
gnome-games 2.18.1-0ubuntu1
gnome-games-data 2.18.1-0ubuntu1
gnome-icon-theme 2.18.0-0ubuntu4
gnome-keyring 0.8.1-0ubuntu1
gnome-keyring-manager 2.18.0-0ubuntu1
gnome-mag 0.14.3-0ubuntu1
gnome-media 2.18.0-0ubuntu1
gnome-media-common 2.18.0-0ubuntu1
gnome-menus 2.18.0-0ubuntu3
gnome-mime-data 2.4.3-1
gnome-mount 0.5-2ubuntu8
gnome-netstatus-applet 2.12.1-0ubuntu3
gnome-nettool 2.18.0-0ubuntu1
gnome-orca 2.18.1-0ubuntu1
gnome-panel 2.18.1-0ubuntu3.1
gnome-panel-data 2.18.1-0ubuntu3.1
gnome-pilot 2.0.15-0.1ubuntu1
gnome-pilot-conduits 2.0.15-0.1ubuntu1
gnome-power-manager 2.18.2-0ubuntu3
gnome-screensaver 2.18.1-0ubuntu1
gnome-session 2.18.0-0ubuntu3
gnome-spell 1.0.7-1ubuntu2
gnome-system-monitor 2.18.1.1-0ubuntu1
gnome-system-tools 2.18.1-0ubuntu1
gnome-terminal 2.18.0-0ubuntu1
gnome-terminal-data 2.18.0-0ubuntu1
gnome-themes 2.18.1-0ubuntu1
gnome-user-guide 2.18.1-0ubuntu1
gnome-utils 2.18.0-0ubuntu2
gnome-volume-manager 2.17.0-0ubuntu2
gnome2-user-guide 2.16.1-0ubuntu1
gnomebaker 0.6.0-7ubuntu1
gparted 0.2.5-2ubuntu2
gstreamer0.10-gnomevfs 0.10.12-0ubuntu1
hwdb-client-gnome 0.6.10
language-pack-gnome-en 7.04+20070412
language-pack-gnome-en-base 7.04+20070412
language-pack-gnome-nl 7.04+20070412
language-pack-gnome-nl-base 7.04+20070412
libatspi1.0-0 1.18.1-0ubuntu1
libeel2-2 2.18.0.1-0ubuntu1
libgail-common 1.18.0-0ubuntu1
libgail-gnome-module 1.18.0-0ubuntu1
libgail18 1.18.0-0ubuntu1
libgconf2-4 2.18.0.1-0ubuntu1
libgda2-3 1.2.4-0ubuntu1
libgda2-common 1.2.4-0ubuntu1
libgdl-1-0 0.6.1-1
libgdl-1-common 0.6.1-1
libgnome-desktop-2 2.18.1-0ubuntu1
libgnome-keyring0 0.8.1-0ubuntu1
libgnome-mag2 0.14.3-0ubuntu1
libgnome-media0 2.18.0-0ubuntu1
libgnome-menu2 2.18.0-0ubuntu3
libgnome-pilot2 2.0.15-0.1ubuntu1
libgnome-speech3 0.4.11-0ubuntu1
libgnome-window-settings1 2.18.1-0ubuntu2
libgnome2-0 2.18.0-0ubuntu1
libgnome2-canvas-perl 1.002-1ubuntu2
libgnome2-common 2.18.0-0ubuntu1
libgnome2-perl 1.040-1
libgnome2-vfs-perl 1.060-1
libgnome2-...

Read more...

Erwin Olario (gowin) wrote :

I would like to confirm this problem on Feisty though I never experienced it in Dapper. (I skipped Edgy altogether)

My panel configuration is similar to the OP's.

Changed in gnome-panel:
status: Invalid → Triaged
arkban (arkban) wrote :

FYI this effects Ubuntu 8.04 beta

Chris Coulson (chrisccoulson) wrote :

I get this on every log in on Hardy. It's a serious usability issue, as all my buttons are in a different place every time I log in.

Daniel R. (danielr-es) wrote :

Hi,

I experience the same problem. Installed 8.04 yesterday and my 2 below panels changed positions between logins. Trash icon applet sometimes disappeared too.

Today I relogged in again and it not only happened (again), but all the applet positions in the panel which has menu were messed up.

Sorry but I cannot keep using Ubuntu 8.04 under this conditions.

Anyway, thanks for your work.

Palli (pallipp) wrote :

This bug is one of the most annoying ever. It makes Ubuntu 8.04 useless when every time I've got to arrange the panels from the scratch...

Adam Jeżewski (echinos) wrote :

Confirmed this annoying bug in Ubuntu 8.04.

My workaround:
0. Backup ~/.gconf/apps/panel
1. Press ALT+F2, type gconf-editor, press Enter
2. Expand [apps / panel / applets]
3. For every item in [apps / panel / applets] replace toplevel_id - if the value is top_panel_screen0 change it to bottom_panel_screen0; if the value is bottom_panel_screen0 change it to top_panel_screen0
4. Do the same for [apps / panel / objects]

LuptinPitman (bjmccurley) wrote :

Seeing identical behavior on my new 8.04 install. Apparently doesn't matter the orientation of the bars (ie. top or bottom). Also doesn't matter if desktop effects are on or off.

dale_nx26 (onedayaway) wrote :

Also confirmed here. I try to keep my panel with window menu on bottom and panel with app icons on top of that (both at bottom of screen). When I restart my computer, the panels switch position; they refuse to remain where I place them.

Michael Nagel (nailor) wrote :

i can confirm this happens and annoys me. is there any chance that it will be fixed anytime soon?

workaround seems to be to switch all the buttons on the affected panels, as the "bad ordering" at least seems to be stable. this might eventually result in the same changes as adam Adam Jeżewski workaround but does not include any "advanced techniques"...

Sebastien Bacher (seb128) wrote :

the ubuntu team doesn't have the ressources to work on this issue right know and upstream seems to be busy as well but you are welcome to work on the bug and contribute

Michael Nagel (nailor) wrote :

i created a workaround based on a suggestion found in the gnome bugtracker:

1) find out how your panels are called. its the last part of the strings you get if you run:
gconftool-2 --all-dirs /apps/panel/toplevels

2) run the following script. pass top/bottom/left/right and the names of the panels as arguments. the panel mentioned first will be to the edge of the screen.

Petri Järvisalo (reaby) wrote :

Thanks for the fix, as this little annoyance is no more!
Hopefully we get proper fix soon.

Daniel R. (danielr-es) wrote :

Hint:

In Debian Lenny it just happens the first time you reposition both panels on bottom (this always happened to me with past versions of Gnome). Nevertheless, if you delete the panel you desire to be on top, create a new identical one, and reposition them as you want, this preference is preserved across logins.

That is, you have the same behaviour as in previous versions of Gnome (including Ubuntu 7.10). Not perfect, but bearable.

Attached is a screenshot with desired results.

PD: Could you paste the URL to the gnome bug where you found the suggestion?

Daniel R. (danielr-es) wrote :

The gnome bug is listed on top of this page. Sorry.

Kimiko Koopman (kimiko) wrote :

I'd like to confirm that this bug still exists in Intrepid and Jaunty. The two panels at the top of the screen get switched into the worng order on almost every login.

zozo (zo.zo) wrote :

I have the same problem on Intrepid. As I see the posts this bug could be found in earlier versions too.
If it helps to solve the problem 7.10 is an exception, I used it before but this bug was not present there.

JAL (juha-loukola) wrote :

I have the same problem on Intrepid /64 bit.

fermulator (fermulator) wrote :

Same issue in Jaunty 32-bit.

fermulator (fermulator) wrote :

NOTE: The script supplied by Nagel no longer works in Jaunty. (https://bugs.launchpad.net/gnome-panel/+bug/15442/comments/15)

It LOOKS like it works when it's run (it properly moves the panels around in the right manour), but when you log out and log back in, the panels are back to the old 'wrong order'.

Michael Nagel (nailor) wrote :

the script did always fix it for the current session only. (at least thats what i experienced). i have given up since and use the default layout with one panel at the top and one panel at the bottom of the screen.

Hi,
I'm using Ubuntu Jaunty and have the same problem for as far as i remember using gnome :( (from dapper i think).
My settings is the two pannels at the top.

Until Jaunty it was not so problematic as i could drag and drop one panel to the bottom and to the top really easily at startup. But since Jaunty i just can't drag and drop panels any more (if someone know how to enable drag&drop again i'm interested in) and must right click and then click properties and then configure the pannel to bottom then to top and then close the window. This is just awfull to loose all that time at every gnome login.

But looking around i found first the script in that topic and then another at http://forum.ubuntu-fr.org/viewtopic.php?pid=2683139 but none really work for me :(. So playing arround with gconf-eidtor i finally find a setting that seems to work for 2 weeks now on the 2 computers i use every day.

So in gconf-editor go to apps->panel ->general and find the corresponding entry for you in my case toplevel_id_list and reorder the panels in the list in the order you want them to appear in this case the first is at the edge of the screen.

If you don't know which id match one or another panel then you can go to ( alway sin gconf-editor ) apps->panel->toplevels there you will finds your panels and playing with the option enable_buttons for example may help you identify each of your panels.

Hope this will be a definitive solution, and that i will help others,
Best regards to all.

zozo (zo.zo) wrote :

Hi,

I hope the above will help to make a final solution patch for this problem.

I also found a not so nice solution: deleting one of panels and creating it again. It is workiing for me for a long time now.

Ed Lover (bumrushtheshow) wrote :

"So in gconf-editor go to apps->panel ->general and find the corresponding entry for you in my case toplevel_id_list and reorder the panels in the list in the order you want them to appear in this case the first is at the edge of the screen."

Thank Odin, and thank you. After switching the order of ids in that list, it worked! For the first time in literally years of using Gnome in Ubuntu, I was able to have two panels at the bottom of the screen in the order I specified.

Martin Albisetti (beuno) on 2009-06-22
Changed in hundredpapercuts:
status: New → Confirmed

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project, as it does not affect the default Ubuntu 9.10 experience.

Changed in hundredpapercuts:
status: Confirmed → Invalid

Hi,

still have the problem on Fedora 11, Gnome 2.26.
I fixed it by defining bottom bar as being with y bottom=0 (which was equal to -1). But looks strange anyway...

Vish (vish) on 2009-08-23
affects: hundredpapercuts → null
molecule-eye (niburu1) wrote :

I'm having this issue in Ubuntu 9.10 Karmic. The bottom panel has "expand" disabled and "autohide" enabled. Using the panel preference setting I cannot change its orientation--it's stuck on "top". If I change it in gconf-editor it can be changed but as soon as it unhides, it shoots back to the top of the screen.

Changed in gnome-panel:
importance: Unknown → High
Liam Proven (lproven) wrote :

This still occurs in 10.04 "Lucid" and 10.10 "Maverick". I have just encountered it myself. I had deleted the top panel & moved its contents to the bottom one, Windows-XP-style.

I decided to revert to the GNOME style. I created a new one, positioned it at the top, and moved the menu, launch icons and clock to it.

This worked fine until I rebooted, at which point, both panels revert to the top.

If I go into Properties and try to move the task-switcher panel's position to "bottom", it instantly reverts to "top". If I use gconf-editor to do it, it moves until it autohides, at which point it snaps back to the top again.

I'm amazed that in more than 3 or 4 years, this hasn't been fixed!

Teemu Leisti (teemu-leisti) wrote :

Yep, still a problem in Ubuntu 10.10.

I'm also amazed that such a simple, but annoying, problem hasn't yet been fixed. Can it really be _that_ complicated to fix?

Also an issue in Natty 11.04

Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.