Ubuntu

gnome-shell most keyboard shortcuts not working

Reported by Lucazade on 2012-03-27
564
This bug affects 122 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Updated Bug Description
=======================

For Ubuntu 12.04, System Settings (gnome-control-center and gnome-settings-daemon) was patched to continue to support the gconf keyboard shortcuts used by Unity, Unity 2D, and the GNOME Classic sessions. Unfortunately, GNOME Shell now uses gsettings keyboard shortcuts so GNOME Shell ignores keyboard shortcut changes that get entered into System Settings>Keyboard>Shortcuts.

This should be fixed for Ubuntu 12.10 but it's too late and complicated to fix for Ubuntu 12.04.

One Workaround
==============
Install dconf-tools
Run dconf-editor
Look in org.gnome.desktop.wm.keybindings or org.gnome.mutter.keybindings

Another Workaround
==================
Set a custom keyboard shortcut. This is useful if you want to set Ctrl+Alt+F to open Firefox for instance. In System Settings, click Keyboard. Switch to the Shortcuts tab and click Custom Shortcuts at the bottom of the list.

Click the + button and add a name to remember the shortcut and the specific command you want to execute. Click Apply. Find the name in the list and click the right half of the row. "Disabled" should change to "New accelerator". Enter the keyboard shortcut you want to use.

Ctrl+Alt+T to open the terminal and several other usual shortcuts from Unity have been added to GNOME Shell on April 17.

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.92-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Tue Mar 27 07:07:44 2012SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 gnome-bluetooth 3.2.2-0ubuntu4
 indicator-datetime 0.3.92-0ubuntu1

Lucazade (lucazade) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

right, that's a known issue but the gnome-shell maintainer prefered to have 3.4 with keybindings issues than 3.2 (we can't update to gsettings because compiz,unity still use gconf)

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Yaroslav (yarosla) wrote :

Is there a workaround? Can I define shortcuts to launch terminal, web browser, etc. using gsettings?

Bazon (bazonbloch) wrote :

Yes, there are two workarounds:

1. If you know the matching command line, just make your own shortcut with the keyboard shortcut GUI. I made that for CTRL-Alt-T and gnome-terminal.
2. If you don't know the matching command line (e.g. for "show activities"), you can use dconf-editor to set keybindings in org.gnome.desktop.wm.keybindings.

I only got one problem with that: what's the name in dconf for the right super key? (one of my keyboards doesn't have a left super key.)

Lucazade (lucazade) wrote :

 there is no "open-terminal" in org.gnome.desktop.wm.keybindings.. I wonder where to set it.

On 04/01/2012 12:34 AM, Lucazade wrote:
> there is no "open-terminal" in org.gnome.desktop.wm.keybindings.. I
> wonder where to set it.
>
You can just create a new one in system settings > keyboard > shortcuts
 > custom
Something like name of Open Terminal, command of gnome-terminal, bind
it to Crtl+Alt+t & reassign

Lucazade (lucazade) wrote :

@mc3man
tried to fix shortcuts from system settings but open terminal with ctrl+alt+t
works only in gnome-fallback.. It still doesn't work in gnome-shell.

Yaroslav (yarosla) wrote :

Can't use suggested workarounds (or I don't fully understand them).

If it were possible to assign keyboard shortcuts for gnome shell via "system settings > keyboard" there would be no this bug report in the first place, I think.

Strange thing is that some assignments do work. For example I can assign Ctrl+Alt+T to launch calculator, "web browser" or "home folder", but not terminal.

Even for web browser I can't use combinations with Super key. Eg., Ctrl+Super+T. It gets assigned OK, but does not work.

By the way I can't find neither "web browser" nor "calculator" key in org.gnome.desktop.wm.keybindings (gsettings). It must be somewhere else.

My another observation that is different from original bug description is that most default shortcuts actually work. Navigation, screenshots - all work. Super+up/super+down maximizes/restores window OK. Although Ctrl+Super+L does not lock screen, Super+S just passes 'S' letter.

My gnome shell is 3.4 already.

Doug McMahon (mc3man) wrote :

On 04/01/2012 04:00 AM, Lucazade wrote:
> @mc3man
> tried to fix shortcuts from system settings but open terminal with ctrl+alt+t
> works only in gnome-fallback.. It still doesn't work in gnome-shell.
>
Maybe bring this up on ubuntu forum to see - I've no issue with setting
*Custom* shortcuts in gnome-shell thru System Settings inc. reassigning
ctrl+alt+t from Launch Terminal to to a custom one to do the same

Jérôme Poulin (jeromepoulin) wrote :

Since gnome-shell 3.4 I cannot use the Super key in any shortcuts.

Jeremy Bicha (jbicha) wrote :

Jérôme, that's a different bug. I think Unity/Compiz may be at fault.

You'll still need to use dconf-editor though to set GNOME Shell shortcuts for Ubuntu 12.04.

Yaroslav (yarosla) wrote :

> You'll still need to use dconf-editor though to set GNOME Shell shortcuts for Ubuntu 12.04

Could you please explain how to set shortcut to launch terminal using dconf-editor?

Jeremy Bicha (jbicha) on 2012-04-19
description: updated
Savannah King Norton (sln45) wrote :

I don't have ctrl+alt+t to open the terminal.

Daniel Stensnes (dstensnes) wrote :

Can i just wipe the settings from gconf?

Daniel Stensnes (dstensnes) wrote :

or maybe even wipe gconf from the system?

Jeremy Bicha (jbicha) wrote :

Daniel, no. Someone could compile gnome-settings-daemon and gnome-control-center without the revert-gsettings patches, but that's not supported by Ubuntu and will to some extent break using keyboard shortcuts in Unity or GNOME Classic. As is mentioned in the bug description, this bug should get fixed for 12.10 and there are some less destructive workarounds.

Daniel Farrell (dfarrell07) wrote :

>> You'll still need to use dconf-editor though to set GNOME Shell shortcuts for Ubuntu 12.04

>Could you please explain how to set shortcut to launch terminal using dconf-editor?

I have the same question. I can use dconf to setup keyboard shortcuts for functions it has listed as default options, like mapping minimize to 'Scroll_Lock', but I haven't figure out how to add custom shortcuts, like launching a terminal via gnome-terminal with 'Insert'. How can I create a custom shortcut for launching a terminal in GNOME Shell and 12.04?

I should note that ctrl+alt+t works for me, but changing that shortcut in System Settings is ineffective.

Doug McMahon (mc3man) wrote :

"How can I create a custom shortcut for launching a terminal in GNOME Shell and 12.04?"

Just create it in the 'Shortcuts > Custom Shortcuts'. You can't just use "Insert", it needs a modifier like Ctrl, Alt, ect.

*If you want to use Super that usually requires a little work . Ex. - Super+Insert
Set it first in the above Shortcuts > Custom Shortcuts
Then open gconf-editor > /desktop/gnome/keybindings/custom*
In the binding key change the <Super> to <Mod4>, ie. <Mod4>Insert

Daniel Farrell (dfarrell07) wrote :

Thanks Doug, that worked well. Is it gsettings that doesn't support single key shortcuts, like 'Insert'? I was able to use 'Insert' to launch a terminal via 'Shortcuts > Custom Shortcuts' in 11.10 and GNOME 3. Is there an way to use single key shortcuts, other than switching off of GNOME 3? Thanks again for the help.

Karl J. Smith (karl-karl) wrote :

I'm running gnome-shell and have been running konsole for years as my terminal, because I like to use the konsole menu shortcut ctrl-alt-s to set the window titles. I've tried all of the above workarounds, but under 12.04, ctrl-alt-s always acts as the window-shade to make the window shrink and reappear.

Yaroslav (yarosla) wrote :

@Karl

Try this:

gsettings set org.gnome.desktop.wm.keybindings toggle-shaded "['']"

This shall remove the shortcut. Or you can reassign it like this:

gsettings set org.gnome.desktop.wm.keybindings toggle-shaded "['<Primary><Super>s']"

Then restart gnome shell.

Jay Pipes (jaypipes) wrote :

How can something as basic and simple as this fall through the QA cracks? :(

Justin Rissler (jbrrissler) wrote :

Affects me too, and those "workarounds" won't help when trying to set things such as "Audio Mute" and "Audio Pause"...

Bazon (bazonbloch) wrote :

Could someone please tell me, where I can find the settings for increasing/decreasing the a11y magnifier zoom setting in dconf-editor?
Setting them doesn't work as well, so I'd like to make it by hand...

Karl J. Smith (karl-karl) wrote :

@Yaroslav - Thanks! That worked!

It seems this is because Ubuntu patched gnome-settings-daemon/gnome-control-center to use GConf for keybindings.
This causes all built-in shortcuts to not work at all, and the custom shortcuts to misbehave when using the "Meta"-key.

There is a bug at gnome bugzilla for the meta-key-issue: https://bugzilla.gnome.org/show_bug.cgi?id=659899

I summarized the workarounds here: http://hacksr.blogspot.co.at/2012/06/gnome-34-in-ubuntu-1204-and-keyboard.html

Bazon (bazonbloch) wrote :

@Christoph Gritschenberger:
Thanks for posting your summary, that helped answering my questions:
in #5: Right Super Key is <Mod4>
in #26: keys for magnifier are in dconf in org/gnome/settings-daemon/plugins/media-keys
(all paths:
    org/gnome/settings-daemon/plugins/media-keys
    org/gnome/mutter/keybindings
    org/gnome/desktop/wm/keybindings
    org/gnome/shell/keybindings
why are they so cluttered...?)

gcb (descartavel1) wrote :

Thanks Bazon!

just a note, org/gnome/settings-daemon/plugins/media-keys for me only had one custom shortcut i created via System Settings>keyboard>shortcuts.

gnome 3.4.2 here.

I still can't find the lock screen one...

Anyway i can textually search those keys/values? are they in a file like gconf/gconf2 used to be?

gcb (descartavel1) wrote :

created one shortcut named 'uniquestring' and greped for that on my home dir... now i have a WTF?! look on my face when i noticed that the .config/dconf/user which is supposed to have my settings is a binary file

assume i must write a parser tool using http://developer.gnome.org/glib/2.32/glib-GVariant.html to do anything with it

This bug and workarounds should probably be turned into an askubuntu question. Better/cleaner to update workaround info there.

gcb <email address hidden> wrote:

>created one shortcut named 'uniquestring' and greped for that on my
>home
>dir... now i have a WTF?! look on my face when i noticed that the
>.config/dconf/user which is supposed to have my settings is a binary
>file
>
>assume i must write a parser tool using
>http://developer.gnome.org/glib/2.32/glib-GVariant.html to do anything
>with it
>
>--
>You received this bug notification because you are subscribed to the
>bug
>report.
>https://bugs.launchpad.net/bugs/965921
>
>Title:
> gnome-shell most keyboard shortcuts not working
>
>Status in “gnome-control-center” package in Ubuntu:
> Confirmed
>Status in Baltix GNU/Linux:
> New
>
>Bug description:
> Updated Bug Description
> =======================
>
> For Ubuntu 12.04, System Settings (gnome-control-center and gnome-
> settings-daemon) was patched to continue to support the gconf keyboard
> shortcuts used by Unity, Unity 2D, and the GNOME Classic sessions.
> Unfortunately, GNOME Shell now uses gsettings keyboard shortcuts so
> GNOME Shell ignores keyboard shortcut changes that get entered into
> System Settings>Keyboard>Shortcuts.
>
> This should be fixed for Ubuntu 12.10 but it's too late and
> complicated to fix for Ubuntu 12.04.
>
> One Workaround
> ==============
> Install dconf-tools
> Run dconf-editor
>Look in org.gnome.desktop.wm.keybindings or
>org.gnome.mutter.keybindings
>
> Another Workaround
> ==================
>Set a custom keyboard shortcut. This is useful if you want to set
>Ctrl+Alt+F to open Firefox for instance. In System Settings, click
>Keyboard. Switch to the Shortcuts tab and click Custom Shortcuts at the
>bottom of the list.
>
> Click the + button and add a name to remember the shortcut and the
> specific command you want to execute. Click Apply. Find the name in
> the list and click the right half of the row. "Disabled" should change
> to "New accelerator". Enter the keyboard shortcut you want to use.
>
> Ctrl+Alt+T to open the terminal and several other usual shortcuts from
> Unity have been added to GNOME Shell on April 17.
>
>
> ProblemType: BugDistroRelease: Ubuntu 12.04
> Package: gnome-control-center 1:3.3.92-0ubuntu4
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> Date: Tue Mar 27 07:07:44 2012SourcePackage: gnome-control-center
> UpgradeStatus: No upgrade log present (probably fresh install)
> usr_lib_gnome-control-center:
>  gnome-bluetooth 3.2.2-0ubuntu4
>  indicator-datetime 0.3.92-0ubuntu1
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/965921/+subscriptions

--
Sent from my phone. Please excuse my brevity.

zdenek.zikan (zdenek-zikan) wrote :

It is quite sad that such important bugs don't get get fixed in the LTS release. :-/

Anyway, does anybody know how to use "Print Screen" key for shortcut? I tried Print_Screen, PrintScreen, PrintScrn. Thanks.

Open up "xev" on a terminal and press printscreen

(I'd tell you, but my keyboard doesn't have one)

Jeremy Bicha (jbicha) on 2012-08-24
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-control-center (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low

Jeremy: does this mean it is fixed in 12.10?

And as this is a regression, will the fix be SRU'd into 12.04 (especially given that 12.04 is an LTS)?

Jeremy Bicha (jbicha) wrote :

Yes, it's fixed in 12.10.

No, this won't ever be fully fixed in 12.04 because it requires Compiz & Unity to be ported from gconf to gsettings. That kind of huge change won't be allowed in stable releases. Notably, no one has ported Unity 2D to gsettings so that code isn't even in the 12.10 archives but Unity 2D is still supported in 12.04.

Dhiraj Patra (dhiraj-patra) wrote :

My Ubuntu 12.04 lts stop working all short cut for even select all, open terminal, copy, paste etc

It is almost impossible to work on Ubuntu.

How to solve this?

Thanks

Hi,
alt-tab not working. Tried everything, gconf-editor, dconf-editor, keyboard, keyboard shortcuts; alt-tab is mapped indeed to the correct keys, but doesn't do anything for my ubuntu 12.10.

Thanks.

Hey, very useful that you included the dconf work-around... I've been struggling with this one for a day! Such a relief... I was configuring easystroke and I couldn't get it to do a minimize action. Now it works perfectly! thanks...

gsmetal (gsmetal) on 2013-10-22
Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → Invalid
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.