Ubuntu

Changing Default Application for Music/Video/Photos has no effect on some registered types

Reported by Thibaut Brandscheid on 2011-10-17
156
This bug affects 27 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Medium
Unassigned
Precise
Low
Unassigned
Quantal
Medium
Unassigned

Bug Description

1) Oneiric
System Settings → System Info → Default Applications
Issue reproted by OP: png, gif, svg, xpm (maybe more) do not open with correct application.

2) Precise
System Settings → Details → Default Applications
Issue reported in Bug #924388: Video opens with Totem even if VLC is selected as default

3) Upstream:
System Settings → Details → Default Applications
Issue reported in Gnome-bugs #662191: Setting default music player only works for ogg vorbis files

What you expected to happen:
1) When changing the default image viewer in from 'Image Viewer' to 'Shotwell Viewer' a double click on any image should open the image in 'Shotwell Viewer'.

2) When changing default video player, all video files should open using that app.

3) When changing default music player, all music files should open using that app.

What happened instead:
1) When clicking on a png, gif, xpm or svg file Ubuntu will open them in 'Image Viewer' instead of the system default image viewer → 'Shotwell Viewer'.

2) Videos open in Totem even though VLC is selected to be default.

3) Default music player only works for ogg files

summary: Changing the default application for photos has no effect for several
- image types images (png...)
+ image types (png...)

Thank you for your bug report, that setting is for photos though, not image, it's worth noting also that shotwell only handle the photo formats, not gif, xpm etc

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Invalid

When changing the default photo application to 'Shotwell Viewer' to view images I do assume that it opens all kind of image formats that it is capable of viewing → .png

For a dev png might be not an image format but for the people out there - they don't know what the differences of jpg and png are and when to use the one or the other.

The reason I use 'Shotwell Viewer' is because of its editing skills, for the rest I don't see (as user) any differences to 'Image Viewer'.

Changed in gnome-control-center (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed

Make it a papercut project

komputes (komputes) wrote :

This affects Video as well, see Bug #924388

summary: - Changing the default application for photos has no effect for several
- image types (png...)
+ Changing Default Application for Music/Video/Photos has no effect
Changed in gnome-control-center (Ubuntu):
importance: Low → Medium
komputes (komputes) on 2012-03-20
description: updated
tags: added: css-sponsored-p

I just installed smplayer like this:
sudo apt-get install smplayer

Then I went to System Settings > Details (poorly named) > Default Applications

I changed both video and audio to be handled by default with smplayer (I actually suggest making it the default player in the upcoming release).

However, if I now go to an audio or video file, and double-click them, they still open in Rhythmbox and Totem (respectively).

Changing default applications doesn't work yet in 12.04 Beta 2.

summary: - Changing Default Application for Music/Video/Photos has no effect
+ Changing Default Application for Music/Video/Photos has no effect on
+ some types
summary: Changing Default Application for Music/Video/Photos has no effect on
- some types
+ some registered types

I guess this isn't an exact duplicate, but it is related:
https://bugs.launchpad.net/bugs/611754

Thank you for your email!

I think this is related, just not well described.
I think I remember that this kind of feature didn't work in MS Windows either.
The way I understand this feature is whatever application is set as default application should be tried first to open a file with a probable extension.

>________________________________
> Von: Lonnie Lee Best <email address hidden>
>An: <email address hidden>
>Gesendet: 22:52 Mittwoch, 18.April 2012
>Betreff: [Bug 876897] Re: Changing Default Application for Music/Video/Photos has no effect on some registered types
>
>I guess this isn't an exact duplicate, but it is related:
>https://bugs.launchpad.net/bugs/611754
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (985187).
>https://bugs.launchpad.net/bugs/876897
>
>Title:
>  Changing Default Application for Music/Video/Photos has no effect on
>  some  registered types
>
>Status in GNOME Control Center:
>  Confirmed
>Status in “gnome-control-center” package in Ubuntu:
>  Triaged
>
>Bug description:
>  1) Oneiric
>  System Settings → System Info → Default Applications
>  Issue reproted by OP: png, gif, svg, xpm (maybe more) do not open with correct application.
>
>  2) Precise
>  System Settings → Details → Default Applications
>  Issue reported in Bug #924388: Video opens with Totem even if VLC is selected as default
>
>  3) Upstream:
>  System Settings → Details → Default Applications
>  Issue reported in Gnome-bugs #662191: Setting default music player only works for ogg vorbis files
>
>
>  What you expected to happen:
>  1) When changing the default image viewer in  from 'Image Viewer' to 'Shotwell Viewer' a double click on any image should open the image in 'Shotwell Viewer'.
>
>  2) When changing default video player, all video files should open
>  using that app.
>
>  3) When changing default music player, all music files should open
>  using that app.
>
>  What happened instead:
>  1) When clicking on a png, gif, xpm or svg file Ubuntu will open them in 'Image Viewer' instead of the system default image viewer → 'Shotwell Viewer'.
>
>  2) Videos open in Totem even though VLC is selected to be default.
>
>  3) Default music player only works for ogg files
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/gnome-control-center/+bug/876897/+subscriptions
>
>
>

Yes, but as you know, the main point is that there is no functioning GUI for setting default applications. The user should be able to choose/change which applications launch for each (an unlimited number) file type.

Look at the attached screen shot. Notice how Ubuntu's "Open With" feature is missing the "Always use the selected program to open this kind of file" check box.

sae.area (saearea-test) wrote :

Thank you for your email!
Actually there is such an option, just at another place.
When you right click on the file and go to properties, there is a tab called "Open with"
it lists a number of applications and you can choose one and click on "Set as default".

In my option this does suffice. Having a global option, as in the bug I opened (which is a duplicate of another bug), I think would make it even more user-friendly. Otherwise I don't see the use of having the Default setting control panel under settings, when that setting doesn't have any effect.

>________________________________
> Von: Lonnie Lee Best <email address hidden>
>An: <email address hidden>
>Gesendet: 15:08 Freitag, 20.April 2012
>Betreff: [Bug 876897] Re: Changing Default Application for Music/Video/Photos has no effect on some registered types
>
>Yes, but as you know, the main point is that there is no functioning GUI
>for setting default applications. The user should be able to
>choose/change which applications launch for each (an unlimited number)
>file type.
>
>Look at the attached screen shot. Notice how Ubuntu's "Open With"
>feature is missing the "Always use the selected program to open this
>kind of file" check box.
>
>** Attachment added: "MissingAlwaysCheckbox.png"
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/876897/+attachment/3095715/+files/MissingAlwaysCheckbox.png
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (985187).
>https://bugs.launchpad.net/bugs/876897
>
>Title:
>  Changing Default Application for Music/Video/Photos has no effect on
>  some  registered types
>
>Status in GNOME Control Center:
>  Confirmed
>Status in “gnome-control-center” package in Ubuntu:
>  Triaged
>
>Bug description:
>  1) Oneiric
>  System Settings → System Info → Default Applications
>  Issue reproted by OP: png, gif, svg, xpm (maybe more) do not open with correct application.
>
>  2) Precise
>  System Settings → Details → Default Applications
>  Issue reported in Bug #924388: Video opens with Totem even if VLC is selected as default
>
>  3) Upstream:
>  System Settings → Details → Default Applications
>  Issue reported in Gnome-bugs #662191: Setting default music player only works for ogg vorbis files
>
>
>  What you expected to happen:
>  1) When changing the default image viewer in  from 'Image Viewer' to 'Shotwell Viewer' a double click on any image should open the image in 'Shotwell Viewer'.
>
>  2) When changing default video player, all video files should open
>  using that app.
>
>  3) When changing default music player, all music files should open
>  using that app.
>
>  What happened instead:
>  1) When clicking on a png, gif, xpm or svg file Ubuntu will open them in 'Image Viewer' instead of the system default image viewer → 'Shotwell Viewer'.
>
>  2) Videos open in Totem even though VLC is selected to be default.
>
>  3) Default music player only works for ogg files
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/gnome-control-center/+bug/876897/+subscriptions
>
>
>

Burkart Lingner (burkart) wrote :

I recently wrote a blog entry on how to easily set up VLC to open all video files. If you like to set other default applications, the command sequence can be modified accordingly. The article can be found at http://www.bollchen.de/blog/2012/02/command-line-magic-open-with-vlc/

Yes, that method works (thank you), but none the less (for user-friendliness' sake), you should provide such options where they're most commonly used; put a check-box in the open with dialog (see attachment).

I submitted this upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=674480

However, link above is not directly related to the bug we're discussing here; it is indirectly related though.

sae.area (saearea-test) wrote :

Hello,

thanks again for your email!
This feature existed in older GNOME versions (e.g. GNOME 2.32.1)
Please see attached image.

>________________________________
> Von: Lonnie Lee Best <email address hidden>
>An: <email address hidden>
>Gesendet: 18:21 Freitag, 20.April 2012
>Betreff: [Bug 876897] Re: Changing Default Application for Music/Video/Photos has no effect on some registered types
>
>I submitted this upstream:
>https://bugzilla.gnome.org/show_bug.cgi?id=674480
>
>However,  link above is not directly related to the bug we're discussing
>here; it is indirectly related though.
>
>
>** Bug watch added: GNOME Bug Tracker #674480
https://bugzilla.gnome.org/show_bug.cgi?id=674480
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (985187).
>https://bugs.launchpad.net/bugs/876897
>
>Title:
>  Changing Default Application for Music/Video/Photos has no effect on
>  some  registered types
>
>Status in GNOME Control Center:
>  Confirmed
>Status in “gnome-control-center” package in Ubuntu:
>  Triaged
>
>Bug description:
>  1) Oneiric
>  System Settings → System Info → Default Applications
>  Issue reproted by OP: png, gif, svg, xpm (maybe more) do not open with correct application.
>
>  2) Precise
>  System Settings → Details → Default Applications
>  Issue reported in Bug #924388: Video opens with Totem even if VLC is selected as default
>
>  3) Upstream:
>  System Settings → Details → Default Applications
>  Issue reported in Gnome-bugs #662191: Setting default music player only works for ogg vorbis files
>
>
>  What you expected to happen:
>  1) When changing the default image viewer in  from 'Image Viewer' to 'Shotwell Viewer' a double click on any image should open the image in 'Shotwell Viewer'.
>
>  2) When changing default video player, all video files should open
>  using that app.
>
>  3) When changing default music player, all music files should open
>  using that app.
>
>  What happened instead:
>  1) When clicking on a png, gif, xpm or svg file Ubuntu will open them in 'Image Viewer' instead of the system default image viewer → 'Shotwell Viewer'.
>
>  2) Videos open in Totem even though VLC is selected to be default.
>
>  3) Default music player only works for ogg files
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/gnome-control-center/+bug/876897/+subscriptions
>
>
>

sae.area (saearea-test) wrote :

Thank you very much for the great blog post! I hope you don't mind that I included the link in the following bug comment:

https://bugzilla.gnome.org/show_bug.cgi?id=674480

>________________________________
> Von: Burkart Lingner <email address hidden>
>An: <email address hidden>
>Gesendet: 16:27 Freitag, 20.April 2012
>Betreff: [Bug 876897] Re: Changing Default Application for Music/Video/Photos has no effect on some registered types
>
>I recently wrote a blog entry on how to easily set up VLC to open all
>video files. If you like to set other default applications, the command
>sequence can be modified accordingly. The article can be found at
>http://www.bollchen.de/blog/2012/02/command-line-magic-open-with-vlc/
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (985187).
>https://bugs.launchpad.net/bugs/876897
>
>Title:
>  Changing Default Application for Music/Video/Photos has no effect on
>  some  registered types
>
>Status in GNOME Control Center:
>  Confirmed
>Status in “gnome-control-center” package in Ubuntu:
>  Triaged
>
>Bug description:
>  1) Oneiric
>  System Settings → System Info → Default Applications
>  Issue reproted by OP: png, gif, svg, xpm (maybe more) do not open with correct application.
>
>  2) Precise
>  System Settings → Details → Default Applications
>  Issue reported in Bug #924388: Video opens with Totem even if VLC is selected as default
>
>  3) Upstream:
>  System Settings → Details → Default Applications
>  Issue reported in Gnome-bugs #662191: Setting default music player only works for ogg vorbis files
>
>
>  What you expected to happen:
>  1) When changing the default image viewer in  from 'Image Viewer' to 'Shotwell Viewer' a double click on any image should open the image in 'Shotwell Viewer'.
>
>  2) When changing default video player, all video files should open
>  using that app.
>
>  3) When changing default music player, all music files should open
>  using that app.
>
>  What happened instead:
>  1) When clicking on a png, gif, xpm or svg file Ubuntu will open them in 'Image Viewer' instead of the system default image viewer → 'Shotwell Viewer'.
>
>  2) Videos open in Totem even though VLC is selected to be default.
>
>  3) Default music player only works for ogg files
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/gnome-control-center/+bug/876897/+subscriptions
>
>
>

SleepZ (davidrak) wrote :

Is there a quick fix for this? I tried entering "xdg-mime default totem.desktop audio/x-mp3" to make Dash launch totem for my mp3s but it still launches RhythmBox.

Sebastien Bacher (seb128) wrote :

right click on a file in nautilus?

SleepZ (davidrak) wrote :

I'd like to get used to dash. It makes the hassle of opening up nautilus and double clicking on files go away. I remember I didn't used to have this problem. But if there's not a fix then I guess I'll have to stick with what I know.

Changed in gnome-control-center (Ubuntu):
status: Triaged → Confirmed

Right click on a file that is of the type you want to change.

Click "Properties" from the context menu

Click on the open with tab.

Check box that says "Always open with this" (or something like that)

Sam_ (and-sam) wrote :

Reference for #19 can be viewed in nautilus user-guide.
http://library.gnome.org/users/user-guide/stable/gosnautilus-75.html.en

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Mardi Hockenberry (dakotahes) wrote :

Thank you for the information. Interestingly, I used https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/876897 and my application did not appear. There was no option to add it either, so I settled for another. The reason I wanted to change it in the first place is that Shotwell takes forever to load to view pictures. I have settled for Image Viewer.

Changed in gnome-control-center:
status: Confirmed → Invalid
Changed in gnome-control-center (Ubuntu):
status: Triaged → Confirmed
Timothy Arceri (t-fridey) wrote :

This bug is still triaged, see the new upstream bug. In future please check this before changing the status

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
status: Invalid → New
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
Changed in gnome-control-center:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu13

---------------
gnome-control-center (1:3.4.2-0ubuntu13) quantal; urgency=low

  * debian/control.in:
    - don't Build-Depends on libgconf2
    - Recommends libcanberra-pulse (lp: #1004973)
  * debian/patches/58_ubuntu_icon_views_redesign.patch:
    - updated geometry to avoid scrolling by default by adding space to
      display an extra icon row
  * debian/patches/62_update_translations_template.patch:
    - stop listing deprecated source
  * debian/patches/96_sound_nua_panel.patch:
    - stop using gconf there
  * debian/patches/git_update_mimetypes.patch:
    - "set related mime types when changing preferred apps" (lp: #876897)
  * debian/gnome-control-center.postinst:
    - drop old transitional code
 -- Sebastien Bacher <email address hidden> Tue, 28 Aug 2012 18:24:53 +0200

Changed in gnome-control-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.