Please remove python-gtkhtml2 from package dependencies

Bug #538773 reported by UGN on 2010-03-14
314
This bug affects 70 people
Affects Status Importance Assigned to Milestone
BloGTK
Critical
JayReding
blogtk (Ubuntu)
Undecided
Unassigned
eikazo (Ubuntu)
Undecided
Unassigned
foomatic-gui (Ubuntu)
Undecided
Unassigned
gnochm (Ubuntu)
Undecided
Unassigned
gnome-python-extras (Ubuntu)
Undecided
Unassigned
lekhonee (Ubuntu)
Undecided
Unassigned
penguintv (Ubuntu)
Undecided
Unassigned
pida (Debian)
Fix Released
Unknown
pida (Ubuntu)
Undecided
David Futcher
setroubleshoot (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnochm

gnochm in lucid
gnochm:
 Зависит: python-gtkhtml2 but it is not installable

The list of packages affected by the python-gtkhtml2 removal:

$ grep-aptavail -F"Depends" -F"Recommends" -F"Suggests" -sPackage python-gtkhtml2
Package: eikazo
Package: foomatic-gui
Package: gnochm
Package: lekhonee-gnome
Package: penguintv
Package: pida
Package: python-gnome2-extras
Package: setroubleshoot

Changed in gnochm (Ubuntu):
status: New → Confirmed
summary: - gtnochm inlucid cant install ( gnochm: Зависит: python-gtkhtml2 but it
+ gnochm in lucid cant install ( gnochm: Зависит: python-gtkhtml2 but it
is not installable)

dan@shuttle:~$ sudo aptitude install gnochm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  gnochm
The following NEW packages will be installed:
  libchm1{a} python-chm{a}
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 227kB of archives. After unpacking 1,176kB will be used.
The following packages have unmet dependencies:
  gnochm: Depends: python-gtkhtml2 which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
gnochm [Not Installed]

Score is -9881

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

Savvas Radevic (medigeek) wrote :

This is from the changelog in gnome-python-extras:

gnome-python-extras (2.25.3-4.1ubuntu2) lucid; urgency=low

  * Drop python-gtkhtml2 package and libgtkhtml2-dev build dependency, so that
    we can drop the obsolete gtkhtml2 from main.

 -- Martin Pitt <email address hidden> Mon, 08 Mar 2010 17:42:37 +0100

summary: - gnochm in lucid cant install ( gnochm: Зависит: python-gtkhtml2 but it
- is not installable)
+ Please remove python-gtkhtml2 from package dependencies
description: updated
Ali Afshar (aafshar) wrote :

PIDA should not depend on gtkhtml2 package. How would I go about getting that false dependency removed?

Changed in pida (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eikazo - 0.5.2-6ubuntu1

---------------
eikazo (0.5.2-6ubuntu1) lucid; urgency=low

  * debian/control: Remove obsolete python-gtkhtml2 from Depends (LP: #538773)
  * Eikazo/Help.py: Quick inline patch to stop crashing due to python-gtkhtml2
    removal. This doesn't fix any crashes when the user tries to open up help
    but allows the app to run. Will talk to upstream about fixing this properly.
 -- David Futcher <email address hidden> Wed, 31 Mar 2010 19:09:02 +0100

Changed in eikazo (Ubuntu):
status: New → Fix Released
David Futcher (bobbo) on 2010-03-31
Changed in pida (Ubuntu):
assignee: nobody → David Futcher (bobbo)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pida - 0.5.1-5.1ubuntu1

---------------
pida (0.5.1-5.1ubuntu1) lucid; urgency=low

  * debian/control:
    - Remove dependency on obsolete python-gtkhtml2 (LP: #538773)
    - Replace gvim dependency with vim-gtk as gvim no longer exists in Ubuntu
    - Add emcas as an alternative dependecy to vim-gtk (LP: #504754)
    - Add ${misc:Depends} to Depends to placate lintian
  * debian/compat: Update to compatibility level 7 as 4 is pretty old
  * debian/rules: Remove obsolete call to dh_desktop
 -- David Futcher <email address hidden> Wed, 31 Mar 2010 21:53:08 +0100

Changed in pida (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package setroubleshoot - 2.2.52-1ubuntu1

---------------
setroubleshoot (2.2.52-1ubuntu1) lucid; urgency=low

  * Remove dependency on obsolete package python-gtkhtml2 (LP: #538773)
  * Add python-selinux to Depends to stop the app crashing on start
 -- David Futcher <email address hidden> Wed, 31 Mar 2010 22:22:39 +0100

Changed in setroubleshoot (Ubuntu):
status: New → Fix Released
Changed in pida (Debian):
status: Unknown → New
Martin Pitt (pitti) wrote :

Closing manually due to syntax error in changelog:

penguintv (4.0.0-0ubuntu4) lucid; urgency=low

  * debian/control: removed unused dependency on python-gtkhtml2 (LP: 538773)

 -- Fabrice Coutadeur <email address hidden> Thu, 22 Apr 2010 21:02:47 +0200

Changed in penguintv (Ubuntu):
status: New → Fix Released

I'm still getting this in Lucid (1 day before the final release).

I think bug #123582 is related to this one (as it's the one that introduced
that dependency), but that was a long time ago, things
may have changed a lot in two years.

True, I can still confirm it for these packages:

$ grep-aptavail -F"Depends" -F"Recommends" -F"Suggests" -sPackage
python-gtkhtml2

Package: foomatic-gui
Package: gnochm
Package: lekhonee-gnome

The problem is that some packages appear to really depend on
python-gtkhtml2, so they need a code patch to be clear. :)

Ben Shadwick (benshadwick) wrote :

gnochm cannot be installed from the Ubuntu 10.04 package manager. I get the following error:

gnochm:
 Depends: python-gtkhtml2 but it is not installable

Why is there a package in the repository that can't be installed? Is there a workaround?

Tim Hawes (trhawes) wrote :

Blogtk depends on this as well.
Traceback (most recent call last):
  File "/usr/bin/blogtk", line 14, in <module>
    import gtkhtml2
ImportError: No module named gtkhtml2

David (gtcodave) wrote :

hellsbovine@juice:~$ sudo apt-get install blogtk
[sudo] password for hellsbovine:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed
  blogtk
0 upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
Need to get 0B/70.3kB of archives.
After this operation, 586kB of additional disk space will be used.
Selecting previously deselected package blogtk.
(Reading database ... 127474 files and directories currently installed.)
Unpacking blogtk (from .../blogtk_1.1-2ubuntu3_all.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_GB.utf8.cache...
Processing triggers for python-support ...
Setting up blogtk (1.1-2ubuntu3) ...

Processing triggers for python-central ...
hellsbovine@DAVE:~$ blogtk
Traceback (most recent call last):
  File "/usr/bin/blogtk", line 14, in <module>
    import gtkhtml2
ImportError: No module named gtkhtml2
hellsbovine@juice:~$

---

Is that annoying or what?!

Ben Shadwick (benshadwick) wrote :

Reported by multiple people (see comments).

Changed in blogtk:
status: New → Confirmed
Ben Shadwick (benshadwick) wrote :

Added blogtk to the affected list and marked it as confirmed.

David (gtcodave) wrote :

I'm very new to the whole launchpad scene. So i hope my copy+paste from console (above post) was enough to support this as a bug.

But the curious part of me wants a blogger, a better ubuntu and wants to know if there's a work-around / fix for this issue?

v1nsai (v1nsai) wrote :

I solved this by downloading python-gtkhtml2 from the debian repos.

http://packages.debian.org/sid/python-gtkhtml2

Kwacka (kwacka2) wrote :

Thanks for the link v1nsai, it worked for me.

apt-get install gnochm gave

gnochm
 Depends: python-gtkhtml2 but it is not installable

with Debian package now installs

JayReding (jayreding) on 2010-06-05
Changed in blogtk:
assignee: nobody → JayReding (jayreding)
importance: Undecided → Critical
status: Confirmed → Fix Committed
JayReding (jayreding) on 2010-06-05
Changed in blogtk:
milestone: none → 2.0
status: Fix Committed → Fix Released
Alexander Sell (ubuntu.alex) wrote :

The link posted above
http://packages.debian.org/sid/python-gtkhtml2
 doesn't work, so I can not sove the problem...

Ok, I found python-gtkhtml2 at this link:
http://packages.ubuntu.com/karmic/python-gtkhtml2

Navigate to the bottom of the page for the "download" section.

Mahmoud Tantawy (mtantawy) wrote :

it is not fixed yet!
cannot install this python-gtkhtml2

nieproszenieja (mateusz-szulc) wrote :

Gnochm has still broken dependencies.

mateusz@venema ~ $ grep-aptavail -F"Depends" -F"Recommends" -F"Suggests" -sPackage python-gtkhtml2
Package: foomatic-gui
Package: gnochm
Package: lekhonee-gnome

Mike Goldberg (gdimike-gmail) wrote :

I can also confirm that this is still broken.

$ sudo apt-get install gnochm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnochm: Depends: python-gtkhtml2 but it is not installable
E: Broken packages

Changed in pida (Debian):
status: New → Fix Committed
Changed in pida (Debian):
status: Fix Committed → Fix Released
Lavande (lavande) wrote :

$ sudo apt-get install lekhonee-gnome
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  lekhonee-gnome: Depends: python-gtkhtml2 but it is not installable
E: Broken packages

hi, i'm newbie on UBUNTU.. i can't use my printer..when i'm trying to print the printer act as like to print but no text were printed..how to solved this..

p/s:sorry for my broken english...

it works guyz
1. sudo apt-get install dctrl-tools
2. sudo grep-aptavail -F"Depends" -F"Recommends" -F"Suggests" -sPackage python-gtkhtml2
3. sudo dpkg -i python-gtkhtml2_2.25.3-3ubuntu1_i386.deb (thank you Savvas radevick for download link)
4. sudo apt-get install -f
5. sudo apt-get install gnochm

then gnochm works

maurya777 (maurya777) wrote :

Installed successfully after the Deb package reffered by Savvas Radevic, Thanks Savvas.

mgmechanics (mgmechanics) wrote :

Blogtk still doesn't work (installed today):

Traceback (most recent call last):
  File "/usr/bin/blogtk", line 14, in <module>
    import gtkhtml2
ImportError: No module named gtkhtml2

Downloading python-gtkhtml2 and installing it (thanks to Savvas Radevic wrote on 2010-06-13) fixed this problem.

jbatista (jmnbatista) wrote :

buntubunny's workaround worked for me.

AwarenesS (voidplayer) wrote :

This is still happening

SerP (serp2002) wrote :

fix not released...

root@citadel:/home/serp# aptitude install gnochm
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Reading extended state information
Initializing package states... Готово
The following packages are BROKEN:
  gnochm
The following NEW packages will be installed:
  python-chm{a}
0 packages upgraded, 2 newly installed, 0 to remove and 46 not upgraded.
Need to get 195kB of archives. After unpacking 1 061kB will be used.
The following packages have unmet dependencies:
  gnochm: Зависит: python-gtkhtml2 which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
gnochm [Not Installed]

Score is -9881

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

Ubuntu 10.10, BloGTK doesn't launch:

grigory@Enteropia:~$ BloGTK
Traceback (most recent call last):
  File "/usr/bin/BloGTK", line 7, in <module>
    from BloGTK import *
  File "/usr/share/blogtk/BloGTK.py", line 14, in <module>
    import gtkhtml2
ImportError: No module named gtkhtml2

Micah Gersten (micahg) wrote :

This was fixed with gnome-python-extras 2.25.3-5ubuntu1

Changed in gnome-python-extras (Ubuntu):
status: New → Fix Released
JW (arch0njw) wrote :

Is there going to be a backport fix for 10.04 LTS (after all... it's an LTS)?

I'm on 10.04 and am encountering this issue even after running all the updates shown in Update Manager. When is the fix expected to be available for 10.04?

redtux (redtux2000) wrote :

You might need to reopen this for 11.04 - see bug #773757

WHAT IS THIS?
Sent on the Sprint® Now Network from my BlackBerry®

-----Original Message-----
From: RedTux <email address hidden>
Sender: <email address hidden>
Date: Sat, 30 Apr 2011 01:30:15
To: <email address hidden>
Reply-To: Bug 538773 <email address hidden>
Subject: [Bug 538773] Re: Please remove python-gtkhtml2 from package
 dependencies

You might need to reopen this for 11.04 - see bug #773757

--
You received this bug notification because you are subscribed to BloGTK.
https://bugs.launchpad.net/bugs/538773

Title:
  Please remove python-gtkhtml2 from package dependencies

Status in BloGTK:
  Fix Released
Status in “eikazo” package in Ubuntu:
  Fix Released
Status in “foomatic-gui” package in Ubuntu:
  New
Status in “gnochm” package in Ubuntu:
  Confirmed
Status in “gnome-python-extras” package in Ubuntu:
  Fix Released
Status in “lekhonee” package in Ubuntu:
  New
Status in “penguintv” package in Ubuntu:
  Fix Released
Status in “pida” package in Ubuntu:
  Fix Released
Status in “setroubleshoot” package in Ubuntu:
  Fix Released
Status in “pida” package in Debian:
  Fix Released

Bug description:
  Binary package hint: gnochm

  gnochm in lucid
  gnochm:
   Зависит: python-gtkhtml2 but it is not installable

  The list of packages affected by the python-gtkhtml2 removal:

  $ grep-aptavail -F"Depends" -F"Recommends" -F"Suggests" -sPackage python-gtkhtml2
  Package: eikazo
  Package: foomatic-gui
  Package: gnochm
  Package: lekhonee-gnome
  Package: penguintv
  Package: pida
  Package: python-gnome2-extras
  Package: setroubleshoot

Dmitry Tantsur (divius) wrote :

Not fixed for BloGTK, reopening.

Superkuh (superkuh) wrote :

Still broken for Ubuntu 10.04 64bit.
I miss gnochm.

Changed in blogtk (Ubuntu):
status: New → Confirmed
Changed in foomatic-gui (Ubuntu):
status: New → Confirmed
Changed in lekhonee (Ubuntu):
status: New → Confirmed
Eduar Arley Cardona (eduar47) wrote :

It's still broken in Ubuntu 10.04 LTS 32bit

eduar@eeepc:~$ sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.

eduar@eeepc:~$ sudo apt-get install gnochm
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  gnochm: Depende: python-gtkhtml2 pero no es instalable
E: Paquetes rotos

misiu_mp (misiu-mp) wrote :

Broken on 10.10 with regard to foomatic-gui and most others.
Its been 2 years on this simple package configuration bug.
Laughable.

misiu_mp (misiu-mp) wrote :

I meant 10.04.

Martin Pitt (pitti) wrote :

foomatic-gui does not depend on this any more, closing.

Changed in foomatic-gui (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

gnochm was removed in 10.10 and later.

Changed in gnochm (Ubuntu):
status: Confirmed → Invalid
Martin Pitt (pitti) wrote :

blogtk was removed in 11.10.

Changed in blogtk (Ubuntu):
status: Confirmed → Invalid
Changed in lekhonee (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

lekhonee is obviously unmaintained, I removed it now.

2012-03-08 15:20:02 INFO Removing candidates:
2012-03-08 15:20:02 INFO lekhonee 0.7-0ubuntu1 in precise
2012-03-08 15:20:02 INFO lekhonee-common 0.7-0ubuntu1 in precise amd64
2012-03-08 15:20:02 INFO lekhonee-common 0.7-0ubuntu1 in precise armel
2012-03-08 15:20:02 INFO lekhonee-common 0.7-0ubuntu1 in precise armhf
2012-03-08 15:20:02 INFO lekhonee-common 0.7-0ubuntu1 in precise i386
2012-03-08 15:20:02 INFO lekhonee-common 0.7-0ubuntu1 in precise powerpc
2012-03-08 15:20:02 INFO lekhonee-gnome 0.7-0ubuntu1 in precise amd64
2012-03-08 15:20:02 INFO lekhonee-gnome 0.7-0ubuntu1 in precise armel
2012-03-08 15:20:02 INFO lekhonee-gnome 0.7-0ubuntu1 in precise armhf
2012-03-08 15:20:02 INFO lekhonee-gnome 0.7-0ubuntu1 in precise i386
2012-03-08 15:20:02 INFO lekhonee-gnome 0.7-0ubuntu1 in precise powerpc
2012-03-08 15:20:02 INFO lekhonee-kde 0.7-0ubuntu1 in precise amd64
2012-03-08 15:20:02 INFO lekhonee-kde 0.7-0ubuntu1 in precise armel
2012-03-08 15:20:02 INFO lekhonee-kde 0.7-0ubuntu1 in precise armhf
2012-03-08 15:20:02 INFO lekhonee-kde 0.7-0ubuntu1 in precise i386
2012-03-08 15:20:02 INFO lekhonee-kde 0.7-0ubuntu1 in precise powerpc
2012-03-08 15:20:02 INFO Removed-by: Martin Pitt
2012-03-08 15:20:02 INFO Comment: unmaintained, uninstallable

Changed in lekhonee (Ubuntu):
status: Triaged → Invalid
Adam Niedling (krychek) wrote :

Martin: why are other bugs for gnochm and blogtk still open then? Can they be closed?
https://bugs.launchpad.net/ubuntu/+source/gnochm/+bugs
https://bugs.launchpad.net/ubuntu/+source/blogtk/+bugs

Adam Niedling [2012-03-08 15:44 -0000]:
> Martin: why are other bugs for gnochm and blogtk still open then? Can they be closed?

They can, yes.

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.