Firefox consumes far too much CPU ressources with web pages involving Adobe flash plugin

Bug #225165 reported by Tristan on 2008-05-01
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

I don't experience any crash, but a huge load when rendering HTML pages with embedded flash elements. I'm under Ubuntu 8.04 official stable release, with Firefow beta 3.0. With approximately ten tabs (eg. from the website www.matbe.com), my Core2Duo T7200 (2 GHz) reach a 70%-90% load on *each* core *simultaneously*. After closing these tabs, System Monitor returns to its normal state, I mean a 5%-20% range on each core, but never both at the same time (under working affairs, with Thunderbird and OpenOffice opened too). My machine is a Dell D620 laptop, with 2 GB RAM. I use the Adobe non-free Flahs plugin.

Greetings !

John Vivirito (gnomefreak) wrote :

Does this happen on firefox-2 or any non flash pages? Can you please give us step by step instructioins on how to reproduce this bug with websites (some without flash if you can see it than. there is another bug for CPU resources and i would like to know weather its the same or not.

Changed in firefox-3.0:
status: New → Incomplete
Jamin W. Collins (jcollins) wrote :

I can consistently reproduce this problem with pages such as:

http://www.theregister.co.uk/2008/05/16/hp_xp_sp3_amd/

This has become such a problem that I've taken to installing Flashblock just to be able to utilize the browser.

Changed in firefox-3.0:
status: Incomplete → Confirmed
Tristan (tristan-ley-laposte) wrote :

I noticed another strange artefact with flash-rendering. When I go on the site http://www.asus.com/index.aspx, for example, menus are hidden by flash content. But I was first annoyed surfing this site :

   1. open www.matbe.com (a hardware site I often read) and open Ubuntu's System Monitor ;
   2. open several tabs (use the "news" tab - or actualités in French -, right on the page) ;
   3. just watch graphs.

Note that switching from one tab to another may cause some graphical artefacts to occur. More precisely, it seems the Flash content appears first, preventing HTML to be rendered for a while. It also seems that some Flash contents are more concerned by this issue than others (like some AMD adds).

With more tabs, it becomes very hard to scroll down with the mouse's wheel ! Flashblock became also quickly a good friend of mine ;-) ...

Anyway, I remember I observed similar behavior of a Gentoo system, installed on the laptop of a friend (same model as mine). He ran Firefox 2. So it is possible that this bug is not exclusively related to Ubuntu, but rather to Firefox or the flashplugin-nonfree package. Or the way they are compiled for Ubuntu...

Fabio Alessandro Locati (f4l3) wrote :

the Adobe non-free plugin is written pretty bad, and that is the problem. Obviusly we can not do nothing, because only Adobe have the source. Now is released a version 10 beta, maybe it works better.

On Thu, May 22, 2008 at 06:19:53PM -0000, Fabio Locati wrote:
> the Adobe non-free plugin is written pretty bad, and that is the
> problem. Obviusly we can not do nothing, because only Adobe have the
> source. Now is released a version 10 beta, maybe it works better.
>

Right, this is not a firefox issue after all

 affects ubuntu/firefox-3.0
 status invalid

however, there are probably a bunch of dupes for this already filed
against the flashplugin-nonfree package

 affects ubuntu/flashplugin-nonfree
 status incomplete

 - Alexander

Changed in firefox-3.0:
status: Confirmed → Invalid
Ruben Verweij (ruben-verweij) wrote :

I have the same problem on Ubuntu 8.04 on a HP compaq nc6000 with Firefox 3.
I hope the new plugin will solve this problem.

Tim Keitt (tkeitt) wrote :

I can also confirm this behavior with Firefox 3 (3.0~b5+nobinonly-0ubuntu3) and the flash plugin (9.0.124.0ubuntu2). Other websites have reported this problem. This issue goes away completely after un-installing the flash plugin.

Jamin W. Collins (jcollins) wrote :

How is this report invalid?

Jamin W. Collins (jcollins) wrote :

Correction, how is it incomplete. What additional information is necessary for this report to be complete?

Rilium (rilium) wrote :

This bug is also affects me. For this site too, but not only for this.
For me, it mostly happen's when playing ANY video with adobe flash plugin, but also with many other diffrent types flash content.
ii firefox 3.0.8+nobinonly-0ubuntu0.8.10.2 meta package for the popular mozilla web browser
ii flashplugin-nonfree 10.0.22.87ubuntu1~intrepid1 Adobe Flash Player plugin installer

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → New
Gonzhauser (gonzhauser) wrote :

http://nuit-blanche.blogspot.com/
stays at 70% CPU with flashplugin-installer and 0% without.
I am using firefox-3.5.

FMaz (fmaz008) wrote :

Yes, when playing one (1) Flash content, the CPU on one of my core raise up to 100% on the core used.
I can confirm this bug too.

So, one year gone, and no any fixes from Adobe?

ruediix@gmail.com (ruedii) wrote :

This is a widely known problem.

I think it is in the Adobe Flash plugin for Linux and not specific to any distribution.

I think Canonical needs to contact Adobe about it.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed

It happens in other browsers such as Epiphany as well in Gnome Shell with the Adobe Flash Plugin.
But also in firefox with moonlight 4 or gnash for example. While in Minitube for example cpu usage remains quite a bit lower.

So, based on some info found, there might possible be a different problem going on additionally, namely on (some system setups) some kind of extensive CPU use when viewing any kind of video in a web browser. What could be the cause of this?

A (short term) solution, might be to use something like cpu-limited and a cache to limit cpu usage and write ahead the video in the cache. Although even better would be to find out the cause of the problem. From what I found this may possibly be somewhat related to what kind of processor and/ or graphics card is used. If this a wider problem than say Ubuntu, Linux kernel problem, Firefox, or Flash, I second getting in touch with each other to work on this.

Platform problem experienced:
Ubuntu: 11.10 64bit using gnome-shell
Pc: HP Mini 110-3700
Processor: Intel Atom Processor N455 (64 bit)
Graphics card: Intel Graphics Media Accelerator 3150

These bug reports maybe related and handy as well:
https://bugs.launchpad.net/ubuntu/+source/human-theme/+bug/293637
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/294972
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/89267
https://bugs.launchpad.net/ubuntu/+source/xulrunner-1.9/+bug/323587

Also using a flash blocker in the browser solved the problem partially for me in the sense that you are not loading flash when doing normal browsing. However this doesn't solve the problem for the WebM (html5) codec (Firefox can't play the h.264 as far as I can tell). There are other tips on the net how to disable video plugins for Firefox, not sure how wished for, or easy to use this is. Disabling all plugin use in Firefox, cause fallback behavior where the plugin is played in the browser itself, thus transferring the problem back to the browser.

This also happens in chromium.

Browser and versions (from stable repo's):
Firefox: 10.0.2
Chromium: 17.0.963.56~r121963
Epiphany: 3.0.4-1

(Side note: Trying to fill in this bug report I had a 'race' condition in firefox of 80/100% cpu and 580 mb of mem used with 6 tabs open. Restarting Firefox and closing the tab for youtube (no flash installed), and turning off javascript for launchpad.net and ubuntu.com solved the problem.

This info may be of some use, tracking this bug down (considering it may have to do with javascript or browsers in general for the issue).

Javascript engine:
Firefox: SpiderMonkey (?)
Chrome: V8
Epiphany: Unable to say with any degree of certainty

Layout Engine:
Firefox: Gecko
Chrome: Webkit
Epiphany: Webkit

Can possibly be advisable to figure out:
Does problem occur on unity, gnome-shell, or other window managers, with or without compiz, e.g. with or without Ice Tea or other plugins installed?

Preliminary conclusion:
This does not appear to be a Ubuntu, Firefox, Flash specific problem, but a problem with a wider scope.

Recomended solution:
Further input and testing need. Working together with different affected and involved parties, liasioning where needed, to find and implement solution.

silentx (silentx-r) wrote :
Download full text (4.8 KiB)

I experience this too since I'm on Ubuntu (Ubuntu 10.10 with each current Firefox / Adobe Flash version)
I'm using the Flash-Aid plugin for FF and it doesn't make a difference whether I use Adobe stable or Beta version of flash.
In the past I've tried each "solution" I've found in the net (without success) for this problem and I'm really annoyed about it...

This URL can be used as reference, I've here a cpu load of 60-89% on a dual core cpu (T61 Intel® Core™2 Duo CPU T7800 @ 2.60GHz × 2 with 4 GB RAM)
often firefox freezes here (app not responding, greyed out)
http://www.gaiaonline.com/tank/11998771/?gsiUrl=www&userEnvironmentId=1237135&version=133&quality=low&location=popUp&isInEdit=false&graphicsServer=http%3A%2F%2Fs.cdn.gaiaonline.com%2Fimages%2FGaia_Flash%2Faquarium%2F

using the same URL on the same machine with windows XP, Firefox 13 and all plugins listed below runs smooth and doesn't bring the cpu's above 30%

Currently I'm running Ubuntu Version 12.04 (precise) (32-Bit), Kernel Linux 3.2.0-25-generic-pae,
with Unity, compiz,

Firefox 13.0 (but it happens in the same way if all plugins and add-ons are disabled except flash)

with the following enabled plugins:
Windows Media Player Plug-in 10 (compatible; Totem)
The Totem 3.0.1 plugin handles video and audio streams.

IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2ubuntu1))
The IcedTea-Web Plugin executes Java applets.

IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (1.1.3-1ubuntu1.1))
The IcedTea-Web Plugin executes Java applets.

QuickTime Plug-in 7.6.6
The Totem 3.0.1 plugin handles video and audio streams.

DivX® Web Player
DivX Web Player version 1.4.0.233

VLC Multimedia Plugin (compatible Totem 3.0.1)
The Totem 3.0.1 plugin handles video and audio streams.

Shockwave Flash
Shockwave Flash 11.2 r202 11.2.202.0

iTunes Application Detector
This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Gnome Shell Integration
This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

and these active addons:
Adblock plus 2.0.3
better privacy 1.68
flash-aid 2.2.3
flashblock 1.5.15.1
ghostery 2.7.2
tab mix plus 0.4.0.2

top without flash:

georg@LinMob:~$ top

top - 20:24:37 up 4:09, 2 users, load average: 0.49, 1.00, 1.37
Tasks: 171 total, 1 running, 170 sleeping, 0 stopped, 0 zombie
Cpu(s): 7.7%us, 3.0%sy, 0.0%ni, 89.3%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 4055644k total, 1967232k used, 2088412k free, 126620k buffers
Swap: 10239996k total, 0k used, 10239996k free, 1093980k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 1733 georg 20 0 425m 201m 37m S 7 5.1 27:04.72 compiz
 1917 georg 20 0 157m 23m 12m S 3 0.6 8:08.14 unity-panel-ser
 1850 georg 20 0 147m 11m 8664 S 2 0.3 4:25.36 indicator-multi
 1919 georg 20 0 65808 7060 3520 S 2 0.2 3:57.25 hud-service
 2521 georg 20 0 586m 118m 33m S 2 3.0 9:27.87 firefox
 1035 root 20 0 150m 132m 12m S 1 3.3 22:32.42 Xorg ...

Read more...

silentx (silentx-r) wrote :
silentx (silentx-r) wrote :
silentx (silentx-r) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers