launchpad causes high CPU utilization with, and eventually crashes of, epiphany-browser and firefox-3.0

Bug #323587 reported by toobuntu on 2009-01-31
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xulrunner-1.9 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

launchpad causes high CPU utilization with, and eventually crashes of, epiphany-browser and firefox-3.0

[Also reported as a bug against epiphany-browser in Bug #323582]

I've had one or two PPA '+archive' pages open in each of epiphany-browser and firefox-3.0 in intrepid for weeks now, although any launchpad page will do. I either lock screen or sleep when away, usually lock screen. CPU would always be at around 45% with those pages loaded, with epiphany-browser and firefox as the top two processes. edge.launchpad.net made no difference as opposed to launchpad.net. Eventually, the CPU would climb all the way up to 90% and sit there for a while, then go up to 100% and crash the browsers. It takes days until the browsers will actually crash, though. Epiphany crashes first; it seems to be significantly more affected by this than does Firefox.

With all launchpad pages closed, and all of the 8 browser windows with a sum total of 64 tabs still open, CPU hovers at 10% (+/- 1%). I should add that the machine was otherwise idle most of the time both when the launchpad pages were loaded and after I closed them. Only had mrxvt running screen, but all terminal emulator tabs were sitting idle, and also sometimes ran liferea and pidgin or irssi, pcmanfm at times, and evince and epdfview at times, too.

$ lsb_release -dr
Description: Ubuntu 8.10

$ apt-cache policy epiphany-browser firefox
epiphany-browser:
  Installed: 2.24.1-0ubuntu1
  Candidate: 2.24.1-0ubuntu1
  Version table:
 *** 2.24.1-0ubuntu1 0
        500 http://mirror.cc.columbia.edu intrepid/main Packages
        100 /var/lib/dpkg/status
firefox:
  Installed: 3.0.5+nobinonly-0ubuntu0.8.10.1
  Candidate: 3.0.5+nobinonly-0ubuntu0.8.10.1
  Version table:
 *** 3.0.5+nobinonly-0ubuntu0.8.10.1 0
        500 http://mirror.cc.columbia.edu intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     3.0.3+nobinonly-0ubuntu2 0
        500 http://mirror.cc.columbia.edu intrepid/main Packages
Release: 8.10

$ uname -srvmo
Linux 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

$ sudo lshw -sanitize -C system,cpu
computer
    description: Notebook
    product: VGN-TX650P
    vendor: Sony Corporation
    version: J0015963
    serial: [REMOVED]
    width: 32 bits
    capabilities: smbios-2.3 dmi-2.3
    configuration: boot=normal chassis=notebook uuid=CE36EA00-DF2D-11D4-8523-00014A987C5D
  *-cpu
       description: CPU
       product: Intel(R) Pentium(R) M processor 1.20GHz
       vendor: Intel Corp.
       physical id: 3
       bus info: cpu@0
       version: 6.13.8
       slot: N/A
       size: 1200MHz
       capacity: 1200MHz
       width: 32 bits
       clock: 100MHz
       capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx up bts est tm2 cpufreq

$ lspci -vvnn | grep VGA | grep Intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03)

Kane (ccregor) wrote :

i beleive that this is due to flash, im having issues with online classes that use flash as their medium for classrooms.
Ive tried libswf and adobe's actual flash, no matter what my Xorg and Xulrunner begin to use upwards of 70% cpu, this makes the desktop lag alot.
I've tried prism and firefox, with the same effects.
I have also an issue with internet explorer and flash in wine, however it becomes wineserver that eats the cpu

the second I close prism/firefox/ie cpu returns to normal and all is fine
i'm sure launchpad uses flash, so this is an issue
however libswf seems more reliable than adobe's flash

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in xulrunner-1.9 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers