High Xorg CPU usage with human theme

Bug #293637 reported by Alejandro R. Mosteo on 2008-11-04
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
human-theme (Ubuntu)
Medium
Unassigned

Bug Description

Computer is an atom 320 with 512MB RAM. Ubuntu 8.10. While not a powerhorse, I'm not sure this is quite normal.

Setup is an idle xubuntu desktop with the CPU, Network and Memory taskbar applets. These applets display usage by means of vertical progress bars.

If in the xfce theme selector I choose either Human or HumanClearlooks themes, Xorg CPU goes, according to top, to 30-50%. I note that these themes animate progress bars continually (slanted darker bars that move), but I don't know if this is actually related.

Chosing other theme (for example the default one), CPU drops to 1-2%. Having compositor enabled or not does not make a noticeable difference (perhaps a 1%).

Not entirely sure if this is a bug, but that large usage when idle, even with this processor, seems suspicious to me.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xorg.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Thanks in advance.

Changed in xorg:
status: New → Incomplete
Alejandro R. Mosteo (mosteo) wrote :
Alejandro R. Mosteo (mosteo) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xorg:
importance: Undecided → Medium
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-01-30
Changed in xorg:
status: Confirmed → New
Charlie Kravetz (charlie-tca) wrote :

this bug has enough information for the developers to begin work; package was set to xfce4 by Bryce Harrington.

Changed in xfce4:
status: New → Triaged
Charlie Kravetz (charlie-tca) wrote :

This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=4949

Lionel Le Folgoc (mrpouit) wrote :

Not a bug in Xfce, trying to guess correct package.

Artem Popov (artfwo) wrote :

This bug appears in GNOME for me as well! No traces of XFCE here on a fully updated Jaunty system.

When there is a Synaptic progressbar on screen (downloading packages), top reports Xorg CPU usage is as high as 50%.

The CPU usage drops to nearly 30%, if I switch themes on the fly to Simple, Industrial, etc. It does not drop that much with Clearlooks and Crux.

As soon as Synaptic finishes its downloads, the CPU usage goes to 5-7%, but if I launch thewidgetfactory (Human theme again), it raises to ~20%.

The widget factory does not show any increases with Raleigh, Redmond, Clearlooks and other themes with static progressbars.

I also suggest it may relate to the Murrine engine, not the Human theme after all.

Changed in xfce:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in xfce:
importance: Undecided → Unknown
status: Invalid → Unknown
Artem Popov (artfwo) wrote :

This bug only seems to appear with ATI opensource driver ("ati"), and seems to disappear when the proprietary driver is enabled.

Charlie Kravetz (charlie-tca) wrote :

@davideotape: Have you looked at the xfce bugzilla? It is invalid there, this is not a Xfce bug. Why change the status of the upstream back from invalid if they are not going to do anything with it?

misiu_mp (misiu-mp) wrote :

I would like to confirm this bug for gnome.
I have intel 960 graphics and a Core2 Duo T9300 @ 2.50GHz .
A good way to reproduce it is to browse among available wireless networks by clicking on the nm applet. It uses those animated bars to show strength of the networks. It takes only few of them to peak one of the cores completely (even though it IS a fast computer). Moving mouse in that window becomes sluggish.

I think it certainly is related to those animations as the network selection pop-up doesn't have much else.

Using other theme then human is alright (all the other themes seem to have static bars).

Since it happens on xfce and gnome, maybe gtk is to blame.

This is the graphics I have:
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)

misiu_mp (misiu-mp) wrote :

Thats on 9.04 .

misiu_mp (misiu-mp) wrote :

Looks like someone is having a similar problem with nv and nouveau on Jaunty: bug #293637.

misiu_mp (misiu-mp) wrote :

It is bug #365199.
There should be an edit function for posts =)

Changed in xfce:
status: Unknown → Confirmed
Chow Loong Jin (hyperair) wrote :

I'm using the Aurora Smooth theme with the Aurora Gtk Engine, and it appears that animated progress bars in Synaptic cause Xorg's CPU usage to rise, but not those in thewidgetfactory. And just for the record, I'm using I965 on Karmic with packages from xorg-edgers.

Vish (vish) wrote :

@hyperair , for the synaptic bug pls see , Bug #355355

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.