Ubuntu

The backspace key pages up instead of going back in history

Reported by Brad Pitcher on 2006-09-18
142
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Low
firefox (Gentoo Linux)
Invalid
Low
firefox (Ubuntu)
Wishlist
Mozilla Bugs
Nominated for Hardy by Martin Olsson
ubufox (Ubuntu)
Wishlist
Alexander Sack
Nominated for Hardy by Martin Olsson

Bug Description

-----
  Workaround/Solution: set browser.backspace_action to 0
-----

Binary package hint: firefox

Normally in Firefox, the backspace key takes you to the previous page in browsing history. In Edgy Knot 3, it performs a "Page Up" instead. "Alt-Left Arrow" still performs as expected by taking you to the previous page in browsing history.

I can confirm this.

Changed in firefox:
status: Unconfirmed → Confirmed
Marius Gedminas (mgedmin) wrote :

Upstream changed the default behavior of Backspace on Linux builds in Firefox 2.0 betas.

You can change it back by opening about:config and changing browser.backspace_action to 0.

Jan Claeys (janc) wrote :

This is a really *annoying* change, because:
1. It changes one of the most-used shortcuts with no good reason, and most people won't find the about:config hack (especially not those that will be confused the most).
2. You need two hands to press Alt+LeftArrow on many non-English keyboards (i.e. those that have an AltGr key).

Can this please be reverted?

towsonu2003 (towsonu2003) wrote :

maybe this should be sent upstream?

I can also confirm this; although I found out about the about:config hack, it still seems like the default breaks expected behavior. I think the reason they changed it is that sometimes when entering form data, backspace could go back a page instead of deleting a character as expected - but are there people who prefer the new behavior?

Toby Smithe (tsmithe) wrote :

It is annoying. Even en_GB keyboards have AltGr; I guess this is especially annoying to everyone outside the USA. Fortunately, my hand can stretch across my laptop's keyboard between the "Alt" and "<-" keys, but anyone with a smaller hand or bigger keyboard will be at a loss. It's uncomfortable to me, as it involves unusual wrist movement. This is a large usability regression.

towsonu2003 (towsonu2003) wrote :

I was checking around to see if they would fix this, and, as Marius Gedminas points out, they see this as a feature (and I started to support that after reading arguments). Upstream won't fix this. I doubt Ubuntu will fix it as well...

It seems this is when they changed the behavior: https://bugzilla.mozilla.org/show_bug.cgi?id=325541 (and GOD they have sooo many bugs on this). I'll try to find the upstream bug report that wants this to go away (which probably be marked as "wontfix")...

Jan Claeys (janc) wrote :

I have read several of their arguments, and none of them are convincing IMHO. Why do you think this is a feature?

In my opinion, if hardcore unix users prefer the backspace = pageup behaviour, they can easily change it, as they are experienced users and will find the way how to do it, but breaking existing behaviour for inexperienced users to please the proverbial two or three geeks is stupid.

Ubuntu isn't released with the Caps Lock = Ctrl hack either.

Toby Smithe (tsmithe) wrote :

Exactamondo.

Arwyn Hainsworth (arwyn) wrote :

I think you've got it the other way round Jan, the avarage user will benefit from the backspace = pageup and it's the hardcore unix users that are currently complaining.

You avarage user doesn't use keyboard shortcuts, they use the mouse to click the back button and so they won't notice the change that much. In fact the only time they really notice the shortcut is when their form window accidentaly loses focus and they loose their form data because the browser decided to go back a page.

On reading the firefox bug report you'll find that this was done for better platform (every other app does a page-up) consistancy, so once again this is a feature, not a bug. Live with it.

Toby Smithe (tsmithe) wrote :

What about Windows users migrating?

Most people I know use backspace in Windows in Firefox and IE.

Firefox is it's own platform; it runs on many systems. Why change aboriginal behaviour?

Changed in firefox:
status: Unknown → Rejected
finalbeta (j-greenhouse) wrote :

I personally had to use the hack. Especially on a laptop this feature is dreamy.
I was shocked to see it removed together with them killing the Auto search feature.

Jan Claeys (janc) wrote :

@ Arwyn Hainsworth
Firefox doesn't go back to the previous page if you press backspace while filling out a form, so there is no data loss. And saying that shortcuts are not meant for average users is denigrating.

Also, consistency is something that often improves usability, but not if you use it without thinking. To give you one example: going back to the previous page in lynx, links, elinks, info, etc. is done by pressing the LeftArrow key, so if we change Backspace to PageUp we should add this LeftArrow shortcut to Firefox too. Because we need consistency, you know...

@ Toby Smithe
This is not only about Windows users, but also about those users that have been using Ubuntu for 2 years now (or linux even longer), and suddenly it starts doing weird things.

Jan Claeys wrote:
> @ Arwyn Hainsworth Firefox doesn't go back to the previous page if
> you press backspace while filling out a form, so there is no data
> loss.
>

to reproduce data loss:
1. start filling out a form
2. click somewhere outside the form (one can always miss a form field
while trying to click on it)
3. (accidentally) press Backspace (as if you were gonna delete a
character in the -missed- form field)
4. unless data was kept in the memory (try going forward, weirdly enough
that's not supported by all forms), oopsie ;)

> @ Toby Smithe This is not only about Windows users, but also about
> those users that have been using Ubuntu for 2 years now (or linux
> even longer), and suddenly it starts doing weird things.
>

I see your point. I've been using linux now for about 1,5 years (maybe
less). I still think this backspace bug is a feature (hehe). I saw a
comment that demonstrated this extremely well in one of the bug reports
(someone was citing an example of data loss, where his/her customer was
trying to delete part of a form but instead lost data in the form), but
I can't find it now. that was the comment that changed my mind. before
reading that comment, I strongly objected this pageup thing as well.
sounds completely weird at first...

Note that I don't know about the usability of the new shortcuts (is it
easy to use them with one hand? etc)

> And saying that shortcuts are not meant for [used by] average users is
> denigrating.

I agree.

Jan Claeys (janc) wrote :

Okay, you can have data loss if you make two accidental misses in a row, one with your mouse, the other with your keyboard. It's much easier to get data loss by making one accidental click on the back button or the close button or by pressing Ctrl+W or Alt+F4, or ...

I think that Firefox should ask if you really want to lose the data in the form, but IMHO that's an entirely different bug (Epiphany asks in some cases, but not all).

(BTW: whether pages keep their data after a go forward depends on caching headers and maybe sometimes JavaScript used.)

And the new shortcut requires the use of 2 hands for many users that don't use a US keyboard (if you have a US keyboard, try pressing LeftAlt+LeftArrow, as many non-US keyboards have an AltGr key where RightAlt is on US keyboards, to be able to access additional characters, accents, etc.).

towsonu2003 (towsonu2003) wrote :

Jan Claeys wrote:
> And the new shortcut requires the use of 2 hands for many users that
> don't use a US keyboard (if you have a US keyboard, try pressing
> LeftAlt+LeftArrow, as many non-US keyboards have an AltGr key where
> RightAlt is on US keyboards, to be able to access additional characters,
> accents, etc.).
>

that was what I meant as a usability issue in my previous reply...
making firefox US-centric is a no-no...

leftalt+left arrow is bad for laptops as well (my left arrow is on the
right side, leftalt is on the left side, and my hand is not big enough).

then, for me, the question is, should that go to upstream as a usability
loss bug (if there is such a thing) or should it be fixed only by
ubuntu. that, of course, would have to be answered by a devel :)

Jan Claeys (janc) wrote :

Upstream already rejected this AFAIK, and I don't think a fix by Mozilla.org could be get before Edgy release anyway.

Brad Pitcher (bradpitcher) wrote :

If this change was made to prevent data loss when someone mis-clicks a form field, then backspace should just do nothing, right? Won't the person be a bit confused/annoyed when the browser pages up rather than deleting a character from the field? I imagine if nothing happened they might quickly figure out that the field doesn't have the focus.

Arwyn Hainsworth (arwyn) wrote :

@Brad Pitcher: Agreed, having backspace do nothing would be the best default behariour. That way a misplaced click will not yield unexpected results.

Jan Claeys (janc) wrote :

Arwyn, do you really want to disable all potantially dangerous keys and buttons? Firefox would become completely useless very fast if you go that route...

The possibility for data loss thing is a bug that should be fixed in a general way that doesn't harm usability; e.g. by asking the user if they really want to lose what they wrote in the form whenever they do something that might have that effect.

Throwing away day-to-day usability to mask (not fix!) a bug is never a good solution.

Scott Kitterman (kitterman) wrote :

While I agree with the commenters that say there is are probably better ways to fix this, from my perspective this is definitely a step in the right direction. At least if I accidentally get outside the data entry field and then I backspace I end up on a different part of the page rather than a different page all together.

Arwyn Hainsworth (arwyn) wrote :

@Jan:
All those buttons that can cause data loss and are easy to click accidentaly should be removed. This is standard usability procedure, data loss should not be easy to cause by accident.

That said, in FX this is the only one I've come across, if you know of others, please tell me, so I can file bugs for thier removal.

This has nothing to do with what keyboard you use (I have a GB keyboard with AltGr) and everything to do with a bug that causes data loss.

There are indeed a number of ways to fix this bug, but removing the behaviour that causes the bug is by far the most elligant way of solving it in this situation.

If you consider the fact that there is now only one shortcut that is not easy to do on non-us keyboards a bug, you should file a bug to that effect and not try to repleal a usability bug fix. There are a number of shortcuts possible that are valid for both non-us keyboards and us keyboards that are both easy to use and won't be pressed by accident, how about using one of those?
or how about adding the shortcut AltGr+back = 'go back a page' to get identical behaviour on both us and non-us keyboards?

Jan Claeys (janc) wrote :

Arwyn, your proposal doesn't fix anything, as accidentally pressing AltGr+Backspace instead of AltGr+- or AltGr+$ or whatever other keys are next to it on your keyboard would cause the same dataloss (actually AltGr+$ = "]" on Belgian keyboards, so this isn't an really uncommon combination to press for almost anyone using a web forum).

And the same potential for data loss is there for every possible way to implement this functionality (including the current Alt+Arrow ones and the back/forward buttons on the toolbar).

There are probably hundreds of different ways to get the same type of data loss in Firefox currently; you can't remove all those keys, key combinations and buttons, because there would be no useful keys/buttons left.

I agree that this sort of data loss should be prevented, but this should happen in a sane and clean way (and it can be done; the Firefox developers just have to take the time to do it instead of adding new "features").

Arwyn Hainsworth (arwyn) wrote :

Read my comments carefully, I have nothing against keys that can cause data loss, sometimes that is the required behaviour. It would be a bit troublesome if we couldn't quit a program when we wanted to because we have changed some setting.

No, what I'm against is keys that make it easy to cause ACCIDENTAL data loss. In none of the other examples you provided is it easy to accidentaly loose data, only on purpose.

And this _is_ the sane, clean way of preventing data loss, all other ways are non-trivial, will take up developer time and will provide the same or worse results.

Jan Claeys (janc) wrote :

If you would read what I have written, you would know that I have got a lot more data loss by those other keys than by the backspace key. Not everybody has the same habits, so not everybody makes the same accidents.

Arwyn Hainsworth (arwyn) wrote :

I did read what you said and all I can say is that you must be a very careful typer to lose more data to pressing Alt+F4 than to the backspace bug.

After all it is a lot easier to hit backspace when typing than to click the back button or to hit Alt+F4...

I'm going to withdraw from the argument now, since I believe my point has been made and all I can do is hope that the devs in charge agree with it.

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

This is a request to reverse Bug #325541

On Linux, as with all other platforms, the backspace key should map to "Go back one page", NOT Page Up, as there is already a "Page Up" key not more than 4 cm away from it.

It makes no sense to change a key-mapping so that there are two keys on the keyboard with the same function. It's not intuitive and makes no sense.

Now that the browser.backspace_action pref exists, any Linux vendors that wish to customise their Firefox packages to change the default behavior are free to do so.

Linux users please vote for this bug if you agree.

Reproducible: Always

Steps to Reproduce:
1. Press backspace key
Actual Results:
Browser pages up one screen

Expected Results:
Browser navigates to previous page in browser history

I support this reversal.

I also support this reversal. Why on earth has this been changed?

I am HUGELY in favour of this. The two buttons are right beside each other! I already had a pageup key. Why on earth would I want another!

Rog (roger-mindsocket) wrote :

It wasn't broken, I don't see why it was "fixed", and why so many users of a known feature had to file or find bug reports to discover it. This is precisely the sort of thing that ticks off Joe Average as well as power users. Consistency should be considered a far more important priority, IMHO. At least tell the user when their settings are changed for them.

</rant> :p

If anyone hasn't noticed...... This has bug isn't assigned by anyone anymore.
It was removed some time back.

The developers here simply don't give a flippin f**k what anyone thinks here.
They are typical GNOME people and they do what they want when they want. They
don't ask anyone for their opinions. They simply just do it and god forbid you
disagree with them, they only ignore you then.

Linus Torvalds once called the GNOME people nazi's on the GNOME mailing list
after a huge fight over developing the settings/preferences for users. I refer
you to read
http://mail.gnome.org/archives/usability/2005-December/msg00022.html

The same mentality is here as well and common sense is flushed each morning
when the FF developers wake-up and take the first shit of the day.

This 'feature' _really_ shouldn't be here. I keep on hitting backspace and nothing or the wrong thing happens. BACKSPACE = PAGE BACK . Please, revert this regression.

This is very annoying indeed. I am using Gentoo/KDE (gave up on gnome some time ago) and ran into this stupidity after upgrading to FF2.0. What the heck? Backspace to go BACK is intuitive, backspace to go PAGE UP is.. what moron thought of this? There is a PAGE UP button on the keyboard for this SPECIFICALLY.

I had a discussion about this with caillon and some GNOME people and we decided that the best option is to make backspace do *nothing*. Page-up is a bit silly and "backwards in history" invites dataloss.

(In reply to comment #7)
> I had a discussion about this with caillon and some GNOME people and we decided
> that the best option is to make backspace do *nothing*. Page-up is a bit silly
> and "backwards in history" invites dataloss.
>

What data loss ? I never had any data loss... here again we have a failure of communication.... How is it that making it do "nothing" and "back" have to do with any of that? You gonna remove the back button in the menu now? Good grief... You guys need to go back to coding school and retrieve the common sense.

While I agree that having the backspace button do nothing makes more sense than having it do page up I still don�t think it�s good enough.

I've been using backspace to go back on webpages for years in various browsers and I can�t remember ever loosing any data because of it. If data loss was common, me and other wouldn't use it of course. And even if you go back by misstake when editing something it should still be there when you click forward again.

I don't see the problem here. Why not just leave the keybinding as it always have been? You�re not enhancing the browser in any way by remvoing functionality that people use. Especially not when the new behaviour differs from other browsers.

Seriously, I have been using backspace since, let me think... I can't remember! And I have good memory! For years and years backspace has been _the_ way of going back in history. Please, please, please, changing the behavior of backspace has, in my opinion, crippled the browser. Besides, in Windows, 'data loss' is okay? Because there, backspace still works. Data loss is a non-argument. Backspace = back in history, period.

Hmm, hopefully I'm not being too much of a hypocrite for saying this, but please only comment on this bug if you have something meaningful to add. The name calling and "me too" posts aren't entirely helpful. If you agree, then the best way to show it is by voting for the bug.

Now, in response to Robert O'Callahan, I too must wonder what kind of data loss is possible when using the backspace key to go back, and why this is acceptable for Windows or Mac users. I'm not so afraid of change to suggest that keyboard shortcuts should *never* change--if there is a reasonable argument for changing them--however I do think that consistency across platforms is important.

I realise this shouldn't be a political discussion, but I must say that I don't think Firefox should be directed by GNOME at all, since it is a GTK application, not GNOME, and many people run it under KDE, XFCE, etc. My understanding is that GNOME adopted the Backspace-as-PageUp stance from the EMACS people who were used to this, and this is great, and it makes sense for them. The problem is that most Firefox users, even on Linux, aren't EMACS users any more. Also, is there not a GTK setting to switch all the key-bindings over to EMACS-emulation mode? And thirdly, there is a Firefox config setting to change the behaviour of the backspace key. So with all these things, the minority of users who want to change the backspace functionality can easily do so, and like I said, a particular Linux distribution is free to ship that as the default as well.

Also, for anyone reading this who hasn't found the interim solution to this problem, just set browser.backspace_action=1 in your about:config or user.js, and backspace will navigate back as always.

(In reply to comment #11)
> Hmm, hopefully I'm not being too much of a hypocrite for saying this, but
> please only comment on this bug if you have something meaningful to add. The
> name calling and "me too" posts aren't entirely helpful. If you agree, then
> the best way to show it is by voting for the bug.
>
> Now, in response to Robert O'Callahan, I too must wonder what kind of data loss
> is possible when using the backspace key to go back, and why this is acceptable
> for Windows or Mac users. I'm not so afraid of change to suggest that keyboard
> shortcuts should *never* change--if there is a reasonable argument for changing
> them--however I do think that consistency across platforms is important.
>
> I realise this shouldn't be a political discussion, but I must say that I don't
> think Firefox should be directed by GNOME at all, since it is a GTK
> application, not GNOME, and many people run it under KDE, XFCE, etc. My
> understanding is that GNOME adopted the Backspace-as-PageUp stance from the
> EMACS people who were used to this, and this is great, and it makes sense for
> them. The problem is that most Firefox users, even on Linux, aren't EMACS
> users any more. Also, is there not a GTK setting to switch all the
> key-bindings over to EMACS-emulation mode? And thirdly, there is a Firefox
> config setting to change the behaviour of the backspace key. So with all these
> things, the minority of users who want to change the backspace functionality
> can easily do so, and like I said, a particular Linux distribution is free to
> ship that as the default as well.
>
> Also, for anyone reading this who hasn't found the interim solution to this
> problem, just set browser.backspace_action=1 in your about:config or user.js,
> and backspace will navigate back as always.
>

This isn't about manually changing it back. This about the developers doing it because they "felt it was the way to do it" after years of firefox and other browsers doing the same thing with the backspace. The correct way to fix this is to revert the change back to its original function and *if* anyone wants to change it they can.

I still do not see why this is a difficult issue to understand. I honestly think it's a pride issue now. The developers see the mistake and instead of saying "ok you are right and we made a mistake" it's now a defiance with a lame response that makes zero sense.

Changed in firefox:
status: Unknown → Confirmed
Changed in firefox:
importance: Undecided → Wishlist
Changed in firefox:
assignee: nobody → mozilla-bugs
Changed in firefox:
status: Confirmed → Fix Released
Alexander Sack (asac) on 2007-05-16
Changed in firefox:
status: Confirmed → Rejected
59 comments hidden view all 139 comments
Alexander Sack (asac) wrote :

this is not invalid, but won't fix.

Changed in firefox:
status: Invalid → Won't Fix
Alexander Sack (asac) wrote :

ok, i added ubufox (the ubuntu firefox extension) package as a valid bug target ... I will consider to enable the default backspace action for users that have ubufox installed (which should be most as ubufox is shipped by default).

I targetted this bug for gutsy tribe-6 milestone so I get remembered to come up with a decision by then.

Changed in ubufox:
assignee: nobody → asac
status: New → Triaged
description: updated

On Tue, Aug 21, 2007 at 08:41:04AM -0000, Kevin P. Munn wrote:
> I have read the commments, and arguements, both pro and con.
> As an "End User",, who prefers to keep things simple (KISS Disciple), Having just one key to press is much easier. for me, and colleagues who HAVE to use "Ubuntu" OS (Corporate Mandate) with Firefox. Pressing multiple keys can be confusing as you have to remember which combo does what. Playing "Chase The Cursor" while trying to type work related documents is also annoying, as it is the only viable option.

BTW, this can be irritating especially for novice end-users that don't
understand the concept of focus ... consider that you accidentally
leave a text fiel where you typed a lot of text, then you press
backspace and suddenly you go a page back. I imagine that this can
really confuse users at best ... or even shock them (hey i have lost
all the text i just typed).

 - Alexander

Alexander Sack wrote the following on 08/21/2007 05:15 PM:
> On Tue, Aug 21, 2007 at 08:41:04AM -0000, Kevin P. Munn wrote:
>
>> I have read the commments, and arguements, both pro and con.
>> As an "End User",, who prefers to keep things simple (KISS Disciple), Having just one key to press is much easier. for me, and colleagues who HAVE to use "Ubuntu" OS (Corporate Mandate) with Firefox. Pressing multiple keys can be confusing as you have to remember which combo does what. Playing "Chase The Cursor" while trying to type work related documents is also annoying, as it is the only viable option.
>>
>
> BTW, this can be irritating especially for novice end-users that don't
> understand the concept of focus ... consider that you accidentally
> leave a text fiel where you typed a lot of text, then you press
> backspace and suddenly you go a page back. I imagine that this can
> really confuse users at best ... or even shock them (hey i have lost
> all the text i just typed).
>
>
> - Alexander
>
>
I was thinking the same thing. Although I administer a network of about
35 users who run Firefox exclusively many on Windows where the
functionality exists by default. None of them have ever mentioned
having problems with it.

-Joe Baker

Here's the Firefox documentation page which says that on Linux Backspace should take the user back a page in history. Here's the footnote:
"For this shortcut to work on Linux, use about:config to set the preference browser.backspace_action to 0."

The Documentation link:
http://www.mozilla.org/support/firefox/keyboard#f1

Thanks for your attention to this matter. It really is much simpler to just hit backspace button.

The documentation page shows that both IE and Opera also use Backspace to go back in history as well.

Alexander Sack (asac) on 2007-08-31
Changed in ubufox:
importance: Undecided → Wishlist
Joseph Garvin (k04jg02) wrote :

I can confirm this is still present in the Gutsy release candidate. Everytime my girlfriend uses my computer she complains that backspace doesn't work, because it's the behavior that she's used to on Windows. Opera, Internet Explorer, and Windows Firefox all have backspace go back. Has anyone tested Konqueror, Epiphany, or Safari? I suspect their behavior is similar. I'm not sure what the developers mean when they say this is for more consistency, and frankly since it's not immediately apparent to me as a user, it's not a consistency I want or care about so their reasoning is irrelevant. I would support Ubuntu going against the upstream default. If enough distros do this, it might convince upstream.

1. Alt+Left still works, so going back is consistent in Gnome. Backspace also working doesn't conflict with that.

2. Backspace going up may make sense for browsing a filesystem (even that is arguable), but it doesn't make any sense for the web.

3. Normal users are going to see that it's the one key on their keyboard that has an arrow going backwards. It's fairly intuitive to expect it to go... back. Not up.

4. Page up is like a centimeter away. If I wanted page up I'd press page up.

5. It's more consistent with other browsers.

6. Did I mention my girlfriend complains?

7. If the data loss argument was persuasive, Mozilla would be adopting it for the windows port as well. But they're not.

Jan Claeys (janc) wrote :

Backspace doesn't work like this in Epiphany, but (according to its developers) that's because they can't implement it, because GNOME & Gecko aren't compatible in the way they can intercept keypresses (again, that's what I've been told by some Epiphany devs).

Daniel Abramov (ex) wrote :

That's really annoying.

Martin Olsson (mnemo) wrote :

What if Volvo changed their car design so that you would switch gears with the steering wheel? Sorry, but that's how #&)#"/¤&/#¤ this is. Shortcut keys like this one is a de facto standard.

Arguments about old time unix users is void because A) on Ubuntu there is a lot more "new linux users" these days compared to the number of "old time unix users", and consider also B) in some ancient time some people used CTRL-Y and CTRL-V for page down/up. But guess what? More or less every single keyboard ships with a dedicated button that is labeled "PAGE UP", maybe it's time to evolve and start to use it? For the ultra hardcore people, I suggest "apt-get install old_unix_style_keybinding".

Arguments about "data loss" is void because: A) surf to google.com, B) type in some query, C) press the normal GUI back button in the toolbar, D) data lost. E) big deal get over it.

Arguments about "platform consistency" is void because: A) start the GNOME filemanager, B) scroll down to the last item and select it, C) press BACKSPACE and notice that it does not mean page up.

On a personal level; for now I'll go with the about:config hack, but give me more of these kinds of bugs and then it's bye bye new distro for me. I mean a missing sound driver is one thing because I know everyone *wants* to fix it (albeit it might take a long time). But with bugs like this one are big time showstoppers.

I hope that people can agree on a sensible fix to this bug so that ubuntu can continue to grow.

*** Bug 400518 has been marked as a duplicate of this bug. ***

hackel (hackel) wrote :

A more apt analogy would be changing the gearbox so that shifting into reverse is the *same* as shifting into first, because as we know, shifting into reverse while driving forward can cause some major "data loss". Then putting the actual reverse control not on the steering wheel (where it might even be somewhat convenient), but rather on a separate lever in the passenger glove box that you really have to reach for.

Sadly, yesterday was the ONE YEAR anniversary of this bug existing, and being unresolved (at least to our satisfaction), and I don't see Ubuntu or Mozilla developers eager to fix it at all. The Mozilla bug was reported in Feb 2006 and still nothing. Mozilla changed my original bug on reversing this, to "On Linux, backspace should do NOTHING", which was really irritating seeing as that is not what I wanted at all. I very much agree with you that this makes no sense, and I will not accept it until they also change the default behaviour on Windows and Macintosh platforms.

In , Ffx (ffx) wrote :

(In reply to comment #63)
> Reversibility is definitely good. I think a prompt might be a better idea,
> though. "You have unsaved changes on this page. Are you sure you want to
> navigate away from it?" Then this would apply to any action that navigates
> away from a page, including Backspace, Ctrl+W, closing Firefox, and so on.
> This is already the case in Google apps (programmed in javascript?), but should
> be the default behavior for any page with an edited form.
>
That is definitely the best solution.

Endolith (endolith) wrote :

"Mozilla changed my original bug on reversing this, to "On Linux, backspace should do NOTHING", which was really irritating seeing as that is not what I wanted at all."

Agreed. This is a really irritating non-solution. If they're concerned about data loss, they should implement a solution that fixes *ALL* such data loss issues. Many pages use javascript to pop up a "Are you sure you want to navigate away from this page?" dialog. This should be just be standard on any page with user-changeable elements. Then the backspace/data loss "issue" would be moot.

If you enter any data into a form, then accidently press backspace
and goes backwards, when you press forward, the data you entered is
still there. So there isn't any dataloss.

Elez (elez) wrote :

I submitted a patch to fix this (make backspace go back on ALL platforms) . Please go vote for the bug so it gets in firefox 3.0!
https://bugzilla.mozilla.org/show_bug.cgi?id=400518

Also, Ubuntu should consider patching their packages as this is a pretty straight forward patch. No need to wait for mozilla, which can be pretty slow when it comes to fixing Linux bugs.

Go vote! -> https://bugzilla.mozilla.org/show_bug.cgi?id=400518

hackel (hackel) wrote :

Yeah good luck with that. The Firefox developers and the Ubuntu Firefox package maintainers have all proven that they refuse to listen to user demands, and are going to require each of us to change our config manually. I've all but given up. I tried the exact same thing a year ago, trying to get people to vote for my bug, but my bug report was hijacked and changed the behaviour to do nothing instead of page up. I guess it doesn't hurt to keep trying, though...

Endolith (endolith) wrote :

Everyone keep trying, please. :-)

(In reply to comment #64)
> *** Bug 400518 has been marked as a duplicate of this bug. ***

Not a duplicate, since that bug is asking for the backspace to have it's normal "back" function and this bug is for it to "do nothing", which is a pointless non-solution that has been shown to confuse most users and waste their time.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

hackel wrote:
> Yeah good luck with that. The Firefox developers and the Ubuntu Firefox
> package maintainers have all proven that they refuse to listen to user
> demands, and are going to require each of us to change our config
> manually. I've all but given up. I tried the exact same thing a year
> ago, trying to get people to vote for my bug, but my bug report was
> hijacked and changed the behaviour to do nothing instead of page up. I
> guess it doesn't hurt to keep trying, though...
>

I wouldn't mind hand patching a single config file if it would affect
all the users as their defaults on a multi-user system. I want to
maintain a desktop system for thousands of users.

- --
Joe Baker
Computer and Networking Solutions Consultant
Specializing in Open Source tools that make our world better!

http://www.dcresearch.com

V O T E R O N P A U L F O R P R E S I D E N T !
http://www.ronpaul2008.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHirpS7J1dPd3sAmARAqoUAJ9BWIx5UEoo4HFHXn7TxfsCjOZ67ACfd6Z8
x7QRYxz8IgT7LylSlI6AMjI=
=cMfw
-----END PGP SIGNATURE-----

Well, it was a dup of the original bug, which has been "retargetted" without consent of the original submitter...
Overall an outrageous development - if the developer(s) are so insistent that this is not the desired behavior (which I disagree - there is wide agreement that there should be a one-button shortcut to go 'back' and, like it or not, Backspace has emerged to fill that role), then the bug should be marked WONTFIX.
Right now, the (rewritten) bug summary and status are just a lie.

K.

Seems like this issue is just a matter of different personal opinions. Personal opinions of those who have power to fix this prevail, by definition.

In my opinion, the "accidentally press the back button and lose form data" argument should carry very little weight for this issue. There are just too many prerequisites to trigger it:
1. One is filling out a poorly designed web form that does not save data
2. One makes a typo
3. One is not paying attention
4. One tries to correct the typo using the backspace button without focus

Q1: Out of all the browsing one does, what percentage of time does one spend filling out forms? What percentage of those forms don't save info?
Q2: Out of the above cases, how often does one make typos?
Q3: Out of the above cases, how often does one not pay attention?
Q4: Out of the above cases, how often does one try to correct the typo without first selecting the text field?

I fill out web forms often, but have never run into such a problem. 99.987654231% of the time I am just browsing, and the backspace button is a convenient shortcut to go back a page. I think the shortcut should be there by default. Those who don't want the feature, should disable it for themselves -- as opposed to punishing everybody for someone's inability to stay focused on a web form (pun intended).

(In reply to comment #68)
> In my opinion, the "accidentally press the back button and lose form data"
> argument should carry very little weight for this issue. There are just too
> many prerequisites to trigger it:

Exactly. And turning off the backspace button doesn't even fix the fundamental problem anyway. This isn't the only way to lose form data because of navigation. Disabling the backspace button is just a band-aid. The real solution would be to prevent navigation until the user has confirmed that they want to discard what they have filled out, just like when you are composing a gmail.

Correct, the data loss is not that big of a deal anymore especially with the good work going on in session/history land.

The main points to leave the default as doing nothing are:

* No matter what the default is, there are going to be people that are unhappy with the default, so changing the default is only going to change the group of people that are unhappy with it.

* Backspace=DoNothing fits best with GNOME, according to Callum of GNOME a11y and HIG fame. Whether or not you agree, he owns keybindings for the HIG and his opinion here should weigh heavily.

* Pref locking is not uncommon, especially in corporate settings, so many times changing the pref is not even an option for users:
  + There is another keybinding for "go back a page": Alt+Left, so people can
    still use keynav to go back without tweaking prefs. Yes, I realize it
    means pressing two keys instead of one, so it's "not exactly the same".
  + Those who don't want Backspace=GoBack have no way to get their desired
    behaviour without tweaking prefs.

(In reply to comment #70)
> * No matter what the default is, there are going to be people that are unhappy
> with the default, so changing the default is only going to change the group of
> people that are unhappy with it.

But the majority want it to go back. So instead of pissing off the minority, you just turn it completely off and piss off everyone?

> * Backspace=DoNothing fits best with GNOME, according to Callum of GNOME a11y
> and HIG fame. Whether or not you agree, he owns keybindings for the HIG and
> his opinion here should weigh heavily.

Firefox is a GNOME program?

Am I just imagining that Backspace = back in every other browser and browser-like file manager?

> * Pref locking is not uncommon, especially in corporate settings, so many times
> changing the pref is not even an option for users:
> + There is another keybinding for "go back a page": Alt+Left, so people can
> still use keynav to go back without tweaking prefs. Yes, I realize it
> means pressing two keys instead of one, so it's "not exactly the same".

Assuming their alt key hasn't been changed to a language key, as it is by default on some systems that i've used.

> + Those who don't want Backspace=GoBack have no way to get their desired
> behaviour without tweaking prefs.

Those who want Backspace=GoBack have no way to get their desired
behaviour without tweaking prefs.

(In reply to comment #71)
> But the majority want it to go back.

How do you know?

My point was just that it's dishonest to mark this bug as "fixed" and I can't have a very high opinion of these people anyways.

Thinking about it again, there is probably some truth in it that different behavior with focus within a text field and without can be pretty annoying and therefore "backspace" might be a poor choice (although it is kind of intuitive, that backspace goes "back").

But it is also true, that hitting backspace after losing focus is one of the things that happen quite rarely (might be different, when you're on a modem connection and pages/forms load much slower) - quite a *lot* more often I have hit ^U to clear the line and got the source listing of the page, or ^W to erase the last word and closed the tab or window (ha - talk about data-loss there... you can re-open tabs, but a window is gone).

It seems Bug 400518 someone made the trivial patch to change it - but I can't see if he's a dev who put it in svn/cvs/whatever they use.

Anyways... my feeling is, that this is mainly a matter of taste - some just want to have a simple single-key shortcut to go back (how about "Del" if Backspace is a poor choice? It "does nothing" right now and is hardly used for correction during typing) so the "best" alternative would be what someone already suggested - on the first use of "Backspace" outside a text field, the user should be asked what behavior he wants (do nothing/back in history/page up). As obviously different users want different behaviors and even have a strong opinion on this, the best way would be to ask them - saving them the effort to google for a fix that leads to the behavior they want.

(as this bug is closed, putting a copy of the suggestion to Bug 400518 would be a good idea?)

Uh - about "pref locking" - that works as much (or more) against as for you. In this context, I would like to mention, that I'm not coming from an IE (or even Windows) world, but got used to having Backspace to go back purely on Mozilla/Firefox/Iceweasel (the Debian-distributed Firefox) - so I'm kind of all for locking the prefs - of course, locking them in the behavior I got used to...

K.

> * No matter what the default is, there are going to be people that are unhappy
> with the default, so changing the default is only going to change the group of
> people that are unhappy with it.
>
Like I said in Comment #68, first two sentences.

> * Backspace=DoNothing fits best with GNOME, according to Callum of GNOME a11y
> and HIG fame. Whether or not you agree, he owns keybindings for the HIG and
> his opinion here should weigh heavily.
>

I am not entirely sure why GNOME key bindings are a consideration for this request (really, I don't know!) Firefox is not a GNOME application. The majority of Firefox users don't even use Linux. I use KDE. So what? IF GNOME had it's way, all buttons would be disabled ;) Those users need to be protected from themselves.

> * Pref locking is not uncommon, especially in corporate settings, so many times
> changing the pref is not even an option for users:
> + There is another keybinding for "go back a page": Alt+Left, so people can
> still use keynav to go back without tweaking prefs. Yes, I realize it
> means pressing two keys instead of one, so it's "not exactly the same".

Definitely not the same. Not only does this shortcut consist of two buttons, but both buttons are at the bottom of the keyboard and one of them is far from where the hands usually are. It's just not as fast or ergonomic. Too much movement and effort is required.

> + Those who don't want Backspace=GoBack have no way to get their desired
> behaviour without tweaking prefs.
>

Yes they do. Exactly the same way as I did the opposite. Even in locked corpolitarian environments there are system administrators.

I can buy the argument that whatever you do someone will be unhappy with it. But still, backspace has meant go back in firefox for years and also in most other browsers including the dominant one on the market. So changing it now in firefox makes no sense. People who come from IE will usually not try to change keybindings, they will just be anoyed that firefox doesn't behave the way they are used to.

I haven't read the gnome HIG but I know that the gnome application with the most firefox like UI, nautilus in browser mode, takes you back one step in the filesystem when you press backspace. So for consistency with nautilus backspace should go back in firefox also.

About how many people that are disappointed by the change:
http://www.google.com/search?q=firefox2+backspace+linux

Just look through the ~100 comments on http://ubuntu.wordpress.com/2006/12/21/fix-firefox-backspace-to-take-you-to-the-previous-page/ if you think that there are people out there who like this doing nothing.

If you want to prevent people from losing form data, prevent them from losing form data universally with a "do you want to discard this form?" dialog. Don't cripple the key bindings as a band-aid for a problem that most users don't even have.

Alexander Sack (asac) wrote :

we will not add a tweak for this.

Changed in ubufox:
status: Triaged → Won't Fix
Jan Claeys (janc) wrote :

Too bad, now I'll have to edit Firefox's about:config for every ubuntu install I do... :-(

Changed in firefox:
status: Unknown → Invalid
hackel (hackel) wrote :

I'm glad to see that Gentoo already does The Right Thing by setting the proper pref in their Firefox packages in order to reverse the decision of the Mozilla developers to break standard behaviour and cross-platform consistency. Now it's time for you, Alexander, to follow Gentoo's lead and do the same in Ubuntu's package. Thank you.

Changed in ubufox:
status: Won't Fix → Confirmed

You people are disgusting. Lunix has always had "space forward, backspace back". Making it go back in history is terroristic and should lead to internment at Guantanamo Bay. Making it do nothing is just as bad. "I'm afraid to do it right so I'll break this key". Terrorists.

MadsRH (madsrh) wrote :

WOW, this is a very long thread! I would like to confirm this.

Now, I have not read all the posts here, but in my opinion enabling backspace would make it more intuitive for people coming from a Windows(/MAC?) world. I guess it's all about user-experience.
If ALT+LEFT/RIGHT is still enabled, I really don't see the "harm".

+1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

The page up key provides a backwards scroll.
It would require only one hand to effect the back in history command if
it were tied to the backspace key.

- -Joe Baker

MadsRH wrote:
> WOW, this is a very long thread! I would like to confirm this.
>
> Now, I have not read all the posts here, but in my opinion enabling backspace would make it more intuitive for people coming from a Windows(/MAC?) world. I guess it's all about user-experience.
> If ALT+LEFT/RIGHT is still enabled, I really don't see the "harm".
>
> +1
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFI1nwH7J1dPd3sAmARAr14AKCxNe2EBxlQIcYwrAuQWDe3ptEUtACgqUHt
AlcKLnss51oywbvIw8QeGuE=
=S4E1
-----END PGP SIGNATURE-----

Vista started it. Lets break EAX, DirectSound and a bunch of stuff because we can. And no, you don't get a button to select what behavior you would like.

Then creeps from the pidgin project didn't want chat boxes to be re-sized.

Now we have FF at an all time low, where expected behaviors are simply changed on a whim with no accountability, and there is little be offered in the way of making the new behavior configurable.

This stinks as much as office ribbon. Change for the sake of change sucks. The only good thing to come of this is it reveals the abuse of power and zealotry associated with "having power" in an opensource project.

Alexander Sack (asac) wrote :

Please don't tweak status of "wontfix" bugs. if you want this feature you should really lobby upstream and not with me.

Changed in ubufox:
status: Confirmed → Won't Fix
hackel (hackel) wrote :

Of course we will continue to try to get this bug fixed upstream, however as Mozilla are dragging their heels about this, Ubuntu has the ability to make this simple change to their package so that at least Ubuntu (and Gentoo who has already done this) users of Firefox will be happy.

I won't bother changing the status, but you need to listen to what your fellow Ubuntu users want here... Please don't dismiss this out of hand. There is no reason Mozilla should make this decision for Ubuntu. Thank you for continuing to release excellent packages, we simply want to help make them better.

Endolith (endolith) wrote :

Seems like Ubuntu users generally support this as default:

http://brainstorm.ubuntu.com/idea/9443/

We should decide based on what Ubuntu users want, not what Mozilla thinks is best.

Michael Terry (mterry) on 2009-10-20
tags: added: oem
hackel (hackel) wrote :

Thankfully Chromium (and Google Chrome) get this right, so I would suggest people start using it instead.

Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
removed: oem
Changed in firefox:
importance: Unknown → Low
Changed in firefox (Gentoo Linux):
importance: Unknown → Low
Displaying first 40 and last 40 comments. View all 139 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.