Ubuntu

firefox dropdown menus break after url launched from dash

Reported by Gary Bishop on 2012-07-21
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce:

1. Use the Dash to locate a URL. I used the bookmarks-lens but there are probably other ways.
2. Select the URL and Firefox will open it in a tab.
3. Close that tab.
4. Notice that dropdown menus such as the search engine selector or even the completion dropdowns on the awesome bar or the search box stop working.

This happens when running in safe mode as well.

As I said above it happens with the bookmarks-lens and with my simple python favorites-lens https://github.com/gbishop/favorites-lens but I don't think the problem is in the lens. Either lens is simply providing Unity with a URL.

I assume Unity is supplying the URL to Firefox with something akin to xdg-open. But xdg-open does not cause this problem.

I don't see any messages in the terminal nor in the error console when this is happening.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 14.0.1+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic-pae 3.2.19
Uname: Linux 3.2.0-26-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu11
Architecture: i386
BuildID: 20120713224758
Date: Sat Jul 21 17:25:16 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=Safe Mode/Safe Mode (Out of date)
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Gary Bishop (gb-cs) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
fsando (fsando) wrote :

Firefox 14.01, Ubuntu 12.04, Kernel 3.2.0.27, Unity 3d

I'm having the exact same problem.
Firefox menus reliably stop working whenever I open a web page from the HUD/dash.

I've tried in safemode with the same result.

Regardless of what I'm doing in Firefox, when I open a link from the HUD I get to click on menu one time, after that all dropdowns are gone (including searces in the url bar).

I've only used 12.04 + unity a little over a week but I believe it didn't happen the first days so it may be related version 14, at least I only noticed it in the last couple of days.

fsando (fsando) wrote :

Upon furter research:

This happens only with the "ask ubuntu" lens but not with the video lens which opens links to youtube. So it must be related to the way some lenses send links to firefox.

abhijit (tijybba) wrote :

Yes it happens in Firefox 14.01 , Ubuntu 12.04 64-bit , Kernel 3.2.0.27.29 , Unity 3d.

Apart from Drop-Down Menu , it also disables my RIGHT-CLICK menu in Firefox , nothing happens on right-clicking .

On continues Right-clicks it shows a tranparent Right-click Menu's Rectangular Border and nothing else.

Upon restarting Firfox this problem vanishes , but using Ask-ubuntu lens again triggers this behaviour. Restarting Firefox seems to be current workaround.

abhijit (tijybba) wrote :

i think this should be reported in https://bugs.launchpad.net/askubuntu-lens page rather in Firefox, since Ask Ubuntu lens seems to be the problem . Please comment so , so i would report theis bug in Ask Ubuntu lens page.

Gary Bishop (gb-cs) wrote :

It also happens with the bookmarks-lens and with a quickly-based lens I have written: https://github.com/gbishop/favorites-lens

Since Firefox breaks, there is some bug in Firefox on in the unity interface to it. A lens should not be able to break the browser with a URL.

Gary Bishop (gb-cs) wrote :

I can't find the source of the youtube lens that does not cause this problem but I guess it handles the URI itself since it allows choosing the player to be used. If a lens handles the URI and (for example) using xdg-open to activate it, the bug is not present.

The bug only occurs if the lens relies on the dash to open the URL.

Vít Šesták 'v6ak' (vit6ak) wrote :

Following can be a different bug, but I hope that this is likely to be the same bug:
1. Open Thunderbird
2. Open account settings *from HUD* (it is needed to open it from HUD and NOT from Thunderbird overview page)
3. Try to expand some dropdown menu (e.g. "Outgoing Server (SMTP)" or "Server Settings / Connection Security").

The same proglem appears. The dropdown men does not expand. Since both Firefox and Thunderbird are Gecko-based and there are similar Ubuntu add-ons, I hope this is related.

Vít Šesták 'v6ak' (vit6ak) wrote :

This is probably duplicate of bug 1035755.

Dario Ruellan (druellan) wrote :

I remember having this problem from time to time, but I can no longer reproduce it on Ubuntu 12.04 and Firefox 16.0.2.
Anyone can confirm?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers