Default dictionary is unspecified (was Firefox uses en-GB by default instead of en-US)

Bug #333799 reported by Eric Appleman on 2009-02-24
72
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Wishlist
Ubuntu Translations
Low
Unassigned
firefox (Ubuntu)
Low
Unassigned
Declined for Maverick by Sebastien Bacher
firefox-3.0 (Ubuntu)
Low
Unassigned
Declined for Maverick by Sebastien Bacher
ubufox (Ubuntu)
Low
Chris Coulson
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: mozilla-firefox

It seems that packaged versions of Firefox for Ubuntu are using British English language packs rather than American English language packs.

As an American, I feel deeply offended by the British spellings that are constantly being recommended by the menus and spell check.

(Firefox 3.0, Ubuntu Jaunty)

- Eric

LAST VERSION TESTED:
Karmic with language packs 9.10+20091022

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020518 Ubuntu/9.04 (jaunty) Firefox/3.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020518 Ubuntu/9.04 (jaunty) Firefox/3.0.6

It seems that en-US packaged versions of Firefox for Linux are using British English language packs rather than American English language packs.

As an American, I feel deeply offended by the British spellings that are constantly being recommended by the menus and spell check.

I am able to replicate this with both distro-packaged and Mozilla-issued builds.

- Eric

Reproducible: Always

Changed in firefox:
status: Unknown → New

You're getting the locale XPIs from Ubuntu. If you go to Tools -> Add-ons, click Locales, and then uninstall next to XULRunner (en-GB), you should be able to remove the en-GB locale.

As part of a release, we post the xpi file for every locale onto ftp.mozilla.org. However we do not post the en-US xpi file. We should post the en-US xpi, just like all the other locales.

Background: A user who downloads a non en-US locale, can download the xpi for another locale, and use LocaleSwitcher to switch between the two locales. However, this means that they need to be able to see and download the other xpi. Because we do not post the en-US xpi, users can switch to any locale *except* en-US.

The workaround for now is to have users *start* by downloading the en-US build, and then get any of the other locales that they want. However, we should fix this to make all locales equal, and just post en-US xpi like we do for all other locales.

Fixing this will help resolve bug 479952, which is also tracked by ubuntu issue 333799 (https://bugs.launchpad.net/firefox/+bug/333799/).

Other Linux distributions may have similar reported bugs.

My memory claims that en-US.xpi is not like other ab-CD.xpi in some important way, but refuses to elaborate further and defers to Benjamin.

We don't even generate an en-US.xpi currently, AFAIK.

I think that it could be created fairly simply by doing

make -C browser/locales langpack-en-US

It might be possible to do this as part of the standard `make package` step, even.

I can confirm it happens on some Linux distros. This issue might be depends on bug 485860 which will make things easier.

(In reply to comment #4)
> I think that it could be created fairly simply by doing
>
> make -C browser/locales langpack-en-US

Yes, that seems to work fine for me too.

Moving to Future for now.

Can this be re-triaged now that bug 485935 is complete? The langpacks are already being posted for nightlies, so I think all that is necessary is that the renaming script for releases know about them and put them into the proper place.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-3.6a1pre.en-US.langpack.xpi

(In reply to comment #7)
> Can this be re-triaged now that bug 485935 is complete? The langpacks are
> already being posted for nightlies, so I think all that is necessary is that
> the renaming script for releases know about them and put them into the proper
> place.
>
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-3.6a1pre.en-US.langpack.xpi

If we get rid of this block: http://hg.mozilla.org/build/buildbotcustom/file/cd2b80c3d9b8/l10n.py#l877

I think we'll get this for free. Before that was there the automation would try to build en-US as part of l10n release builds. Let's do that before 3.5b4 builds start and see if that works...don't think we have enough time to do anything more before that.

I just tried a

make installers-en-US

and that doesn't work.

Created an attachment (id=373127)
don't skip en-US when parsing a locales file

(In reply to comment #9)
> I just tried a
>
> make installers-en-US
>
> and that doesn't work(In reply to comment #9)
> I just tried a
>
> make installers-en-US
>
> and that doesn't work.

Guess we won't land my patch before b4, in that case!

Sounds like this won't be happening real soon. Maybe we'll look at doing it between 3.5b4 and the next release but for now, I'm futuring this.

I would like to say that trying to change the package to use en-US removes a lot of other packages along with it and still refuses to use en-US even if its installed.

I've commented over on bug 485935 how the fix there is not release friendly.

Moving to FF3

affects: firefox (Ubuntu) → firefox-3.0 (Ubuntu)
Steve Magoun (smagoun) wrote :

Confirmed this behavior - in an stock install of Jaunty that is (according to System->Administration->Language Support) set up for US/English, Firefox thinks 'behavior' should be spelled 'behaviour', 'artifact' should be spelled 'artefact', and so on.

In FF, Tools->Add-ons->Languages shows that en-gb is installed

Changed in firefox-3.0 (Ubuntu):
status: New → Confirmed
Greg Oliver (oliver-greg) wrote :

This has been happening a LOT LONGER than Jaunty! LOL - I have seen this since I ave been using Ubuntu for over 3 years now since gentoo days....

I always chalked it up to the location of the packager and though who cares - at least it's still English, but it finally got on my nerves since I started using webmail for work, and I was gonna file the bug...

I have seen it with every release I can remember since 6.x days though... I have to admit I only completely backup my and reformat my /home partition every couple of years or so, so thta may have caused it to presist somehow as well.

-Greg

Micah Gersten (micahg) wrote :

Upstream now has a bug open to ship an en-US xpi: https://bugzilla.mozilla.org/show_bug.cgi?id=485860
This would allow Ubuntu to ship the en-US for the US locale.

Firefox 3.0 is only receiving Security Updates and major bug fixes at this point.

Changed in firefox-3.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in firefox-3.0 (Ubuntu):
status: Triaged → Won't Fix

There is not anything Mozilla can do to advance this bug. I regularly use Linux builds from http://www.mozilla.com and the default builds are en-US as well as the source from http://hg.mozilla.org.

Changed in firefox:
status: New → Invalid
Micah Gersten (micahg) on 2009-11-25
Changed in firefox-3.5 (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
description: updated
Adi Roiban (adiroiban) on 2009-11-25
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Low

There seems to be an English XPI file:
ftp://ftp.mozilla.org/pub/firefox/releases/3.5.6/en-US.xpi
However, I do not know the status of this file.

(In reply to comment #14)
> There seems to be an English XPI file:
> ftp://ftp.mozilla.org/pub/firefox/releases/3.5.6/en-US.xpi
> However, I do not know the status of this file.

We're not supposed to be shipping that yet. Must've slipped through for 3.5.6.

Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.

Still not fixed. Milestone missed.

Changed in firefox-3.5 (Ubuntu):
milestone: ubuntu-10.04-beta-1 → none
Chris Coulson (chrisccoulson) wrote :

Is this still an issue for people? We generate a en-US language pack as part of the Firefox build, and actually, en-GB users are currently getting en-US due to a bug in the language pack.

Could people give an example of something that isn't localised correctly? Is it...
1) A part of the UI? If so, please give an example
2) Spelling suggestions?

The distinction is important because they are handled in different places

affects: firefox-3.5 (Ubuntu) → firefox (Ubuntu)
Eric Appleman (erappleman) wrote :

Yes. Very much so.

Spelling suggestions for US installs are still GB. In the Language dialog, US, AU, GB, and CA are listed.

Chris Coulson (chrisccoulson) wrote :

So, this is only spelling suggestions?

Chris Coulson (chrisccoulson) wrote :

And this is only the default? Ie, do you get the correct spelling suggestions when you actually select the English / United States dictionary from the Languages sub-menu in the context menu?

That works fine here, it's only the default which is wrong.

We need to be shipping a pref in the language pack extensions which sets spellchecker.dictionary to the right locale.

Eric Appleman (erappleman) wrote :

Yes, it is still the default on Maverick. The install is only a month old.

According to the Language preferences menu in the content tab, en-us and en are installed with en-us taking priority. Disabling the other langpacks does not help.

I know nothing of this right-click context menu you speak of. Can you be more specific on how this is accessed?

Eric Appleman (erappleman) wrote :

BTW, are there any menu options I should be on the lookout for in order to ascertain whether the Firefox interface itself uses en-US or en-GB?

Chris Coulson (chrisccoulson) wrote :

How are you doing spellchecking then? If you right click on a word on a form, select Check Spelling and then right click again, you will be presented with a list of suggestions and a Language sub-menu.

I'm 100% certain that the rest of the UI is in en-US. There is actually a language pack bug which means that all English variants are localised incorrectly with en-US (bug 632760), and that bug makes it impossible to localize the browser as en-GB.

  On 09/08/2010 10:56 AM, Chris Coulson wrote:
> How are you doing spellchecking then? If you right click on a word on a
> form, select Check Spelling and then right click again, you will be
> presented with a list of suggestions and a Language sub-menu.
>
> I'm 100% certain that the rest of the UI is in en-US. There is actually
> a language pack bug which means that all English variants are localised
> incorrectly with en-US (bug 632760), and that bug makes it impossible to
> localize the browser as en-GB.
>
Ah. Thanks. Spellcheck was assigned to en-AU in that dropdown.

Just out of curiosity, where are dictionaries stored in the filesystem?

They're stored in /usr/lib/firefox-3.6.*/dictionaries (which is a symlink to the system dictionaries).

I've just done a change in ubufox to set localized defaults for the spellchecker.dictionary preference, so that users get the correct default dictionary depending on their locale. (In the longer term, this is probably best provided elsewhere, eg, by specifying a localized value in chrome://toolkit/global/intl.properties and setting the preference in firefox. However, this would require modifying all of the language packs, and ubufox currently provides a means to implement this all in one place).

However, it currently doesn't work because that prerefence doesn't support localized values, so I'm just testing a patch for that which I will send upstream shortly.

Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in ubufox (Ubuntu):
status: New → Triaged
importance: Undecided → Low
summary: - Firefox uses en-GB by default instead of en-US
+ Default dictionary is unspecified (was Firefox uses en-GB by default
+ instead of en-US)
Changed in ubuntu-translations:
status: Triaged → Invalid
Changed in ubufox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)

Created attachment 473187
Support localized preference for spellchecker.dictionary

From the last few comments of https://launchpad.net/bugs/333799, the default dictionary setting does not match the users locale (and I can recreate this too - my default dictionary appears to be an arbitrary language).

This seems to be because we ship with no default in the "spellchecker.dictionary" pref.

To fix this, I'd like to be able to ship a locale-specific default for this preference in Ubuntu, but this preference currently does not support localization. The attached patch addresses this.

At this stage you might need to jump on irc.mozilla.org #developers to find someone to check in your patch.

Chris Coulson (chrisccoulson) wrote :

The patch for localizing the spellcheck.dictionary preference has been committed upstream now. I'm not sure if this bug justifies backporting that to 3.6 though, we could just wait for Firefox 4.

I'll see how my workload shapes out for the rest of the week

Changed in firefox:
importance: Unknown → Medium
Micah Gersten (micahg) on 2010-10-08
Changed in firefox:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in firefox:
importance: Unknown → Wishlist
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9~rc2-0ubuntu10

---------------
ubufox (0.9~rc2-0ubuntu10) natty; urgency=low

  * Set maxVersion to 4.0.*, things are not likely to break before final
    - update debian/patches/06_firefox-4.patch
  * Fix LP: #333799 - Default dictionary is unspecified
    - add debian/patches/08_default_dictionary.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Wed, 26 Jan 2011 16:04:50 +0000

Changed in ubufox (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) on 2011-02-15
Changed in firefox (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
status: Triaged → Invalid
Roman (thezub) wrote :

This was not fixed, the solution is to uninstall hunspell and myspell and firefox-locale-en https://bugs.launchpad.net/language-selector/+bug/1026869 is a bug I filed. Uninstalling firefox-locale-en is necessary, otherwise en_US (which is incorrect, and duplicate) is sometimes chosen as the default spellchecker.

Eric Gregory (eric-yorba) wrote :

This is getting really annoying. Any chance we'll ever see a fix for this?

Micah Gersten (micahg) wrote :

This was fixed, if you're experiencing similar issues, please file a new bug and reference this bug number. See https://wiki.ubuntu.com/MozillaTeam/Bugs on how to report Mozilla bugs in Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.