Ubuntu

GNOME Shell display problems with FGLRX

Reported by Sean Fitzpatrick on 2011-09-01
510
This bug affects 101 people
Affects Status Importance Assigned to Milestone
fglrx
Won't Fix
High
Baltix
Undecided
Unassigned
fglrx-installer (Ubuntu)
High
Unassigned
gnome-shell (Debian)
Fix Released
Unknown

Bug Description

Major display issues with Gnome Shell on a clean and updated install of 11.10. I suspect it's due to running ATI graphics with fglrx since I don't have issues on my netbook. Basically the top panel is completely garbled and a mess of different colours; at times I can notice the global menu from the Unity panel in the background of the Gnome Shell panel. Also various letters in the panel text appear as teal-coloured rectangles of various sizes. I tried to get a screenshot, but the screenshot tool just displays an empty wallpaper. Display issues also occur for example in the Alt+F2 dialogue box.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-shell 3.1.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Aug 31 21:00:06 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110802.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Gnome-Shell is still not working with fglrx, this will maybe be fixed with AMD 11.9 - drivers. But even with the opensource xorg-drivers I have the same issue: panel appears behind transparent gnome-shell for some strange reason. Using gnome-shell 3.1.9 and Ubuntu 11.10 with all updates.

I've managed to figure out that it's in fact not the Unity panel, but the menu bar for Nautilus that's hiding under the Gnome panel. (This became obvious in instances where either the Gnome shell or the Unity shell failed to load, and I was left with just an empty desktop and the menu bar.)

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Sean, could you please confirm whether GNOME Shell is still broken after you've upgraded to gnome-shell 3.1.4-0ubuntu4 ?

Hi Jeremy,
I've checked that everything is up-to-date, and I'm showing version 3.1.90.1-0ubuntu4 for GNOME Shell. Is there a PPA version I should be using? In any case, it's still broken for me with the fglrx drivers. Here's a screenshot:

summary: - Unity panel appears under gnome shell panel
+ Nautilus panel appears under gnome shell panel

I changed the description to reflect the fact that it's actually the Applicaiton menu for nautilus, although perhaps 'gnome-shell broken with fglrx' is more to the point. I can get the overview to come up, but it's very choppy.

Jeremy Bicha (jbicha) wrote :

This appears to be fixed in the next version of fglrx: http://ati.cchtml.com/show_bug.cgi?id=99#c65

I don't know if that will make it into Ubuntu 11.10 or not.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
summary: - Nautilus panel appears under gnome shell panel
+ GNOME Shell display problems with FGLRX
Jeremy Bicha (jbicha) on 2011-09-11
affects: gnome-shell (Ubuntu) → fglrx-installer (Ubuntu)

I'll try installing the latest drivers from the AMD website at some point, although Unity's working just fine for me at the moment so I'm not too bothered!

Jeremy Bicha (jbicha) wrote :

I just want to add that if the open source graphics driver works, you should try that. From re-reading the comments on the other bug report, I think the fglrx update to fix this won't even be released until after 11.10 is.

Changed in gnome-shell (Debian):
status: Unknown → Confirmed

OK, although it's been my experience with Ubuntu up to and including 11.04 that with the open source driver most games with 3D graphics are unplayable - even something like SuperTuxKart. So I'd rather have Unity+Games than GNOME Shell with no games, especially since my preferences lean towards Unity anyway :-)

New catalyst is out, so can anyone try does it fix the issue?
Quote from Arch's fglrx maintainer:

"catalyst 11.9 is online, although strange thing:

the URL of the driver has changed - was: ati-driver-installer-11-8-x86.x86_64.run , is ati-driver-installer-11.9.x86.x86_64.run, i actually found this 11.9 driver because of misstype smile LOL

i was expecting better GNOME3 support, but it looks like only rainbow bar was fixed, other problems like slow windows moving stayed"

11.9 did not helps for me. Less garbage in gnome-shell session, but followed by gnome-shell crash.
Garbage on screen on KDE session. I have to downgrade to 11.8 :-(

I don't use gnome so haven't tested it, but with 11-9 the performance is muuuch better for me on KDE - with the exceptions of 4 lockups (xserver segfaults) in 1 hour --> downgrading to 11.8 for now. Does anybody else experience this?

Mark Baker (distobj) wrote :

It's basically the same for me with 11.9 vs. 11.8; a slightly different mess, but just as unusable.

Changed in gnome-shell (Debian):
status: Confirmed → Fix Released
Elthommo (elthommo) wrote :

I have the latest updated 11.10 and I still have this problem with the "rainbow" top bar in Gnome Shell. I have a AMD Radeon HD 6800 Series

I get that black and white rainbow at the start.
Goes back to proper after five seconds.

On Tue, Oct 11, 2011 at 9:15 PM, Elthommo <email address hidden> wrote:

> I have the latest updated 11.10 and I still have this problem with the
> "rainbow" top bar in Gnome Shell. I have a AMD Radeon HD 6800 Series
>
> ** Attachment added: "screenshot"
>
> https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/838577/+attachment/2536956/+files/screenshot.xcf
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (853315).
> https://bugs.launchpad.net/bugs/838577
>
> Title:
> GNOME Shell display problems with FGLRX
>
> Status in AMD fglrx video driver:
> Unknown
> Status in “fglrx-installer” package in Ubuntu:
> Triaged
> Status in “gnome-shell” package in Debian:
> Fix Released
>
> Bug description:
> Major display issues with Gnome Shell on a clean and updated install
> of 11.10. I suspect it's due to running ATI graphics with fglrx since
> I don't have issues on my netbook. Basically the top panel is
> completely garbled and a mess of different colours; at times I can
> notice the global menu from the Unity panel in the background of the
> Gnome Shell panel. Also various letters in the panel text appear as
> teal-coloured rectangles of various sizes. I tried to get a
> screenshot, but the screenshot tool just displays an empty wallpaper.
> Display issues also occur for example in the Alt+F2 dialogue box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-shell 3.1.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
> Uname: Linux 3.0.0-9-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Wed Aug 31 21:00:06 2011
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64
> (20110802.1)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gnome-shell
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fglrx/+bug/838577/+subscriptions
>

David Raid (davidraid) wrote :

I had this problem (the rainbow bar) with 11.8, when I installed 11.9 from the ATI website, it solved the bar problem but created a new issue. Now, whenever I run Skype, the notification bar becomes unstable. The Activities window is also unstable. Gnome Shell 3.2.

Abner Rizzi (bacteria666) wrote :

i have same problem with ubuntu 11.10 with all updates

Les Lamb (kernelles) wrote :

Wait....I just realized I have no problems running Gnome Shell on the same machine with Fedora 15 running from a Live CD. Are we barking up the right tree with this bug? Has anyone else tried running another Gnome 3.x distro with success, that can't get it to work in Ubuntu?

But with the Fedora 15 Live CD you'd be using the open source drivers - GNOME shell works fine with those, last time I tried. (I had Fedora 15 installed for awhile but had all kinds of pain with broken packages, system settings, etc.) It's a bit of a hassle to get fglrx drivers installed on Fedora so it's unlikely you were using them on the Live CD, unless I'm missing something.

Les Lamb (kernelles) wrote :

Good point, Sean. Thanks.

Max Patzelt (max-patzelt) wrote :

Had the same Problem, after installing the fglrx driver i got the rainbow bar in gnome. This worked for me :

  sudo /usr/share/ati/fglrx-uninstall.sh # (if it exists)
  sudo apt-get remove --purge fglrx*
  sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
  sudo apt-get install xserver-xorg-video-ati
  sudo apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64 xserver-xorg-core
  sudo dpkg-reconfigure xserver-xorg

Les Lamb (kernelles) wrote :

Thanks, Max. This worked for me, too, but of course it means flgrx is no longer installed.

Andreas Grois (soulsource) wrote :

Why is this marked as "fix released" (also at debian)? There are updated packages with which the bug is less severe, but it is still there.

amdlin (amdlintuxos) wrote :

this bug affects me too.
ubuntu 11.10, catalyst 11.8, gnome-shell is unusable, i am staying in fallback gnome3 mode.
with open source video driver gnome-shell works fine. (but i have to use the catalyst to have top of opengl perfomance )
 Radeon 5550.

d3ngar (d3ngar) wrote :

Yes, when it says 'fix released', I would like some information of when this fix makes it to the end customer.

I have tried re-installing ATI drivers (as per Max Patzlet) := After re-boot I don't see anything. Had to re-install fglrxdefault packages
I then tried the AMD drivers 11.9 := Same as above. Nothing loads up and I had to go into recovery mode and install the drivers I previously purged.

I have a Sony Vaio laptop with a Radeon Mobility HD 3600 or something.

Thanks,

Chris

Steffen Sindzinski (stesind) wrote :

This only means that the fix is released, not that it is available. So far you would have to install fglrx from the ATI website manually. This means download and compile, see wiki for more information. Best is over an existing fglrx so that all the xorg stuff is right. So you should have installed version 11.9 before by additional drivers function. Just uninstall the old fglrx and double click on the new one for installing. Do the same with the control center. The earlier mentioned way to purge is not recommended by me.

d3ngar (d3ngar) wrote :

Hi Steffen,

I would like to do that, but I'm not completely sure how.

I tried the steps outlined here (
https://help.ubuntu.com/community/BinaryDriverHowto/ATI?highlight=%28ATI%29
 )

Unfortunately this means that I get NO picture at all... I then have to boot
into recovery mode and reverse all the changes.
I did purge the old packages before though.
I also tried to replace the xorg.conf with the one created during install
(as you say: 'so that all the xorg stuff is right'). This also had no effect
: blank screen!

Thanks,

Chris

On 19 October 2011 11:41, Steffen Sindzinski <email address hidden>wrote:

> This only means that the fix is released, not that it is available. So
> far you would have to install fglrx from the ATI website manually. This
> means download and compile, see wiki for more information. Best is over
> an existing fglrx so that all the xorg stuff is right. So you should
> have installed version 11.9 before by additional drivers function. Just
> uninstall the old fglrx and double click on the new one for installing.
> Do the same with the control center. The earlier mentioned way to purge
> is not recommended by me.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/838577
>
> Title:
> GNOME Shell display problems with FGLRX
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fglrx/+bug/838577/+subscriptions
>

d3ngar (d3ngar) wrote :

// mmm, I might be double posting, cause I simply replied to the email that I received. If so, I'm sorry to spam!

Hi Steffen,

I would like to do that, but I'm not completely sure how.

I tried the steps outlined here ( https://help.ubuntu.com/community/BinaryDriverHowto/ATI?highlight=%28ATI%29 )

Unfortunately this means that I get NO picture at all... I then have to boot into recovery mode and reverse all the changes.
I did purge the old packages before though.
I also tried to replace the xorg.conf with the one created during install (as you say: 'so that all the xorg stuff is right'). This also had no effect : blank screen!

You are a bit vague when you mention:
"So you should have installed version 11.9 before by additional drivers function. Just uninstall the old fglrx and double click on the new one for installing. Do the same with the control center."

Thanks,

Chris

Jiri Grönroos (jiri-gronroos) wrote :

Don't bother with the newest version, gnome-shell is still broken with fglrx 11.9 (at least on my 5770 GPU).

Steffen Sindzinski (stesind) wrote :

For me it works ok. I have got a 5750. Are you sure you installed the correct preperitary driver of the ATI web site? You probably have the open source driver running. The version should be 2:8.892 as shown in synaptics and must be enabled by xorg, means shown active in the additional drivers dialog. I just had some trouble to install the compiled drivers by the softwarecenter. Not it is installed and still cannot find the control center in unity. I have to call it manually. Dont know why. Maybe it does not work with manually installed applications. BTW Gnome Shell is still less mature that unity. A lot of functions is missing. To make it work one has to install a lot of stuff. Best is the ppa by webup8.org and follow their hints. For me I rather stay at unity.

Didier Fort (didier-fort) wrote :

Same issue here. Here is my context:

$ fglrxinfo
display: :0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6350
OpenGL version string: 4.1.11005 Compatibility Profile Context

$ lspci| grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc Cedar PRO [Radeon HD 5450]

$ sudo aptitude show fglrx
Package: fglrx
New: yes
State: installed
Automatically installed: no
Version: 2:8.881-0ubuntu4
Priority: extra
Section: restricted/misc

I have tried more than one suggestion and I had multiple failures and reboots.

Please note the discrepancy between the Radeon version number.

Thanks.

Steffen Sindzinski (stesind) wrote :

This is the Ubuntu fglrx driver, not the latest by AMD. With this driver Gnome shell does not work. You have to compile manually the AMD website driver and install it over an existing fglrx. Please see the wiki pages how to do this.

Didier Fort (didier-fort) wrote :

Thanks.

I tried that:
sudo ./ati-driver-installer-11-9-x86.x86_64.run

But I get this:
[Error]A previous installation of fglrx driver detected to be loaded.
User must uninstall existing fglrx driver
or run install with force option.
Forcing the installation is not recommended.

I also tried to run:
sudo aptitude purge fglrx

And then run the latest ATI install, but it always complains about fglrx
still being installed.

On Thu, Oct 20, 2011 at 2:56 PM, Steffen Sindzinski <
<email address hidden>> wrote:

> This is the Ubuntu fglrx driver, not the latest by AMD. With this driver
> Gnome shell does not work. You have to compile manually the AMD website
> driver and install it over an existing fglrx. Please see the wiki pages
> how to do this.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/838577
>
> Title:
> GNOME Shell display problems with FGLRX
>
> Status in AMD fglrx video driver:
> Unknown
> Status in “fglrx-installer” package in Ubuntu:
> Triaged
> Status in Baltix GNU/Linux:
> New
> Status in “gnome-shell” package in Debian:
> Fix Released
>
> Bug description:
> Major display issues with Gnome Shell on a clean and updated install
> of 11.10. I suspect it's due to running ATI graphics with fglrx since
> I don't have issues on my netbook. Basically the top panel is
> completely garbled and a mess of different colours; at times I can
> notice the global menu from the Unity panel in the background of the
> Gnome Shell panel. Also various letters in the panel text appear as
> teal-coloured rectangles of various sizes. I tried to get a
> screenshot, but the screenshot tool just displays an empty wallpaper.
> Display issues also occur for example in the Alt+F2 dialogue box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-shell 3.1.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
> Uname: Linux 3.0.0-9-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Wed Aug 31 21:00:06 2011
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64
> (20110802.1)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gnome-shell
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fglrx/+bug/838577/+subscriptions
>

--
--
<email address hidden>

d3ngar (d3ngar) wrote :

Alright:

I have found this guide: https://help.ubuntu.com/community/BinaryDriverHowto/ATI

I have tried that in the past. I removed the default driver and installed these from binaries. My screen blanks during boot.

fglrxinfo
display: :0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5400 Series
OpenGL version string: 4.1.11005 Compatibility Profile Context

The hardware is supported.

The tutorial mentions 4 files, I only get 3. The missing one is: fglrx-modaliases_~

Do you know if this is default for this version? Surely it's missing?

Thanks.

Steffen Sindzinski (stesind) wrote :

This worked for me on a configuration with fglrx installed:

1.Download the current ATI driver here: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
2. Build the driver in terminal and download directory with: sh ati-driver-installer-11-9-x86.x86_64.run --buildpkg
3. Remove the installed fglrx: sudo apt-get purge fglrx fglrx-amdcccle
4. Install the new driver packages by double clicking on the before built debs.
5. Make sure that the driver is installed: dpkg -l fglrx*
6. Restart
7. Check with: fglrxinfo

Normally it is recommended to execute but I did not do: sudo aticonfig --initial
This writes the xorg configuration

If you wish to change back to the normal fglrx:
sudo apt-get purge fglrx fglrx-amdcccle
sudo apt-get install fglrx fglrx-amdcccle

d3ngar (d3ngar) wrote :

But do you know if fglrx-modaliases_~ is mandatory? Is that file produced
when you build the deb files? I don't have it, maybe that is why I can't
boot into the graphics mode with your recommendations?

Sent from my Android.
On Oct 21, 2011 7:52 AM, "Steffen Sindzinski" <email address hidden>
wrote:

> This worked for me on a configuration with fglrx installed:
>
> 1.Download the current ATI driver here:
> http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
> 2. Build the driver in terminal and download directory with: sh
> ati-driver-installer-11-9-x86.x86_64.run --buildpkg
> 3. Remove the installed fglrx: sudo apt-get purge fglrx fglrx-amdcccle
> 4. Install the new driver packages by double clicking on the before built
> debs.
> 5. Make sure that the driver is installed: dpkg -l fglrx*
> 6. Restart
> 7. Check with: fglrxinfo
>
> Normally it is recommended to execute but I did not do: sudo aticonfig
> --initial
> This writes the xorg configuration
>
> If you wish to change back to the normal fglrx:
> sudo apt-get purge fglrx fglrx-amdcccle
> sudo apt-get install fglrx fglrx-amdcccle
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/838577
>
> Title:
> GNOME Shell display problems with FGLRX
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fglrx/+bug/838577/+subscriptions
>

Steffen Sindzinski (stesind) wrote :

There is no fglrx-modaliases any more. Try to choose recovery mode in Grub and then just resume. Maybe you should wait until the new fglrx is in repositories.

d3ngar, blank screen after installing drivers is another bug

what you are experiencing might be related to this:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/855943

d3ngar (d3ngar) wrote :

Thanks Steffen & klerfayt!

I actually got it working under Steffen's instructions:
Purge fglrx, install the debs generated. Re-boot into recovery (to avoid screen blank) and then resume normal boot.

This makes nearly everything look smooth. The fonts sometimes are blurred and in italic on hover, but it's on and off and doesn't really bother me.

Thanks for all your help. Will this be marked as available when the fix is out? I wouldn't mind skipping the recovery-mode at some point.

Sprocketme2 (sprocketme2) wrote :

I've followed Steffen's instructions, including installing normal fglrx, then downloading the ATI driver from http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx, purching fglrx and fglrx-amdcccle then installing the new drivers. After a reboot I come to blank screen. I can boot recovery just fine, but even then im getting mediocre performance. glxgears is around 2500fps in gnome-shell but is at about 10000fps in gnome-classic. Gnome-shell is generally choppier too. Window transitions and moving windows is not smooth.

Is there a solution to the blank screen? Is my performance normal for the current state of drivers?

Benjamin Schmid (benbuntu) wrote :

Using an ATI 4200 HD upgrading to Catalyst 11.9 did NOT WORK for me, either.
Rainbow effect is solved, and display looks fine for a few second, but soon gets disorted (window contents diagonally shifted) and instable. Switching to text console returns a unreadablye display and finally locks the whole netbook (Thinkpad Edge 11).

Erik Zoltan (erik-zoltan) wrote :

I'm attaching a screenshot taken with a digital camera since it's hard to get a picture of this one. This shows the problems I'm having on a fresh install with gnome shell and all packages up to date out of the default repositories. One is the font problems in the gnome shell menu, and the other is the diagonal effect on dialogs and pulldown menus. It certainly makes for an interesting computing experience ;).

Erik Zoltan (erik-zoltan) wrote :

I found a small workaround. I went into the universal access menu and selected "Large text". It improved the appearance of the gnome menu, and the improvement persisted even after I turned off large text.

Sketches (conor-smurf) wrote :

Erik woot! That made it usable for me! Thanks
driver:

> Unknown
> Status in “fglrx-installer” package in Ubuntu:
> Triaged
> Status in Baltix GNU/Linux:
> New
> Status in “gnome-shell” package in Debian:
> Fix Released
>
> Bug description:
> Major display issues with Gnome Shell on a clean and updated install
> of 11.10. I suspect it's due to running ATI graphics with fglrx since
> I don't have issues on my netbook. Basically the top panel is
> completely garbled and a mess of different colours; at times I can
> notice the global menu from the Unity panel in the background of the
> Gnome Shell panel. Also various letters in the panel text appear as
> teal-coloured rectangles of various sizes. I tried to get a
> screenshot, but the screenshot tool just displays an empty wallpaper.
> Display issues also occur for example in the Alt+F2 dialogue box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-shell 3.1.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
> Uname: Linux 3.0.0-9-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Wed Aug 31 21:00:06 2011
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64
> (20110802.1)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gnome-shell
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fglrx/+bug/838577/+subscriptions
>

axeoth (axeoth) wrote :

@Erik Zoltan, @Sketches: can you, please, detail the exact steps? I try to reproduce your workaround, however I fail to find "Large text" option. Thanks.

axeoth (axeoth) wrote :

I found how to do it. So, for the reference:

Click "Activities" on the top panel of Gnome Shell. Then type "Universal Access", then ENTER. Then choose Display: Text Size to "Large", then choose again "Normal". This will reuslt in partially fixing the fonts in Gnome Shell.

However, the "Nautilus" menu bar is still visible under the top Gnome Shell panel. This is really, really strange.

Jaime Rave (jaimerave) wrote :

AMD AMD Catalyst 11.10 has been released, and according to Phoronix http://www.phoronix.com/scan.php?page=news_item&px=MTAwODg, this bug was finally fixed. Can you give it a try??

Here is the link: http://www2.ati.com/drivers/linux/ati-driver-installer-11-10-x86.x86_64.run

Steffen Sindzinski (stesind) wrote :

The blank sceen bug after boot has gone with 11.10. Gnome shell looks good, but the screen refreshes quite often. Seems the display manger or window manager crashes and is restarted.

In Unity the AMD Catalyst Control Center is not availible in Unity.

I tested the 11.10 version of fglrx.
It's almost fixed, the context menus and some objects are still buggy. Can't make screenshots. Topbar and its menus are fixed.

* Now the installer installs the packages needed for package building.

Steffen Sindzinski (stesind) wrote :

Dont know, here it flickers a lot.

Using fglrx 11.10 (Oneiric), GNOME Shell sometimes get closed when I open some app or click on some control. As I said, the tooltips, context menus and some apps gets distorsioned.

I regret that the performance is slower than with the free driver, even turning off vertical sync in the AMD panel and in ccsm.

shinyblue (shinyblue) wrote :

I installed 11.9 and 11.10 and both flickr horribly and some stuff like hover tool tips are all warped. :-(

Steffen Sindzinski (stesind) wrote :

The flickering has gone for me since I disabled some features in CCC.

Aldo Nogueira (aldo-nogueira) wrote :

I noticed the top bar gets fixed when I installed cantarell fonts. Something happens when a font package is installed that fixes most of Gnome Shell. The tooltips are still distorted, though.
Using fglrx from 11.10 repositories.

Luca Invernizzi (invernizzi) wrote :

I confirm that
apt-get install fonts-cantarell
mitigates the problem.
The texts, popups and tooltips are now fine, although a couple of icons are still funny (accessibility and bluetooth -- the mouse-over effect fixes them though).

Using fglrx driver on ubuntu 11.10, Radeon HD 3600.

atosatto (atosatto-hotmail) wrote :

Same for me:
apt-get install fonts-cantarell
works fine.

I've installed fonts-cantarell and I'm afraid that the problem persists for me. I can't see any difference, gnome-shell is still completely unusable.

I use ubuntu 11.10 64 bits and fglrx 2:8.881-0ubuntu4.1

Bryce Harrington (bryce) wrote :

Hey sean-fitzpatrick,

Hi, thanks for reporting this issue during the development period of
Ubuntu.

I notice there's not been further comments to the bug report since the
release came out, would you mind updating us on the status of it in the
release?

Are you still able to reproduce the issue? If not, do you think the bug
report can be closed, or do you think we should continue tracking it?

Changed in fglrx-installer (Ubuntu):
status: Triaged → Incomplete

Hi Bryce,
I stopped trying to use gnome shell not long after reporting the bug; partly because it just wasn't working, but mostly because I've been happy with Unity and haven't felt the urge to play with other desktops lately.
However, there are plenty of comments from people other than myself, so I suspect the issue is ongoing.

axeoth (axeoth) wrote :

For me, installing fonts-cantarell is a *temporary* fix, i.e. it only works until the next login.

Then, I have to reinstall the package (i.e. using --reinstall) to fix, once again.

It is just a temporar workaround, just like using the "Universal Access" was.

OTOH, the top ("Activities") bar in Gnome Shell is very strange, it has horizontal white stripes on it, thus making it almost unreadable, but I could bear that.

Daniel Mohr (dm0hr) wrote :

I agree with David Lopez:

For me, the problem also persists when installing fonts-cantarell. Mostly, drop-down menus and tooltips are totally corrupted. Scrolling is worse than with the open driver. But 3D effects are far smoother. From time to time the screen flickers completely. Overall, gnome-shell is unusable.

Also using Ubuntu 11.10 64bit and and fglrx 2:8.881-0ubuntu4.1. I tried the newest driver from the ATI website (11.10) and it doesn't fix the problem. Additionally, there are module loading problems with this version. But I think, this should be another bug.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Confirmed
axeoth (axeoth) wrote :

I should add that my videocard is ATI HD 3470 with 256 MB.

axeoth (axeoth) wrote :

Sorry for being confrontational, but I found the proposal to close down the bug report a bit unbearable. Besides the original poster there are many others which are confronted with this problem, as the thread shows it. The idea is not to close the bug reports ("maybe a wonder happened and now there is no longer the need to work on it"), but to solve those bug reports. If "wonders" are expected, migrating to another distribution may be one... Oneiric has many problems per sé, dismissing its users is the worst choice, as they are already quite dissapointed.

axeoth (axeoth) wrote :

I succeeded in finding a workaround for Gnone Shell being displayed correctly. Caution: this describe what I remember I did, and I did not reproduce it.

Basically, I tried to follow the steps presented here:

http://drivers.downloadatoz.com/tutorial/28724,how-to-install-and-uninstall-amd-catalyst-11-10-on-ubuntu-11-10-oneiric-ocelot.html

So, now, to what I did:

1. I unninstalled fglrx* according to the procedure therein
2. I downloaded the Catalyst driver and tried to install it
3. Installation failed and told me about using (but not recommending using) the "--force" option
4. I installed Catalyst using the "--force option"
5. I restarted and entered Gnome Shell, which was falling back in the fallback mode and had some strange resolution
6. I unninstalled the Catalyst driver according to the procedure described therein
7. I restarted and, now, for an unknown reason, Gnome Shell is displayed correctly

OTOH, Unity is still not working (only the Nautilus toolbar is displayed) and only Unity-2D is wavailable.

Do not forget about being cautious.

The (this morning) update of fglrx-updates &co (Now at version 2:8.881-0ubuntu6.1) seems to have fixed the worst of it.
Nevertheless, there is still some (minor, but not nice) problem. See the attached shot --- easier than explain.

(5 minutes...)

well, I stand back, it seems that it's impossible to get a shot of the screen. More of that. The problem I was noticing above is that for example, in a gnome terminal, if you go the terminal-profile menu, and select the profiles... submenu, when you hover on the submenu it get mangled. The same happens to the "new" scrollbar sometime.

For the other thing: it seems that it's impossible to get a screenshot. When I try it, I get only an old wallpaper (I am rotating them) and no windows. Should be fglrx- related, because on my laptop, intel graphic card, same O.S., it works ok.

Some more info: had a lot of tearing when activating the "notification" (mouse in the lower right corner) area. Unbearable with "anti tearing" off, simply annoying with "anti tearing on".

Still unable to obtain a screenshot. Can anyone confirm this?

Daniel Mohr (dm0hr) wrote :

Also tested the new version of fglrx-updates 2:8.902-0ubuntu0.1. Still the same problems: Corrupted dialogs, tooltips and dropdowns. Very bad performance (scrolling, animations). With the open driver everything's much smoother (but far from perfect).

I confirm what Romano said: Also can't take screenshots. Because of this, I attached a photo of my screen (corrupted drop down in firefox).

System: Ubuntu Oneiric 64bit with Radeon HD 4290.

Yes, I have similar (albeit normally smaller) corrupted drop down and scroll-bars.

d3ngar (d3ngar) wrote :

Yes, the problem persists and we don't have anyone assigned to this bug.

Why won't Canonical address this problem? FGLRX is not that uncommon. Very few people find Unity a 'suitable' replacement and it's sad to see that we are essentially forced to migrate to a different distribution.

Steffen Sindzinski (stesind) wrote :

I do not have the blank screen after booting any more. So there is a progress. Still gnome shell is unusable because of poor performance and flickering. Rest is ok. Why should Canonical care about a competing desktop? I tried this Fedora 16 Live CD this week and I cannot even boot it - blank screen.

Dylan McCall (dylanmccall) wrote :

On Wed, Nov 16, 2011 at 12:36 PM, d3ngar <email address hidden> wrote:
> Why won't Canonical address this  problem? FGLRX is not that uncommon.
> Very few people find Unity a 'suitable' replacement and it's sad to see
> that we are essentially forced to migrate to a different distribution.

Hold on, did you find a distro where the FGLRX driver doesn't have
this issue? Please reply with the distro, its version, and the version
of fglrx. It would be very helpful, because as far as I am aware this
problem is in ATI's hands. If someone has worked around it (even
inadvertently) it would be really helpful.

Another data point: the lock-screen simply makes the screen a mess (complete lack of sync, it seems, like the not-so-good-old-times when you got ModeLine frequency wrong in x11.conf files).

Uf. Need to go back to Unity to be able to work, I hope it will be fixed soon.

Jeroen Keiren (jkeiren) wrote :

For me the issue seems to be fixed using the 11.11 version of fglrx.

nothing (odisplayo) wrote :

It's long time that we wait for a patch.

Dmitry (fwebstudio) wrote :

fuck AMD/RADEON driver bugs, buy NVIDIA!!!

Steffen Sindzinski (stesind) wrote :

Somewhere I read that the latest Gnome shell from Ricotz PPA will work but this is not the case. So you do not have to install it.

Alfagulf (alfagulf) wrote :

Dmitry,
That is exactly what I did...... The second part I mean!! :)

Dmitry (fwebstudio) wrote :

The quality of video drivers NVIDIA is good for Linux, AMD linux driver support is bad. Take an example consider include video acceleration in browsers, according to the requirements were only NVIDIA. For Windows driver from NVIDIA and AMD satisfy these requirements. It is worth considering what company to buy graphics card for users of linux.

cdwolf (charlespoetwolf) wrote :

Hmm... I was having a lot of issues, but going into Display in CCC and changing use graphics processor for scaling to use display for scaling fixed most of my issues, there are random white bars on the panel still but other than that, and flickering when I hit the application hotspot thing. Other than those, its mostly usable now :D

cdwolf (charlespoetwolf) wrote :

never mind on that last one, it was a very temporary fix and suddenly everything is worse

cdwolf (charlespoetwolf) wrote :

Hmm, I installed fglrx-updates and now it works almost perfect, theres only a glitch when the notifier pops up

Geoff Smith (taurusone) wrote :

Mostly usable - #80 and only a glitch - #82 are no good for me. I am waiting for a permanent fix before I install fglrx driver again. I hope ATI solves problem soon.

I have hand-installed fglrx-updates, and now it's almost ok for me - I just have the glitches on pop-up tips and ayatana scroll bars, but it's usable and quite fast. Using that now, let's see.

Jockey (additional hardware) continue to think that no additional driver is installed. Trying to "activate" it will break everything, and I need a reboot to have accelerated graphics back.

Correcting myself. Crashing like a crazy when viewing/editing videos. Back to unity. Sigh.

cdwolf (charlespoetwolf) wrote :

11.12 seems to fix it. Not available in repositories, I found a ppa with it, but it doesn't allow individual install, so your going to have to go on google and find it. (For some reason ATI/AMD did not post the Linux version on their site.)

I had some success with 11.12 as well. I can't declare full victory because I am having trouble using dual monitors with it--seeing some problems with Gnome Shell that I am not seeing under unity such as flickering and freezing (sometimes only on the external monitor). But in general, I can use Gnome Shell with this version. I downloaded the driver directly from AMD at http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx.

I followed these instructions, which were somewhat simpler than others I have seen (though it doesn't do all of the uninstalling that some of the other instruction sets I have seen do), to install it: http://mygeekopinions.blogspot.com/2011/06/how-to-install-atiamd-catalyst-linux.html

Obviously I substituted the current filenames for the older ones in the instructions. But install and reboot and I was able to see Gnome Shell with perfect clarity, not with garbled menus and crazy stripes, etc.

cdwolf (charlespoetwolf) wrote :

Well, I should correct myself. It works on single monitors with 11.12, but you need to turn on antitear and (in my case at least) disable notifications by clicking on your name in the top right and selecing Notifactions [ ] Off

Steffen Sindzinski (stesind) wrote :

The new driver version 12-1 available from http://support.amd.com/us/Pages/AMDSupportHub.aspx finally fixed it for my notebook with HD4650. All animations and so are fast and smooth. For installation you will need to download the package from the site above.

The following steps only work if you were using the fglrx before!

At my system 2 additionally packages were needed:
sudo apt-get install execstack dh-modaliases

go to your download folder:
cd Downloads

generate the Debs:
sh ati-driver-installer-12-1-x86.x86_64.run --buildpkg

install the Debs:
sudo dpkg -i fglrx*.deb

Changed in fglrx:
importance: Unknown → High
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.