Ubuntu

Installing then uninstalling FGLRX makes Oneiric's Unity unbootable

Reported by Jonathan Meek on 2011-09-21
162
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Compiz Core
Undecided
Unassigned
fglrx-installer (Ubuntu)
High
Alberto Milone
Oneiric
High
Alberto Milone
Precise
High
Alberto Milone
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

I was attempting to test this bug: https://bugs.launchpad.net/bugs/781384 by installing FGLRX via jockey-gtk. After I found that there were no fixes (still), I went back to jockey and uninstalled FGLRX. However, upon rebooting, I found that Unity would not load. Applications had their title bars, however and were able to be moved.

I ran a terminal and ran "unity" and was received various "Compiz couldn't load plugin X : could not locate libgl.so.1" etc. I checked on a live USB of mine and this file doesn't exist in a standard install. The only way I could find to fix it was to reinstall the FGLRX driver to get things to work temporarily. (Which i did not want to do because of aforementioned bug).

If you need any more information, I will be glad to pass it along. Running up-to-date 64bit Oneiric.

affects: fglrx → compiz-core-ubuntu

Can you please try removing fglrx again, and before you reboot do:
sudo dpkg-reconfigure libgl1-mesa-glx

I doubt this is a compiz bug , it probably something with fglrx's posrm script
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Jonathan Meek (shroudedcloud) wrote :

I will as soon as I can, I am currently away from a stable connection (in case something goes wrong, I wouldn't be able to fix it)

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
affects: compiz-core-ubuntu → compiz-core
Changed in compiz-core:
status: New → Incomplete
Jonathan Meek (shroudedcloud) wrote :

That command did NOT work. Same broken environment upon restarting.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Confirmed

OK. What about
sudo update-alternatives --config x86_64-linux-gnu_gl_conf
and you choose /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf, and reboot?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Even better, just post the result of
cat /etc/alternatives/x86_64-linux-gnu_gl_conf after you remove fglrx
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Just tried it myself on another install; it is broken; this is after removing fglrx:

ls -la /etc/alternatives/ | grep x86_64-linux-gnu
lrwxrwxrwx 1 root root 22 2011-09-24 09:10 x86_64-linux-gnu_10fglrx -> /usr/lib/fglrx/10fglrx
lrwxrwxrwx 1 root root 28 2011-09-24 09:10 x86_64-linux-gnu_amdconfig -> /usr/lib/fglrx/bin/amdconfig
lrwxrwxrwx 1 root root 30 2011-09-24 09:10 x86_64-linux-gnu_amdnotifyui -> /usr/lib/fglrx/bin/amdnotifyui
lrwxrwxrwx 1 root root 22 2011-09-24 09:10 x86_64-linux-gnu_ati_conf -> /usr/lib/fglrx/etc/ati
lrwxrwxrwx 1 root root 28 2011-09-24 09:10 x86_64-linux-gnu_aticonfig -> /usr/lib/fglrx/bin/aticonfig
lrwxrwxrwx 1 root root 29 2011-09-24 09:10 x86_64-linux-gnu_atieventsd -> /usr/lib/fglrx/bin/atieventsd
lrwxrwxrwx 1 root root 27 2011-09-24 09:10 x86_64-linux-gnu_atiodcli -> /usr/lib/fglrx/bin/atiodcli
lrwxrwxrwx 1 root root 25 2011-09-24 09:10 x86_64-linux-gnu_atiode -> /usr/lib/fglrx/bin/atiode
lrwxrwxrwx 1 root root 31 2011-09-24 09:10 x86_64-linux-gnu_fgl_glxgears -> /usr/lib/fglrx/bin/fgl_glxgears
lrwxrwxrwx 1 root root 31 2011-09-24 09:10 x86_64-linux-gnu_fglrx_dri -> /usr/lib/fglrx/dri/fglrx_dri.so
lrwxrwxrwx 1 root root 48 2011-09-24 09:10 x86_64-linux-gnu_fglrx_drv -> /usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
lrwxrwxrwx 1 root root 28 2011-09-24 09:10 x86_64-linux-gnu_fglrxinfo -> /usr/lib/fglrx/bin/fglrxinfo
lrwxrwxrwx 1 root root 24 2011-09-24 09:10 x86_64-linux-gnu_fglrx_modconf -> /lib/fglrx/modprobe.conf
lrwxrwxrwx 1 root root 25 2011-09-24 09:10 x86_64-linux-gnu_gl_conf -> /usr/lib/fglrx/ld.so.conf
lrwxrwxrwx 1 root root 38 2011-09-24 09:10 x86_64-linux-gnu_grub_fb_blacklist -> /usr/share/fglrx/fglrx.grub-gfxpayload
lrwxrwxrwx 1 root root 25 2011-09-24 09:10 x86_64-linux-gnu_initramfs-hook -> /lib/fglrx/initramfs-hook
lrwxrwxrwx 1 root root 29 2011-09-24 09:10 x86_64-linux-gnu_libAMDXvBA_cap -> /usr/lib/fglrx/libAMDXvBA.cap
lrwxrwxrwx 1 root root 29 2011-09-24 09:10 x86_64-linux-gnu_libaticalcl.so -> /usr/lib/fglrx/libaticalcl.so
lrwxrwxrwx 1 root root 31 2011-09-24 09:10 x86_64-linux-gnu_libaticalcl.so_lib32 -> /usr/lib32/fglrx/libaticalcl.so
lrwxrwxrwx 1 root root 29 2011-09-24 09:10 x86_64-linux-gnu_libaticalrt.so -> /usr/lib/fglrx/libaticalrt.so
lrwxrwxrwx 1 root root 31 2011-09-24 09:10 x86_64-linux-gnu_libaticalrt.so_lib32 -> /usr/lib32/fglrx/libaticalrt.so
lrwxrwxrwx 1 root root 19 2011-09-24 09:10 x86_64-linux-gnu_xorg_extra_modules -> /usr/lib/fglrx/xorg

Reinstall libgl1-mesa-glx solves the issue; so fglrx should have a update-alternatives trigger...

Changed in compiz-core:
status: Incomplete → Invalid

This is not compiz bug, it's fglrx's

Alberto Milone (albertomilone) wrote :

šumski: did you remove fglrx manually (e.g. with sudo apt-get remove fglrx) or through Jockey?

Alberto, i used jockey for both installing and uninstalling. Will try both with apt-get
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Download full text (4.7 KiB)

sudo apt-get purge fglrx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  fakeroot libgomp1 gcc-4.6 libc6-i386 lib32gcc1 libquadmath0 gcc dkms libc6-dev linux-libc-dev patch manpages-dev
  libc-dev-bin
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  fglrx* fglrx-amdcccle*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 130 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 92098 files and directories currently installed.)
Removing fglrx-amdcccle ...
Removing fglrx ...
Removing all DKMS Modules
Done.
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken.
update-alternatives: warning: skip creation of /usr/bin/amdcccle because associated file /usr/lib/fglrx/bin/amdcccle (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/share/applications/ubuntu-amdcccle.desktop because associated file /usr/share/fglrx/amdcccle.desktop (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/share/applications/ubuntu-amdccclesu.desktop because associated file /usr/share/fglrx/amdccclesu.desktop (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/bin/amdupdaterandrconfig because associated file /usr/lib/fglrx/bin/amdupdaterandrconfig (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/bin/amdxdg-su because associated file /usr/lib/fglrx/bin/amdxdg-su (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-initramfs: deferring update (trigger activated)
Purging configuration files for fglrx ...
update-initramfs: deferring update (trigger activated)
dpkg: warning: while removing fglrx, directory '/usr/lib/dri' not empty so not removed.
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for ureadahead ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0.0-11-generic

ls -la | grep x86_64-linux-gnu
lrwxrwxrwx 1 root root 22 2011-09-26 18:39 x86_64-linux-gnu_10fglrx -> /usr/lib/fglrx/10fglrx
lrwxrwxrwx 1 root root 28 2011-09-26 18:39 x86_64-linux-gnu_amdconfig -> /usr/lib/fglrx/bin/amdconfig
lrwxrwxrwx 1 root root 30 2011-09-26 18:39 x86_64-linux-gnu_amdnotifyui -> /usr/lib/fglrx/bin/amdnotifyui
lrwxrwxrwx 1 root root 22 2011-09-26 18:39 x86_64-linux-gnu_ati_conf -> /usr/lib/fglrx/etc/ati
lrwxrwxrwx 1 root root 28 2011-09-26 18:39 x86_64-linux-gnu_aticonfig -> /usr/lib/fglrx/bin/aticonfig
lrwxrwxrwx 1 root root 29 2011-09-26 18:39 x86_64-linux-gnu_atieventsd -> /usr/lib/fglrx/bin/atieventsd
lrwxrwxrwx 1 root root 27 2011-09-26 18:39 x86_64-linux-gnu_atiodcli -> /usr/lib/fglrx/bin/atiodcli
lrwxrwxrwx 1 root root 25 2011-09-26 18:39 x86_64-linux-gnu_atiode -> /usr/lib/fglrx/bin/atiode
lrwx...

Read more...

sudo apt-get install --reinstall libgl1-mesa-glx
...
Unpacking replacement libgl1-mesa-glx ...
Setting up libgl1-mesa-glx (7.11-0ubuntu3) ...
update-alternatives: warning: alternative /usr/lib/fglrx/ld.so.conf (part of link group x86_64-linux-gnu_gl_conf) doesn't exist. Removing from list of alternatives.
update-alternatives: warning: alternative /usr/lib/pxpress/ld.so.conf (part of link group x86_64-linux-gnu_gl_conf) doesn't exist. Removing from list of alternatives.
update-alternatives: warning: /etc/alternatives/x86_64-linux-gnu_gl_conf is dangling, it will be updated with best choice.
update-alternatives: using /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Britt Yazel (brittyboi) wrote :

I too have this bug. I tried all of the previous fixes and none worked. I am on 11.10 x64 beta 2, and I can say this problem has occurred on both of my computers and I have tried each with jockey and with apt-get, both achieving the same result.

My laptop is running an mobility radeon hd4250 and my PC is running a radeon hd 6950

Britt Yazel (brittyboi) wrote :

Edit on my previous comment:

I ran this command 1 last time and received this result:

sudo apt-get install --reinstall libgl1-mesa-glx
...
Unpacking replacement libgl1-mesa-glx ...
Setting up libgl1-mesa-glx (7.11-0ubuntu3) ...
update-alternatives: warning: alternative /usr/lib/fglrx/ld.so.conf (part of link group x86_64-linux-gnu_gl_conf) doesn't exist. Removing from list of alternatives.
update-alternatives: warning: alternative /usr/lib/pxpress/ld.so.conf (part of link group x86_64-linux-gnu_gl_conf) doesn't exist. Removing from list of alternatives.
update-alternatives: warning: /etc/alternatives/x86_64-linux-gnu_gl_conf is dangling, it will be updated with best choice.
update-alternatives: using /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

After reboot it did in fact fix my desktop.

So for some reason, after removing fglrx in the onieric builds, mesa-glx is not getting reinstalled

jsubei (jsubei) wrote :

same for me but when i run the re-install comand for libgl1-mesa-glx : (sorry, it is in french, but the last line, the error, is in english)

sudo apt-get install --reinstall libgl1-mesa-glx
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 100 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ oneiric/main libgl1-mesa-glx amd64 7.11-0ubuntu3 [100 kB]
100 ko réceptionnés en 0s (266 ko/s)
E: Internal Error, No file name for libgl1-mesa-glx

Jonathan Meek (shroudedcloud) wrote :

I had the same issue, I got around it by installing synaptic and telling it to reinstall both libgl1-mesa-glx AND libgl1-mesa-glx:i386. Hope that helps you.

Also, is anyone actually working on this bug?

Alberto Milone (albertomilone) wrote :

please try to reproduce the issue and attach your /var/log/jockey.log or I won't be able to see what's going on (and fix it)

Aurélien COUDERC (coucouf) wrote :

Here you go !

Jiri Grönroos (jiri-gronroos) wrote :

On 64-bit Oneiric

sudo apt-get install --reinstall libgl1-mesa-glx

did help after removing fglrx , now I'm able to run gnome-shell again without top panel being corrupted.

Steve Langasek (vorlon) wrote :

whatever is happening here, it should definitely be fixed by SRU.

Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
milestone: none → oneiric-updates
Changed in fglrx-installer (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
Aurélien COUDERC (coucouf) wrote :

Agreed, for non-techie users it’s going to break their systems in a way they can’t fix (neither Unity nor Unity 2D work with the broken libGL).

Andrew Clunis (orospakr) wrote :

I did the procedures suggested by @jiri-gronroos and @shroudedcloud, with these reuslts:

    E: Internal Error, No file name for libgl1-mesa-glx

Jonathan Meek (shroudedcloud) wrote :

Did you do what I said in comment #16? (I.E. also get libgl1-mesa-glx:i386?)

Andrew Clunis (orospakr) wrote :

Aha. In trying to use --reinstall, I ended up hitting another bug, #859188. On that bug, commenter Sal Mazzola (@salmaz) suggests using this alternative method to work around it:

    apt-get download libgl1-mesa-glx libgl1-mesa-dri
    dpkg --install libgl1-mesa-*.deb

I now have working GLX again!

Andrew Clunis (orospakr) wrote :

Good point, Jonathan. For copy/paste convenience for folks:

    apt-get download libgl1-mesa-glx libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
    dpkg --install libgl*deb

Changed in fglrx-installer (Ubuntu Oneiric):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu Oneiric):
status: Confirmed → In Progress
Changed in fglrx-installer (Ubuntu Precise):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.881-0ubuntu5

---------------
fglrx-installer (2:8.881-0ubuntu5) precise; urgency=low

  * debian/fglrx.prerm.in:
    - Make sure to remove the correct alternatives on package
      removal (LP: #855943).
    - Call ldconfig with the LDCONFIG_NOTRIGGER=y environment
      variable, as in the postinst script.
 -- Alberto Milone <email address hidden> Tue, 25 Oct 2011 17:52:12 +0200

Changed in fglrx-installer (Ubuntu Precise):
status: In Progress → Fix Released
Alberto Milone (albertomilone) wrote :

I've just uploaded the fix in precise and in oneiric-proposed

Hello Jonathan, or anyone else affected,

Accepted fglrx-installer-updates into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in fglrx-installer-updates (Ubuntu Precise):
status: New → Fix Released
Changed in fglrx-installer-updates (Ubuntu Oneiric):
status: New → Fix Committed
Changed in fglrx-installer (Ubuntu Oneiric):
status: In Progress → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Jonathan, or anyone else affected,

Accepted fglrx-installer into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Aurélien COUDERC (coucouf) wrote :

Confirming the fix in oneiric with fglrx 8.881-0ubuntu4.1.

Thanks a lot !

Martin Pitt (pitti) on 2011-10-27
tags: added: verification-done
removed: verification-needed
TBeholder (turbobeholder) wrote :

But "link group x86_64-linux-gnu_gl_conf is broken" itself is NOT fglrx problem as the same happens even without fglrx installed! Inability to circumvent it or sometimes uninstall correctly may be, of course. I don't have "unbootable" problem, but GL still does NOT work normally on Oneiric, with versions - fglrx, fglrx-updates and downloaded Catalyst (the same which DID work perfectly on Lucid!) - differing in specific failures.

It's about mesa GL packages for Oneiric:
libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libglu1-mesa
In Synaptic they all are flagged as installed, but "installed files" lists are unavailable because packages are not installed, and an attempt to reinstall any of them causes this very error.

TBeholder (turbobeholder) wrote :

P.S.: another error on reinstall has libxrender1 (dependency of fglrx). "E: Internal Error, No file name for libxrender1"

Eugene Crosser (crosser) wrote :

TBeholder: the underlying problem is tracked as the Bug #859188, you might want to track it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.881-0ubuntu4.1

---------------
fglrx-installer (2:8.881-0ubuntu4.1) oneiric-proposed; urgency=low

  * debian/fglrx.prerm.in:
    - Make sure to remove the correct alternatives on package
      removal (LP: #855943).
    - Call ldconfig with the NOTRIGGER environment variable
      as in the postinst.
 -- Alberto Milone <email address hidden> Tue, 25 Oct 2011 18:18:36 +0200

Changed in fglrx-installer (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:8.881-0ubuntu6.1

---------------
fglrx-installer-updates (2:8.881-0ubuntu6.1) oneiric-proposed; urgency=low

  * debian/fglrx-updates.prerm.in:
    - Make sure to remove the correct alternatives on package
      removal (LP: #855943).
    - Call ldconfig with the NOTRIGGER environment variable
      as in the postinst.
 -- Alberto Milone <email address hidden> Wed, 26 Oct 2011 15:18:15 +0200

Changed in fglrx-installer-updates (Ubuntu Oneiric):
status: Fix Committed → Fix Released
udippel (udippel) wrote :

Since I upgraded it yesterday, it has become impossible to wake up my monitor from its energy-saving state. Whenever it has kicked in, only a hard reboot makes the monitor come back. No action on mouse or keyboard; the monitor remains pitch black.
I do NOT say it has to make with this package, but I never had this before and it totally coincides with this upgrade.
Details are available under bug 886496.
Contact me for a solution, or further details, please.

Alberto Milone (albertomilone) wrote :

@udippel: I don't think my changes could ever caused what you described in the bug report. You can try removing fglrx and see if you can still reproduce the problem without it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments