sometime empathy chat dialogs open empty/with a negative unread count

Bug #1261060 reported by _dan_ on 2013-12-15
168
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

* Impact:
sometime messages are not displayed when opening the chat view after receiving one

* Test Case:
- open the empathy contact list
- select the contact that is going to send you a message
- clear the history
- send the message
- open it by clicking the buddy list entry

-> the message should be listed in the chat view

* Regression potential:
check that messages are correctly listed in chat view, in correct order and the scrolling is done correct when adding new ones

------------

Whenever i get a message in empathy (google talk account) and i open the message via the blue indicator symbol, only an empty window opens, swallowing the message, with title (-X unread)

See screenshot:
https://dl.dropboxusercontent.com/u/27087995/ubuntubugs/unread.png

desired behaviour:
have the message appear in the window

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-messages 13.10.1+13.10.20131011-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Sun Dec 15 02:02:26 2013
InstallationDate: Installed on 2013-12-13 (1 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: indicator-messages
UpgradeStatus: No upgrade log present (probably fresh install)

_dan_ (dan-void) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Cédric Bellegarde (gnumdk) wrote :

will this be fixed in LTS 14.04?

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I managed to reproduce that issue one time after starting empathy today but it doesn't seem to happen anymore now ... do you have exact steps to reproduce the bug? The unread counter of -1 is a bit weird

Iterating with some restarts of empathy I ended up in a situation where the indicator had a stack of unread entries for empathy where I had no unread messages as well

Lars, could you have a look?

Changed in indicator-messages (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → High
tags: added: ubuntu-desktop-trusty
Sebastien Bacher (seb128) wrote :

That seems an upstream empathy bug, https://bugzilla.gnome.org/show_bug.cgi?id=662672 (that has mention of similar issues on fedora without using the indicator)

Changed in indicator-messages (Ubuntu):
assignee: Lars Uebernickel (larsu) → nobody
status: Confirmed → Triaged
affects: indicator-messages (Ubuntu) → empathy (Ubuntu)
summary: - opening an unread message via the indicator makes empathy open an empty
- window, forgetting the msg
+ sometime empathy chat dialogs open empty/with a negative unread count
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Confirmed

Still in empathy 3.8.6 (ubuntu 14.04). Workaround: open chat window from messaging menu (new message) or contact list, select contact menu > previous conversions. New messages are available here.

@Sebastien Bacher (seb128)

How to reproduce :

Keep close the chat window (not all, assume you will going to chat with friend A). When A will send you new messages, notification will be shown and messaging menu's color will change as new message arrive. Now open friend A's chat window (from messaging menu or contact list or wherever), chat window is blank, no new messages are visible and still read status icon in chat window (left top) is unread (i have unread messages).

Changed in empathy (Ubuntu Trusty):
status: Triaged → Confirmed

Seems bug was fixed upstream (see https://bugzilla.gnome.org/show_bug.cgi?id=662672). Are there any plans to update Empathy in 14.04?

Vladimir (semenov-mailbox) wrote :

How can I upgrade empathy in ubuntu 14.04?
I updated to version 3.10.3 empathy, but there remains the problem!

description: updated

This annoying bug is still present in 14.04 :(

Miguel Rubio-Roy (mrubioroy) wrote :

The bug has been solved for 3.8.6-0ubuntu10

Does the following link mean that the patched version will only be deployed with Ubuntu 14.10 ?
https://launchpad.net/ubuntu/+source/empathy/3.8.6-0ubuntu10

If so, I'd like to insist that this is an important bug that severely hinters empathy usability and need to be corrected ASAP.

Hello _dan_, or anyone else affected,

Accepted empathy into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/empathy/3.8.6-0ubuntu9.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in empathy (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
kgi (iacovou) wrote :

Hi Chris,

Thanks for your efforts. I've installed 3.8.6-0ubuntu9.1, and unfortunately it's inconclusive.

For me (as with others), the error occurs when I have no chat window open with the correspondent and I am sent a new message.

In this case, the main list of contacts shows the "flashing light" (there's also no integration with desktop notifications, so I don't get the "blue envelope", but that might be an unrelated bug).

When I click on the contact with the flashing light, I still see the "(-1 unread)" in the title bar. However, whether the message shows up seems to be a bit random.

The first time I tried it, the messages appeared. This was with three messages, so maybe the later ones had some kind of "flush" action that caused the earlier ones to appear.

The second time I tried it, I saw nothing in the window. The name of the contact showed a "white speech bubble" showing that there was an unread message, but there was no message. The title bar said "(-1 unread)".

The third time I tried it, it worked (I saw the new message). However, the (presumably) previous message was visible. Interestingly, it's not "styled" in the same way: it doesn't appear in a little speech bubble with colours, but is instead plain unstyled black and white text.

Hope this is useful.

_dan_ (dan-void) wrote :

Worked for me, thank you.

_dan_ (dan-void) wrote :

I tested this version:
3.8.6-0ubuntu9.1

Sebastien Bacher (seb128) wrote :

@kgi: did you restart your session before trying?

Sebastien Bacher (seb128) wrote :

Could somebody try that fix, so we can move it to trusty-updates?

_dan_ (dan-void) wrote :

Alreqdy tried and commented on it

Ubuntu 14.04 LTS

Tested package 3.8.6-0ubuntu9.1 and it works. Thanks

Vladimir (semenov-mailbox) wrote :

Very good!!!! 3.8.6-0ubuntu9.1 it worked!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.8.6-0ubuntu9.1

---------------
empathy (3.8.6-0ubuntu9.1) trusty; urgency=medium

  * debian/patches/git_correct_display_messages.patch:
    - "EmpathyChat: Fix pending messages not being displayed",
      thanks Lars Uebernickel and Xavier Claessens for investigating the
      issue (lp: #1261060)
 -- Sebastien Bacher <email address hidden> Wed, 23 Apr 2014 15:35:16 +0200

Changed in empathy (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for empathy has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in empathy:
status: Confirmed → Fix Released
Mathew Hodson (mathew-hodson) wrote :

Fix in Utopic with https://launchpad.net/ubuntu/+source/empathy/3.8.6-0ubuntu11

This bug is mentioned in the changelog.

Changed in empathy (Ubuntu):
status: Confirmed → Fix Released
payman (peymandelshad) wrote :

I can still reproduce this bug in Empathy 3.8.6 on Ubuntu 14.04 LTS.

Wallrider (sergey-volkov-a) wrote :

Also have this problem.
Empathy 3.8.6 on Ubuntu 14.04 LTS.

Wallrider (sergey-volkov-a) wrote :

Sorry, I mean I can reproduce other bug - https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/1235472

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.