Please update Ekiga to 3.00

Bug #274085 reported by Greg A
158
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
Intrepid Ibex Backports
Undecided
Unassigned
ekiga (Debian)
Fix Released
Unknown
ekiga (Ubuntu)
Wishlist
Unassigned
Declined for Gutsy by Steve Langasek
Declined for Hardy by Steve Langasek
Declined for Intrepid by Martin Pitt

Bug Description

Binary package hint: ekiga

Ekiga 3.00 has just been released. This is a major update to the current version in the repositories.

    * New user interface with a buddy list
    * Accelerated video display (Unix: XVideo, Windows: DirectDraw)
    * Nice incoming call notifications
    * Easier configuration assistant
    * New quality meter in the status bar
    * Buddy list with extended status information
    * Displays network neighbours in the buddy list
    * Better keyboard shortcuts
    * Automatic account completion in the URL bar
    * New chat window
    * New address book supporting Evolution contacts, LDAP contacts and more
    * New account window allowing easier account creation
    * New call panel

http://blog.ekiga.net/?p=97

I don't suppose this justifies a freeze exception for Intrepid as it is installed by default and is in main (even if not that many people use it).

Related branches

Revision history for this message
ethana2 (ethana2) wrote :

This at least needs to be in backports. I always enable backports for myself 'cause it seems half the time everything else is too old. I'd recommend updating it in main also, but perhaps the ubuntu developers would be more amicable to that if they shipped a 3.0.1 release of some kind in a month or so.

Revision history for this message
Wouter Stomp (wouterstomp-deactivatedaccount) wrote :

Perhaps there could be an ekiga3 package in universe? Like with firefox2/3 in previous releases?

Revision history for this message
Yannick Defais (sevmek) wrote :

If you release for intrepid, apply the following patch to ekiga 3.0.0 source, which prevent the main window to be close for ever.

Best regards,
Yannick

Revision history for this message
-Zeus- (matthew-momjian) wrote :

I think this will be applied in intrepid, so I am going to invalidate it.

Changed in ekiga:
status: New → Invalid
-Zeus- (matthew-momjian)
Changed in ekiga:
status: Invalid → Confirmed
Revision history for this message
Craig (candrews-integralblue) wrote : Re: [Bug 274085] Re: Please update Ekiga to 3.00

Why did you the issue? It hasn't been fixed... Should it remain open for discussion and progress tracking?
------Original Message------
From: -Zeus-
Sender: <email address hidden>
To: <email address hidden>
ReplyTo: Bug 274085
Sent: Sep 24, 2008 4:28 PM
Subject: [Bug 274085] Re: Please update Ekiga to 3.00

I think this will be applied in intrepid, so I am going to invalidate
it.

** Changed in: ekiga (Ubuntu)
       Status: New => Invalid

--
Please update Ekiga to 3.00
https://bugs.launchpad.net/bugs/274085
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Sent via BlackBerry from T-Mobile

Revision history for this message
Marcus Granado (mrc-gran) wrote :

ekiga 3.0 should definitely make it to Intrepid main, as the default good-looking alternative to skype.

Revision history for this message
Hew (hew) wrote :

Ekiga 3.0 is considered to be a part of GNOME 2.24 [1], so it should be considered part of the Intrepid release goals.

[1] http://library.gnome.org/misc/release-notes/2.24/#rnusers.ekiga

Changed in ekiga:
importance: Undecided → Wishlist
Revision history for this message
Hew (hew) wrote :

In the comments of bug 204352, Yannick Defais notes that Ekiga 3.0 is already targeted for Intrepid.

Changed in ekiga:
status: Confirmed → Triaged
Revision history for this message
Yannick Defais (sevmek) wrote :

Hello Hew McLachlan,

I'm part of the Ekiga team. I'm not part of Ubuntu. I just said, the ekiga team will do its best to release 3.0 in time _for_ inclusion in Intrepid (our "target"). And I think we did it in time. Now it is up to the Ubuntu team to intregrate it. (and a few comments above I provide a patch against a nasty bug in the ekiga 3.0.0 source in dpatch format to help the packaging).
I also have personal package for ekiga SVN here:
https://launchpad.net/~sevmek/+archive which might help packaging.

I do not package for Ubuntu main archive...

Best regards,
Yannick

Revision history for this message
tlp (tlp) wrote :

As others have pointed out, Ekiga 3.0.0 is part of GNOME 2.24 and should be included with Intrepid. That aside, I think that the differences are tremendous; please don't make us wait another 6 months for inclusion.

Revision history for this message
Yann (lostec) wrote :

Waiting another 6 month? That would be a year because Ekiga 3.0 was first planned for 8.04 LTS version: For this one it should be put in the backport short list because LTS users may not want to wait 2 more years!

Concerning Ekiga itself, the interface is much more beautiful and user friendly... but this is a pity ZRTP was removed from 3.0 goals.

But the reason may be : Will ZRTP be the SIP-Crypto standardisation winner? Maybe a custom and implementation easy solution based on SIP ports SSL tunneling should be added (even if not compatible with other SIP clients in this mode) as all this still not show any progress since too many years. Or at least the ability for Ekiga to go through a socks proxy, making it easy for users to use their own tunnelling solution (SSH...).

Regards.

Revision history for this message
Martin Pitt (pitti) wrote :

The biggest problem with this is that, unlike other GNOME components,
Intrepid did not get pre-releases of ekiga 3.0, and thus didn't get
any required libraries etc. either. So changing it now would be a
pretty severe regression potential.

I don't want to say that I outright refuse the idea (I agree that it
would be nice to have), but we need a maintainer who is interested to
looking after ekiga, work on providing working intrepid packages,
making sure that configuration upgrades etc. from 2.0 work, and care
about regressions that arise from that upgrade. If anyone wants to
take this responsibility, that would be great, and the update would
have my blessing.

Revision history for this message
Xamusk (ronanpaixao) wrote :

Well, there is a PPA for Intrepid available:
https://launchpad.net/~sevmek/+archive

Maybe its owner could help.

Revision history for this message
Yannick Defais (sevmek) wrote :

Hello,

I've made packages for Ekiga 3.0.

You have Ekiga 3.0 for Gutsy, Hardy and Intrepid, on all 3 available architectures: i386, amd64 and LPIA.

Warning: I'm not part of Ubuntu or Canonical, those packages came without any support. (still i'll try to help if I can). Do not expect to keep your settings from 2.0 (well, i do not know what will happen...)

https://launchpad.net/~sevmek/+archive

@Canonical team: Those packages are clean (no patches for PTLIB, no patches for OPAL, very few for Ekiga), it use the tarballs released by upstream on GNOME FTP. I use the same sources for all ubuntu flavor and arch, and the same debian repository too. The packaging were heavily simplified during the development process. My packages are much more easier to maintain than previously. Please, drop an eye on it to integrate Ekiga 3.0 into Intrepid and to Hardy backports. The only libraries which need to be upgraded are PTLIB and OPAL. If you want some imporvements, you can ask me directly, I'm part of upstream.

Best regards,
Yannick Defais

Revision history for this message
Hew (hew) wrote :

Yannick: Martin Pitt said that Ekiga 3.0 will only be accepted if we get a maintainer to take care of the expected bugs / regressions from such a release. Would you be able to do this? It sounds like there are a number of users willing to help with testing, and with an Ekiga developer as a maintainer, I believe this would satisfy the requirements for inclusion in Intrepid.

Revision history for this message
Hew (hew) wrote :

I added that ppa, and there are a number of dependency conflicts in Intrepid. The dependencies should be:
libpt-1.10.10* rather than libpt*
libdc1394-22 rather than libdc1394-13
libopal-2.2 rather than libopal

Attempting to install Ekiga 3.0 at the moment results in the Ubuntu versions of the packages being removed, including ubuntu-desktop.

Revision history for this message
Yannick Defais (sevmek) wrote :

Hello,

libpt has to be upgraded, same for libopal. Those are the main Ekiga's libraries. libpt (namely PTLIB) for devices, and libopal (OPAL) for protocols/codecs. We could probably install in parallel, but, which packages use those libraries except Ekiga ???

For libdc1394-22 it is because of the libpt DC plugin for digital camera. This plugin has no support upstream, i will remove it from the intrepid packs.

Finaly, I've not the willing the do someone else paid job. In the old days it was seb128's job. Ekiga is part of main, thus i think it should be handle by one of the ubuntu/canonical employees.

Best regards,
Yannick

Revision history for this message
Yannick Defais (sevmek) wrote :
Download full text (3.9 KiB)

Hello,

I updated the intrepid packages:

Take a regular ubuntu-desktop install, add the PPA, then $ sudo aptitude update,

$ LC_ALL=C sudo aptitude upgrade
W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
The following NEW packages will be installed:
  libopal{a} libpt{a} libpt-plugins-avc{a}
The following packages will be REMOVED:
  libopal-2.2{u} libpt-1.10.10{u} libsdl1.2debian{u} libsdl1.2debian-alsa{u}
The following packages will be upgraded:
  ekiga
1 packages upgraded, 3 newly installed, 4 to remove and 0 not upgraded.
Need to get 14.1MB of archives. After unpacking 2675kB will be used.
Do you want to continue? [Y/n/?]
WARNING: untrusted versions of the following packages will be installed!

Untrusted packages could compromise your system's security.
You should only proceed with the installation if you are certain that
this is what you want to do.

  ekiga libopal libpt-plugins-avc libpt

Do you want to ignore this warning and proceed anyway?
To continue, enter "Yes"; to abort, enter "No": Yes
Writing extended state information... Done
Get:1 http://ppa.launchpad.net intrepid/main libpt-plugins-avc 2.4.1-0~0intrepid9 [27.8kB]
Get:2 http://ppa.launchpad.net intrepid/main libpt 2.4.1-0~0intrepid9 [1073kB]
Get:3 http://ppa.launchpad.net intrepid/main libopal 3.4.1-0~0intrepid9 [3070kB]
Get:4 http://ppa.launchpad.net intrepid/main ekiga 3.0.0-0~0intrepid10 [9908kB]
Fetched 14.1MB in 39s (357kB/s)
Selecting previously deselected package libpt-plugins-avc.
(Reading database ... 98449 files and directories currently installed.)
Unpacking libpt-plugins-avc (from .../libpt-plugins-avc_2.4.1-0~0intrepid9_i386.deb) ...
Selecting previously deselected package libpt.
Unpacking libpt (from .../libpt_2.4.1-0~0intrepid9_i386.deb) ...
Selecting previously deselected package libopal.
Unpacking libopal (from .../libopal_3.4.1-0~0intrepid9_i386.deb) ...
Preparing to replace ekiga 2.0.12-0ubuntu5 (using .../ekiga_3.0.0-0~0intrepid10_i386.deb) ...
Unpacking replacement ekiga ...
Processing triggers for man-db ...
(Reading database ... 98603 files and directories currently installed.)
Removing libopal-2.2 ...
Removing libpt-1.10.10 ...
Removing libsdl1.2debian ...
Removing libsdl1.2debian-alsa ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Setting up libpt (2.4.1-0~0intrepid9) ...

Setting up libpt-plugins-avc (2.4.1-0~0intrepid9) ...
Setting up libopal (3.4.1-0~0intrepid9) ...

Setting up ekiga (3.0.0-0~0intrepid10) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Init...

Read more...

Revision history for this message
Yannick Defais (sevmek) wrote :

oops, that's wrong... no more plugins...

Revision history for this message
Mahdi (mahdi-hates-spam) wrote :

Finally :)
Thanks Yannick!

Revision history for this message
Garrett Fields (fields-g) wrote :

I've also been waiting years and believe this is a MAJOR contribution to linux. I can convince MANY people to give Ubuntu a try once videoconferencing reaches quality levels equivalent to other applications/devices.

Congrats and Thanks!

Revision history for this message
tictactoe (xavier-garel) wrote :

I am working for the education, and we are expecting to give teachers an alternative to Skype (which is closed and proprietary software). The necessary integration of Ekiga 3 is essential to the use of Ubuntu Linux in schools and colleges.

Thks Yannick for you help and I hope Ubuntu Desktop Team we will find a way to run easily Ekiga3 in Intrepid ...

Best regards,

xgl.

Revision history for this message
Yannick Defais (sevmek) wrote :
Download full text (4.9 KiB)

Hi Hew McLachlan,

I changed the 3. 0 deps for intrepid: it should fix your issue. On my system:

ekiga/3.0/intrepid$ LC_ALL=C sudo aptitude install ekiga
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  libopal{a} libpt{a} libpt-plugins-alsa{a} libpt-plugins-avc{a} libpt-plugins-v4l{a} libpt-plugins-v4l2{a}
The following packages will be REMOVED:
  libdirectfb-1.0-0{u} libopal-2.2{a} libpt-1.10.10{a} libpt-1.10.10-plugins-alsa{a} libpt-1.10.10-plugins-v4l{a} libpt-1.10.10-plugins-v4l2{a}
  libsdl1.2debian{u} libsdl1.2debian-alsa{u} libts-0.0-0{u}
The following packages will be upgraded:
  ekiga
1 packages upgraded, 6 newly installed, 9 to remove and 0 not upgraded.
Need to get 1190kB/14.2MB of archives. After unpacking 332kB will be used.
Do you want to continue? [Y/n/?]
WARNING: untrusted versions of the following packages will be installed!

Untrusted packages could compromise your system's security.
You should only proceed with the installation if you are certain that
this is what you want to do.

  ekiga libpt-plugins-v4l2 libpt-plugins-avc libpt-plugins-v4l libpt-plugins-alsa libpt

Do you want to ignore this warning and proceed anyway?
To continue, enter "Yes"; to abort, enter "No": Yes
Writing extended state information... Done
Get:1 http://ppa.launchpad.net intrepid/main libpt-plugins-alsa 2.4.1-0~0intrepid24 [27.9kB]
Get:2 http://ppa.launchpad.net intrepid/main libpt-plugins-v4l2 2.4.1-0~0intrepid24 [31.9kB]
Get:3 http://ppa.launchpad.net intrepid/main libpt-plugins-v4l 2.4.1-0~0intrepid24 [30.3kB]
Get:4 http://ppa.launchpad.net intrepid/main libpt-plugins-avc 2.4.1-0~0intrepid24 [27.8kB]
Get:5 http://ppa.launchpad.net intrepid/main libpt 2.4.1-0~0intrepid24 [1072kB]
Fetched 1190kB in 7s (158kB/s)
(Reading database ... 97959 files and directories currently installed.)
Preparing to replace ekiga 2.0.12-0ubuntu5 (using .../ekiga_3.0.0-0~0intrepid22_i386.deb) ...
Unpacking replacement ekiga ...
Processing triggers for man-db ...
(Reading database ... 98085 files and directories currently installed.)
Removing libopal-2.2 ...
Removing libpt-1.10.10 ...
Removing libpt-1.10.10-plugins-alsa ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Selecting previously deselected package libpt-plugins-alsa.
(Reading database ... 98067 files and directories currently installed.)
Unpacking libpt-plugins-alsa (from .../libpt-plugins-alsa_2.4.1-0~0intrepid24_i386.deb) ...
dpkg: libpt-1.10.10-plugins-v4l2: dependency problems, but removing anyway as you request:
 ubuntu-desktop depends on libpt-1.10.10-plugins-v4l2.
(Reading database ... 98071 files and directories currently installed.)
Removing libpt-1.10.10-plugins-v4l2 ...
Selecting previously deselected package libpt-plugins-v4l2.
(Reading database ... 98068 files and directories currently installed.)
Unpacking libpt-plugins-v4l2 (from .../libpt-plugins-v4l2_2.4.1-0~...

Read more...

Revision history for this message
Hew (hew) wrote :

Thanks Yannick. Ekiga installs without removing ubuntu-desktop, and only removes the packages it is replacing. This is a good solution.

Revision history for this message
Hew (hew) wrote :

I think it's safe to say Ekiga 3 won't be in Intrepid. Marking Won't Fix.

If you need Ekiga 3 for Intrepid, add Yannick's PPA: https://launchpad.net/~sevmek/+archive

Changed in ekiga:
status: Triaged → Won't Fix
Revision history for this message
Steve Langasek (vorlon) wrote :

Declining the fix for intrepid is for the release team to decide, Hew. Furthermore, even if this is declined for intrepid, the request for updating would remain valid for Jaunty. Reopening the bug.

Changed in ekiga:
status: Won't Fix → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

I wanted to test the ekiga 3.0 packages (thanks Yannick for putting them together!) However, it seems that the library packages are broken now. First, a normal dist-upgrade doesn't work:

$ LANG= sudo apt-get dist-upgrade
[...]
The following packages will be REMOVED:
  ekiga libopal-2.2 libpt-1.10.10 libpt-1.10.10-plugins-v4l libpt-1.10.10-plugins-v4l2 ubuntu-desktop
0 upgraded, 0 newly installed, 6 to remove and 0 not upgraded.

And a direct install explains why:

$ LANG= sudo apt-get install ekiga:
[...]
The following extra packages will be installed:
  libopal libpt libpt-plugins-alsa libpt-plugins-avc libpt-plugins-v4l libpt-plugins-v4l2
Suggested packages:
  libopal-plugins-h264 libopal-plugins-ilbc libpt-plugins-oss siproxd gnugk mediaproxy ser openser rtpproxy
  asterisk yate callweaver libopal-dev libopal-dbg libopal-doc libpt-dbg libpt-dev libpt-doc
The following packages will be REMOVED:
  libopal-2.2 libpt-1.10.10 libpt-1.10.10-plugins-alsa libpt-1.10.10-plugins-v4l libpt-1.10.10-plugins-v4l2
The following NEW packages will be installed:
  libopal libpt libpt-plugins-alsa libpt-plugins-avc libpt-plugins-v4l libpt-plugins-v4l2
The following packages will be upgraded:
  ekiga
1 upgraded, 6 newly installed, 5 to remove and 1 not upgraded.

Yannick, why did you remove the SONAME parts from the libraries? A shared library "libopal" is invalid, since it breaks parallel installability of several SONAMEs (ABI versions), which is necessary for upgrades.

So we do need newer opal etc. library versions for the new ekiga?

Revision history for this message
Martin Pitt (pitti) wrote :

For the record, I am trying to build the 3.0.0 ekiga source package on intrepid, but I have quite a lot of difficulties, since there are several bugs which break the build. The source package itself has md5 mismatches, I fixed the "cp * build-gtkonly" (trying to copy a directory into itself), and will probably figure out a solution for the "./configure: not found" problem as well (running autoreconf or so), but it will take a while.

Yannick, it seems you needed a lot of "hit it over the head" black magic to actually build this? :-)

Revision history for this message
Yannick Defais (sevmek) wrote :

@Martin Pitt,

What are you talking about??

My source package build on gutsy, hardy and intrepid on all arch. Where exactly are the issues you point to??

The upstream sources are here:
http://ftp.gnome.org/pub/gnome/sources/ptlib/2.4/
http://ftp.gnome.org/pub/gnome/sources/opal/3.4/
http://ftp.gnome.org/pub/gnome/sources/ekiga/3.0/

Best regards,
Yannick

Revision history for this message
Eugen Dedu (eugen-dedu) wrote :

Hi,

It would be a pity if ekiga 3.0 will not be in intrepid, as it has a nearly 3 years of development. Also, there has been no important bug since the release, one week ago. For my part, I try to push ekiga/ptlib/opal to debian (my bulds are at http://snapshots.debian.net/snapshots/debian). They will appear in experimental as soon as ptlib source package exists the new queue (http://ftp-master.debian.org/new.html). I plan to maintain them in debian, I would like to help for ubuntu too, but I do not work on ubuntu. Now, for this bug:

The soname are 2.4.1, resp. 3.4.1 (no compatilibty between minor versions, i.e. 2.4.2 will not be compatible to 2.4.1), so the packages have to be renamed libpt2.4.1 and libopal3.4.1.

I don't know about the md5 mismatches, but this will be solved of course upon building.

"cp * build-gtkonly" should have a - before it in the Makefile, in order not to take into account the known error "Cannot copy a directory into itself". There's no harm here. Anyway, gtkonly build is not very tested, upstream proposed not to ship it yet in official packages.

./configure: not found This problem comes from: if you use the SVN sources, you must use autogen.sh, because they do not have a configure file. If you use the release versions, i.e. the tar.gz from ftp.gnome, as given in the previous link, then you must use ./configure (it does not have autogen.sh).

For your dist-upgrade error: I do not understand why ekiga is not correctly installed, is it because the name of the packages?

The last versions of ptlib (2.4.1) and opal (3.4.1) are mandatory for ekiga 3.0.

Greetings,
Eugen

Revision history for this message
Martin Pitt (pitti) wrote :

Hi Yannick,

Yannick Defais [2008-10-03 0:00 -0000]:
> What are you talking about??
>
> My source package build on gutsy, hardy and intrepid on all arch.

See my troubles in my previous bug comments. Maybe you have a newer
source package which isn't present in your PPA?

(Also, the broken library package renames are a critical issue which
prevent uploading them to intrepid)

Revision history for this message
Martin Pitt (pitti) wrote :

Hi Eugen,

Eugen Dedu [2008-10-03 14:58 -0000]:
> The soname are 2.4.1, resp. 3.4.1 (no compatilibty between minor
> versions, i.e. 2.4.2 will not be compatible to 2.4.1), so the packages
> have to be renamed libpt2.4.1 and libopal3.4.1.

Right.

> "cp * build-gtkonly" should have a - before it in the Makefile, in order
> not to take into account the known error "Cannot copy a directory into
> itself".

That doesn't make sense to me, since it will just always fail, and the
following commands will just break because the build-gtkonly/
directory is empty. I fixed it by replacing it with

  cp -a `find -maxdepth 1 ! -name 'build-*' ! -name '.*' ! -name debian` build-gtkonly

> ./configure: not found This problem comes from: if you use the SVN
> sources, you must use autogen.sh, because they do not have a configure
> file. If you use the release versions, i.e. the tar.gz from ftp.gnome,
> as given in the previous link, then you must use ./configure (it does
> not have autogen.sh).

Ah, I added a "autoreconf -i -v;" right after the "cd build-gtkonly"
command line. But indeed the orig.tar.gz should ship them
pre-generated, since calling autoconf at build time is the source of
lots of hassle (not really a problem if the new packages do it that
way, as long as it works.)

> For your dist-upgrade error: I do not understand why ekiga is not
> correctly installed, is it because the name of the packages?

Yes, probably because the new library packages from the PPA have some
weird Conflicts:, and are not installable in parallel with the current
Intrepid versions (with the older SONAME).

Thanks, Martin

Revision history for this message
Eugen Dedu (eugen-dedu) wrote :

Hi Martin,

Martin Pitt wrote:
> Hi Eugen,
>
> Eugen Dedu [2008-10-03 14:58 -0000]:
>> "cp * build-gtkonly" should have a - before it in the Makefile, in order
>> not to take into account the known error "Cannot copy a directory into
>> itself".
>
> That doesn't make sense to me, since it will just always fail, and the
> following commands will just break because the build-gtkonly/
> directory is empty. I fixed it by replacing it with
>
> cp -a `find -maxdepth 1 ! -name 'build-*' ! -name '.*' ! -name debian`
> build-gtkonly

Yes, your command is better, mine is simpler :o)

In fact, my command was: -cp -a * build-gtkonly, which works (even with
the known error 'copy into itself'). (I don't understand why it would
not work, anyway, it's a minor thing.)

--
Eugen

Revision history for this message
Yannick Defais (sevmek) wrote :

Le lundi 06 octobre 2008 à 15:07 +0000, Martin Pitt a écrit :
> Hi Yannick,
>
> Yannick Defais [2008-10-03 0:00 -0000]:
> > What are you talking about??
> >
> > My source package build on gutsy, hardy and intrepid on all arch.
>
> See my troubles in my previous bug comments. Maybe you have a newer
> source package which isn't present in your PPA?
>
> (Also, the broken library package renames are a critical issue which
> prevent uploading them to intrepid)
>

Let's clarify this once again: I'm not responsible for the lack of Ekiga
3.0 packages in Ubuntu. Blame the ubuntu team, not me...

The upstream source i use is there:
http://launchpadlibrarian.net/18002791/ekiga_3.0.0.orig.tar.gz

Revision history for this message
Guillaume Desmottes (cassidy) wrote :

That's not the Ubuntu team team which is to blame but the Ekiga one. They didn't follow the GNOME schedule as they didn't release devloppement versions during this cycle so the needed depencies were not packaged and Ekiga 3 was not extensively tested in Intrepid.

Revision history for this message
Martin Pitt (pitti) wrote :

Guillaume Desmottes [2008-10-07 8:33 -0000]:
> That's not the Ubuntu team team which is to blame but the Ekiga one.
> They didn't follow the GNOME schedule as they didn't release
> devloppement versions during this cycle so the needed depencies were not
> packaged and Ekiga 3 was not extensively tested in Intrepid.

I humbly ask to stop this assignment of blame. There was an upstream
beta release earlier on [1]. The simple fact is that we currently have no
Ubuntu developer who "owns" ekiga and keeping it up to date, so it's
really not just upstream's fault.

That the release came very late is an unfortunate timing, but we
cannot expect the world to synchronize to Ubuntu's release cycle.

Martin

[1] http://ftp.gnome.org/pub/gnome/sources/ekiga/2.9/ (September 2)

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Revision history for this message
Yannick Defais (sevmek) wrote :

@Martin Pitt,

You're right, blaming won't improve anything. As I see the situation, Ekiga 3 will not be in intrepid at its release date. I will release soon some packages for Intrepid, Hardy and Gutsy on http://ekiga.net (with the SONAME part). When Ubuntu will include Ekiga 3, I will redirect to those packages.

Best regards,
Yannick

Revision history for this message
Jessie Lawrence (nightwolf177-deactivatedaccount) wrote :

no, ekiga 3 is part of gnome 2.24, and it is part of intrepid's release goals as stated above. after all, its not like they have a choice. if they didnt include ekiga 3 in intrepid, we would be forced to feast on the brains of the living.

Revision history for this message
Stani (stani) wrote :

"Discussion about whether or not to update Ekiga and GIMP took place,
seb128 was s strong proponent of updating both and GIMP is at least
already on his list."
https://lists.ubuntu.com/archives/ubuntu-devel/2008-October/026644.html

Revision history for this message
greenhunter (tierfreunde-hagenburg) wrote :

I am still looking forward for ekiga 3 in intrepid to get ppl away from prop. software, finally.

24 comments hidden view all 104 comments
Revision history for this message
Anakin Starkiller (sunrider) wrote :

Hi Troels, thx for your PPA, but I launch Ekiga in a terminal, i've got this :
"ekiga: symbol lookup error: /usr/lib/libpangocairo-1.0.so.0: undefined symbol: cairo_has_current_point"

Revision history for this message
Anakin Starkiller (sunrider) wrote :

Sorry, the problem came from cairo-dock and glitz (from svn)...nothing to do with ekiga

Revision history for this message
Troels Liebe Bentsen (tlbdk) wrote :

Sure you don't get this bug with other gtk apps?:

https://bugs.launchpad.net/ubuntu/+bug/255660

Regards Troels.

On Fri, Nov 7, 2008 at 9:43 AM, Anakin Starkiller <email address hidden> wrote:
> Hi Troels, thx for your PPA, but I launch Ekiga in a terminal, i've got this :
> "ekiga: symbol lookup error: /usr/lib/libpangocairo-1.0.so.0: undefined symbol: cairo_has_current_point"
>
> --
> Please update Ekiga to 3.00
> https://bugs.launchpad.net/bugs/274085
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "ekiga" source package in Ubuntu: Triaged
> Status in "ekiga" source package in Debian: Unknown
>
> Bug description:
> Binary package hint: ekiga
>
> Ekiga 3.00 has just been released. This is a major update to the current version in the repositories.
>
> * New user interface with a buddy list
> * Accelerated video display (Unix: XVideo, Windows: DirectDraw)
> * Nice incoming call notifications
> * Easier configuration assistant
> * New quality meter in the status bar
> * Buddy list with extended status information
> * Displays network neighbours in the buddy list
> * Better keyboard shortcuts
> * Automatic account completion in the URL bar
> * New chat window
> * New address book supporting Evolution contacts, LDAP contacts and more
> * New account window allowing easier account creation
> * New call panel
>
> http://blog.ekiga.net/?p=97
>
> I don't suppose this justifies a freeze exception for Intrepid as it is installed by default and is in main (even if not that many people use it).
>

Revision history for this message
carloslaunchpad (correiodesportivo) wrote :

hi,

reading this I was able to install ekiga 3 in my new intrepid installation. tanks!

but there's some problems....
can't make the connection. I received this message

"O Ekiga foi incapaz de configurar automaticamente as definições da sua rede. Ainda o pode utilizar, mas terá de configurar as definições de rede manualmente.
Consulte http://wiki.ekiga.org/index.php/Enable_port_forwarding_manually para obter instruções (em inglês)"

it says something like:

Unable to automatic detect your lan configuration. go to http://wiki.ekiga.org/index.php/Enable_port_forwarding_manually for instructions...

I went there but I'm newbie so its not so easy to follow. in the previous version of ekiga this was automatic... ther is a easy way to do this?

an finally, my contacts, i still have the names but not the numbers.

tanks for your help.

Revision history for this message
Anakin Starkiller (sunrider) wrote :

Troels Liebe Bentsen >> thx for the link. that was exactly this bug. Something to do with some cairo-dock dependencies...
Anyway, I have another issue : I can't call <email address hidden> (ekiga SIP account) to make an echo test...it says it is unreachable...

Revision history for this message
Troels Liebe Bentsen (tlbdk) wrote :

It would seem this would be a problem with Ekiga importing your old
settings, so I guess your best option would be filing a bug report
with them. I only packaged it, so I really don't know how it deals
with importing old settings.

But for me it imported my ekiga.net account settings and the one contact I had.

Regards Troels.

On Fri, Nov 7, 2008 at 5:24 PM, carloslaunchpad
<email address hidden> wrote:
> hi,
>
> reading this I was able to install ekiga 3 in my new intrepid
> installation. tanks!
>
> but there's some problems....
> can't make the connection. I received this message
>
> "O Ekiga foi incapaz de configurar automaticamente as definições da sua rede. Ainda o pode utilizar, mas terá de configurar as definições de rede manualmente.
> Consulte http://wiki.ekiga.org/index.php/Enable_port_forwarding_manually para obter instruções (em inglês)"
>
> it says something like:
>
> Unable to automatic detect your lan configuration. go to
> http://wiki.ekiga.org/index.php/Enable_port_forwarding_manually for
> instructions...
>
> I went there but I'm newbie so its not so easy to follow. in the
> previous version of ekiga this was automatic... ther is a easy way to do
> this?
>
> an finally, my contacts, i still have the names but not the numbers.
>
> tanks for your help.
>
> --
> Please update Ekiga to 3.00
> https://bugs.launchpad.net/bugs/274085
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "ekiga" source package in Ubuntu: Triaged
> Status in "ekiga" source package in Debian: Unknown
>
> Bug description:
> Binary package hint: ekiga
>
> Ekiga 3.00 has just been released. This is a major update to the current version in the repositories.
>
> * New user interface with a buddy list
> * Accelerated video display (Unix: XVideo, Windows: DirectDraw)
> * Nice incoming call notifications
> * Easier configuration assistant
> * New quality meter in the status bar
> * Buddy list with extended status information
> * Displays network neighbours in the buddy list
> * Better keyboard shortcuts
> * Automatic account completion in the URL bar
> * New chat window
> * New address book supporting Evolution contacts, LDAP contacts and more
> * New account window allowing easier account creation
> * New call panel
>
> http://blog.ekiga.net/?p=97
>
> I don't suppose this justifies a freeze exception for Intrepid as it is installed by default and is in main (even if not that many people use it).
>

Revision history for this message
Troels Liebe Bentsen (tlbdk) wrote :

I had problems with <email address hidden> also in the start, but for some
reason it is working now. It might just be that the echo test at
ekiga.net just was down because another echo test worked every time:
sip:*<email address hidden>

Regards Troels.

On Fri, Nov 7, 2008 at 6:22 PM, Anakin Starkiller <email address hidden> wrote:
> Troels Liebe Bentsen >> thx for the link. that was exactly this bug. Something to do with some cairo-dock dependencies...
> Anyway, I have another issue : I can't call <email address hidden> (ekiga SIP account) to make an echo test...it says it is unreachable...
>
> --
> Please update Ekiga to 3.00
> https://bugs.launchpad.net/bugs/274085
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "ekiga" source package in Ubuntu: Triaged
> Status in "ekiga" source package in Debian: Unknown
>
> Bug description:
> Binary package hint: ekiga
>
> Ekiga 3.00 has just been released. This is a major update to the current version in the repositories.
>
> * New user interface with a buddy list
> * Accelerated video display (Unix: XVideo, Windows: DirectDraw)
> * Nice incoming call notifications
> * Easier configuration assistant
> * New quality meter in the status bar
> * Buddy list with extended status information
> * Displays network neighbours in the buddy list
> * Better keyboard shortcuts
> * Automatic account completion in the URL bar
> * New chat window
> * New address book supporting Evolution contacts, LDAP contacts and more
> * New account window allowing easier account creation
> * New call panel
>
> http://blog.ekiga.net/?p=97
>
> I don't suppose this justifies a freeze exception for Intrepid as it is installed by default and is in main (even if not that many people use it).
>

Revision history for this message
Anakin Starkiller (sunrider) wrote :

Troels Liebe Bentsen >> yes , now it works like a charm ;) Thx ;)

Revision history for this message
TTcircus (ttcircus-deactivatedaccount) wrote :

So, is there anyone out there who could provide ubuntu newbies like me with an easy step-by-step procedure to install ekiga 3 on intrepid??
Or will I have to wait til the next release in 6 months? That would be a shame... I use ekiga 2 and I could do with the nice 3.0 upgrade, I try and understand what you're talking about here and I'm afraid I just don't get it. And please don't start telling me it's only available for linux experts....
thanks!

Revision history for this message
Troels Liebe Bentsen (tlbdk) wrote :

Hey, you just need to add the ppa repository to your third-party
repositories, then you should be able to install the new ekiga after
that.

Here is instructions:

https://help.ubuntu.com/8.04/add-applications/C/extra-repositories-adding.html

No expertise required, but some reading and time might be.

Regards Troels.

On Tue, Nov 11, 2008 at 12:35 PM, TTcircus <email address hidden> wrote:
> So, is there anyone out there who could provide ubuntu newbies like me with an easy step-by-step procedure to install ekiga 3 on intrepid??
> Or will I have to wait til the next release in 6 months? That would be a shame... I use ekiga 2 and I could do with the nice 3.0 upgrade, I try and understand what you're talking about here and I'm afraid I just don't get it. And please don't start telling me it's only available for linux experts....
> thanks!
>
> --
> Please update Ekiga to 3.00
> https://bugs.launchpad.net/bugs/274085
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "ekiga" source package in Ubuntu: Triaged
> Status in "ekiga" source package in Debian: Unknown
>
> Bug description:
> Binary package hint: ekiga
>
> Ekiga 3.00 has just been released. This is a major update to the current version in the repositories.
>
> * New user interface with a buddy list
> * Accelerated video display (Unix: XVideo, Windows: DirectDraw)
> * Nice incoming call notifications
> * Easier configuration assistant
> * New quality meter in the status bar
> * Buddy list with extended status information
> * Displays network neighbours in the buddy list
> * Better keyboard shortcuts
> * Automatic account completion in the URL bar
> * New chat window
> * New address book supporting Evolution contacts, LDAP contacts and more
> * New account window allowing easier account creation
> * New call panel
>
> http://blog.ekiga.net/?p=97
>
> I don't suppose this justifies a freeze exception for Intrepid as it is installed by default and is in main (even if not that many people use it).
>

Revision history for this message
Alexander Hunziker (alex-hunziker) wrote :

TTcircus,

open System -> Administration -> Software sources. Go to third-party software and click Add... Paste the following line into the box:

deb http://ppa.launchpad.net/tlbdk/ubuntu intrepid main

and click OK. After that, ekiga 3 should be available from within Synaptic Package manager.

For another time: if you need help, please consider getting it in forums/chats. This here is for reporting bugs.

Revision history for this message
TTcircus (ttcircus-deactivatedaccount) wrote :

Thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Revision history for this message
Yannick Defais (sevmek) wrote :

Ekiga 3.0.1 is now in debian:
http://packages.qa.debian.org/e/ekiga.html

Revision history for this message
Martin Pitt (pitti) wrote :

I built the new package ptlib and new opal version from Debian experimental and merged Debian experimental's ekiga package.

However, when I actually tried out 3.0 I was pretty shocked to be honest. It seems to have forgotten all of my 2.x settings: accounts, call history, and it can't even read the SIP contacts out of evolution any more which were written with 2.0. Both 2.x and 3.x use gconf, and the key structure doesn't seem to be that different.

In this state I'm glad that we didn't rush 3.0 into intrepid, it would have been a very unfriendly upgrade. I'm going to file some bugs upstream.

Revision history for this message
Martin Pitt (pitti) wrote :

Also, this seems to have broken my ekiga.net account. I cannot dial any @ekiga.net numbers any more, 500@ (echo test) just stays silent, and other numbers which worked before (such as *<email address hidden>) now just say "user not found".

Revision history for this message
Martin Pitt (pitti) wrote :

My diamondcard account still works, so it's not a problem with the audio settings or something such.

Revision history for this message
Martin Pitt (pitti) wrote :

Upstream bugs:

 * Filed http://bugzilla.gnome.org/show_bug.cgi?id=561180 about the configuration migration issue
 * Confirmed http://bugzilla.gnome.org/show_bug.cgi?id=544210 about ekiga.net echo test not working any more
 * Filed http://bugzilla.gnome.org/show_bug.cgi?id=561182 about the broken provider gateway numbers

So I propose to wait with the update for a bit; probably upstream has some more questions about those bugs, so let's debug them first.

Thanks all, Martin

Revision history for this message
Martin Pitt (pitti) wrote :

The provider gateway numbers have been fixed now at @ekiga.net. I triaged the other bugs, they got responses very fast (great!)

http://bugzilla.gnome.org/show_bug.cgi?id=554402 is another upgrade blocker, though.

Revision history for this message
Savvas Radevic (medigeek) wrote :

There's a new ekiga 3.0 package in debian experimental:
http://packages.debian.org/experimental/ekiga

Revision history for this message
Savvas Radevic (medigeek) wrote :

Sorry, wrong tag

Revision history for this message
Philip Macpherson (philipmac1) wrote :

The new ekiga from your package takes up to 25 seconds to call someone (i.e before the new window loads)

This is from debugging level 1. Tell me if you need a higher level

/12/01 22:49:41.033 2:46.346 ThreadID:0xb3773b90 PWLib Destroyed thread 0x8de1270 dialer:0xb3773b90(id = 0)
 2008/12/01 22:50:21.939 3:27.252 Aggregator:0xb55beb90 ALSA Device plughw:1 Opened
2008/12/01 22:50:21.954 3:27.267 Aggregator:0xb55beb90 Media Clamping RTP media stream data size from 33 to minimum 2048
2008/12/01 22:50:21.963 3:27.276 Aggregator:0xb55beb90 ALSA Device plughw:1 Opened
2008/12/01 22:50:21.978 3:27.291 Aggregator:0xb55beb90 Media Clamping RTP media stream data size from 33 to minimum 528

Martin Pitt (pitti)
Changed in ekiga:
assignee: nobody → pitti
status: Triaged → In Progress
Revision history for this message
Eugen Dedu (eugen-dedu) wrote :

Martin Pitt wrote:
> ** Changed in: ekiga (Ubuntu)
> Assignee: (unassigned) => Martin Pitt (pitti)
> Status: Triaged => In Progress

Martin, if you update ekiga, please take the stable snapshot from today
(or later), the following fix is important in my opinion:

2008-12-07 15:19 dsandras

         * ChangeLog, src/gui/assistant.cpp, src/gui/conf.cpp,
           src/gui/main.cpp: Do not show the assistant after an upgrade for
           which Ekiga was already
           successfully setup.
           Correctly migrate audio & video devices settings, as well as the
           full
           name and the ekiga.net / diamondcard settings. (#561180)

--
Eugen

Revision history for this message
Martin Pitt (pitti) wrote :

Hi Eugen,

Eugen Dedu [2008-12-07 19:19 -0000]:
> Martin, if you update ekiga, please take the stable snapshot from today
> (or later), the following fix is important in my opinion:
>
> 2008-12-07 15:19 dsandras
>
> * ChangeLog, src/gui/assistant.cpp, src/gui/conf.cpp,
> src/gui/main.cpp: Do not show the assistant after an upgrade for
> which Ekiga was already
> successfully setup.
> Correctly migrate audio & video devices settings, as well as the
> full
> name and the ekiga.net / diamondcard settings. (#561180)

Sure, that was exactly the patch I was waiting for :-) I integrated
it.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ekiga - 3.0.1-1ubuntu1

---------------
ekiga (3.0.1-1ubuntu1) jaunty; urgency=low

  * Merge to Debian experimental, to get Ekiga 3. (LP: #274085) Remaining
    Ubuntu changes:
    - Launchpad Integration: (Ubuntu specific)
      + debian/control.in: Add liblaunchpad-integration-dev build dependency.
      + Add ubuntu_lpi.patch: Call launchpad_integration_add_items() in main() and
        check for the launchpad-integration pkg-config module.
      + Add autoconf.patch: autoconf changes from above patch.
    - Add ubuntu_desktop-file-onlyshowin.patch: Show ekiga in Mobile, too.
      (Ubuntu specific).
    - debian/control.in: Add missing fdupes build dependency for identical
      GNOME help file symlinking. (Debian #505536)
  * Drop 42_change_pixmaps.dpatch: Many of the old icons do not exist any
    more, some have been replaced, and keeping the remaining three would make
    them look very inconsistent.
  * Convert our dpatches to quilt patches and rewrite them for new upstream
    version.
  * Add migrate_2.0_settings.patch: Properly migrate settings from
    2.0. Taken from upstream SVN, thanks to Damien Sandras!

ekiga (3.0.1-1) experimental; urgency=low

  [ Eugen Dedu ]
  * New version. (Closes: #500089).
  * Add our own changelog file in /usr/share/doc.
  * Remove gnomemeeting transitional package.
  * Discover new interfaces. (Closes: #488199).
  * Compile with dbus support. (Closes: #467212).
  * Numeric keypad inserts digits at correct position. (Closes: #440159).
  * Use libnotify upon call. (Closes: #412604).
  * Symlink identical GNOME help files, to reduce size. (Closes: #505536).
  * Explicitely build-depends on a few dev packages, even if they were
    pulled out anyway by the other dependencies.

  [ Loic Minier ]
  * Use clean:: instead of clean: in rules.
  * Don't disable Uploaders: generation for control.in -> control generation
    in rules.
  * Fix some tabs which were size 4 anyway.
  * Generate a PO template during build by calling intltool-update -p in
    install; thanks Ubuntu and Martin Pitt; closes: #505535.
  * Also let the -dbg depend on ${misc:Depends}.
  * Cleanup rules; in particular, use dpkg-parsechangelog and honor
    distclean/clean failures, remove old clean rules, commented out stuff,
    gtk-only stuff.
  * Pass -s to dh_* in binary-arch.
  * Use debian/*.links and debian/*.manpages instead of symlink manually or
    passing files to dh_installman.
  * Use ftp.gnome.org in copyright.
  * Switch to quilt and fix target deps in the process; build-dep on quilt
    instead of dpatch; rename news.dpatch to 00_news.patch and refresh;
    replace 00list with series.
  * Install autotools-dev config.guess and .sub after patching.

 -- Martin Pitt <email address hidden> Sun, 07 Dec 2008 10:30:45 -0800

Changed in ekiga:
status: In Progress → Fix Released
Revision history for this message
Yannick Defais (sevmek) wrote :

Hello,

Thank you Martin Pitt. It is the first time I see some QA work on Ekiga. That's very nice from you :D

Best regards,
Yannick

Revision history for this message
Piotr Morgwai Kotarbiński (morgwai) wrote :

any chance to see ekiga-3 in intrepid backports?

Thanks

  Morg

Revision history for this message
Martin Pitt (pitti) wrote :

A backport requires ptlib, opal, and ekiga. I personally updated the ekiga package on intrepid, worked fine. Added backports task to get ack'ed by backporter's team.

Revision history for this message
Piotr Morgwai Kotarbiński (morgwai) wrote :

I did it too, but it was quite problematic: ekiga depends also on libpt-plugins-alsa and the corresponding version of libpt-plugins-alsa depends on newer version of libasound (1.0.18) than the one currently available in intrepid repositories. After I upgraded it most applications were unable to play any sound. Updating pulse to verision (also not available for intrepid) solved this problem.

The main problem however is the fact that after all those upgrades ekiga crashes when I try to make a call ;]

Thanks

  Morg

Revision history for this message
Daniel Swarbrick (pressureman) wrote :

Any chance of getting 3.10 in Jaunty? CELT and G.722 support has been added.

http://mail.gnome.org/archives/ekiga-devel-list/2009-January/msg00052.html

Since Empathy seems to always crash when calling GTalk buddies, Ekiga (on Windows too) looks like a possible alternative.

Revision history for this message
Onkar Shinde (onkarshinde) wrote :

@Daniel,

The announcement mentions that it is a beta release. So I don't think there is any point in updating to 3.10 just now.

And now that this bug is marked fix released please log a new bug for any new upstream version.

Revision history for this message
Yannick Defais (sevmek) wrote :

Hello,

@Daniel,
3.1 is indeed a BETA, it was released to follow the Gnome agenda. The plan is to release a stable version for next stable release of Gnome. The BETA is there for testing purpose and to help packagers...

You are right to point out the new audio codecs; Ekiga reached now CD quality for audio :)

Best regards,
Yannick

Revision history for this message
bojo42 (bojo42) wrote :

@Onkar: Wasn't that the problem with intrepid and Ekiga 3.0, that there where no testing packages included from the beginning?

@backporters: I can confirm that backporting the jaunty packages to intrepid with prevu worked fine.

BTW: Ekiga 3.0.2 is out, would be great to update the packages before backporting :) Here is the list of changes:

    * Make sure sound events are played through the correct devices.(#564370)
    * Fixed crash on missed call.
    * Do not show the assistant after an upgrade for which Ekiga was alreadysuccessfully setup.
    * Added settings migration from Ekiga 2.0.x.
    * Allow answering/rejecting calls from the main window even if we use notifications.
    * Do not try refreshing SUBSCRIBE requests for which the 200 OK contains an expire time of 0.
    * Fixed sending ACK request to incorrect address when particular types of proxies are being used.
    * Fixed test for CANCEL receipt on INVITE clearing call.
    * Ignore multiple forked CANCEL messages.
    * Fixed issue with registration to a non-standard port.
    * Fixed restarting timers if get pathological response to a transaction with incorrect Cseq header field.
    * Fixed missing route set on SIP commands in a dialog when using outbound proxy.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

Tryed ekiga 3.0 from ppa on intrepid and it more or less work. Is there a problem with ekiga.net server ? Most of the time, I cannoct connect (also tried with another account on another computer : same problem)

Revision history for this message
Eugen Dedu (eugen-dedu) wrote :

Lionel Dricot wrote:
> Tryed ekiga 3.0 from ppa on intrepid and it more or less work. Is there
> a problem with ekiga.net server ? Most of the time, I cannoct connect
> (also tried with another account on another computer : same problem)

If there are problems with ekiga, please send e-mail to ekiga mailing
list or create a bug in ekiga.

--
Eugen Dedu

Revision history for this message
Dmytro Korzhevin (korg) wrote :

Hello!

Please, tell me, if Ekiga 3.0.2 will be avaible for Ubuntu 9.04?

Revision history for this message
William King (quentusrex) wrote :

Has there been an update on this issue? I believe that ekiga will be in 9.04, but has the backport made any progress? Also what about the medibuntu issue?

What is the currently maintained way to install? Both PPA's seem to be out of date. Since 3.0.2 released...

Revision history for this message
bojo42 (bojo42) wrote :

@quentusrex: if you want Ekiga 3.0 on intrepid right now, you can use prevu with the jaunty packages. but you have to "prevu" ptlib, then opal and finally ekiga as pitti said. for more information see https://wiki.ubuntu.com/Prevu . regarding the medibuntu issue, i asume you mean the non free plugins of ekiga and yes currently you won't find them ubuntu. so no h264 and ilbc as available codecs for now, but i filed a bugreport against that see https://bugs.launchpad.net/ubuntu/+source/opal/+bug/316971 .

Revision history for this message
legege (legege-legege) wrote :

How can we get H263-1998 codec with the tlbdk PPA?

Changed in ekiga:
status: Unknown → Fix Released
Changed in ekiga (Ubuntu):
assignee: pitti → nobody
Revision history for this message
Cosme Domínguez (cosme) wrote :
Changed in intrepid-backports:
status: New → Invalid
Revision history for this message
Yury V. Zaytsev (zyv) wrote :

Hi folks!

I am tired of waiting, so I backported latest Ekiga 3.2.6 to Hardy myself:

https://launchpad.net/~zyv/+archive/ppa

Packages that I had to backport specifically:

ekiga 3.2.6-1ubuntu2~hardy1~ppa4
libdc1394-22 2.1.2-2ubuntu1~hardy1~ppa1
libraw1394 2.0.4-1ubuntu3~hardy1~ppa1
libusb-1.0 2:1.0.6-1ubuntu1~hardy1~ppa1
libv4l 0.6.4-1ubuntu2~hardy1~ppa1
opal 3.6.6~dfsg-4ubuntu2~hardy1~ppa1
ptlib 2.6.5-1ubuntu2~hardy1~ppa1
speex 1.2~rc1-1ubuntu2~hardy1~ppa1

Please be mindful of the fact, that I have a lot of other backports in my PPA that I need personally, so don't unwillingly screw up your system by blindly upgrading everything you can find.

Սահակ (petrosyan)
Changed in hardy-backports:
status: New → Invalid
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.