gwibber-service crashed with error in connect()

Bug #522538 reported by Vish on 2010-02-16
This bug affects 726 people
Affects Status Importance Assigned to Milestone
desktopcouch
High
Chad Miller
desktopcouch (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: gwibber

Crashed when system was doing a routine daily update. [aparmor update? ]

ProblemType: Crash
Architecture: i386
CheckboxSubmission: 417990aadff2335cd485c57bb06c8968
CheckboxSystem: 5484a8dd99f006173bd2ac53fa4837c2
Date: Tue Feb 16 10:16:16 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
InterpreterPath: /usr/bin/python2.6
Package: gwibber-service 2.29.1-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with error in connect()
Uname: Linux 2.6.32-13-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Vish (vish) wrote :
tags: removed: need-duplicate-check
Vish (vish) on 2010-02-16
visibility: private → public
Victor Vargas (kamus) wrote :

I tried to reproduce this issue in a fully updated Lucid with gwibber 2.29.90-1 but works fine for me. Please could you try to reproduce this issue in latest version of gwibber included in Lucid? Thanks!

Changed in gwibber (Ubuntu):
status: New → Incomplete
Oded Arbel (oded-geek) wrote :

I just had this crash on a Lucid Alpha 3

Vish (vish) wrote :

I'm no longer facing this bug. IMO , It can be marked as fixed.

However , since the earlier comment 3 mentions the crash still happening. I'm setting this to new.

Changed in gwibber (Ubuntu):
status: Incomplete → New
Haggai Eran (haggai-eran) wrote :

I just had this crash on an updated lucid. (gwibber version 2.29.90.1-0ubuntu2).
I got the error when network manager was still connecting to the network.

Benjamin Humphrey (humphreybc) wrote :

Same problem here.

Lazaro Alejo (habanany) wrote :

No se .

Same problem when emerging from hibernation

Victor Vargas (kamus) wrote :

Please could you upgrade to latest version of gwibber (2.29.92) and check if this problem is still affecting you? Thanks!

Changed in gwibber (Ubuntu):
status: New → Incomplete
Vish (vish) wrote :

Seems to be working fine with latest gwibber, Gwibber 2.29.92.1
If anyone is noticing the bug , do report back .

Changed in gwibber (Ubuntu):
status: Incomplete → Fix Released

I can't report what caused this error, the apport message was on my screen when I returned from work.

Alwin Garside (yogarine) wrote :

Just also got this while starting up Gwibber 2.29.92.1-0ubuntu1

I also got this issue just done update before hand

taz (mxonetaz) wrote :

I have this problem when waking the computer from stand-by

Tenoch (mignonmexicain) wrote :

I send the computer to hibernate then when i woke up the computer the crashed happened.

Dave-B (david-balch) wrote :

I have gwibber-service 2.29.92.1-0ubuntu1, and noticed the apport icon, so submitted the report.

Changed in gwibber (Ubuntu):
status: Fix Released → New
Sjors Gielen (sgielen) wrote :

Same thing happened here: I returned from hibernation on a fully updated Ubuntu Lucid on MacBook Pro, and I got a popup that Gwibber had crashed.

Also getting this on 2.29.92-1, both gwibber-service and gwibber itself are broken and won't start up without crashing.

Changed in gwibber (Ubuntu):
assignee: nobody → raphael (raphael-jacomelle)
ablack (blackhand08) wrote :

After hibernating the program crashes every time i launch it.

José A. Muñiz (josemuniznyc) wrote :

Same problem when emerging from hibernation. Every... Single... Time...

José A. Muñiz (josemuniznyc) wrote :

Crap. I hit post before finishing! That should teach me about being snarky.

I'm on 2.29.92.1 and get a crash on gwibber after every hibernation and most sleeps. Also after closing the program, I often (maybe a tad more than 50% of the time) get a crash upon restarting the program from the Apps menu.

Vish (vish) wrote :

Unassigning Raphael as it seems like an accidental assign.

Confirming from the several "me too" replies.

Changed in gwibber (Ubuntu):
assignee: raphael (raphael-jacomelle) → nobody
status: New → Confirmed
tags: added: bugpattern-needed
Dan Dart (dandart) wrote :

Yep, AppArmor update time for me too.

kushalhada (kushalhada) wrote :

Ubuntu Software Center froze and I chose to wait just before Gwibber crashed with this error message for me a few minutes ago.

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
Matthew Horr (matthorr) wrote :

This happens to me when waking from suspend (Lucid and gwibber 2.29.92.2-0ubuntu1) on MacBook Pro 1,1. I am unable to restart gwibber after the crash.

Mynk (mr-mynk) wrote :

I had hibernated the laptop with the gwibber window up. When I switched on the laptop I got the message. This should be the latest version of gwibber.

Josh Anders (cybiko123) wrote :

Crashed when switching from wlan0 to eth0.

has (henrik-a-schultz) wrote :

This bug appears when coming out of suspend.
Maybe connected to the issues I'm having with the network manager / wifi - internet sometimes is unreachable.

#28, yeap. Just happened to me too.

Les Pounder (lespounder) wrote :

Also happens with AMD64 (64bit) version of Ubuntu 10.04 Beta 1

kikl (kilian-klaiber) wrote :

Same problem when emerging from hibernation

Shwan (shwan-ciyako) wrote :

same here , "This bug appears when coming out of suspend."

Same. When coming out of standby mode

Please excuse the brevity, sent from an Android mobile device.

On Mar 29, 2010 12:21 PM, "Shwan" <email address hidden> wrote:

same here , "This bug appears when coming out of suspend."

--
gwibber-service crashed with error in connect()
https://bugs.launchpad.net/bugs/522538
You rece...

viktor (lfraisse) wrote :

Crash occured on resuming the session (after suspending for 1 hour).

Up-to-date Lucid beta1 - amd64.

Tim Medcalf (tim-medcalf) wrote :

Same here. Resuming from hibernate consistently results in Gwibber crash alert.

Dell Studio XPS 16
2.6.32-18-generic 64bit

Gavin Chappell (g-a-c) wrote :

Here also after resuming from hibernation and on wireless (so could be related to NetworkManager not connecting quickly enough?). I haven't tried with a staticised eth0 configuration and a cable plugged in to see if "removing" NM from the equation improves things at all.

Toshiba Portege A600, fully updated Lucid (dist-upgraded from Karmic to Lucid Alpha 2) 2.6.32-18-generic #27-Ubuntu SMP Fri Mar 26 21:13:44 UTC 2010 x86_64

Pedro Villavicencio (pedro) wrote :

I'm getting the same crash here, Ken , may you please have a look ? Thanks.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: Confirmed → Triaged
DFOXpro (dfoxpro) wrote :

guigui14100 wrote on 2010-03-11: #8
Same problem when emerging from hibernation

me ++

Adam (adam-jackman) wrote :

happened to me on returning from hibernation.

kromeclutch (kromeclutch) wrote :

I got this error after coming out of 'suspend.'

tags: added: bugpattern-written
removed: bugpattern-needed
Changed in gwibber (Ubuntu):
status: Triaged → Confirmed
importance: Medium → High
affects: gwibber (Ubuntu) → desktopcouch (Ubuntu)
affects: gwibber → desktopcouch
Changed in desktopcouch:
importance: Undecided → High
status: New → Fix Committed
Changed in desktopcouch (Ubuntu):
status: Confirmed → Fix Committed
Changed in desktopcouch (Ubuntu):
status: Fix Committed → Fix Released
sam tygier (samtygier) on 2010-04-26
Changed in desktopcouch (Ubuntu):
status: Fix Released → Confirmed
Chad Miller (cmiller) on 2010-04-27
Changed in desktopcouch:
status: Fix Committed → In Progress
38 comments hidden view all 118 comments
Elie M. (elie-md) wrote :

well I'm sorry to tell u I have 0.6.4-0ubuntu3 and still the bug isnt fixed as yet, it still occurs to me as I pasted in:

https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/534941

so nothing's fixed yet. either something else is causing me this or the fix isnt working everywhere. thx and thx for further help if I'm wrong, but I'm sure I have 0.6.4-0ubuntu3 of desktopcouch, python-desktopcouch-records, python-desktopcouche.

Thor Arne Kolberg (tagreblok) wrote :

Also running 0.6.4-0ubuntu3, not fixed.
Bug 575461 was submittet after the bug should have been fixed by desktopcouch update.

Jeremy Bicha (jbicha) wrote :

I reported this as bug 577196 which was marked as a duplicate of this one. Gwibber works fine for me in GNOME but not in KDE.

Omer Akram (om26er) wrote :

If I build desktopcouch with the proposed branch gwibber does not start on my system (works fine in normal conditions).

ciaron (ciaron-linstead) wrote :

I can confirm I'm still seeing this bug with gwibber 2.30.0.1-0ubuntu1 and desktopcouch 0.6.4-0ubuntu3.

When I try to start the Gwibber client, I see the following in ~/.cache/gwibber/gwibber.log:

2010-05-16 23:02:40,806 - Gwibber GNOME Client - INFO - Running from the system path
2010-05-16 23:02:41,164 - Gwibber Dispatcher - ERROR - Failed to raise client (DBusException(dbus.String(u'Message did not receive a reply (timeout by message bus)'),),)

ciaron (ciaron-linstead) wrote :

I should say by "this bug" I mean that the Gwibber client won't restart after a suspend.

If I kill gwibber-service and restart Gwibber from the Me Menu, it works, until the next suspend.

Brendan_P (brendan-p) wrote :

Can confirm this behaviour after resume from suspend.

naranco (naranco) wrote :

confirmed on an up to date ubuntu lucid system.

levu (levu) wrote :

i have got a workaround: kill the gwibber-service and than restart gwibber. After resume, gwibber-service should reconnect. I can't find out who is responsible for this bug, so i can't give him this notice.
I have no diff because i can't yet code python.
-- levu

Omer Akram (om26er) wrote :

I have build desktopcouch with the proposed fix to this bug report. Apparently there are no regressions but also I never faced this crash before. Can any one facing this issue please try the following and see if the crash stops

$ sudo add-apt-repository ppa:om26er/test ;sudo apt-get update ;sudo apt-get upgrade

If it works then great but if you face any other problem you can downgrade by disabling the ppa and then

$ sudo apt-get install desktopcouch/lucid desktopcouch-tools/lucid python-desktopcouch/lucid python-desktopcouch-records/lucid

Omer Akram (om26er) wrote :

I take my words back. The crash still occurs, this time I reproduced it.

robbie (roberto-tomas-cuentas) wrote :

kitallis tells me he has the same problem as https://bugs.edge.launchpad.net/gwibber/+bug/523964 - which is marked as duplicate of this problem. I had him run python -d gwibber and he gets this ewrror log http://pastie.org/private/bzlwxgrvth1mx6r2mzdkqg
-- there's a connection refuse error that is causing the socket object not to be set up .. then it passes a nul object and falls next the tipical error:
  File "/usr/lib/python2.6/httplib.py", line 330, in __init__
    self.fp = sock.makefile('rb', 0)
AttributeError: 'NoneType' object has no attribute 'makefile'

As I said in an other bug report [1], it seems like the couchdb service may go away for some reason (going to sleep seems to trigger this sometimes) and come back listening on a different port. Some debugging in gwibber-service let us see that its desktopcouch.records.server instance still holds the original port number (<OAuthCapableServer 'http://localhost:33312'>).

This means that simply trying to reconnect to the server won't work ; the server is no longer listening on this port. I don't know the internals of desktopcouch well enough to know at which level it should be best to drop the reference to the old server url and get a new one.

[1] https://bugs.edge.launchpad.net/gwibber/+bug/523964/comments/32

Thor Arne Kolberg (tagreblok) wrote :

My problem turned out to bee easy to fix.
Gwibber crashed upon startup, no service to stop.

I had disabled password at login to Ubuntu. Once I enabled it, Gwibber was working totally fine.

Assid (assid) wrote :

Im still facing issues on this. Im not going to pastebin the error since it seems everyone else has already done that. I am curious tho, shouldnt this have been fixed before it going stable?

I have always had a password on my account, so im not sure its the same as what @thor faced

joe155 (joe-r-155) wrote :

I can second Assid's comment - still get the problem. It momentarily went away, and wasn't around when I first installed, but now I can't get it to work. I've always had a password on my account.

Could it be caused by something like couchDB?

Ryan Fugger (rfugger) wrote :

This seems to be related to the bug in httplib2 here:

http://code.google.com/p/httplib2/issues/detail?id=62

See also launchpad bug #523327.

heynnema (heynnema) wrote :

Sorry to whine... but as important as Gwibber was to the Lucid release, I can't believe that this Gwibber crash at wake from resume bug hasn't been nailed yet. It happens EVERY time my laptop wakes from sleep. SUDO /ETC/INIT.D/WHINING STOP. Giggle.

YannUbuntu (yannubuntu) wrote :

As it is not mentionned in the original report, I add that i just had this bug when waking up from sleep (like heynnema #96). On an updated Lucid 32bits, Nec LL550/H.

Gary Walker (gewalker) wrote :
Download full text (3.4 KiB)

Same bug here. Running Lucid Netbook Ed. on Acer AOD250. No whining. I have to say that I'm generally thrilled with the caliber of product coming out of Ubuntu these days. Hope this helps. Feel free to ping me for additional info or testing.

gary@meatwad:~$ gwibber

** (gwibber:15730): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (gwibber:15730): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (gwibber:15730): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 67, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 447, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 41, in __init__
    if len(json.loads(self.service.GetAccounts())) == 0:
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 491, in GetAccounts
    for account in self.accounts.get_records(COUCH_TYPE_ACCOUNT, True):
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 482, in get_records
    exists = self.view_exists(view_name, design_doc)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 429, in view_exists
    self.with_reconnects(self.db.__getitem__, doc_id)["views"]
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 168, in with_reconnects
    self._reconnect()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 176, in _reconnect
    if self._database_name not in self._server:
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 124, in __contains__
    self.resource.head(validate_dbname(name))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 981, in head
    return self._request('HEAD', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 1129, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 901, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 871, in _conn_request
    respo...

Read more...

Download full text (3.2 KiB)

Same here:

$ gwibber

** (gwibber:13258): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (gwibber:13258): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (gwibber:13258): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 67, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 447, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 41, in __init__
    if len(json.loads(self.service.GetAccounts())) == 0:
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 491, in GetAccounts
    for account in self.accounts.get_records(COUCH_TYPE_ACCOUNT, True):
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 482, in get_records
    exists = self.view_exists(view_name, design_doc)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 429, in view_exists
    self.with_reconnects(self.db.__getitem__, doc_id)["views"]
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 168, in with_reconnects
    self._reconnect()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 176, in _reconnect
    if self._database_name not in self._server:
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 124, in __contains__
    self.resource.head(validate_dbname(name))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 981, in head
    return self._request('HEAD', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 1129, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 901, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 871, in _conn_request
    response = conn.getresponse()
  File "/usr/lib/python2.6/httplib.py", line 984, in getresponse
    method=self._method)
  File "/usr/lib/python2.6/httplib.py", line 330, in __init__
    self.fp = sock.makefile('rb', 0)
AttributeError: 'NoneType' object ha...

Read more...

Galvao (er.galvao) wrote :

I'm assuming it's the same bug, but just to play safe, if I try running gwibber from shell I get this (Kubuntu 10.04 here):

zaphod@magrathea:~$ gwibber

** (gwibber:11092): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (gwibber:11092): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (gwibber:11092): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 67, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 447, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 29, in __init__
    self.model = gwui.Model()
  File "/usr/lib/python2.6/dist-packages/gwibber/gwui.py", line 42, in __init__
    self.settings = util.SettingsMonitor()
  File "/usr/lib/python2.6/dist-packages/gwibber/util.py", line 91, in __init__
    DEFAULT_SETTINGS)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/util/couch.py", line 66, in __init__
    self.database = CouchDatabase(dbname, create=True)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server.py", line 57, in __init__
    server_class=server_class, oauth_tokens=oauth_tokens, ctx=ctx)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 152, in __init__
    self._reconnect()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 176, in _reconnect
    if self._database_name not in self._server:
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 124, in __contains__
    self.resource.head(validate_dbname(name))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 981, in head
    return self._request('HEAD', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 1129, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 901, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 871, in _conn_request
    response = conn.getresponse()
  File "/usr/lib/python2.6/httplib.py", line 984, in getresponse
    method=self._method)
  File "/usr/lib/python2.6/httplib.py", line 330, in __init__
    self.fp = sock.makefile('rb', 0)
AttributeError: 'NoneType' object has no attribute 'makefile'
zaphod@magrathea:~$

The content of desktop-couchdb.stderr.* when gwibber-service stops working properly:

heart_beat_kill_pid = 2954
heart_beat_timeout = 11
heart: Thu Jun 24 10:19:32 2010: Erlang has closed.^M
Segmentation fault
heart: Thu Jun 24 10:19:34 2010: Executed "/usr/bin/couchdb -k". Terminating.^M

Traceback from gwibber-service is:

  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 540, in refresh
    operations = list(self.collector.get_operations())
  [...]
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 750, in connect
    raise socket.error, msg
socket.error: [Errno 111] Connexion refusée

If I relaunch gwibber, I get the following log message from gwibber-service. This comes from the patch of bug #539674 :

WARNING:root:DB connection timed out. Reconnecting.

My understanding so far:
  - couchdb/desktopcouch server crashes for some unknown reason.
  - gwibber-service tries to connect to desktopcouch.
    - This probably launches a new instance of couchdb/desktopcouch via DBus, but on a different port.
    - httplib2 fails to connect to the couchdb server because the couchdb client still holds the url of the crashed server.
    - The new httplib2 raises socket.error instead of AttributeError, so there is no reconnect.
  - gwibber is launched, which cause the same problem, but httplib2 raises AttributeError (?).
    - The gwibber service tries to reconnect, but it fails for the same reason.

I can improve things with the following (crude) code appended to desktopcouch/records/server.py, but gwibber will still crash by not handling exceptions in other cases :

    def get_records(self, record_type=None, create_view=False,
             design_doc=None):
        try:
            return super(CouchDatabase, self).get_records(record_type, create_view, design_doc)
        except:
            print "*** lp522538 ***"
            print "old uri: %s" % self.server_uri
            # Find the new port on which couchdb is listening.
            port = desktopcouch.find_port(ctx=self._server_class_extras["ctx"])
            self.server_uri = "http://localhost:%s" % port
            print "new uri: %s" % self.server_uri
            self._reconnect()
            return super(CouchDatabase, self).get_records(record_type, create_view, design_doc)

gsiliceo (nombre-falso) wrote :

getting this bug also, out of the box in lucid

tulskiy (tulskiy) wrote :

Still getting this bug. As a temporary fix, could someone tell me how to restart gwibber-service on resume from sleep?

Omer Akram (om26er) wrote :

@Chad Miller, these logs http://launchpadlibrarian.net/49543529/gwibber.txt might be useful

Changed in desktopcouch:
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) wrote :

I have a patch for desktopcouch, but I can't decide on the best way to handle this down.

desktopcouch is a thin wrapper around python-couchdb, and in creating and using views, client programs access and use python-couchdb functions directly. Here's one problem I can't fix inside desktopcouch without adding a layer between them.

dbus.exceptions.DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 413, in Refresh
    self.refresh()
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 558, in refresh
    operations = list(self.collector.get_operations())
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 169, in get_operations
    for o in self.account_to_operations(acct):
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 149, in account_to_operations
    args = self.handle_max_id(acct, opname)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 118, in handle_max_id
    result = view[[id, opname]][[id, opname]].rows
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 893, in rows
    self._fetch()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 881, in _fetch
    data = self.view._exec(self.options)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 766, in _exec
    resp, data = self.resource.get(**self._encode_options(options))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 978, in get
    return self._request('GET', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/python2.6/dist-packages/httplib2/__init__.py", line 1129, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/python2.6/dist-packages/httplib2/__init__.py", line 901, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/python2.6/dist-packages/httplib2/__init__.py", line 871, in _conn_request
    response = conn.getresponse()
  File "/usr/lib/python2.6/httplib.py", line 988, in getresponse
    method=self._method)
  File "/usr/lib/python2.6/httplib.py", line 330, in __init__
    self.fp = sock.makefile('rb', 0)
AttributeError: 'NoneType' object has no attribute 'makefile'

Note, no "desktopcouch" in there. :(

I'll post what I have that re-connects CouchDatabase objects, but views are harder to fix.

Omer Akram (om26er) wrote :

any chances for a Lucid fix?

Braiam Peguero (braiampe) wrote :

Me too. On lucid 10.04.1, from hibernation status, but a difference that all my app's and service crash, the X server restart after the wake up, the system became unstable and I restart.

rebecacaca (rsdavies) wrote :

I found a hint for a solution here:
https://bugs.launchpad.net/ubuntu/+source/python-httplib2/+bug/523327

Check your /etc/hosts file has the following:

127.0.0.1 localhost
127.0.1.1 computer name

Mine had "username-laptop" where it should have had "computer name". After changing this it works perfectly.

murrayf (murrayf07) wrote :

  ... I'm not sure...

On 16/08/10 06:18, rebecacaca wrote:
> I found a hint for a solution here:
> https://bugs.launchpad.net/ubuntu/+source/python-httplib2/+bug/523327
>
> Check your /etc/hosts file has the following:
>
> 127.0.0.1 localhost
> 127.0.1.1 computer name
>
> Mine had "username-laptop" where it should have had "computer name".
> After changing this it works perfectly.
>

I can't believe that one of the key features of 10.04 still isn't working...

After all it is "social from the start"

Omer Akram (om26er) wrote :

There are atleast 3 duplicates to this bug per weak. if anyone suspends and resumes he can't start gwibber without killing the service. I would have prepared a ppa but apparently the branch linked to this bug report does not apply to desktopcouch 0.6.4 source.

Changed in desktopcouch (Ubuntu):
milestone: none → ubuntu-10.10
Martin Schaaf (mascha) wrote :

This bug affects also gwibber version 2.30.2-0ubuntu1.

Stuart Bishop (stub) wrote :

Gwibber in Lucid is pretty much unusable due to this bug. A work around is to install the Gwibber packages from Maverick, which is working just fine here. The Maverick packages do not use desktop-couch. Keeping the Maverick packages up to date is an exercise for the reader as I don't think the stable 2.31 releases exist in a PPA.

tags: added: desktop+ u1-lucid-sru u1-maverick
Changed in desktopcouch:
status: In Progress → Fix Committed
Ken VanDine (ken-vandine) wrote :

I marked this as fixed released in Maverick, we think the work around in 0.6.6-0ubuntu3 has been working.

Changed in desktopcouch (Ubuntu Maverick):
status: Confirmed → Fix Released
Sohail Mirza (mirzmaster) wrote :

Has this bug been fixed in Maverick? I still encounter this bug virtually every time I come out of standby on my laptop (which is multiple times a day). I am running the Maverick beta with the following package versions:

gwibber 2.31.94-0ubuntu1
gwibber-service 2.31.94-0ubuntu1
libgwibber0 0.0.6-0ubuntu1
desktopcouch 0.6.8-0ubuntu1

If further log information is required, I would appreciate some direction on how I can go about capturing logs.

tags: removed: u1-maverick
Chad Miller (cmiller) on 2010-10-08
Changed in desktopcouch:
status: Fix Committed → Fix Released
Changed in desktopcouch (Ubuntu Lucid):
status: New → Triaged
milestone: none → ubuntu-10.04.2
importance: Undecided → High
1 comments hidden view all 118 comments
Martin Pitt (pitti) wrote :

Lucid 10.04.2 is already deeply frozen, so moving milestone.

Changed in desktopcouch (Ubuntu Lucid):
milestone: ubuntu-10.04.2 → ubuntu-10.04.3
assignee: nobody → Ken VanDine (ken-vandine)
Changed in desktopcouch (Ubuntu Lucid):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in desktopcouch (Ubuntu Maverick):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in desktopcouch (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Redsandro (redsandro) wrote :

Confirmed on Ubuntu 10.04.2 LTS with Gwibber 2.30.3-0ubuntu2
Workaround:
sudo killall -9 gwibber-service && gwibber &

Adolfo Jayme (fitojb) on 2014-10-18
no longer affects: desktopcouch (Ubuntu Lucid)
Displaying first 40 and last 40 comments. View all 118 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.