Ubuntu

Desktop-effect does not enable cube

Reported by mariano.iannuzzi on 2007-03-05
104
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Alexandre Vassalotti
desktop-effects (Ubuntu)
Medium
Travis Watkins

Bug Description

Binary package hint: desktop-effects

I ran desktop-effects and had all the nice compiz effects working but the cube and cube rotation. Looking at the compiz settings I found that the cube and rotation effects were enable, but they were not working (even after restarting the PC)

Running this command (as suggested in Ubuntu Forums) fixed the problem:

gconftool-2 --type int --set /apps/compiz/general/screen0/options/hsize 4
gconftool-2 --type int --set /apps/compiz/general/screen0/options/number_of_desktops 1

Thanks!

Marianoi

Changed in desktop-effects:
assignee: nobody → avassalotti
status: Unconfirmed → In Progress

Change the package to Compiz, as this bug is directly related to it.

Sebastien Bacher (seb128) wrote :

That not a bug. The cube effect has no real use and it's breaking the workspace switcher, we did that change on purpose to make the interface coherent with GNOME

Hello,

Thanks. But in Desktop-Effects there is an option saying "shown
desktop in a cube" or something like that (I am at work now do not
have my Ubuntu box with me, sorry). What does that option mean? I'd
believe it is sort of confusing...

Thanks again for the hard work

Cheers

Mariano

On 3/5/07, Sebastien Bacher <email address hidden> wrote:
> That not a bug. The cube effect has no real use and it's breaking the
> workspace switcher, we did that change on purpose to make the interface
> coherent with GNOME
>
> --
> Desktop-effect does not enable cube
> https://launchpad.net/bugs/89786
>

Emilio Pozuelo Monfort (pochu) wrote :

That is because desktop-effects enables it in compiz, but it doesn't work in compiz, not in desktop-effects.

Hello,

Thanks!!

So, it is a bug then? (I mean, should it enable the cube or not?)

Cheers

Mariano

On 3/5/07, Emilio Pozuelo Monfort <email address hidden> wrote:
> That is because desktop-effects enables it in compiz, but it doesn't
> work in compiz, not in desktop-effects.
>
> --
> Desktop-effect does not enable cube
> https://launchpad.net/bugs/89786
>

Emilio Pozuelo Monfort (pochu) wrote :

Yes, this is a bug, which will probably be fixed for Feisty (as we have a patch now).

Best regards
Emilio

great!

On 3/5/07, Emilio Pozuelo Monfort <email address hidden> wrote:
> Yes, this is a bug, which will probably be fixed for Feisty (as we have
> a patch now).
>
> Best regards
> Emilio
>
> --
> Desktop-effect does not enable cube
> https://launchpad.net/bugs/89786
>

I cleaned the workspaces fix patch, and included as debian patch in the desktop-effects package. With the previous Compiz patch, this should fix all the problems we had with enabling the cube.

Changed in desktop-effects:
assignee: nobody → avassalotti
status: Unconfirmed → In Progress
Travis Watkins (amaranth) wrote :

It should only set the number of workspaces to 1 when you tick the cube box. it should then revert to the default setting when you untick the cube box.

Sitsofe Wheeler (sitsofe) wrote :

There is also an issue concerning the number of desktops when running metacity or compiz by hand...

This looks very similar to bug #82957 ...

Sitsofe Wheeler (sitsofe) wrote :

Travis:

Why did you forward dupe? Why not credit the person who reported it first?

Travis Watkins (amaranth) wrote :

This bug has more information and someone working on a fix.

Sitsofe Wheeler (sitsofe) wrote :

Travis:
Excellent reason.

llimaa (llimaa) wrote :

I have the same problem!
The cube works now after applying the gconftool-2 solution from the top but only two sides of the desktop are showed (even after adding 4 workspaces).

My second problem is that I'm using dual monitors and I have 2 cubes when i rotate. In a another distro(Rh-fc6) it was possible to have a big large unified cube that goes over both monitors.

Would be cool if someone could find a solution or fix that,too.

VF (vfiend) wrote :

"My second problem is that I'm using dual monitors and I have 2 cubes when i rotate. In a another distro(Rh-fc6) it was possible to have a big large unified cube that goes over both monitors."

You should probably file a seperate bug for that, llimaa.

Nick (morrownr) wrote :

This bug is not fixed in the Beta.

I did a clean install of the Fiesty Beta this morning and had to make the changes as suggested by the OP. Cube works great now.

If Cube is going to be supported in Fiesty this needs to be fixed. Having a menu item called "Workspaces on a Cube" that doesn't actually do what it indicates it will do is not a good thing.

Changed in desktop-effects:
importance: Undecided → Medium
Travis Watkins (amaranth) wrote :

As this bug is in the way desktop-effects turns on cube and not something compiz is actually doing wrong I'm going to reject the bug against compiz.

Changed in compiz:
status: In Progress → Rejected
zeddock (jim-leaders) wrote :

I hope it being rejected against compiz does not mean that this bug will not be fixed in Feisty.

I am on a Dell Latitude D800 with NV28 [GeForce4 Ti 4200 Go AGP 8x] as my video. Everytime I try to use Desktop Effects, the changes to my xorg.conf create an error on reboot.

I have to go in and change nvidia to nv to get back to GUI.

I think the system should consider whether I need the legacy or newer nvidia driver. Then it should work when I turn on the effects. If it Can't it should at least say WHY it can't, (but I think that is another bug.)

This past Sunday or Monday I had the effects working with the cube displayed, so i know there is a fix. Will the fix make it into Feisty?

Thanx.

zeddock

Sebastian Breier (tomcat42) wrote :

This bug will be fixed, it's already being worked on.

However, what you're describing is a completely different matter (problems with the NVidia driver + desktop-effects) and should be reported in a new bug.

Emilio Pozuelo Monfort (pochu) wrote :

And they're already reported: Bug #89697, Bug #97037

On 3/29/07, Sebastian Breier <email address hidden> wrote:
> However, what you're describing is a completely different matter
> (problems with the NVidia driver + desktop-effects) and should be
> reported in a new bug.

No. I have a laptop with an NVidia GeForce 440 Go, and cube works
great, as long as I manually set desktops to 1 and hsize to 4 via
gconf. So, PLEASE TAKE NOTICE that the real issue, at least for me,
was that the gconf values were not being modified correctly. When I
edited them manually, as checking the box *should* do, everything
worked fine. I don't understand the argument that there is a "bug" in
the NVidia driver when everything worked great after I made the
changes manually. Please provide any reasoning for this so that I may
understand...
--
Kristian Hermansen

Sebastian Breier (tomcat42) wrote :

o_O?

I was replying to zeddock. He said that he had problems with the NVidia driver. The current bug is a gconf/compiz issue and has nothing to do with the driver. I merely pointed that out to zeddock.

You should note that this is the original bug for a duplicate that You (Kristian) reported, and when I'm replying to certain statements here I'm not necessarily talking to You. ;)

If You don't have any problems with the NVidia driver, then that's perfectly fine. zeddock has, and he should talk about it in another bug, not this one.

On 3/29/07, Sebastian Breier <email address hidden> wrote:
> You should note that this is the original bug for a duplicate that You
> (Kristian) reported, and when I'm replying to certain statements here
> I'm not necessarily talking to You. ;)
>
> If You don't have any problems with the NVidia driver, then that's
> perfectly fine. zeddock has, and he should talk about it in another bug,
> not this one.

I agree. I just wanted to make sure that you weren't referring to the
entire issue, since I did log another bug (and since closed it on my
own). I closed it after finding this thread...
--
Kristian Hermansen

Travis Watkins (amaranth) wrote :

This debdiff should fix the bug.

Changed in desktop-effects:
assignee: avassalotti → amaranth
Sebastien Bacher (seb128) wrote :

Thank you for the work on it:

 desktop-effects (0.7.1-0ubuntu4) feisty; urgency=low
 .
   * debian/patches/05_flip_hsize_and_desktops_for_cube.patch:
     Make the cube checkbutton work with our default settings.

Changed in desktop-effects:
status: In Progress → Fix Released
Nicolas DERIVE (kalon33) wrote :

This fix doesn't seem to work on my computer... The box is checked but it does nothing with compiz.

Sebastian Breier (tomcat42) wrote :

Nicolas: Are you sure that 0.7.1-0ubuntu4 is installed? Not undermining your competence, I just want to make sure. ;-)

zeddock (jim-leaders) wrote :

How can I verify?
zeddock

Sebastian Breier wrote:
> Nicolas: Are you sure that 0.7.1-0ubuntu4 is installed? Not undermining
> your competence, I just want to make sure. ;-)
>
>

Sebastian Breier (tomcat42) wrote :

In a console:
"dpkg -l | grep desktop-effects"

Output should be something like:
"ii desktop-effects 0.7.1-0ubuntu4"

Daniel Hollocher (chogydan) wrote :

The cube stops working when I open and close the Desktop Effects configuration window multiple times. First, it sets the number of workspaces to one, and converts the workspaces to cube faces. Then, it sets the number of cube-faces down to one. Maybe this has something to do with this bug.

To work around, I increase the number of workspaces, and then open and close the Desktop Effects configuration a single time, thus invoking the conversion of workspaces to cube faces.

Sebastian: I get the above output, when I entered the above command.

VF (vfiend) wrote :

Daniel is exactly right, it still doesn't work right here. I also have desktop-effects 0.7.1-0ubuntu4

VF (vfiend) wrote :

This is a slightly different bug so I've opened it as bug 103042

Nicolas DERIVE (kalon33) wrote :

Sebastian : I slightly modifity your command because it wasn't working, but yes, I have the good version, and the problem remains.

nicolas@spiralo-vertigo:~$ dpkg -l desktop-effects
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-============================================
ii desktop-effect 0.7.1-0ubuntu4 preferences applet for configuring desktop e

Tormod Volden (tormodvolden) wrote :

I can also confirm bug #103042 (using today's daily-live) which I guess is related to Travis' and Sebastian's fix in this bug.

Nicolas DERIVE (kalon33) wrote :

I think that I found a possible causis : it is impossible to use more than 1 workspace with the "activate workspaces..." option, if you modify it when this option is activated, it is not saved. Restarting the desktop-effects app shows an unchecked box, and enable "activate workspaces..." turns your workspaces to only one.

Amazing Iceman (iceman-arenas) wrote :

Hello, I'm currently using Feisty. It would be nice if the Cube effect switched our workspaces, and not the way it currently operates.

I have the same problem, and I even after I make the suggested changes (I have been using gconf-editor):

/apps/compiz/general/screen0/options/hsize 4
/apps/compiz/general/screen0/options/number_of_desktops 1

If for some reason compiz crashes, the value for hsize would default back to 1 and the cube would stop working again, until I make the change manually.

I have one question: Which one of the two is the development team going to implement as the preferred windows effects manager in Ubuntu Feisty: Compiz or Beryl ?

I understand there are many opinions about the two, I just want to know which one will be more integrated in the final release.

Thanks.

VF (vfiend) wrote :

Compiz is already integrated. (Desktop Effects is a front-end/configuration tool for compiz)

zeddock (zeddock) wrote :

I want to say "Thanx!"

I am on a Dell Latitude D800 with nVidia GeForce4 Go 4200 Ti AGP8.

Upon a first try yesterday night, I could not use the 96xx driver and Enable Desktop Effects. (I ended up with a corrupted xorg.conf file)

This morning I have done a complete reinstall using the beta ISO.
On first boot after the install the update manager said there was a ton of updates that were needed. I updated. (Took hours!)

After the update it asked for a reboot. I did it. Checked updates again. No more...

I went to restricted manager and saw the 96xx installed but not in use. I checked it to ON.
I rebooted... hoping to not see a blank screen again...

Rebooted fine! Although I do not see an nVidia white, logo screen, it was obvious it was working and the Restricted Manager said "In Use" as well.

I rebooted just to make sure xorg.conf would not be corrupted.
Reboot went fine.

I enabled Desktop Effects. Almost immediately I got a requester to keep current or Previous settings, something I did not see before when it would fail...
I said Keep Current, and checked on the show desktop on cube.

I rebooted twice to verify it was solid.......

It is now solid for me.

Thanx again!!!

zeddock

I'm using Feisty stable, and every time I disable and enable desktop effects "hsize" is set to "1" (even if the cube is enabled). It worked only when I enabled effects for the first time.

VF (vfiend) wrote :

Emilio, that's bug 102309, please comment there

Bakul Krishana (bakul-linux) wrote :

Well, here is the procedure I fixed the bug in my machine..
Step 1. System--> Preferences-->Desktop Effects: Uncheck the box for "Worspaces on cube" (Assuming, desktop effects are ON)
Step 2: Close the Preferences Window, this should reset the settings, and now you can see only one Workspace in panel
Step 3. Right Click on the workspace panel--> Preferences
Step 4: Increase the number of workspaces ( I set it for 4), and close the preferences window
Step 5: Go back to System--> Preferences-->Desktop Effects: Check the box for "Workspaces on cube"
Step 6: As a precaution, first click on Workspace 2, to check whether cube effect is coming or not. If not, try your luck again. :)

Now test it by moving some window, it may take few seconds to move it, but keep dragging.

Conclusion: For me, it seems that the code is conflicting between number of Workspaces and Desktop effect... so first enable the desktop effects, then set the wobbling effect... then set the number of workspaces, and then set the cube effect.
Your setup may again break if you increase or decrease then number of workspaces. If it happens, repeat the steps from 1 to 6.

Tom Bott (tombott) wrote :

I would just like to confirm that I have exactly the same problem.
I can get the Workspace on a cube to work again by following the above steps (I've been doing the exact same procedure for a while).
I have an Acer Aspire 9500 Laptop with an ATI Mobility Radeon X700 Graphics Card.
I am using Feisty Stable and running 0.7.1-0ubuntu4 for desktop-effects

zeddock (zeddock) wrote :

Not sure how this bug should be changed since newest entries look like Gusty, not Feisty. But obviously Cube not working again.

zeddock

Changed in desktop-effects:
status: Fix Released → Confirmed
sam tygier (samtygier) wrote :
Changed in desktop-effects:
status: Confirmed → Fix Released
Jerkyboy017 (rmtarriff) wrote :

I am completely new to Linux...I was wondering how to get the workspace in a cube because compiz doesn't seem to really enable it. I tried using beryl and it really messed up my computer so i had to uninstall that. If there is a patch or something that i can enable, that would be really helpful.

Ryan

John Dong (jdong) wrote :

This bug, however is STILL in gutsy, even though the package name may have
changed. I had to use gconf to enable the cube;

On 9/4/07, sam tygier <email address hidden> wrote:
>
> desktop-effects is not in gutsy
>
> http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=desktop-effects&searchon=names&subword=1&version=all&release=all
>
> ** Changed in: desktop-effects (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> Desktop-effect does not enable cube
> https://bugs.launchpad.net/bugs/89786
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

zeddock (zeddock) wrote :

How is the cube supposed to be turned on in the latest Gusty?

zeddock

zeddock (zeddock) wrote :

I ended up going through Synaptics and installing the compizsettings-manager.
Once installed I went into the app and turned on cube and cube-rotation. It works now.

Hope this helps fix the bug.
BTW I think the bug is correct even for Gusty as Desktop Effects do appear as a tab in the Appearance section of System | Prefs...

zeddock

aenesias (aenesias) wrote :

hi i have already installed ubuntu i read all of the above but i think they wont fix it

i have intel 965 chipset family machine i think i dont have problem with this it is already listed in devices however i cant open desktop effects

it always says " Desktop effects could not be enabled "

i really need help thanks...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments