[regression] Customized shortcuts don't work in compiz 1:0.9.7.0~bzr2995-0ubuntu1

Bug #931927 reported by Vincent Ladeuil on 2012-02-14
124
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Compiz Expo Plugin
High
Sam Spilsbury
Compiz Main Plugins
High
Sam Spilsbury
compiz (Ubuntu)
High
Unassigned
compiz-plugins-main (Ubuntu)
Undecided
Unassigned

Bug Description

Since I upgraded afew minutes ago, all the shortcuts I defined in compiz 'commands' are lost as well as the ones I defined in 'wall', in short, all of them.

Instead I get the 'Keyboard shorcuts' help screen, ironic, but not helpful :-/

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 290.10 Wed Nov 16 17:39:29 PST 2011
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-12ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,shift,imgpng,commands,regex,grid,ring,vpswitch,compiztoolbox,session,unitymtgrabhandles,mousepoll,move,snap,resize,gnomecompat,wall,resizeinfo,animation,expo,ezoom,workarounds,fade,scale,unityshell]
CompositorRunning: compiz
Date: Tue Feb 14 09:25:08 2012
DistUpgraded: Log time: 2012-01-23 15:49:17.472988
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-173, 173.14.30, 3.2.0-15-generic, x86_64: installed
 nvidia-current, 290.10, 3.2.0-15-generic, x86_64: installed
 vboxhost, 4.1.8, 3.2.0-15-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation G98 [GeForce 8400 GS] [10de:06e4] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8266]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64+mac (20110427.1)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-15-generic root=UUID=9e03ea1c-298d-4b96-9870-4db1fe183774 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-13 (1 days ago)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 12/05/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1003
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P6T DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1003:bd12/05/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP6TDELUXE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Vincent Ladeuil (vila) wrote :
Vincent Ladeuil (vila) wrote :

Moreover, even the short cuts documented in the said help screen don't work either: <Shift><Super> + W, <Shift> Cursor keys

<Control> Tab does nothing either

I can't navigate between my workspaces nor windows anymore...

Help !

Vincent Ladeuil (vila) wrote :

<Super> + S still works

Vincent Ladeuil (vila) wrote :

<Super> 1..9 still work too

Switching to unity 2D seem to work around most of the issues but restrict to 2x2 workspaces despit my settings saying 3x3

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Andreas Hasenack (ahasenack) wrote :

All my shortcuts stopped working too, despite still being defined in the keyboard config settings.

Jonathan Davies (jpds) on 2012-02-14
tags: added: rls-mgr-p-tracking
Omer Akram (om26er) on 2012-02-14
affects: unity (Ubuntu) → compiz-core
summary: - unity has stolen all my <super> shortcuts
+ Keyboard shortcuts lost in compiz 1:0.9.7.0~bzr2995-0ubuntu1

I can't reproduce this bug with the upstream code (lp:compiz-core revision 2998). Just tested about a dozen actions with various plugins and they all seem to work. Perhaps it's a problem with the packaging in precise?

All: Could you please reply with brief comments confirming the version of compiz you have installed as well as the exact key combination that is not working and what you expect it to do?

affects: compiz-core → compiz (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Maybe this is just an upgrade problem? Does it only affect key combinations you had customized before upgrading to 0.9.7 ?

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

To clarify, I tested various actions of:
core composite opengl move resize decor mousepoll wall scale compiztoolbox switcher water expo grid animation
And they seem to work with the upstream code default key-combos.

Didier Roche (didrocks) wrote :

@Daniel, in viewport, we try setting "got to specific viewport", "swith to viewport" to, for instance, ctrl + h, pressing ctrl + h, nothing worked. Same with other key combinations.

tags: added: compiz-ff-precise
Sebastien Bacher (seb128) wrote :

the issue happens with the current precise in unity or non-unity (gnome-panel and compiz) sessions, using "switch to viewport" or "cube" and setting "switch to viewport <n>" in ccsm or gnome-control-center

Sebastien Bacher (seb128) wrote :

same issue with compiz from
https://launchpad.net/~unity-team/+archive/compiz-testing/+packages

note that compiz segfaults when using ccsm to disable the viewport switcher

Daniel van Vugt (vanvugt) wrote :

So are you saying that this bug is only about customized (non-standard) shortcuts set in ccsm?

I also noticed that some Gnome shortcuts don't work, but that appears to be an old bug present in oneiric too.

Sebastien Bacher (seb128) wrote :

Daniel, I'm not sure what I described is this bug, what I get is bug #932172 (the only custom keybindings I use are the "go to workspace <n>"), can you confirm if those work for you?

Some people mentioned having issues with "send win to background" or "hot corner", so yes, they all seem to be non standard keybindings, the standard ones work fine here (ctrl-alt-arrows, super-w, etc)

Andreas Hasenack (ahasenack) wrote :

It's some shortcuts, not all. My examples are:
- switch workspaces, as others have reported (I use alt-<n>)
- launch terminal. This one was working while it was at the default value (ctrl-alt-t). I then changed it to my usual alt-t, and it stopped working. Changing it back to ctrl-alt-t didn't fix it.

I tried changing another one that was working from its default value to something else. I used "lock", whose default is ctrl-alt-l. Changed it to alt-x, worked, changed it back to ctrl-alt-l, still worked.

Didier Roche (didrocks) wrote :

@Andras: I tried to change launch terminal to Ctrl + ALt + e here (from gnome-control-center, which changed the binding in ccsm), and it worked.

Andreas Hasenack (ahasenack) wrote :

Well, it's not working here since yesterday's update (my morning at UTC-2). Right now, launch terminal and switch to workspace <n> are not working. I don't think I have other customizations, and I only launched ccsm once after installation to increase the number of desktops from 4 to 6, and I did it very carefully knowing ccsm can break a system as easy as an egg. This was weeks ago.

Andreas Hasenack (ahasenack) wrote :

Do you want me to try an unity --reset and start over? Making sure shortcuts are working right after that, then apply my customisations again?

Dean Henrichsmeyer (dean) wrote :

It doesn't work here either. You can change the keyboard shortcuts by going to System Settings -> Keyboard -> Shortcuts and if you change the switching workspaces shortcuts, it does nothing. Launching terminal, making an application sticky, etc, work but switching workspaces does not.

It's the same behavior on two different precise machines and happened at the same time. It's clearly a regression.

Andreas Hasenack (ahasenack) wrote :

I have compiz 1:0.9.7.0~bzr2995-0ubuntu1 btw.

Didier Roche (didrocks) on 2012-02-15
Changed in compiz-core:
status: New → Confirmed
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz-core:
assignee: nobody → Łukasz Zemczak (sil2100)
Łukasz Zemczak (sil2100) wrote :

I did some testing around this issue in both the 1:0.9.7.0~bzr2995-0ubuntu1 version and the latest source from the compiz-core trunk, and I noticed that a keyboard shortcut stops working after you modify it in any way. And even if you change it back later, it still doesn't work. So it might be something with keybinding configuration.

Changed in compiz-core:
assignee: Łukasz Zemczak (sil2100) → Sam Spilsbury (smspillaz)
Changed in compiz-core:
status: Confirmed → In Progress
milestone: none → 0.9.7.2
milestone: 0.9.7.2 → 0.9.7.0

Hey all, could we please make this bug about customized compiz actions only?

The Gnome problem with System Settings > Keyboard > Shortcuts being ignored is an old problem that is present in oneiric too. I think that needs a separate bug.

summary: - Keyboard shortcuts lost in compiz 1:0.9.7.0~bzr2995-0ubuntu1
+ [regression] customized keyboard shortcuts don't work in compiz
+ 1:0.9.7.0~bzr2995-0ubuntu1
Sam Spilsbury (smspillaz) wrote :

core is doing something really stupid.

Will have a fix in 30 minutes.

Daniel van Vugt (vanvugt) wrote :

Awesome. Thanks Sam.

prusswan (prusswan) wrote :

Please update the description to include mouse as well (see Bug #932624)

summary: - [regression] customized keyboard shortcuts don't work in compiz
+ [regression] Customized shortcuts don't work in compiz
1:0.9.7.0~bzr2995-0ubuntu1
Sam Spilsbury (smspillaz) wrote :

Ok, took a little longer because of the whole static initialization and destruction nightmare.

Had to break the API :( But the merge prop can be found here. Only one plugin needed to be updated afaict

Changed in compiz-expo-plugin:
status: New → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-plugins-main:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz (Ubuntu):
status: Incomplete → In Progress
Changed in compiz-plugins-main (Ubuntu):
status: New → In Progress
status: In Progress → New
Changed in compiz (Ubuntu):
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
tags: added: qa-manual-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0~bzr2995-0ubuntu2

---------------
compiz (1:0.9.7.0~bzr2995-0ubuntu2) precise; urgency=low

  * debian/compiz-kde.install, debian/control, debian/rules:
    - disable right now kde build for compiz-kde package. It's using
      deprecated kde libraries and fails to build on armel. It's
      probably as well not needed anymore as most of kde users are using
      kwin which is better integrated to kde than compiz. There is not
      anymore upstream compiz maintenance on this plugin as well.
      (LP: #931500)
  * debian/patches/fix_931958.patch:
    impossible to click on keyring dialog since the upgrade. Doesn't really
    fix 931958 as per say, but another issue impacting seahorse.
  * debian/patches/fix_871801.patch:
    window management, alt-tab - After using 'show desktop' to minimise
    all windows, opening any new window also incorrectly restores all
    the minimised windows (LP: #871801)
  * debian/patches/fix_925293.patch:
    Add support for key "tap" detection (LP: #925293)
  * debian/patches/fix_933226.patch:
    Fix FTBFS in previous commit (LP: #933226)
  * debian/patches/fix_932087.patch:
    Initialize the _NET_WM_STATE_FOCUSED (LP: #932087)
  * debian/patches/fix_931473.patch:
    - Menus don't fully appear (LP: #931473)
    - Rendering menus leaves transparent areas (LP: #932813)
  * debian/patches/fix_931927.patch:
    - Customized shortcuts don't work in compiz 1:0.9.7.0~bzr2995-0ubuntu1
      (LP: #931927). Breaks API/ABI.
 -- Didier Roche <email address hidden> Thu, 16 Feb 2012 15:11:51 +0100

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-02-16
Changed in compiz-core:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu2

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu2) precise; urgency=low

  [ Sam Spilsbury ]
  * debian/patches/expo_api_931927.patch
  * debian/patches/workarounds_923087.patch
    - adjust for API breaks (LP: #931927, #923087)

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest compiz-dev for ABI dev
 -- Didier Roche <email address hidden> Thu, 16 Feb 2012 15:14:05 +0100

Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

This was a very bad update, hopefully that is known, if not Bug 933680

Dean Henrichsmeyer (dean) wrote :

Agreed, keyboard shortcuts are still broken for me after the update. I have it set so that Ctrl-Left/Right/Up/Down switches workspaces. What happens after this update is that Right/Left/Up/Down switch workspaces with no modifier whatsoever.

Andreas Hasenack (ahasenack) wrote :

FWIW, my shortcuts started working again right after the update:
- switch to workspace, alt-<n>
- open terminal, alt-t

But then I got hit by bug #933615 ;)

Doug McMahon (mc3man) wrote :

@ Dean - That is an issue that affects ccsm, tilda, maybe some other apps, not related to this. If you wish see - Bug 929926 Bug 929366

The fix on custom shortcuts still doesn't allow any that use initiate_all including the previously working super+W to actually work as intended, ie. - from all workspaces Bug 931601

prusswan (prusswan) wrote :

Haven't had a chance to test it yet, but I am curious about how the manual testing is conducted, which shortcuts have been tested to be working as a direct result of the fix? (i.e. they weren't working before)

Daniel van Vugt (vanvugt) wrote :

This is not fix committed to compiz-core yet. The patch that was pulled into 1:0.9.7.0~bzr2995-0ubuntu2 is not approved by development and is still under review.

Changed in compiz-core:
status: Fix Committed → In Progress
Dean Henrichsmeyer (dean) wrote :

@ Doug (mc3man) I don't follow. I don't use ccsm, tilda, or others.. I only use the keyboard shortcuts in system settings. I have one precise machine in which Ctrl-arrow switches workspaces just fine and one that does not. It stopped working when this bug was introduced.

Are you saying that bug 931601 is the culprit?

On 02/20/2012 02:42 PM, Dean Henrichsmeyer wrote:
> @ Doug (mc3man) I don't follow. I don't use ccsm, tilda, or others.. I
> only use the keyboard shortcuts in system settings. I have one precise
> machine in which Ctrl-arrow switches workspaces just fine and one that
> does not. It stopped working when this bug was introduced.
>
> Are you saying that bug 931601 is the culprit?
>
Dean - not at all. Your previous made it seem possible you were using
ccsm to set the mentioned binding.
I was commenting that one can't set a binding for key combo in ccsm if
the use the Ctrl key while doing so.
It will be inputed as <Primary> which will be ignored and the remainder
of the set combo will be the actual binding. (Same thing happens in Tilda

Dean Henrichsmeyer (dean) wrote :

Ah! This is exactly what happens in keyboard preferences in system settings then. The reason why my other precise machine works is I didn't set those preferences while this bug was in place.

For example, I have CTRL-arrow set to switch workspaces. Right now I can switch workspaces with just arrow keys which means the Ctrl key is completely ignored even though it shows up in the preferences. So how do I get this addressed?

Doug McMahon (mc3man) wrote :

On 02/20/2012 04:17 PM, Dean Henrichsmeyer wrote:
> Ah! This is exactly what happens in keyboard preferences in system
> settings then. The reason why my other precise machine works is I didn't
> set those preferences while this bug was in place.
>
> For example, I have CTRL-arrow set to switch workspaces. Right now I can
> switch workspaces with just arrow keys which means the Ctrl key is
> completely ignored even though it shows up in the preferences. So how do
> I get this addressed?
>
Dean - out of my league though I will say I've never nor currently see
that using the Ctrl key when creating a binding being an issue in
"Keyboard". Only in ccsm & Tilda so far
Maybe post a question in ubuntu questions or try an interactive forum?

Daniel van Vugt (vanvugt) wrote :

Merged into lp:compiz-core at revision 3010

Changed in compiz-core:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Merged into lp:compiz-expo-plugin at revision 141

Changed in compiz-expo-plugin:
status: In Progress → Fix Committed
importance: Undecided → High
Changed in compiz-plugins-main:
status: New → Triaged
importance: Undecided → High
milestone: none → 0.9.7.0
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:compiz-plugins-main at revision 17.

Changed in compiz-plugins-main:
status: Triaged → Fix Committed
Roi DM (roi-dm) on 2012-02-28
Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
Changed in compiz-plugins-main:
status: Fix Released → Fix Committed
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in compiz-expo-plugin:
status: Fix Committed → Fix Released
Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
To post a comment you must log in.