Ubuntu

Can't change cursor style using Compiz.

Reported by Bastanteroma on 2007-02-19
560
This bug affects 225 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Binary package hint: compiz

With compiz running, choosing a nondefault cursor style, such as "redglass" or any of the other packaged options, only seems to actually change the cursor when it is over Firefox. Over every other window or the desktop the default cursor persists stubbornly.

Changed in compiz:
assignee: nobody → gandalfn
status: Unconfirmed → Confirmed
Nicolas Bruguier (gandalfn) wrote :

Thanks for bug report, here a patch to add cursor theme support in compiz. This patch needs to add libxcursor-dev build-dep

Nicolas Bruguier (gandalfn) wrote :

This second patch is autogen result before apply first patch

Nicolas Bruguier (gandalfn) wrote :

debdiff include :
-> inotify patch (Ubuntu: #82336)
-> mouse move key patch (Ubuntu: #86378)
-> add cursor theme patch (Ubuntu: #86184).
     warning this patchs must be apply before add-workspace-terminal-keybindings

Sebastien Bacher (seb128) wrote :

Thank you for the patch Nicolas. That upload fixes the bug:

 compiz (1:0.3.6-1ubuntu4) feisty; urgency=low
 .
   * Sync with Debian
   * debian/control:
     - don't Conflicts with the new libmetacity0 package
     - make new packages Conflicts,Replaces for binary split
     - the package is maintained by the MOTU team
   * debian/compiz-plugins.gconf-defaults:
     - change schemas values from there instead of patching the source
   * debian/patches/080_cube_settings_for_ubuntu.patch:
     - updated image and color for Ubuntu
   * debian/patches/081-restart.patch:
     - compiz restarts only if it is the current window manager
   * debian/patches/082_basic-focus-prevention-support.patch:
     - upstream patch : Add basic prevention focus support
   * debian/patches/084_render-decoration-after-client-window.patch:
     - upstream patch : Render decorations after client window so it's
       possible to have decorations that cover part of the client window.
   * debian/patches/085-fix-show-managed-window.patch:
     - don't focus new window if a user input in active window
   * debian/patches/086-workspaces-terminal-keybindings.patch:
     - add workspaces and terminal keybindings
   * debian/patches/086-workspaces-terminal-keybindings-schemas.patch:
     - compiz.schemas regen with workspaces and terminal keybindings
   * debian/patches/087_terminate-move.patch:
     - use upstream patch, terminate move state on button clicks.
   * debian/patches/088-gnome-bridge-keybindings-plugin.patch:
     - metacity / compiz keybindings plugin sync
   * debian/patches/099_autogen.patch:
     - run autogen to update Makefile
 .
    [ Nicolas Bruguier ]
   * debian/control:
     - add libxcursor-dev build-dep
   * debian/patches/089_init-inotify-struct.patch:
     - initialize inotify struct on startup (Ubuntu: #82336)
   * debian/patches/090_fix-mouse-move-key.patch:
     - fix mouse mouse move key gconf entry (Ubuntu: #86378)
   * debian/patches/091-add-cursor-theme-support.patch:
     - add cursor theme and size support (Ubuntu: #86184)

Changed in compiz:
importance: Undecided → Medium
status: Confirmed → Fix Released
Raivis Dejus (orvils) wrote :

Ok, I don't understand a bit if the fix was released 2007-02-21 then and if yesterday after upgrading to Gutsy I still get this bug then should I report this bug again for Gutsy or this is the right place to inform you about this problem still existing.

Csaba Szilveszter (csakoka) wrote :

This is probably a stupid question: How do you apply these patches? :-s

Hey, after 3 years, I think the bug is still active. I'm using Ubuntu Karmic with Compiz 0.8.2, and I can't change the cursor theme without logout/login. The only cursors changing are Busy and Text; and over Firefox and OOo.

I forgot to mention, I'm using Compiz from Ubuntu repos.

Majestyx (majestyx) wrote :

In the early Sunday morning i make the latest updates (via bash & upt-get) BTW: i have per default the 3D settings turn off. (it is a IBM T41 whit only 32MB "GPU" (ATI).

After the update i turn on the 3D whit "normal" settings. Whit the pop up: if you wish to keep the settings press button. the appearance - window was frozen. i click on : keep settings. compiz came up (the screen flickers shortly) and i have the "buggy" cursor theme "blue" (i have else wise a white cursor)

but, i open a new appearance window, (yes its works, in background i have the frozen appearance-window) and set up my white cursor theme. i do a reboot....... nothing happens...

after reboot: the cursor theme is always buggy. i have a blue not more a white cursor. and all so the "old bug" whit the "no expand gnome panel" on bottom. (equal: whit 3D or whit out 3D, no expand bottom panel is all ways after reboot on top) if i set no expand to the bottom gnome panel - after any reboot the bottom panel is on the top. whit preselect "no" to the "expand". i can NOT put a gnome-panel on bottom.

bummer ;)

nice Sunday @ all

JarekJ83 (jarekj83) wrote :

same problem is in Lucid Lynx

Hugo (hugo-franco75) wrote :

After more than 3 years the bug is still there... how come?

antonioni (antonioni-rocha) wrote :

Bug fixed here... but in Lucid Lynx it continues. ¬¬'

This issue appears to still exist in Lucid and Maverick, as per <a href="http://ubuntuforums.org/showthread.php?t=1578873">this forum post</a>. I am changing the status to "confirmed" for now, given that it has yet to be fixed in the latest releases.

Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
VPablo (villumar) on 2010-10-04
summary: - Can't change cursor style using Compiz in Feisty.
+ Can't change cursor style using Compiz.
VPablo (villumar) wrote :

I think this is fixed on Maverick. I have cursor modified on all the applications.

Changed in compiz (Ubuntu):
assignee: Nicolas Bruguier (gandalfn) → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Medium → Low
milestone: none → natty-alpha-3
hackel (hackel) wrote :

Still very much alive in Natty as of today. What's worse is that, apparently, the "Default Pointer" size is smaller than whatever is being chosen automatically, resulting in a change of pointer size. It's small (or whatever size I manually set it to) when on a Firefox window, for example, but moving it up to the panel makes it large. Shouldn't this be a priority, seeing as how Compiz + Unity is the default in Natty and this is a rather large usability issue? The pointer shouldn't be spontaneously changing on users, and the ability to change the pointer size is important for accessibility.

Just tried Natty in a VirtualBox vm. The issue happens for me too. The switch to DMZ (Black) is not honored.

At least there is an easy workaround. Changing the cursor with

$ sudo update-alternatives --config x-cursor-theme

works!

I just updated to Natty.
In my theme customisation menu, I can see cursors as I saw in previous versions of ubuntu - only now I cannot change from the default cursor at all, even if I switch to metacity and back to compiz (cursor is changed only in metacity, but returns to the default in compiz).

oh, and 'sudo update-alternatives --config x -cursor-theme' won't select the themes I want either.

Having this issue in Natty, updated a few days ago. This seemed to be fixed in Maverick but has reverted to its old ways.

I'd argue that this is an accessibility issue -- many users select a large cursor theme for more visibility, but this is of no use if it doesn't apply everywhere.

dirkhartzer (dirkhartzer) wrote :

I can confirm this bug in natty.

I feel this is a HUGE spoiler as the default cursor is ugly and you see it every time you move your mouse over a window egde

Clint Byrum (clint-fewbar) wrote :

Given the number of users reporting this as a problem, I'm raising this to an importance of Medium. While it is just "cosmetic", it seems fundamental to accessibility.

Changed in compiz (Ubuntu):
importance: Low → Medium
Scott Kitterman (kitterman) wrote :

I think the fix I tried to get in for this was correct and the regression comment was spurious. See https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/459647/comments/44

Colin (tekash) wrote :

I can confirm this bug in 11.04 as well; using Unity and Compiz.

Here is my workaround: (I think Step 6 was last and not before #4...)
1) Manually unpack your cursor tar.gz files in usr/share/icon.
2) Log out and back in to have Natty see all the ones you just unpacked in the Pointer selection menu.
3) Go to System Settings -> Appearance -> Customize -> Pointer tab -> Select the theme you unpacked in step 1 -> Save your custom theme -> Close the Appearance window.
4) Navigate to etc/alternatives and edit x-cursor-theme. It should say:
[Icon Theme]
Inherits=NAME_OF_A_UNPACKED_FOLDER_IN_STEP_1
5) Log out and back in.
Alas, it still only half worked for me and was using an old icon set I had chosen on some pages.
6) Go to Appearances again and notice that your Theme may now NOT be selected and be Custom instead. I could not delete Custom, so selected the same icons, border window, cursors etc and saved it with the same name in Step 3 overwriting the original.
7) Enjoy. If you want to use another cursor set, start again at Step 3.

gcb (descartavel1) wrote :

It was working for me on 10.11 (was using stock black cursor, medium)

after upgrade to 11.04, cursor reverted to white, small.

changing it on the appearance window does nothing.

I installed 'Obsidian cursor' - a very nice shiny black cursor (a little large for some tastes), and then manually edited my config files in ~/.icons and /usr/share folders in order to get it working - it works perfectly across compiz and metacity... it appears the problem is that selecting a cursor isn't correctly updating the system.

I tried installing the "Crystal" cursor set, but then decided it wasn't in my tastes. I manually removed the theme via Synaptic, but the blue cursor still would not change to the DMZ-Black cursor I had been using previously. Using 'sudo update-alternatives --config x -cursor-theme' mentioned above, I selected the DMZ black theme in Terminal. Still no luck. However, logging out then back in seemed to do the trick. I can't confirm it, but I surmise that using 'sudo update-alternatives --config x -cursor-theme' to select your cursor then logging out then back in may be a workaround. You would have to do this every time you want to switch cursors.

Nicolas Briche (nbriche) wrote :

The update-alternatives solution, however, does not correct the size aspect of the cursor theme.

I chose DMZ-Black medium for my (then) karmic install on a netbook. The theme migrated correctly until natty, where the symptoms desctibed in this bug occurred: correct theme over non-GTK windows only, default everywhere else. No amount of UI-based config corrected it. After a couple hours, update-alternatives managed to bring back DMZ-Black, but not the medium size. So now my cursor switches sizes depending on the window it's hovering.

Braiam Peguero (braiampe) wrote :

Confirmed on a fresh installation of Natty. Right now in FF, I see the custom cursor, but if I point another app/section I see the default one. Also it needs patch reworks.

David Tombs (dgtombs) wrote :

@Scott: Could you clarify your comment? Do you mean that you think this bug is fixed right now in Natty?

Scott Kitterman (kitterman) wrote :

I think the fix I linked to is correct. I didn't check if it's applied in 11.04

This bug is not fixed in my 11.04.

After selecting a new cursor, I still see my Obsidian cursor - however if I take a screenshot it captures the newly selected cursor! Switching to Metacity shows the new cursor, but returning to Compiz shows the old one again.

The only way to do this with compiz is to manually edit the files as suggested before and restart.

Scott Kitterman (kitterman) wrote :

OK. I checked. The issue in https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/459647/comments/44 is still there. Fixing that would be, I think the first thing to do.

Kangarooo Jānis (kangarooo) wrote :

Confirmed on 10.04.2 clean Ubuntu

vivichrist (vivichrist) wrote :

on fresh install bug is still present in Gnome but not Unity

vivichrist (vivichrist) wrote :

on fresh install bug is still present in Gnome but not Unity for 10.04

vivichrist (vivichrist) wrote :

sorry 11.04

mikeloco14 (mikeloco14) wrote :

unlike #35, I can reproduce it in Unity on a fresh install and it's killing me

Mike Doherty (doherty) wrote :

This was reported in 2007 - how is it not fixed in 2011?

AJenbo (ajenbo) wrote :

Probably because no one who is affected by it has cared enough to fix it?

Dean Sadites (dsadites-gmail) wrote :

ATTENTION DEVELOPERS: You may be treating this as a low-priority item simply because you believe it to be cosmetic in nature. However, you need to be treating this as an accessibility issue and giving it a little more attention than it has gotten over the past several years that this defect has stagnated and continually resurfaced. Users with impaired vision absolutely depend on the ability to increase the mouse pointer size (especially on today's high resolution displays). While some of the workarounds above allow a different cursor theme to be installed, none of them solve the related problem in which the mouse pointer cannot be resized when Compiz is enabled (even with the default DMZ White theme).

Please focus on fixing the basics (and ensuring they remain stable from release to release) before wasting time on things like Unity and other relatively pointless endeavors like overlay scroll-bars.

AJenbo (ajenbo) wrote :

Dean negative comments rarely gets positive results. The current recommendation for users with disabilities is to run the system with out compiz (not just because of this issue), of cause unfortunate as compiz can provide desktop zooming witch is of grate help to users that are impaired vision.

Dean Sadites (dsadites-gmail) wrote :

> Dean negative comments rarely gets positive results

I wouldn't characterize my comment as negative. It was an appeal to whoever should be fixing this to give it a higher priority than a simple 'cosmetic' issue. And disabling Compiz is not an option since it's providing many other essential accessibility tools (desktop zoom, negative image, brightness control, etc.). At any rate, I was trying to keep my comment on topic. Let's not turn this bug report into a forum for disputing each other's comments.

AJenbo (ajenbo) wrote :

Ok, it was just that "wasting time on things like Unity" seamed a bit rude an unnecessary. Pointing out that compiz is needed for good accessibility is an important note I think.
Do you think we should maybe promote this bug to a paper cut?

Dean Sadites (dsadites-gmail) wrote :

> Ok, it was just that "wasting time on things like Unity"
> seamed a bit rude an unnecessary.

I hear you. My point wasn't that Ubuntu should not be pursuing new features but, rather, that they need to get basic functionality working and stable first. It just seems that, all too often, we just get everything working, and then the next upgrade breaks things all over again. I realize that there are complexities in making different components work together, especially when they're always changing. However, this particular issue has plagued Ubuntu on and off for 4 years now. Duplicate defects (each with their own lists of comments) for this issue have been logged 16 separate times. I suspect that it has taken a back seat to other issues mainly because it's perceived as being cosmetic in nature. I want to raise awareness that many of the people asking and waiting for this bug to be fixed are not just interested in trying out the latest 'eye candy'. For some, it really is a functional issue.

> Do you think we should maybe promote this bug to a paper cut?

Sure, if that will help get it resolved faster. However, given that it's been fixed before and tends to keep resurfacing in subsequent releases, I think there also needs to be a quality control process at Canonical where certain known recurring issues specifically get tested during each release cycle.

There was at one point a patch for this that was released into
updates, and some people said it worked, and others said it didn't, so
then it was removed again as an incorrect patch. I wonder if it was
correct for one cause, but perhaps there are multiple bugs that
exhibit similar symptoms.

Ovidiu Zeicu (ovidiu-zeicu) wrote :

A possible workaround that might work for some was posted by Colin in Bug #459647 comment #137.
I made only step 4 and a reboot and it sovled the problem.
But... this is only a workaround, not a permanent fix.

drillerccg (ddsinaurora) wrote :

I never had any use for eye-candy hence no need to change themes or cursor icons. That is until my 78 year-old mother-in-law complained that the cursor was too small. I tried to change the size on default cursor and it did in some windows but not on desktop or system windows. The search began and I came across this you tube video that solved my problem, the link at the end. Here is a step by step of what I did courtesy of AbhiramH on you tube:

1-Go to http://gnome-look.org/ , click on X11 Mouse Themes in the left margin, and download a pointer theme you like. I needed a large cursor so I downloaded Large Mouse Cursor 1.0
 http://gnome-look.org/content/show.php/Large+Mouse+Cursors?content=140787

2-go to download folder and extract to desktop, you now have a folder on desktop named as the downloaded theme

****MY extracted folder was named Large Mouse Cursor and I had to rename it Large-Mouse-Cursor (with dashes) to get this to work, it seems like spaces don't really work in this process. Themes without spaces worked without renaming.

3-Fire up the terminal, type sudo nautilus, enter password
4- once browsing as root in the file browser, copy the folder on the desktop and paste to usr/share/icons folder
5-close nautilus and terminal
6- Fire terminal again and type sudo gedit /usr/share/icons/default/index.theme
7-enter password
8- when the file opens, you will see Inherits=name of your current pointer theme, change that to Inherits=name of new pointer theme which is the name of the extracted folder you copied in step 4. Mine was Inherits=Large-Mouse-Cursors (again note the lack of space and addition of dashes)
9-save and exit.
10- now go to system/preferences/appearance, click customize, click pointer tab, and choose your new pointer theme, and exit
11- shut down and restart. Log in and out did not work for me. That's it, it should work.

Other than a few exceptions above, I take no credit for this. All the credit goes to this dude AbhiramH on you tube

http://www.youtube.com/watch?v=CvS9kh_bMyM

It seems that this is not compiz related. I have the same effect with Ubuntu 11.10 and gnome shell. Compiz and Unity are not installed. I've tested some other distros with gnome shell and could not reproduce the error there.

Le Gluon Du Net (legluondunet) wrote :

still have this problem on Ubuntu Oneiric, why we could no more change cursor theme without to have root rights?

This workaround fixed the situation for me. I was able to set another Theme, which is used in all places and situations now:

http://kubuntuforums.net/forums/index.php?topic=3112235.0

This leads me to the question: is the alternative systems not updated when changing the cursor? Is this the error?

Mackenzie Morgan (maco.m) wrote :

Using alternatives would not be a valid fox for this our the source of this
bug. Updating alternatives has a system wide effect. Themes should be
per-user.

Maco
On Oct 16, 2011 7:16 AM, "Thorsten Reinbold" <
<email address hidden>> wrote:

> This workaround fixed the situation for me. I was able to set another
> Theme, which is used in all places and situations now:
>
> http://kubuntuforums.net/forums/index.php?topic=3112235.0
>
>
> This leads me to the question: is the alternative systems not updated when
> changing the cursor? Is this the error?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (459647).
> https://bugs.launchpad.net/bugs/86184
>
> Title:
> Can't change cursor style using Compiz.
>
> Status in “compiz” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: compiz
>
> With compiz running, choosing a nondefault cursor style, such as
> "redglass" or any of the other packaged options, only seems to
> actually change the cursor when it is over Firefox. Over every other
> window or the desktop the default cursor persists stubbornly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/86184/+subscriptions
>

Still present in Oneiric. Does not seem to be Compiz-related, as it also occurs in Gnome Shell and Openbox.

Changed in compiz (Ubuntu):
milestone: natty-alpha-3 → later
Arnaud Soyez (weboide) wrote :

Also affected in Xubuntu Precise beta1.

schwa (jwood3-142) wrote :

Same issue in Ubuntu Precise beta2.

I partially get different cursors in Firefox but even when changing the default index.theme to inherit my chosen theme it still gives me a black looking cursor on the desktop, in other apps, etc.

schwa (jwood3-142) wrote :

Sorry, just tried another way and got in working in Pangolin...

update-alternatives --config x-cursor-theme

changed the theme for the desktops, etc

AND

changing the cursor with gnome "advanced settings" set the theme for Firefox, etc.

MC Return (mc-return) wrote :

Here, on 12.04 the default cursor is now mixed with the new cursor (sometimes the original cursor shows, sometime the newly selected one)...

Actually I like the mix I have, it is like a chameleonic cursor now :)

Example: When resizing a window and hovering over the edge of the window to do so, the new animated cursor shows, but the moment I click the left mousebutton, the cursor changes to the original Ubuntu one (which has no animation), I can now resize the window. When I release the button again it changes back to the new theme again.

Shivkumar Jha (drshiv) wrote :

This bug has been around for more than 2 years that I recall. This is the
reason I stopped using ubuntu
On May 31, 2012 3:25 AM, "MC Return" <email address hidden> wrote:

> Here, on 12.04 the default cursor is now mixed with the new cursor
> (sometimes the original cursor shows, sometime the newly selected
> one)...
>
> Actually I like the mix I have, it is like a chameleonic cursor now :)
>
> Example: When resizing a window and hovering over the edge of the window
> to do so, the new animated cursor shows, but the moment I click the left
> mousebutton, the cursor changes to the original Ubuntu one (which has no
> animation), I can now resize the window. When I release the button again
> it changes back to the new theme again.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (459647).
> https://bugs.launchpad.net/bugs/86184
>
> Title:
> Can't change cursor style using Compiz.
>
> Status in “compiz” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: compiz
>
> With compiz running, choosing a nondefault cursor style, such as
> "redglass" or any of the other packaged options, only seems to
> actually change the cursor when it is over Firefox. Over every other
> window or the desktop the default cursor persists stubbornly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/86184/+subscriptions
>

Eddie Dunn (eddie-dunn) wrote :

While there doesn't seem to be an official way to change the cursor in Ubuntu 12.04 (the Appearance section under System Settings is woefully lacking in options), I do believe this issue needs to be addressed because of the accessibility considerations mentioned above.

Is anyone aware of what it is that causes the discrepancy that if you change pointer theme the default cursor remains the same but is updated to the new theme when it changes appearance to become e.g a resize cursor, or changes when it hovers over certain applications like Firefox?

I am using ubuntu 12.04 64 bit with Gnome 3.4 installed. I have downloaded a mouse theme and changed it via using ubuntu tweak. But it doesn't working! Only seems to actually change the cursor when it is over Firefox. Over every other window or the desktop the default cursor persists. This bug is very very old and should be fixed immediately!

I am also sad because there is no official way to change themes, cursors, fonts etc. We can only change wallpaper!! 10.04 was the best ubuntu distro ever..............

Will this bug be fixed in 13.04? I'm going to open a new report if not, because to be honest this is ridiculous.

Ritesh Khadgaray (khadgaray) wrote :

compiz needs to be updated to use org.gnome.desktop.interface for themes and cursor settings.

rtimai (rtimai) wrote :

Confirming this bug persists in Ubuntu 13.04 AMD64

Changing Zoom options in CompizConfig Settings Manager had no effect (thus, I uninstalled CCSM.) It certainly appears that Unity is abandoning notebook and desktop users.

Is there a temporary manual fix, config edit?

Matthew Gregg (mcg) wrote :

Ended up finding this bug after a fruitless attempt to change the mouse cursor size for my vision impaired daughter. I can confirm that this bug purists in 14.04 as well.

Ladislav Urošević (urosldp) wrote :

I can confirm that this bug purists in 14.04 too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers