Bluetooth Logitech Dinovo Edge Keyboard/Mouse does not work anymore

Bug #269851 reported by arndtc on 2008-09-13
126
This bug affects 21 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Marc Deslauriers
Declined for Lucid by Marc Deslauriers
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

Bluetooth Logitech Dinovo Edge Keyboard/Mouse used to work fine in Hardy, but doesn't work on newer Ubuntus (including Lucid beta).

Related branches

Daniel Sandman (almehdi) wrote :

Still no fix? i am writing this on Onboard. I'm running intrepid beta.

Dwayne Nelson (edn2) wrote :

I am having new problems with my diNovo as well - I think it may have something to do with a difference in the way that the dongle is being recognized and initialized during startup because I am able to get it to work if I follow these steps:

(1) unplug the dongle from the USB slot,
(2) plug the dongle back in to the USB slot
(3) pair the dongle and keyboard

I have to do this every time I boot the machine now where with Hardy I only had to do step #3

Ville Ranki (ville-ranki) wrote :

I just had the same problem when upgrading from Hardy to Intrepid via
Update Manager.

During installation the keyboard & mouse stopped working. I had to reinsert
the USB dongle to get it back working. Also after rebooting i had to do the
same thing. Something has definitely been broken in Intrepid.

AFAIK the Dinovo's USB dongle is visible to PC as a usb HID device, not a Bluetooth dongle.

Notice the difference in log messages after reinserting the dongle:

[ 193.492384] usb 3-2.2: configuration #1 chosen from 1 choice
[ 193.514295] input: Logitech Logitech BT Mini-Receiver as /devices/pci0000:00/0000:00:10.1/usb3/3-2/3-2.2/3-2.2:1.0/input/input6
[ 193.540410] input,hidraw0: USB HID v1.11 Keyboard [Logitech Logitech BT Mini-Receiver] on usb-0000:00:10.1-2.2

(Reinsert the dongle)

[ 193.618349] usb 3-2.3: new full speed USB device using uhci_hcd and address 8
[ 193.774629] usb 3-2.3: configuration #1 chosen from 1 choice
[ 193.800360] input: Logitech Logitech BT Mini-Receiver as /devices/pci0000:00/0000:00:10.1/usb3/3-2/3-2.3/3-2.3:1.0/input/input7
[ 193.836461] input,hiddev96,hidraw1: USB HID v1.11 Mouse [Logitech Logitech BT Mini-Receiver] on usb-0000:00:10.1-2.3

Ville Ranki (ville-ranki) wrote :

Should this be moved from bluez to whatever project handles the USB HID devices (kernel?)?

The bug is still happening and is pretty annoying.

Dwayne Nelson (edn2) wrote :

I tried Jaunty last week and can confirm that the problem exists on 2.6.28 as well. Something was broken in Intrepid.

For more detail, the connection between the dongle and the keyboard remains/resumes after rebooting. I can navigate BIOS fine and have no problem navigating the boot menu when I use a LIve CD. The disconnection happens after Ubuntu starts loading so I no longer have control by the time X is running. Removing and reinserting the dongle (then pairing it again) seems to be the only way to fix it (because there is no input).

I could try logging in remotely and executing some diagnostic commands, but I have no idea which ones would be useful. Ideas?

I will also try a Live CD for another 2.6.27 or 2.6.28 distribution (probably sometime this weekend) to see if the problem is specific to Ubuntu. If you get a chance to try that first, please let us know how it goes.

arndtc (arndtc) wrote :

I would really like to see this fixed as well, its really getting frustrated with crawling under my desk to reconnect, every time I have to reboot.

I'm open to helping troubleshoot this problem if someone will let me know what information they need.

Jonathan Bower (jonathan.bower) wrote :

As a temporary fix, edit /etc/default/bluetooth and edit:
HID2HCI_ENABLED=1
to
HID2HCI_ENABLED=0

/j

arndtc (arndtc) wrote :

Thanks for the temporary fix.

This seems to be related to the following debian bug.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497

arndtc (arndtc) wrote :
description: updated
summary: - Intrepid Ibex Alpha 5 Bluetooth Logitech Dinovo Edge Keyboard/Mouse
- don't work
+ Bluetooth Logitech Dinovo Edge Keyboard/Mouse dones not work anymore

I have the same Logitech Dinovo Edge bluetooth keyboard/trackpad. It also worked OOTB in Hardy but had failed in newer Ubuntu's.

I did the /etc/default/bluetooth HID2HCI_ENABLED=0 trick and that worked in Intrepid, but in jaunty, it gives intermittent problems where the trackpad works, but the keyboard is disabled or suddenly stops working until the dongle is unplugged, replugged.

I then changed HID2HCI_UNDO=1 to HID2HCI_UNDO=0 and that helped, but I would still get random keyboard disconnects.

I then edited /etc/init.d/bluetooth and changed HID2HCI_ENABLED=1 to HID2HCI_ENABLED=0 and that seems to have finally settled it down.

The only problem is that this work around disables the rest of normal bluetooth functions, but since it's a HTPC, I don't really need that ability at this time.

Steve Alexander (stevea) wrote :

My Logitech DiNovo Edge keyboard needed to be removed from the bluetooth-properties application, and reassociated, several times a day when I was using Jaunty.

I recently updated to the in-progress Karmic release, and it works fine.

Ville Ranki (ville-ranki) wrote :

Are you using it as a bluetooth mouse/kb or with the USB dongle provided with the keyboard?

The dongle looks like HID keyboard and mouse to PC, not a bluetooth dongle.

Dwayne Nelson (edn2) wrote :

Problem is back on Lucid -- unplugging and replacing doesn't fix it anymore -- I will check to see if the HID2HCI_ENABLED setting has changed.

Dwayne Nelson (edn2) wrote :

No "bluetooth" file in the /etc/default directory -- not sure where the file went but assuming this would mean default values were used. Will check later today whether restoring the file brings back the pre-Lucid functionality.

mvisa (mikko-puolikuu) wrote :

Stopped working in Lucid about a week ago. I cannot get it to connect _at all_. Worked fine before this. I use the included dongle, if that matters.

mvisa (mikko-puolikuu) wrote :

Just tested and verified, this definitely works on Jaunty (I have two of these keyboards, both work on two different Jaunty machines), but not on Lucid. Also the keyboard works in the Lucid-machine _before_ Ubuntu is loaded (I can get to the BIOS for instance), but after that it doesn't.

Wonder if the package is correct ie. bluez as this doesn't necessarily relate to bluetooth? AFAIK the dongle is seen as a normal USB input device to the OS.

managementboy (managementboy) wrote :

I can confirm, update from karmic to lucid disables previously working dinovo edge keyboard

tucker (t-alltheseworlds) wrote :

working great after adding and pairing it in system > preferences > bluetooth manager

Dwayne Nelson (edn2) wrote :

There was a question posted about this issue here:

https://answers.launchpad.net/ubuntu/+question/105987

I purchased a separate bluetooth dongle and was able to get my keyboard to sync by logging in from another computer and pairing the keyboard with the other dongle. The disadvantage of using this separate dongle is that I don't have access to the keyboard until the OS has loaded.

Hopefully the late April release will solve this as I wasn't happy about having to buy a separate bluetooth dongle and new users might never be able to sort the issue out.

Martin Rehn (minpost) wrote :

Confirming this on Lucid. The diNovo worked perfectly up to and including Karmic. Now it is completely dead. I actually thought the radio in the dongle was dead for a long while, until I plugged it into a Mac and it worked right away.

I tried pairing the keyboard in Blueman. I press the connect button on the keyboard after which it shows up in the list of devices, and then I try to pair it. No success. The attempt times out.

I tried the /etc/default/bluetooth thing. No success.

After pairing the dongle and keyboard on the Mac I get the diNovo to work in the bios and in Grub, but as soon as Linux boots up, it nukes the connection completely. This led me to try to uninstall and purge every package that had some shade of "blue" in it. That did not help.

<rant>I bought this keyboard knowing full well that bluetooth HID has never worked on Linux. That is why I got this clever model that presents itself as a keyboard/mouse rather than trying to do the bluetooth thing: As long as the OS does absolutely nothing everything should be fine. For a while Linux fell for it, and the shiny little keyboard worked, but at this point the penguin has apparently worked up the smarts to break the poor thing. Congratulations.</rant>

mvisa (mikko-puolikuu) wrote :

I have this working now thanks to previously mentioned launchpad answer: https://answers.launchpad.net/ubuntu/+question/105987

Did this:

1) System -> Preferences -> Bluetooth
2) Setup New Device
3) Forward, choose dinovo
4) Choose "0000" From PIN options
5) Press "connect" on the back of the dinovo
6) Type "0000" on the dinovo and press "Enter"

Steps 5) and 6) are missing from the answers link, figured those out from logitech forums..

That's it.

Although, after one reboot the pairing was lost, which is a bit annoying as you need another keybard to pair it again. Hope this was just due to Lucid being beta ...

Martin Rehn (minpost) on 2010-04-12
Changed in bluez (Ubuntu):
status: New → Confirmed
Martin Rehn (minpost) on 2010-04-14
description: updated
Martin Rehn (minpost) wrote :

I can't make mvisa's suggestion (#21) work. Whatever I do, the bluetooth LED just keeps flashing on the keyboard. The diNovo is still a total loss under Lucid, but only under Lucid.

Aryding (aryding) wrote :

Plugging the bluetooth dongle back into the USB port only gives me approximately 1 second of use before it turns off again. After several efforts of plugging it in and taking it out, I was able to enter my password and log in.

What I found is that the bluetooth manager was asking for me to allow my keyboard to connect. I do not have an extra mouse or keyboard to accept the security policy so Lucid continues to be worthless.

mvisa (mikko-puolikuu) wrote :

After some testing, still having problems with this. I can get it paired just ok using procedure above, BUT it frequently somehow "loses" the pairing. I have to get another keyboard and pair it AGAIN and AGAIN. Sigh.

tommy (yobbobandana) wrote :

Hi, the solution proposed in this comment seems to bring back the old behaviour and my DiNovo now works again, can you try it out with the DiNovo Edge?

https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/550288/comments/10

Mustis (mustis-welho) wrote :

Thanks, Tommy! That worked with my Dinovo Edge.

Martin G Miller (mgmiller) wrote :

After doing a 9.10 to 10.04 upgrade, I noticed on the first boot that a screen appeared asking for permission for my Logitch bluetooth keyboard/trackpad (Dinovo Edge) to connect. There was also a check box to "always remember" this setting.

Unfortunately, while I was reading it, after about 10 seconds, it timed out and closed. I could not figure out how to get that dialog back and the Dinovo edge did not work. I hooked up a Ps2 keyboard and mouse and followed the instructions in Post #25 by Tommy.

That worked and my Dinovo edge is back to normal. The file the instructions tell you to edit has a warning in it saying not to edit this file because it will be overwritten on subsequent upgrades, so this is just a temporary work around.

Assuming the dialog that showed on first boot would have fixed the issue, there should not be a timeout on it. It should stay up until dismissed. There should also be some way to get it to come back. Rebooting the machine did not help. Once timed out, the dialog will not come back. Also, even if it stayed on screen, you could not use the Dinovo Edge to click it, because it doesn't have permission to connect yet, so you need time to hook up another keyboard.

Why was the default changed in the 70-hid2hci.rules from hidraw to hiddev for 10.04? I assume there had to be a good reason, but it negatively impacts Logitech bluetooth keyboards.

tc7 (tc7) wrote :

Logitech Mx5000 Bluetooth keyboard stopped working after an upgrade from Karmic to Lucid.

Re-pairing the device got my keyboard running again, but stopped working on reboot / resume from suspend.
The temporary workaround was to unplug / plug in the bluetooth dongle.

Changing hiddev back to hidraw in 70-hid2hci.rules fixed this for me too.
thanks Tommy!

Now if I can only get my bluetooth keyboard working in grub (as it used to do some time ago) ...

Steven Lottes (slottes) wrote :

I have a DiNovo Edge and it was working in Grub.

Changing hiddev back to hidraw in 70-hid2hci.rules fixed this for me. I found the instructions here: https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/550288/comments/10

Comments in the header of 70-hid2hci.rules say not to edit because the file will be overwritten on updates.

So for now I apparently have to redo this fix every time an update overwrites the rules file.

I did not turn off bluetooth in the notification bar, but it disappeared. I have not tried to connect other bluetooth devices, such as my phone.

mvisa (mikko-puolikuu) on 2010-05-17
summary: - Bluetooth Logitech Dinovo Edge Keyboard/Mouse dones not work anymore
+ Bluetooth Logitech Dinovo Edge Keyboard/Mouse does not work anymore
Jack Deslippe (jdeslip) wrote :

I also have this problem with my DiNovo Edge. And the temporary fix worked for me as well. But, this is clearly a regression (users don't like it when their keyboard stops working after upgrading) and should be changed in the default install. The bug is not assigned to anybody. Does anyone know who to contact about this?

Unai Uribarri (unaiur) wrote :

The USB dongle that comes with the DiNovo Edge has a bug in its firmware. It crashes when the keyboard initiates the connection (when a key is pressed) and the connection is encrypted. If the host initiates the connection (when pairing) or the connection isn't encrypted (like in Windows XP), the dongle works okay.

There are two solutions to this problem:
 a. Buy another Bluetooth dongle without this problem
 b. Disable Bluetooth encryption
 c. Upgrade the dongle firmware (warning: this is dangerous).

My dongle has the firmware upgraded to version 2.1.238 and works flawlessly. The instructions to upgrade the firmware are here:

https://bugs.launchpad.net/ubuntu/+source/bluez-utils/+bug/151559/comments/11

arndtc (arndtc) wrote :

I just updated to Lucid this weekend and ran into this problem again. The comments by tommy solved the problem.

The latest post may actually explain this problem that appears to be seen by many different Logitech bluetooth keyboards. (I did a search and found quite a few different bug reports of various Logitech keyboards on Lauchpad). The problem I see is that the upgrade option is pretty risky, and there were no instructions provided for pairing the DiNovo Edge with another BT receiver so it will work at boot time, before Ubuntu is running. Or how to disable the Bluetooth encryption.

Since it seems that this is something that Windows can work around I would hope that Ubuntu could find a way to work around it as well.

arndtc (arndtc) wrote :

Also how do you find out what the firmware version is on your BT dongle?

braweheart (braweheart) wrote :

This worked for me (hope I remenber the steps correctly):
Rightclick BTicon, Configure
Press connect on the keyboard
Choose the kayboard and click next.
A code will appear.
Press and hold the connect button on the usb dongel
Enter the kode on the keyboard
Press enter.
Now you can let go of connect on the dongel.
Finished

TheFinePrint (rolmol) wrote :

Summary refers to Lucid beta. The problem is also present on Lucid final, as installed from the alternate CD. I only have diNovo-keyboards in my disposal, so even the workarounds are a bit of a hassle since I can't log on without some older live CD.

TheFinePrint (rolmol) wrote :

Both a google search and a local search in the bug database reveals that this is a recurring problem, and at least every other Ubuntu release breaks the keyboard support. This is particularly problematic because it's nearly impossible to fix without a second keyboard, and since most live CDs don't support cryptsetup and LVM. I ended up using System Rescue CD to perform the fix mentioned on the blog below. Note that it refers back to a different Launchpad bug.

Please include diNovo edge and other affected Logitech peripherals in the compatibility testing, so that we don't need all these unnecessary bug reports.

http://awesomelinux.blogspot.com/2010/05/ubuntu-1004-lucid-logitech-dinovo-edge.html
http://www.sysresccd.org/Main_Page
https://launchpad.net/+search?field.text=dinovo

arndtc (arndtc) wrote :

Just ran an update on Lucid and lost my Logitech DiNovo Edge keyboard again.

This time I tried braweheart's instructions, and that seemed to work. The real test is weather this survives a reboot, or another update.

Here is an update to the instructions from braweheart.

 - Left click on the BT icon and select Setup New Device...
 - Press connect on the keyboard.
 - Choose the BT keyboard (i.e. Logitech DiNovo Edge) and click next.
 - A code will appear.
 - Press and hold the connect button on the usb dongle.
 - Enter the kode on the BT keyboard.
 - Press enter.
 - Now you can let go of connect on the dongle.
 - Finished.

mvisa (mikko-puolikuu) wrote :

Lost the keyboard also after yesterdays update. Not very convenient.

braweheart (braweheart) wrote :

My method worked also on a new install, on the same computer thou.

My Dinovo are still working after yesterdays update, but I am running on the 2.6.34 kernel.

Oli Wade (olithered) wrote :

@braweheart: clicking on the icon is not possible when the mouse is part of the wireless keyboard setup. Changing hiddev to hidraw worked for me.

Martin G Miller (mgmiller) wrote :

This bug appears resolved in Maverick. I have tried both 32 bit and 64 bit versions of 10.10 and the Dinovo keyboard works perfectly with no configuration. They have rewritten the 70-hid2hci.rules to include both hidraw and hiddev lines for 2 different classes of Logitech devices. This seems to have done the trick.

Yes, all appears to be fine now with Maverick. Cheers.

Jamie P.

“Strange women lying in ponds distributing swords is no basis for a system of government. Supreme executive power derives from a mandate from the masses, not from some farcical aquatic ceremony.” — Dennis the Peasant, Monty Python and the Holy Grail

> Date: Fri, 15 Oct 2010 23:01:31 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 269851] Re: Bluetooth Logitech Dinovo Edge Keyboard/Mouse does not work anymore
>
> This bug appears resolved in Maverick. I have tried both 32 bit and 64
> bit versions of 10.10 and the Dinovo keyboard works perfectly with no
> configuration. They have rewritten the 70-hid2hci.rules to include both
> hidraw and hiddev lines for 2 different classes of Logitech devices.
> This seems to have done the trick.
>
> --
> Bluetooth Logitech Dinovo Edge Keyboard/Mouse does not work anymore
> https://bugs.launchpad.net/bugs/269851
> You received this bug notification because you are a direct subscriber
> of the bug.

Sam Brightman (sambrightman) wrote :

Fix needs backporting to Lucid - upgrade from Karmic still leaves me with no input devices with which to apply fixes/upgrade to Maverick.

Hi all.

I'm marking this as Fix Released, as Maverick works out-of-the box. Let's keep backports alive to package develpers decision.

Changed in bluez (Ubuntu):
status: Confirmed → Fix Released
Sam Brightman (sambrightman) wrote :

Once again, unsurprisingly, broken on upgrade. Mid-upgrade from Lucid to Maverick keyboard stopped working and flashes red Bluetooth light. What now? Into the roof to fetch the old keyboard for the fifth time?

Martin G Miller (mgmiller) wrote :

I also recently did a 9.10 to 10.04 to 10.10 upgrade (32 bit) on an old Dell notebook I decided to use as a HT computer. It only has a single USB 1.1 port that the dongle is plugged into. My Dinovo did not work until I finished the upgrade to 10.04, then it was fine and continued working fine throughout the upgrade process from 10.04 to 10.10, and continued to work as expected after the final upgrade. Although I did not need to, have you tried just unplugging and replugging the dongle? Did you try the buttons on the keyboard and dongle to make them see each other again? That may be all it takes.

wk (wkleedorfer) wrote :

not sure if this is the right place, but after upgrading from 11.10 to 12.04 yesterday i still had to manually change the udev rule (hiddev -> hidraw) to get the DiNovo working. Which is a pain in the ass since i always have to get an old keyboard from somewhere.

This happens to me every major update btw. not just this one (10.04 -> 10.10, 10.10 -> 11.04 ....)

Martin G Miller (mgmiller) wrote :

This has been an ongoing problem, so I find out where the changes are for the version I am about to upgrade to and then, after doing the upgrade, but before you reboot, make the needed changes while your keyboard is still working. Then when you reboot, it will continue to work and you don't have to go hunting for a wired keyboard.

Setting back to Incomplete since this doesn't actually appear to be fixed.

Can you please provide the exact change you're making to 97-bluetooth-hid2hci.rules and the output of lsusb? Seems to me like maybe the logitech rules include a device it shouldn't, and it should be adjusted so that the diNovo gets properly set in hidraw mode no matter what.

Thanks!

Changed in bluez (Ubuntu):
status: Fix Released → Incomplete
importance: Undecided → Medium
Martin G Miller (mgmiller) wrote :

This is what I am doing:
gksudo gedit /lib/udev/rules.d/97-bluetooth-hid2hci.rules

Look for the line under "# Logitech devices" that starts with:
KERNEL=="hiddev*"
and change it to:
KERNEL=="hidraw*"
The rest of the line is left as is. Save, restart.

Here is the output of lsusb:
~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:0b04 Logitech, Inc.
Bus 003 Device 003: ID 046d:c713 Logitech, Inc.
Bus 003 Device 004: ID 046d:c714 Logitech, Inc. diNovo Edge Keyboard

wk (wkleedorfer) wrote :

about the same as mgmiller:

original line /lib/udev/rules.d/97-bluetooth-hid2hci.rules:
14 KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]| c71[34bc]",
replaced with :
14 KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]| c71[34bc]",

relevant output of "lsusb -v" is:
Bus 002 Device 005: ID 046d:c714 Logitech, Inc. diNovo Edge Keyboard
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x046d Logitech, Inc.
  idProduct 0xc714 diNovo Edge Keyboard
  bcdDevice 49.00
  iManufacturer 1
  iProduct 2
  iSerial 3
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 34
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 4
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 98mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 1 Boot Interface Subclass
      bInterfaceProtocol 2 Mouse
      iInterface 0
        HID Device Descriptor:
          bLength 9
          bDescriptorType 33
          bcdHID 1.11
          bCountryCode 0 Not supported
          bNumDescriptors 1
          bDescriptorType 34 Report
          wDescriptorLength 301
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0008 1x 8 bytes
        bInterval 2

Changed in bluez (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
tommy (mesilliac) wrote :

This change to the source package should correctly support the diNovo Edge Keyboard,
without affecting other Logitech devices.

I've verified it works for me when applied manually to
 /lib/udev/rules.d/97-bluetooth-hid2hci.rules

I tried switching the :c713 device over too,
didn't seem to make a difference so i left it as is,
the keyboard and touchpad seem to work fine either way.

Can someone provide `lsusb` output for devices other than the keyboard?
It will need to be incorporated into the patch.

This is what mine shows up as:
    ID 046d:c714 Logitech, Inc. diNovo Edge Keyboard

=== modified file 'scripts/bluetooth-hid2hci.rules'
--- scripts/bluetooth-hid2hci.rules 2011-07-28 16:47:35 +0000
+++ scripts/bluetooth-hid2hci.rules 2012-07-24 10:45:29 +0000
@@ -11,7 +11,10 @@
   RUN+="hid2hci --method=dell --devpath=%p", ENV{HID2HCI_SWITCH}="1"

 # Logitech devices
-KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
+KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[3bc]", \
+ RUN+="hid2hci --method=logitech-hid --devpath=%p"
+# Logitech, Inc. diNovo Edge Keyboard
+KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c714", \
   RUN+="hid2hci --method=logitech-hid --devpath=%p"

 ENV{DEVTYPE}!="usb_device", GOTO="hid2hci_end"

Changed in bluez (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.101-0ubuntu3

---------------
bluez (4.101-0ubuntu3) quantal; urgency=low

  * debian/patches/dinovo_edge_keyboard.patch: support diNovo Edge
    keyboard. (LP: #269851)
 -- Tommy <email address hidden> Fri, 27 Jul 2012 15:15:48 +1200

Changed in bluez (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.