Packages failed archive rebuild test possibly due to python-central transition

Bug #204895 reported by Scott Kitterman on 2008-03-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
blogtk (Ubuntu)
Medium
Siegfried Gevatter
bzr-builddeb (Ubuntu)
Undecided
Reinhard Tartler
cfv (Ubuntu)
Undecided
Scott Kitterman
clive (Ubuntu)
Undecided
Unassigned
compizconfig-settings-manager (Ubuntu)
Medium
Siegfried Gevatter
elixir (Ubuntu)
Undecided
Unassigned
enthought-traits (Ubuntu)
Undecided
Albert Damen
enthought-traits-ui (Ubuntu)
Undecided
Unassigned
exo (Ubuntu)
Undecided
Cody A.W. Somerville
flickrfs (Ubuntu)
Medium
Scott Kitterman
gnuradio (Ubuntu)
Undecided
Unassigned
harvestman (Ubuntu)
Medium
Scott Kitterman
hippo-canvas (Ubuntu)
Undecided
Unassigned
jppy (Ubuntu)
Undecided
Nick Piper
lybniz (Ubuntu)
Undecided
Unassigned
mayavi2 (Ubuntu)
Undecided
Stephan Ruegamer
model-builder (Ubuntu)
Undecided
Stephan Ruegamer
oggconvert (Ubuntu)
Undecided
Luca Falavigna
psyco (Ubuntu)
Undecided
Unassigned
pybridge (Ubuntu)
Undecided
Scott Kitterman
pychess (Ubuntu)
Undecided
Scott Kitterman
pyflakes (Ubuntu)
Undecided
Stephan Ruegamer
pyopengl (Ubuntu)
Undecided
Unassigned
pyro (Ubuntu)
Undecided
Scott Kitterman
python-aptsources (Ubuntu)
Medium
Scott Kitterman
python-fuse (Ubuntu)
Undecided
Unassigned
python-kde4 (Ubuntu)
Undecided
Scott Kitterman
python-numpy (Ubuntu)
Undecided
Unassigned
python-omniorb2 (Ubuntu)
Undecided
Unassigned
python-pmw (Ubuntu)
Undecided
Scott Kitterman
python-scipy (Ubuntu)
Undecided
Unassigned
pyxplot (Ubuntu)
Undecided
Unassigned
quantlib-swig (Ubuntu)
Undecided
Unassigned
revelation (Ubuntu)
Undecided
Unassigned
schooltool (Ubuntu)
Undecided
Unassigned
screenlets (Ubuntu)
Undecided
Unassigned
service-discovery-applet (Ubuntu)
Undecided
Unassigned
simple-ccsm (Ubuntu)
Undecided
Unassigned
sonata (Ubuntu)
Undecided
Unassigned
speech-dispatcher (Ubuntu)
Undecided
Unassigned
sqlrelay (Ubuntu)
Undecided
Scott Kitterman
wammu (Ubuntu)
Undecided
Unassigned
willowng (Ubuntu)
Undecided
Scott Kitterman
wxglade (Ubuntu)
Undecided
Chris Brotherton
wxwidgets2.6 (Ubuntu)
Undecided
Unassigned
xapian-bindings (Ubuntu)
Undecided
Unassigned

Bug Description

python-central 0.6 uses now a package and tool independent directory
to store the architecture independent files. Files which were located
in /usr/share/pycentral/site-packages/<package> are now located in
/usr/share/pyshared. Your package apparently hardcodes the former
location in some places. Please fix the packaging to work with the new
file locations.

This issue also affects Debian and a number of packages in Debian have already
been updated. The affected packages may just need a synch/merge.

The packages listed as affected all failed a recent test rebuild of the
archive. It may or may not be a result of the python-central changes.
Attached it a list of the build numbers for each package. You can look up
the builds at:

http://builder.ubuntuwire.com:9998/job/X

 affects ubuntu/blogtk
 affects ubuntu/bzr-builddeb
 affects ubuntu/cfv
 affects ubuntu/clive
 affects ubuntu/compizconfig-settings-manager
 affects ubuntu/exo
 affects ubuntu/flickrfs
 affects ubuntu/gnuradio
 affects ubuntu/harvestman
 affects ubuntu/hippo-canvas
 affects ubuntu/jppy
 affects ubuntu/lybniz
 affects ubuntu/mayavi2
 affects ubuntu/model-builder
 affects ubuntu/oggconvert
 affects ubuntu/psyco
 affects ubuntu/pybridge
 affects ubuntu/pychess
 affects ubuntu/pyflakes
 affects ubuntu/pyopengl
 affects ubuntu/pyro
 affects ubuntu/python-aptsources
 affects ubuntu/python-fuse
 affects ubuntu/python-kde4
 affects ubuntu/python-numpy
 affects ubuntu/python-omniorb2
 affects ubuntu/python-scipy
 affects ubuntu/pyxplot
 affects ubuntu/quantlib-swig
 affects ubuntu/revelation
 affects ubuntu/schooltool
 affects ubuntu/screenlets
 affects ubuntu/service-discovery-applet
 affects ubuntu/simple-ccsm
 affects ubuntu/sonata
 affects ubuntu/speech-dispatcher
 affects ubuntu/sqlrelay
 affects ubuntu/wammu
 affects ubuntu/willowng
 affects ubuntu/wxglade
 affects ubuntu/wxwidgets2.6
 affects ubuntu/xapian-bindings

  +-------------------------------+-------+---------------------+--------+
| name | id | build_start | status |
+-------------------------------+-------+---------------------+--------+
| blogtk | 5883 | 2008-02-27 15:54:14 | 300 |
| bzr-builddeb | 9226 | 2008-02-29 01:02:21 | 300 |
| cfv | 9841 | 2008-02-29 08:21:11 | 300 |
| cfv | 20791 | 2008-03-13 00:31:00 | 300 |
| clive | 12556 | 2008-03-08 17:09:37 | 300 |
| compizconfig-settings-manager | 10759 | 2008-03-02 17:13:17 | 300 |
| exo | 11750 | 2008-03-03 09:30:20 | 300 |
| flickrfs | 10765 | 2008-03-02 17:16:55 | 300 |
| flickrfs | 21718 | 2008-03-14 10:51:33 | 300 |
| gnuradio | 839 | 2008-02-25 10:53:42 | 300 |
| harvestman | 6277 | 2008-02-27 18:48:15 | 300 |
| harvestman | 17230 | 2008-03-10 22:14:41 | 300 |
| hippo-canvas | 8147 | 2008-02-28 13:18:09 | 300 |
| hippo-canvas | 19101 | 2008-03-11 22:42:36 | 300 |
| jppy | 4084 | 2008-02-26 22:22:18 | 300 |
| lybniz | 21617 | 2008-03-14 09:36:08 | 300 |
| mayavi2 | 6723 | 2008-02-27 23:14:43 | 300 |
| mayavi2 | 17679 | 2008-03-11 04:09:16 | 300 |
| model-builder | 4881 | 2008-02-27 05:15:48 | 300 |
| model-builder | 15836 | 2008-03-10 06:19:56 | 300 |
| oggconvert | 16043 | 2008-03-10 09:45:29 | 300 |
| psyco | 5040 | 2008-02-27 07:19:26 | 300 |
| psyco | 15994 | 2008-03-10 08:57:03 | 300 |
| pybridge | 6570 | 2008-02-27 21:25:39 | 300 |
| pybridge | 17524 | 2008-03-11 01:53:18 | 300 |
| pychess | 20423 | 2008-03-12 18:03:20 | 300 |
| pyflakes | 22037 | 2008-03-14 14:44:05 | 300 |
| pyopengl | 21924 | 2008-03-14 13:22:02 | 300 |
| pyro | 8898 | 2008-02-28 21:59:22 | 300 |
| pyro | 19850 | 2008-03-12 10:09:13 | 300 |
| python-aptsources | 9571 | 2008-02-29 04:56:54 | 300 |
| python-aptsources | 20521 | 2008-03-12 19:47:16 | 300 |
| python-fuse | 22271 | 2008-03-14 17:24:55 | 300 |
| python-kde4 | 1738 | 2008-02-25 23:56:24 | 300 |
| python-kde4 | 12694 | 2008-03-08 19:01:25 | 300 |
| python-numpy | 1390 | 2008-02-25 18:34:15 | 300 |
| python-numpy | 12345 | 2008-03-08 12:26:53 | 300 |
| python-numpy | 23928 | 2008-03-14 22:17:35 | 300 |
| python-omniorb2 | 1076 | 2008-02-25 15:15:29 | 300 |
| python-omniorb2 | 12033 | 2008-03-08 08:49:39 | 300 |
| python-pmw | 14965 | 2008-03-10 01:12:56 | 300 |
| python-scipy | 9387 | 2008-02-29 02:56:21 | 300 |
| python-scipy | 20338 | 2008-03-12 16:39:48 | 300 |
| pyxplot | 8300 | 2008-02-28 15:15:23 | 300 |
| pyxplot | 19253 | 2008-03-12 01:16:33 | 300 |
| quantlib-swig | 11221 | 2008-03-02 23:21:39 | 300 |
| quantlib-swig | 22175 | 2008-03-14 16:21:30 | 300 |
| revelation | 3413 | 2008-02-26 14:19:10 | 300 |
| schooltool | 11622 | 2008-03-03 04:41:28 | 300 |
| schooltool | 22578 | 2008-03-14 20:34:50 | 300 |
| screenlets | 15847 | 2008-03-10 06:31:30 | 300 |
| service-discovery-applet | 21330 | 2008-03-14 05:22:44 | 300 |
| simple-ccsm | 11475 | 2008-03-03 02:35:15 | 300 |
| sonata | 16485 | 2008-03-10 14:32:14 | 300 |
| speech-dispatcher | 11752 | 2008-03-03 09:33:45 | 300 |
| sqlrelay | 14414 | 2008-03-09 12:04:17 | 300 |
| wammu | 16008 | 2008-03-10 09:07:17 | 300 |
| willowng | 4445 | 2008-02-27 01:11:04 | 300 |
| willowng | 15399 | 2008-03-10 03:31:10 | 300 |
| wxglade | 7609 | 2008-02-28 08:41:36 | 300 |
| wxglade | 18565 | 2008-03-11 16:10:53 | 300 |
| wxwidgets2.6 | 1543 | 2008-02-25 21:08:57 | 300 |
| xapian-bindings | 11384 | 2008-03-03 01:35:05 | 300 |
| xapian-bindings | 22339 | 2008-03-14 18:06:04 | 300 |
+-------------------------------+-------+---------------------+--------+

Scott Kitterman (kitterman) wrote :
Changed in python-kde4:
assignee: nobody → kitterman
status: New → In Progress
Changed in exo:
assignee: nobody → cody-somerville
status: New → Invalid
Olly Betts (ojwb) wrote :

I don't see where this is hardcoded in xapian-bindings - the only match for a grep for pycentral is where we call "dh_pycentral". If there is an error, please point out where it is and I will fix it in the debian packages I'll be preparing shortly.

The buildd failure is due to you trying to build xapian-bindings 1.0.4 against libxapian-dev 1.0.5 (which the build-deps don't allow), so I suspect xapian-bindings is a false positive.

On Friday 21 March 2008 21:51:42 Olly Betts wrote:
> I don't see where this is hardcoded in xapian-bindings - the only match
> for a grep for pycentral is where we call "dh_pycentral". If there is
> an error, please point out where it is and I will fix it in the debian
> packages I'll be preparing shortly.
>
> The buildd failure is due to you trying to build xapian-bindings 1.0.4
> against libxapian-dev 1.0.5 (which the build-deps don't allow), so I
> suspect xapian-bindings is a false positive.

Thanks for the quick and detailed response. It sounds like you are right.

Scott Kitterman (kitterman) wrote :

python-kde4 failure appears to have been caused by lack of build-dep on python-sip4 that's already been fixed.

Changed in python-kde4:
status: In Progress → Invalid
Changed in xapian-bindings:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pychess - 0.8~beta4-1ubuntu1

---------------
pychess (0.8~beta4-1ubuntu1) hardy; urgency=low

  * Adjust debian/rules so that it no longer removes the empty /usr/lib that
    python-central no longer creates (LP: #204895) so the package will build
  * Change maintainer to MOTU

 -- Scott Kitterman <email address hidden> Sat, 22 Mar 2008 00:01:26 -0400

Changed in pychess:
status: New → Fix Released
Scott Kitterman (kitterman) wrote :

Already fixed in python-scipy

Changed in python-scipy:
status: New → Fix Released
Scott Kitterman (kitterman) wrote :

Already fixed in python-numpy

Changed in python-numpy:
status: New → Fix Released
Changed in pybridge:
assignee: nobody → kitterman
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pybridge - 0.3.0-1ubuntu1

---------------
pybridge (0.3.0-1ubuntu1) hardy; urgency=low

  * Update pybridge-common.dirs to create a dir in pyshared instead of
    pycentral (LP: #204895)
  * Move binary-arch rules to binary-indep since packages are arch all
  * Move build-depends-indep python to build-depends to satisfy clean
  * Bump standards to 3.7.3 without further change
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Scott Kitterman <email address hidden> Sat, 22 Mar 2008 01:08:37 -0400

Changed in pybridge:
status: In Progress → Fix Released
Olly Betts (ojwb) wrote :

Is it possible to unsubscribe xapian-developers from this bug, now that it's acknowledged as not being a xapian bug? I can't see how to do it for myself.

I'm getting rather a lot of irrelevant email from this bug right now (and apologies to everyone else subscribed for this irrelevant email!)

Scott Kitterman (kitterman) wrote :

If you have an unsubscribe link I'd try that. It'd be on the left side near the top. I'd suggest filing bugs on Launchpad if you're unhappy with how it works. Sorry about this.

LaserJock (laserjock) wrote :

Olly, unfortunately that is Launchpad bug #83488 which I've added a link to your comment to.

Changed in oggconvert:
assignee: nobody → dktrkranz
status: New → In Progress
Reinhard Tartler (siretart) wrote :

bzr-builddeb seems to have suffered of a transient problem in bzr. http://builder.ubuntuwire.com:9998/job/20177 shows a successful build, so I'm invalidating this bugtask.

Changed in bzr-builddeb:
assignee: nobody → siretart
status: New → Invalid

I don't have an unsubscribe link on this page and I am getting a lot of emails I don't want from this bugreport... please fix this.

sam tygier (samtygier) wrote :

lybniz 1.3.2-2 from debian fixes this. see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=472015
http://code.google.com/p/bollin/source/detail?r=3023 shows the changes made.
do i need to file freeze exception and sync request bugs, or can someone just push this through?

Changed in pychess:
assignee: nobody → kitterman
Fahad Sadah (fahadsadah) wrote :

OK, I'm taking a random one on for myself!

Changed in mayavi2:
assignee: nobody → fahadsadah
status: New → In Progress
Fahad Sadah (fahadsadah) wrote :

mayavi2 has no source package.
Taking another!

Fahad Sadah (fahadsadah) wrote :

OK, unassigning.
I didn't read the comments, sorry.

Changed in blogtk:
assignee: nobody → rainct
importance: Undecided → Medium
status: New → In Progress
Fahad Sadah (fahadsadah) on 2008-03-22
Changed in mayavi2:
assignee: fahadsadah → nobody
status: In Progress → New
Julien Lavergne (gilir) wrote :
Siegfried Gevatter (rainct) wrote :

Nothing to fix in blogtk; build test was against an older version.

Changed in blogtk:
status: In Progress → Invalid
Changed in compizconfig-settings-manager:
assignee: nobody → rainct
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oggconvert - 0.3.1-2ubuntu1

---------------
oggconvert (0.3.1-2ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Fix LP: #204895
    Remaining changes:
    - Suggest gstreamer multiverse plugins

oggconvert (0.3.1-2) unstable; urgency=low

  * debian/rules:
    - Do not delete /usr/lib directory, this was due to a python-central
      bug, now solved (Closes: #472017).
  * debian/control:
    - Build-depend on python-central (>= 0.6).
    - s/Gnome/GNOME/, fix spelling-error-in-description lintian warning

 -- Luca Falavigna <email address hidden> Sat, 22 Mar 2008 17:08:14 +0100

Changed in oggconvert:
status: In Progress → Fix Released
Siegfried Gevatter (rainct) wrote :

There isn't any problem with compizconfig-settings-manager neither.

Changed in compizconfig-settings-manager:
status: In Progress → Invalid
Changed in pyro:
assignee: nobody → kitterman
status: New → In Progress
Onkar Shinde (onkarshinde) wrote :

Please find attached debdiff for sonata.

Changed in sonata:
assignee: nobody → onkarshinde
status: New → In Progress
assignee: onkarshinde → nobody
status: In Progress → Confirmed
Onkar Shinde (onkarshinde) wrote :

Please find attached debdiff for clive.

Changed in clive:
status: New → Confirmed
Onkar Shinde (onkarshinde) wrote :

Please find attached latest debdiff for sonata. Previous one didn't have maintainer field changes.

Onkar Shinde (onkarshinde) wrote :

Please find attached latest debdiff for clive. Previous one didn't have maintainer field changes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyro - 3.7-1ubuntu1

---------------
pyro (3.7-1ubuntu1) hardy; urgency=low

  [ Bernd Zeimetz ]
  * debian/control:
    - Adding Homepage field, removing pseudo-field from description
    - Rename XS-Vcs-* fields to Vcs-* (dpkg supports them now)
    - Updating my email address.

  [ Sandro Tosi ]
  * debian/control
    - uniforming Vcs-Browser field
    - bump Standards-Version to 3.7.3
    - bump versioned build-dep on python-central to at least 0.6
  * debian/copyright
    - converted to UTF-8
    - renamed copyright section to license
    - indented upstream author and license with 4 spaces
    - added copyright notice
  * debian/pyro-doc.doc-base
    - updated section
    - removed empty tailing lines
  * debian/pyro-gui.install
    - updated due to new python-central directories structure
  * debian/pyro.install
    - updated due to new python-central directories structure
  * debian/rules
    - updated due to new python-central directories structure (Closes:
      #472039)

  [ Scott Kitterman ]
  * Upload DPMT svn trunk to fix python-central related FTBFS (LP: #204895)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Scott Kitterman <email address hidden> Sat, 22 Mar 2008 13:43:55 -0400

Changed in pyro:
status: In Progress → Fix Released
Onkar Shinde (onkarshinde) wrote :

#

clive (0.4.3-1ubuntu1) hardy; urgency=low

  * debian/rules
    - Remove code to delete /usr/lib. Not needed anymore.
  * debian/control
    - Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Onkar Shinde < <email address hidden>> Sat, 22 Mar 2008 23:23:51 +0530

Changed in clive:
status: Confirmed → Fix Released
Onkar Shinde (onkarshinde) wrote :

#

sonata (1.4.2-1ubuntu1) hardy; urgency=low

  * debian/rules
    - Remove the command to delete /usr/lib. Not needed anymore.
  * debian/control
    - Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Onkar Shinde < <email address hidden>> Sat, 22 Mar 2008 23:22:55 +0530

Changed in sonata:
status: Confirmed → Fix Released

I think it is solved:

* debian/rules
   - Build API docs.
   - Add a binary-predeb rule to delete empty /usr/lib folder and bad
   theme folder.
   - Remove other rm and rmdir commands, handle by *.install files.
   - Fix 755 mode for svg and conf files.
   - Add screenletsd.1 in man pages.

Changed in screenlets:
status: New → Fix Released
Julien Lavergne (gilir) wrote :

No, it's not. Actually, it's this binary-predeb rule which cause the failure.
The debdiff to fix this : http://launchpadlibrarian.net/12694185/screenlets_0.0.12-0ubuntu2.debdiff

On Sat, 22 Mar 2008 19:38:01 -0000
Festor Wailon Dacoba <email address hidden> wrote:

> I think it is solved:
>
> * debian/rules
> - Build API docs.
> - Add a binary-predeb rule to delete empty /usr/lib folder and bad
> theme folder.
> - Remove other rm and rmdir commands, handle by *.install files.
> - Fix 755 mode for svg and conf files.
> - Add screenletsd.1 in man pages.
>
> ** Changed in: screenlets (Ubuntu)
> Status: New => Fix Released
>
> --
> Packages failed archive rebuild test possibly due to python-central transition
> https://bugs.launchpad.net/bugs/204895
> You received this bug notification because you are subscribed to
> screenlets in ubuntu.

Nick Piper (nick-launchpad) wrote :

The jppy build failure was due to a Python packaging bug: https://bugs.launchpad.net/ubuntu/+source/python2.5/+bug/196147

Changed in jppy:
assignee: nobody → nick-launchpad
status: New → Invalid

Can somebody unsubscribe pychess people from this bug? It is already fixed in pychess and I am getting lots of emails filling up my inbox from this report. It seems that I cannot unsubscribe it myself...

On Sat, 22 Mar 2008 22:56:01 -0000 Wouter Stomp <email address hidden>
wrote:
>Can somebody unsubscribe pychess people from this bug? It is already
>fixed in pychess and I am getting lots of emails filling up my inbox
>from this report. It seems that I cannot unsubscribe it myself...
>
No. This is a Launchpad problem. The bug number is referenced somewhere
here in the bug.

Changed in screenlets:
status: Fix Released → Confirmed
Changed in screenlets:
status: Confirmed → Fix Committed
Siegfried Gevatter (rainct) wrote :

Festor: Thanks for your patch, but not that the "Fix Committed" status means that a revision fixing the issue has already been uploaded to Ubuntu, not that a patch is available on the bug report.

Changed in screenlets:
status: Fix Committed → Confirmed
Siegfried Gevatter (rainct) wrote :

s/not/note

Onkar Shinde (onkarshinde) wrote :
Changed in lybniz:
status: New → Confirmed
Onkar Shinde (onkarshinde) wrote :

Builds fine with latest updates. Hence marking as invalid.

Changed in psyco:
status: New → Invalid
Albert Damen (albrt) wrote :

Please sponsor the update for hippo-canvas. This update builds and installs fine in a Hardy pbuilder.
A version bump for python-central is not needed. The same package builds and installs in a Gutsy pbuilder as well.

Changed in hippo-canvas:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package model-builder - 0.4.1-2ubuntu2

---------------
model-builder (0.4.1-2ubuntu2) hardy; urgency=low

  * debian/rules: Fixing pycentral FTBFS (LP: #204895)

 -- Stephan Hermann <email address hidden> Sun, 23 Mar 2008 22:44:24 +0100

Changed in model-builder:
status: Confirmed → Fix Released
Stephan Ruegamer (sadig) on 2008-03-23
Changed in model-builder:
assignee: nobody → shermann
status: New → Confirmed
Stephan Ruegamer (sadig) on 2008-03-23
Changed in mayavi2:
assignee: nobody → shermann
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mayavi2 - 2.0.2a1-4ubuntu1

---------------
mayavi2 (2.0.2a1-4ubuntu1) hardy; urgency=low

  * debian/rules: fix pycentral FTBFS (LP: #204895)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Stephan Hermann <email address hidden> Sun, 23 Mar 2008 23:02:43 +0100

Changed in mayavi2:
status: New → Fix Released
Stephan Ruegamer (sadig) on 2008-03-23
Changed in pyflakes:
assignee: nobody → shermann
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyflakes - 0.2.1+svn14502-1ubuntu1

---------------
pyflakes (0.2.1+svn14502-1ubuntu1) hardy; urgency=low

  * debian/rules: fixed pycentral FTBFS (LP: #204895)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Stephan Hermann <email address hidden> Sun, 23 Mar 2008 23:11:00 +0100

Changed in pyflakes:
status: Confirmed → Fix Released
Stephan Ruegamer (sadig) wrote :

builds fine for me

Changed in pyopengl:
status: New → Invalid
Changed in schooltool:
assignee: nobody → kitterman
status: New → In Progress
assignee: kitterman → nobody
status: In Progress → Invalid
Changed in screenlets:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in screenlets:
assignee: kitterman → nobody
status: In Progress → Fix Released
Changed in schooltool:
status: Invalid → Won't Fix
Changed in cfv:
assignee: nobody → kitterman
status: New → In Progress
Changed in flickrfs:
assignee: nobody → kitterman
importance: Undecided → Medium
status: New → In Progress
Changed in gnuradio:
status: New → In Progress
Changed in harvestman:
assignee: nobody → kitterman
importance: Undecided → Medium
status: New → In Progress
Changed in gnuradio:
status: In Progress → Invalid
Changed in hippo-canvas:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in lybniz:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in lybniz:
assignee: kitterman → nobody
status: In Progress → Fix Released
Changed in hippo-canvas:
assignee: kitterman → nobody
status: In Progress → Fix Released
Changed in python-aptsources:
assignee: nobody → kitterman
importance: Undecided → Medium
status: New → In Progress
Changed in python-aptsources:
status: In Progress → Invalid
Changed in python-fuse:
status: New → Invalid
Changed in python-omniorb2:
status: New → Invalid
Changed in pyxplot:
status: New → Invalid
Changed in cfv:
status: In Progress → Fix Released
Changed in flickrfs:
status: In Progress → Fix Released
Changed in harvestman:
status: In Progress → Fix Released
Stefan Ebner (sebner) on 2008-03-28
Changed in wammu:
assignee: nobody → sebner
status: New → In Progress
Stefan Ebner (sebner) wrote :

Debdiff for wammu. Builds fine here.

Changed in wammu:
assignee: sebner → nobody
status: In Progress → Confirmed
Stefan Ebner (sebner) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wammu - 0.25-2ubuntu1

---------------
wammu (0.25-2ubuntu1) hardy; urgency=low

  * debian/rules: Remove the rmdir for /usr/lib.
    Not necessary anymore. (LP: #204895)
  * debian/control:
  + Bump python-control versioning to python-central (>= 0.6)
  + Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Stefan Ebner <email address hidden> Fri, 28 Mar 2008 21:05:32 +0100

Changed in wammu:
status: Confirmed → Fix Released
Stefan Ebner (sebner) wrote :

revelation FTBFS was caused by an unmet depency on python-gnome2-desktop.

Changed in revelation:
status: New → Invalid
Albert Damen (albrt) wrote :

Speech-dispatcher has already been fixed, just after the build failure reported on ubuntuwire. It builds fine in a Hardy pbuilder.

speech-dispatcher (0.6.6-0ubuntu5) hardy; urgency=low

  * debian/patches/05_honour-environment.dpatch: Drop for now, proper integration
    work will be done in Intrepid.
  * debian/speech-dispatcher.profile.d: Drop, same as above.
  * Run as system service by default, this will change for intrepid.
  * debian/rules: Adjust for recent pycentral updates.

 -- Luke Yelavich <email address hidden> Wed, 05 Mar 2008 13:48:11 +1100

Changed in speech-dispatcher:
status: New → Invalid
Changed in wxwidgets2.6:
status: New → Invalid
Changed in python-pmw:
assignee: nobody → kitterman
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package elixir - 0.5.0-1ubuntu1

---------------
elixir (0.5.0-1ubuntu1) hardy; urgency=low

  * Update debian/rules not move egginfo since python-central handles it now
    (LP: #204895)
  * Bump python-central build-dep to 0.6
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Scott Kitterman <email address hidden> Sat, 29 Mar 2008 14:31:09 -0400

Changed in elixir:
status: New → Fix Released
Changed in quantlib-swig:
status: New → Invalid
Matti Lindell (mlind) wrote :

simple-ccsm task is invalid, current version (0.7.2-0ubuntu1) builds without problems. FTBFS version was 0.6.99+git20080112-0ubuntu1.

Changed in simple-ccsm:
status: New → Invalid
Matti Lindell (mlind) wrote :

service-discovery-applet was a false positive, current version (0.4.4-3) builds without problems.

Changed in service-discovery-applet:
status: New → Invalid
Albert Damen (albrt) on 2008-03-29
Changed in sqlrelay:
status: New → In Progress
Changed in willowng:
assignee: nobody → albrt
status: New → In Progress
Changed in sqlrelay:
assignee: nobody → albrt
Albert Damen (albrt) wrote :

Please sponsor this debdiff for sqlrelay.
The FTBFS was caused by the compiler flag -Wno-long-double, which seems to be caused by a change in gcc 4.2.3-2ubuntu2. See also the similar case with petsc in bug 199256.
As debian/rules already had the logic to use dpatch, I made the change to configure using dpatch and added dpatch as build-dependency.
The package builds fine in a Hardy pbuilder. By also patching config.mk.in and configure.in, the package also builds when autoreconf is used.

Changed in sqlrelay:
assignee: albrt → nobody
status: In Progress → Confirmed
Albert Damen (albrt) wrote :

Please sponsor attached debdiff for willowng.

Changed in willowng:
assignee: albrt → nobody
status: In Progress → Confirmed
Cesare Tirabassi (norsetto) wrote :

willowng: I have a package ready to upload already for this, but I want to check with amaranth first as he may want to do something more.

Changed in willowng:
assignee: nobody → norsetto
status: Confirmed → In Progress
Cesare Tirabassi (norsetto) wrote :

Ah, sorry, I see Albert is working on this, so, never mind me, go on with his debdiff.

Changed in willowng:
assignee: norsetto → nobody
status: In Progress → Confirmed
Changed in sqlrelay:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in willowng:
assignee: nobody → kitterman
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package willowng - 0.3-0ubuntu2

---------------
willowng (0.3-0ubuntu2) hardy; urgency=low

  * debian/willowng.install: install files from python2.4 or python2.5
    site-packages directory. Fixes FTBFS (LP: #204895).
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Albert Damen <email address hidden> Sat, 29 Mar 2008 21:29:58 +0100

Changed in willowng:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sqlrelay - 1:0.38-3ubuntu1

---------------
sqlrelay (1:0.38-3ubuntu1) hardy; urgency=low

  * patches/fix-wnolongdouble.dpatch: Remove test for -Wno-long-double
    from configure and don't use this flag. The test succeeded but compiling
    failed. Fixes FTBFS (LP: #204895).
  * Create patches/00list and add fix-wnolongdouble to it.
  * debian/rules: Add fix-wnolongdouble to debian_patches.
  * debian/control:
    - Add dpatch to Build-Depends
    - Modify Maintainer value to match the DebianMaintainerField
      specification.

 -- Albert Damen <email address hidden> Sat, 29 Mar 2008 20:12:11 +0100

Changed in sqlrelay:
status: In Progress → Fix Released
Albert Damen (albrt) wrote :

Please sponsor the attached debdiff for enthought-traits.
The package builds and installs fine in a Hardy pbuilder.
To prevent an installation error about missing files, the removal of the nspkg.pth files had to be done before dh_pycentral is called.

Changed in enthought-traits:
status: New → Confirmed
Albert Damen (albrt) wrote :

Sorry, that was not good yet. Will complete this tomorrow.

Changed in enthought-traits:
assignee: nobody → albrt
status: Confirmed → In Progress
Changed in enthought-traits-ui:
assignee: nobody → albrt
status: New → In Progress
Changed in wxglade:
assignee: nobody → protonchris
status: New → In Progress
Chris Brotherton (protonchris) wrote :

Looks like a new version of wxglade was just added to debian:

http://packages.debian.org/changelogs/pool/main/w/wxglade/current/changelog

The new debian package also appears to fix the python-central issue:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=472037

I will examine the differences in the current ubuntu package and the new debian package more closely tomorrow.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enthought-traits - 2.0.1b1-2ubuntu1

---------------
enthought-traits (2.0.1b1-2ubuntu1) hardy; urgency=low

  * debian/rules:
    - Update SITE_PACKAGES to match the new python-central directory
      structure. Fixes FTBFS (LP: #204895).
    - Move removal of nspkg.pth files from binary-predeb to
      python-install target, to prevent installation errors.
  * debian/control:
    - Bump minimum version of python-central to 0.6.
    - Modify Maintainer value to match the DebianMaintainerField
      specification.

 -- Albert Damen <email address hidden> Sat, 29 Mar 2008 21:52:03 +0100

Changed in enthought-traits:
status: In Progress → Fix Released
Albert Damen (albrt) wrote :

Please sponsor attached debdiff for enthought-traits-ui.
It builds and installs fine in a Hardy pbuilder.

Changed in enthought-traits-ui:
assignee: albrt → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enthought-traits-ui - 2.0.1b1-3ubuntu1

---------------
enthought-traits-ui (2.0.1b1-3ubuntu1) hardy; urgency=low

  * debian/rules:
    - Update SITE_PACKAGES to match new python-central directory
      structure. Fixes FTBFS (LP: #204895).
    - Remove nspkg.pth files in python-install target instead of
      binary-predeb target, to prevent installation errors.
    - Do not remove /usr/lib, this is now handled by python-central.
  * debian/control:
    - Bump minimum version of python-central to 0.6.
    - Modify Maintainer value to match the DebianMaintainerField
      specification.

 -- Albert Damen <email address hidden> Sun, 30 Mar 2008 14:25:23 +0200

Changed in enthought-traits-ui:
status: Confirmed → Fix Released
Chris Brotherton (protonchris) wrote :

Merge from debian unstable for wxglade.

Changed in wxglade:
status: In Progress → Fix Released
Changed in python-pmw:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.