ImportError: No module named _bsddb

Bug #196147 reported by Niall Creech
2
Affects Status Importance Assigned to Milestone
python2.4 (Ubuntu)
Undecided
Unassigned
python2.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python2.5

error running miro_1.1.2-0ubuntu2 on python2.5_2.5.2-0ubuntu4 on current hardy,

Traceback (most recent call last):
  File "/usr/bin/miro.real", line 129, in <module>
    startapp()
  File "/usr/bin/miro.real", line 59, in startapp
    import app
  File "/var/lib/python-support/python2.5/miro/app.py", line 51, in <module>
    import databaseupgrade
  File "/var/lib/python-support/python2.5/miro/databaseupgrade.py", line 39, in <module>
    from storedatabase import SavableObject
  File "/var/lib/python-support/python2.5/miro/storedatabase.py", line 68, in <module>
    import bsddb.db
  File "/usr/lib/python2.5/bsddb/__init__.py", line 51, in <module>
    import _bsddb
ImportError: No module named _bsddb

Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :

verbose python trace attached

Revision history for this message
sojourner (itsmealso2) wrote :

I'll confirm this also occurs on my system , hardy 64bit uptodate as of febuary 27.

Revision history for this message
Pedro Vanzella (ppvanzella) wrote :

Confirmed here, hardy 32bit, updated last february 26, when the bug appeared.

Matthias Klose (doko)
Changed in python2.4:
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.5 - 2.5.2-0ubuntu5

---------------
python2.5 (2.5.2-0ubuntu5) hardy; urgency=low

  * Build-depend on libdb4.2-dev on all architectures; 4.6 is seriously
    broken when used with the _bsddb extension. LP: #196147.

 -- Matthias Klose <email address hidden> Wed, 27 Feb 2008 18:33:53 +0100

Changed in python2.5:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.4 - 2.4.4-7ubuntu5

---------------
python2.4 (2.4.4-7ubuntu5) hardy; urgency=low

  * Build-depend on libdb4.2-dev on all architectures; 4.6 is seriously
    broken when used with the _bsddb extension. LP: #196147.

 -- Matthias Klose <email address hidden> Wed, 27 Feb 2008 18:39:55 +0100

Changed in python2.4:
status: In Progress → Fix Released
Curtis Hovey (sinzui)
affects: python → obsolete-junk
no longer affects: obsolete-junk
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers