Ubuntu

Banshee is unable to retrieve CDs information from MusicBrainz

Reported by Olivier PONCET on 2011-05-05
110
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Medium
Rhythmbox
Invalid
Undecided
Unassigned
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

the MusicBrainz querying policy has changed. now each request MUST provide a user-agent, and Banshee doesn't do this, so any requests are not honored.

Conclusion: we are unable to retreive CDs informations.

http://blog.musicbrainz.org/?p=839

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: banshee 2.0.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu May 5 21:50:53 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: No upgrade log present (probably fresh install)

Olivier PONCET (ponceto) wrote :
Olivier PONCET (ponceto) wrote :

MusicBrainz new Web Service Policy:

http://blog.musicbrainz.org/?p=839

Kamus (kamus) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=649507

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Olivier PONCET (ponceto) wrote :

According to Gabriel Burt [banshee developer], the bug seems to be already fixed in the banshee source code.

Does the patch will be included soon by the ubuntu banshee packaging team or must we wait for ubuntu 11.10 ?

Changed in banshee:
importance: Unknown → Medium
status: Unknown → Invalid
Kamus (kamus) wrote :

Upstream said that this issue is a duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=649401

Changed in banshee:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in banshee:
importance: Unknown → Medium
status: Unknown → Fix Released
Gabe Gorelick (gabegorelick) wrote :

This has been fixed upstream in their master branch, but I think this is a major enough usability bug that it should be backported into natty. Otherwise, users of the new default media player in Ubuntu will have to manually input album information, or use work arounds like the Last.fm fingerprint plugin (which is buggy itself).

Gabe Gorelick (gabegorelick) wrote :

For the record, these are the two relevant commits (on the 2.0 stable branch) that fix this upstream: http://git.gnome.org/browse/banshee/commit/?h=stable-2.0&id=7e756d97b13be1301c487375a5589060a8befb76 and http://git.gnome.org/browse/banshee/commit/?h=stable-2.0&id=727355c16234603734e33c16b713ccfffbcef972. Cherry picking these into natty should be no problem.

There's some news from MusicBrainz saying that the recent failures are NOT caused by User-Agent blocking: http://blog.musicbrainz.org/?p=888

Could somebody please file a bug with bugzilla.gnome.org, if necessary? I don't have an account there.

description: updated
Chris Metzler (cmetzler) wrote :

The change just made to the bug description appears wrong to me. In the Musicbrainz blog post linked to in the description, the Musicbrainz developers say that they are *not* dropping on the floor queries that don't identify a User-Agent; they are throttling them, but not failing to honor them. The Musicbrainz folks think the NGS change is a non-issue here.

Chris Metzler (cmetzler) wrote :

Whoops, sorry Pedro, I thought the description change included suggesting the NGS change is the source of the problem; but apparently that was in the original description. My apologies.

This appears to be the real deal:

http://tickets.musicbrainz.org/browse/MBS-2249

Note that the cause of the Banshee problems appears to be different than that of Sound Juicer and Rhythmbox.

Gabe Gorelick (gabegorelick) wrote :

From the aforementioned MusicBrainz ticket it appears that the real issue is the fact that (correct me if I'm wrong) MusicBrainz now returns multiple matching CDs per request more often, which Banshee cannot handle. This issue has been known for a while upstream [1].

Switching the upstream bug to this one.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=587264

Changed in banshee:
importance: Medium → Unknown
status: Fix Released → Unknown
Gabe Gorelick (gabegorelick) wrote :

As previously mentioned, the issue with Rhythmbox (and Sound Juicer and potentially other apps) is different from Banshee. The problem is that Rhythmbox uses an old version of libmusicbrainz that uses RDF queries, which MusicBrainz no longer supports. See http://tickets.musicbrainz.org/browse/MBS-2249 for more information. Unmarking bug 787475 as a duplicate.

Changed in rhythmbox:
status: New → Invalid
Changed in banshee:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in banshee:
status: Confirmed → Fix Released
Gabe Gorelick (gabegorelick) wrote :

This commit [1] fixes this upstream. It's very small and should be easy to cherry pick into natty.

[1] http://git.gnome.org/browse/banshee/commit/?id=ee467bdc

On 30/05/2011 06:05, Gabe Gorelick wrote:
> This commit [1] fixes this upstream. It's very small and should be easy
> to cherry pick into natty.
>
> [1] http://git.gnome.org/browse/banshee/commit/?id=ee467bdc
>

  affects ubuntu/banshee
  status fixcommitted

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: Triaged → Fix Committed
Gabe Gorelick (gabegorelick) wrote :

I can confirm that commit fixes the issue on banshee 2.0.0-2ubuntu2 (i.e. the version in natty). Can we get it into natty?

Chow Loong Jin (hyperair) wrote :

On 02/06/2011 12:18, Gabe Gorelick wrote:
> I can confirm that commit fixes the issue on banshee 2.0.0-2ubuntu2
> (i.e. the version in natty). Can we get it into natty?
>

Yeah, I can, but I need to first get Banshee approved for the Microrelease SRU
thing: https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions, so
that I can upload 2.0.1 together with this fix.

--
Kind regards,
Loong Jin

Gabe Gorelick (gabegorelick) wrote :

If the microrelease SRU will take too long, is it better to just do a regular SRU for the patch and then drop it when 2.0.1 gets uploaded? It looks kind of bad that the default music player in Ubuntu hasn't been able to get album information for a few months.

Chow Loong Jin (hyperair) wrote :

On 10/07/2011 00:41, Gabe Gorelick wrote:
> If the microrelease SRU will take too long, is it better to just do a
> regular SRU for the patch and then drop it when 2.0.1 gets uploaded? It
> looks kind of bad that the default music player in Ubuntu hasn't been
> able to get album information for a few months.
>

2.0.1 is already in natty-proposed. Perhaps you could test that version, and
also post your verification results in Bug #784179.

--
Kind regards,
Loong Jin

thoughton (thoughton) wrote :

This affects me too. In the meantime I've been using XBMC to rip my CDs instead.

But I must say I agree with the sentiments of some of the earlier commenters: it's disappointing how long it's taking for the existing patch to make its way out "to the masses", especially for such a key feature as the ability of a music application to fetch CD info.

Chow Loong Jin (hyperair) wrote :

Fixed in 2.1.3.

Changed in banshee (Ubuntu):
status: Fix Committed → Fix Released
frank (fhsmith) wrote :

This bug or one very similar appears to be back in 2.6.0 can someone please have a look?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.