Ubuntu

Rhythmbox [0.12.8] & [0.12.5] Not Fetching Album Information From MusicBrainz

Reported by Mikey M on 2011-05-24
372
This bug affects 74 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Confirmed
Undecided
Unassigned
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

May 24th, 2011

On my two Ubuntu machines Rhythmbox is not fetching album tagging information from MusicBrainz even though the information exists on the MusicBrainz database. I checked with the picard program I had on the machines. The CD lookup revealed the tagging information in picard.

Here are my machines:

Pentium D
Memory 2.9 GiB

9.10 [kernel 2.6.31-23-generic]
Rythmbox 0.12.5

libdiscid0 [Version: 0.1.0-1]
libmusicbrainz4c2a [Version: 2.1.5-2ubuntu1]
picard [Version: 0.11-2ubuntu3]

||||||

Core 2 Duo
Memory: 2.0 GiB

10.04 [kernel 2.6.32-31-generic]
Rythmbox 0.12.8

libdiscid0 [Version: 0.2.2-1]
picard [Version: 0.12.1-0ubuntu1]
libmusicbrainz4c2a [Version: 2.1.5-4]

I will check in over the next few weeks to provide more information if necessary.

Hope this helps,
Thanks,
Mike

Mikey M (leadexpert) wrote :

Just ran the --debug command and here is the output.

This CD could not be queried: Cannot find musicbrainz pages on server. Check your server name and port settings.
(03:33:31) [0x87eb028] [metadata_cb] rb-audiocd-source.c:767: ignoring CD metadata from fallback source

Mikey M (leadexpert) wrote :

The debug output says the same thing on both versions/machines.

To reproduce:

1. Insert a well known cd into the tray

2. Run rhythmbox --debug

3. Go to the CD section under the area titled "Devices"

4. Hit the "Reload Album Information" button.

5. Look at debug information.

Additionally:
I have also disabled the firewall and tried again. That method yielded the same results.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Mikey M (leadexpert) on 2011-05-24
Changed in rhythmbox (Ubuntu):
status: Confirmed → New
John Paton (john-paton) wrote :

I also have the same problem with Banshee which does not seem to be able to obtain album information from MusicBrainz. However if I manually set the album name and artist Banshee does find the album cover art.

Mikey M (leadexpert) on 2011-05-24
description: updated
Paul Beesley (paul-beesley42) wrote :

Also affecting SoundJuicer

Christian Keller: according to MusicBrainz this has NOTHING to do with User-Agent blocking. See <http://blog.musicbrainz.org/?p=888>.

Pedro Villavicencio (pedro) wrote :

according to the blog post, that's why it is not working, we can cherry pick the fix from upstream if there's one.

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Gabe Gorelick (gabegorelick) wrote :

As per [1], this is a different issue from what affected Banshee. That link says a simple packaging change could fix this.

[1] http://tickets.musicbrainz.org/browse/MBS-2249

Iiro R-J (irj-iki) wrote :

In my understanding:
- This is a high priority bug since all the standard ripping methods in Ubuntu 10.04 are affected (Sound-Juicer, Rhythmbox). Also K3b in the Kubuntu side has same broken dependency, but as it uses freedb.org as first priority, users are not directly affected...

-the fix should be easy:
Rhythmbox-plugins and sound-juicer are built with libmusicbrainz4c2a. This is an old version 2.1.5 with now removed interface. The dependency should be towards libmusicbrainz3 (=3.0.2) which includes the XML based interface.

I can not verify it, but I believe that Ubuntu 10.10 has already this dependency fixed.

Please note that Ubuntu 10.04 has plenty of other packages that can not work towards Musicbrainz after they removed old depreciated interface. For example python-musicbrainz, libkcddb4, kscd, prokyon3, muine, goobox, gmerlin...
These are minor issue, since they are not standard installed applications like Rhythmbox, but also mean that users have few easy alternatives to work-around.

Andy Extance (aextance) wrote :

I agree that this should be made a higher priority.

Dan Rollo (bha-worldnet) wrote :

This is a pretty big deal what something that used to work stops working in an LTS release. Any workarounds while we wait for a repackaging? I tried installing libmusicbrainz3-6, but it didn't help. I also couldn't figure out how to remove libmusicbrainz4c2a without having a bunch of rhythmbox stuff also getting removed. Are we just stuck until a fix is packaged?

Changed in rhythmbox (Ubuntu):
importance: Low → Medium

Is there a work around besides manual tagging?

Despite suggestion above that it may work with 10.10... Well, it does not, I just faced this issue. If I read it correctly, the problem is in libmusicbrainz4c2a and it looks like the same version is used in 10.10 and 11.04, i.e. the functionality is broken through the whole range of Ubuntu versions. I think this bug deserves higher priority.

I had one small spell where this resumed working under 10.04, but it stopped again. Later I installed 11.04 on a separate partition, and it also worked for a while, but it too has stopped. I tried to debug the problem (the README says "If the CD lookup is returning weird data, export MUSICBRAINZ_DEBUG before running sound-juicer to turn debugging on in MusicBrainz"), but that step had no discernible effect, and while debugging sound-juicer itself I found it difficult to figure out how the metadata was getting populated.

I too would like to see this given some attention by a knowledgeable expert.

A fixed sound-juicer executable was kindly posted by Philipp Wolfer under bug 455461 .

warjowuch (lulkoek) wrote :

Could a fix please also be released for the musicbraniz packages so rhythmbox/banshee etc can also profit from this?

I have the same problem with sound-juicer and Rhythmbox on Lucid Lynx. Sound juicer works for me now having installed the rebuilt packages against libmusicbrainz3.so.6 as described in bug 455461 - https://bugs.launchpad.net/ubuntu/+source/sound-juicer/+bug/455461. Is there any reason why the same cannot be done for Rhythmbox? Fixing this kind of thing really ought to be a high priority for an Ubuntu long term release.

The patch for sound-juicer adds three new direct build dependencies which includes two packages from universe. This means some sort of request to pull these packages into lucid's main may be required.

libmusicbrainz4-dev is in main, libmusicbrainz3-dev is in universe for lucid. libmusicbrainz3-dev is in main as of natty.

libdiscid0-dev is in universe for lucid, but in main for natty. I don't know if this was a sound-juicer specific dependency.

libneon27-dev is in main, but is it required to fix rhythmbox?

     Drew Daniels
Blog: http://www.boxheap.net/ddaniels/blog

Ewano (i-launchpad-ewano-net) wrote :

How long do we have to wait for the fix to move through the system into the 10.04 LTS?

I have a machine to build for a non computer literate friend, who I've finally managed to talk into trying out Ubuntu. I intend on giving him the latest LTS. He specifically wants to use this machine for managing an iPod and for ripping his cd collection.

I know the workaround (preferred option in some cases I'm sure) is to use something like Asunder to rip, and Rhythmbox to play and manage the collection - but this is not an optimum solution for a non technical user.

Should I set the system up to use Rhythmbox only and run the risk that the fix is still not propagated in the next few weeks, or set up ripping with an alternate ripper and run the risk that after I've set up his machine the fix will come though and I'll have to return and reconfigure his machine?

As previously stated, considering the heavy use that Ubuntu gets as a media playing solution - this really should have a higher priority.

A delay is fair enough if a bug is under investigation and a fix is being coded - but to delay a known fix from being distributed for over a month is just not acceptable in an LTS. How am I supposed to recommend Ubuntu to new users if this kind of fault is not fixed in a timely manner?

I wonder how long before he asks if he can just have M$oft XP and iTunes - which much as I hate to say it does seem to be the best solution right now for the job at hand...

Uberground (uberground) wrote :

Fixed in Rhythmbox source: http://git.gnome.org/browse/rhythmbox/commit/?id=1c2f40b58954be25d0ea31d008a6763997f96307

(I can confirm this error in Ubuntu 9.10 & 11.04, the HTTP requests being made to retrieve album details are returning a 404, see attachment)

Andy Extance (aextance) wrote :

So, is there a way for individual users to exploit the fixed Rhythmbox source code?

Changed in rhythmbox:
importance: Unknown → High
status: Unknown → Fix Released
Paul Crawford (psc-sat) wrote :

I am using 10.04 LTS with the "proposed" updates, but it is not fixed for me yet.

When you say "status: Unknown → Fix Released", how long until it appears in the LTS updates?

Paul Crawford (psc-sat) wrote :

It is now almost a month after "status: Unknown → Fix Released" was reported for this bug.

This still has not been fixed in the 10.04 LTS version.

Can anyone tell me when it will be fixed?

Can anyone tell me what the "support" in "Long Term Support" version is supposed to mean? Does anyone care?

I agree with Paul - it is a shame that it's taken so long to get this fix to end users.

Don't get me wrong, I applaud the work of the open source community and have the greatest respect for those who give their time to support open projects, however I suspect the slow turn-around of this particular case has disheartened a number of would-be Linux users and put people off using Rhythmbox and Ubuntu.

iheartubuntu (iheartubuntu) wrote :

Does not work in Banshee or Rhythmbox... 10.04 LTS and 10.10 versions. A fix would be awesome, thanks!

Andy (andy-akw) wrote :

Still not working with Rhythmbox or Banshee (using 11.04). Raised bug months ago, don't have knowledge to attempt to fix it, very frustrating. Seems to be regarded as just another bugs amongst thousands - wish there was a simple way to shout out that a KEY FEATURE ISN'T WORKING! As an earlier post suggested this could be a show-stopper for many users/potential users of Ubuntu.

iheartubuntu (iheartubuntu) wrote :

Even when it did work, some albums were not found. Im surprised that there are not options in preferences to switch data suppliers for CD info.

Paul Crawford (psc-sat) wrote :

The reason for my annoyance is not the community that has worked on this, after all there is a patch (even if not completely working?) but that cananonical has done nothing to push this out to users, not even as 'proposed' for testing.

And it is not just things like the music player, that you might assume is not important. Bugs of a serious nature such as bug #669808 have had nothing done 6 months after they are accepted, and LONG after the community had patched them.

Tim McCormack (phyzome) wrote :

In Ubuntu 11.04 (Natty Narwhal), sound-juicer works. The interface for selecting between the possible matches is pretty sparse, but it works. sound-juicer will appear as "Audio CD Extractor" in the context menu.

TJ (tj) wrote :

Removed the upstream bug-watch since that only fixes in trunk (currently 0.13.3). This report is for versions <=0.12.8 in 10.04 Long Term Support affected by a change in the MusicBrainz remote API and consequent breaking of the libmusicbrainz lookups.

Changed in rhythmbox:
importance: High → Undecided
status: Fix Released → New
status: New → Confirmed
Dan Rollo (bha-worldnet) wrote :

Urgh. So why is importance "Undecided"? As I've mentioned in a prior post, a regression of a feature in a LTS release is a big deal.

Also, according to post: https://bugs.launchpad.net/rhythmbox/+bug/787475/comments/20 (#20), the fix is included in the Rhythmbox source tree already, so theoretically, posting an updated version of this app in the LTS repo will fix this. How hard would it be to make an updated version of Rhythmbox available in a LTS 'testing' repo? Then we (the people writing these comments...) could try out the fix and report here if it works? (Or am I over simplifying things?)

Given the amount of times this bug has been reviewed/reclassified, it seems a new version could have been posted to testing repo for the same effort.

TJ (tj) wrote :

Hey Dan.

When I get a few minutes I'm going to investigate the most appropriate fix for this, which for an LTS must meet the Stable Release Update (SRU) requirements of being minimally invasive and demonstrably not introducing potential regressions in other areas.

Simon Déziel (sdeziel) wrote :

@TJ, a fix for Lucid would be very appreciated, thanks for looking into this. I'll be available to test if/when you need it.

nescient (nextbutone) wrote :

I've just tried using music cds in Banshee and Rhythmbox on Ubuntu 11.10 and both fail to recognise my music cd. What is going on here? In the 21st century the ability to identify and rip a cd is generally considered to be basic functionality. I am somewhat disappointed that Ubuntu distributes such rubbish software.

There's clearly been too much time wasted on a Unity interface that fewer people want and not enough resources allocated to fixing basic faults.

Why is the Importance/Assigned categories still set to Medium/Unnasigned? Does Canonical want Ubuntu to appeal to music lovers or not?

PS I don't want anyone to be upset by my rant, I just feel that it has to be said.

Timo Aaltonen (tjaalton) wrote :

So this is fixed in 11.10-> and the problem with getting a fix for lucid, maverick and natty is that rhythmbox is in main whereas libmusicbrainz3-6 is in universe. I'm not sure it's possible to provide a SRU rebuilding rhythmbox against the newer lib, but a backport might be possible.

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Changed in rhythmbox (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
Doug McMahon (mc3man) wrote :

Timo Aaltonen (tjaalton) wrote >
>So this is fixed in 11.10->
Well it's not fixed here in 11.10 though it has been in 12.04 . since one of the 290 git builds

As mentioned in other report can't see how it could be working in 11.10, ck the build logs for the latest builds in oneriric-proposed, while libmusicbrainz3-6 is a build-dep, support for musicbrainz is not enabled & there is no install dep on it.

"checking for MUSICBRAINZ3... no"
"configure: MusicBrainz support is disabled"

w

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu Maverick):
status: New → Confirmed
Changed in rhythmbox (Ubuntu Natty):
status: New → Confirmed
Ralph Hyre (launchpooh) wrote :

Launcpad generally needs some attention- I was getting segmentation faults until I reinstalled, though it didn't improve MusicBrainz lookups.

I understand why more a more flexible lookup system like MusicBrainz is needed, but not at the expense of perceived stability. A more detailed error message, with options to retry the lookup if a 404 error is returned, should be provided

Marco Massenzio (m-massenzio) wrote :

Has this been fixed yet for Maverick (10.10)?

This is somehow ridiculous, folks - the change by MusicBrainz was fully reasonable, and the fix probably trivial: a full year on and Rhytmbox is still broken for us on 10.10.

As others have said, this is a functionality we take for granted on our Macs (much as I personally hate iTunes) and even Windoze machines.... and which we used to have on our Ubuntu boxes.

Probably a one-day fix, and it's been here for almost a year now?

PS - this is also one of the reasons I haven't upgraded to 11.x (and most likely won't to 12.x either): I'm comfortable with the stuff that works now, and have no confidence that it will continue to work if I upgrade.
Eye candy is all well and good, but it's the basic functionality that ought to be taken care of first and foremost.

Marco Massenzio (m-massenzio) wrote :

So, I'm running RB 0.13 (maverick 10.10)
the package sources versioning is a bit confusing:

http://ftp.acc.umu.se/pub/GNOME/sources/rhythmbox/
after 0.13, there's 2.95 - what happened to all in-between?

be that as it may, ./configure fails because it's missing gobject-introspection-1.0

On Maverick, sudo apt-get install gobject-introspection finds version 0.9.3, so that's not viable.
Would it be possible to have either a patch or a build that fixes the nonsense with MusicBrainz?

I fully understand the politics and the bureacracy of LTS and the SRU - but if the RB developers could post someplace a patch for the 0.13 (call it 0.13a) version, we could build it ourselves and be done with all this nonsense...

Thanks in advance, as others have said, we all fully appreciate people dedicating their time and effort to freely available software, and it's all the more frustrating when minor annoyances stop us, the users, to fully enjoy a great product!

Still NOT FIXED in Rhythmbox 2.90.1 on Ubuntu 11.10.

Banshee on the same machine looks up album information without problems, as does Rhythmbox on my Debian Testing machine.

Not fixed for me either, i'm running Ubuntu 11.10, Rhythmbox 2.90.1. Are there any workarounds available while we wait for the permanent fix?

On Sun, Apr 8, 2012 at 03:24, Jaakko Hartikainen
<email address hidden>wrote:

> Not fixed for me either, i'm running Ubuntu 11.10, Rhythmbox 2.90.1. Are
> there any workarounds available while we wait for the permanent fix?
>
> Sure:
get a Mac laptop, or befriend someone with an iMac - use iTunes to rip the
CD to MP3 and then move it to your NAS/Linux box :)

(the disturbing bit is that, AFAICT, Rhytmbox is still viewed by Canonical
as the "the" digital player app for 12.04 - whilst, for all intents and
purposes, I think it can be considered an 'abandoned' project...)

> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/787475
>
> Title:
> Rhythmbox [0.12.8] & [0.12.5] Not Fetching Album Information From
> MusicBrainz
>
> Status in The Rhythmbox Music Management Application:
> Confirmed
> Status in “rhythmbox” package in Ubuntu:
> Fix Released
> Status in “rhythmbox” source package in Lucid:
> Triaged
> Status in “rhythmbox” source package in Maverick:
> Confirmed
> Status in “rhythmbox” source package in Natty:
> Confirmed
>
> Bug description:
> May 24th, 2011
>
> On my two Ubuntu machines Rhythmbox is not fetching album tagging
> information from MusicBrainz even though the information exists on the
> MusicBrainz database. I checked with the picard program I had on the
> machines. The CD lookup revealed the tagging information in picard.
>
> Here are my machines:
>
> Pentium D
> Memory 2.9 GiB
>
> 9.10 [kernel 2.6.31-23-generic]
> Rythmbox 0.12.5
>
> libdiscid0 [Version: 0.1.0-1]
> libmusicbrainz4c2a [Version: 2.1.5-2ubuntu1]
> picard [Version: 0.11-2ubuntu3]
>
> ||||||
>
> Core 2 Duo
> Memory: 2.0 GiB
>
> 10.04 [kernel 2.6.32-31-generic]
> Rythmbox 0.12.8
>
> libdiscid0 [Version: 0.2.2-1]
> picard [Version: 0.12.1-0ubuntu1]
> libmusicbrainz4c2a [Version: 2.1.5-4]
>
> I will check in over the next few weeks to provide more information if
> necessary.
>
> Hope this helps,
> Thanks,
> Mike
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/rhythmbox/+bug/787475/+subscriptions
>

Dngrsone (dngrsone) wrote :

This is still a problem in Ubuntu 12.04-desktop-amd64.

MusicBrainz lookup works fine in Rhythmbox 2.96 in 12.04 32 bit. I'll be
setting up an AMD64 machine soon and verify Dngrsone's comment.

Dngrsone, did you verify this with several CDs? Some discs in
MusicBrainz' database lack CD TOCs and thus can't be looked up. Does CD
lookup work with Picard?

Am 22.05.2012 05:02, schrieb Dngrsone:
> This is still a problem in Ubuntu 12.04-desktop-amd64.
>

Dngrsone (dngrsone) wrote :

I have tried several CDs, several different times.

I am running Ubuntu-desktop-12.04-amd64 (originally beta2) on an HP G72 laptop with Intel dual-core T4500 processor and 8GB RAM.

Picard detects CDs just fine (CD under test, 4 Non Blondes), but Rhythmbox cannot detect (Rhythmbox v 2.96).

When I installed 12.04beta2 in early April, I had installed and tried using Banshee but that program was a frequent crasher, so I went back to Rhythmbox. If Banshee is more stable now and will detect CDs, then I will go to it (I prefer Banshee, actually). At the moment, I have to resort to booting into Win7 just to rip my music.

Glenn Moloney (g-moloney) wrote :

My daughter is running 12.04 64 bit & it picks up CD info no worries. Unless it's to do with installing 12.04 from beta 2? Maybe create a bootable USB of release 12.04 64bit, boot off the USB then insert a CD & see what Rhythmbox does as a suggestion??? Just wish correct the fault for 10.04.

Dngrsone: MusicBrainz CD lookup works fine in Rhythmbox 2.96 on my Ubuntu 12.04 64 bit machine.

Dngrsone (dngrsone) wrote :

I uninstalled Rhythmbox, rebooted the machine and reinstalled, still not happy. I will download a fresh 12.04 .iso and see if it works any better...

Dngrsone (dngrsone) wrote :

Okay, booted ubuntu-12.04-desktop-amd64.iso from a USB drive; Rhythmbox still does not recognize a CD (in this case Limp Bizkit Hitz, recognnized by Banshee).

Philip Kovac (pkovac) wrote :

Still affects me on Ubuntu 10.04 Desktop AMD64. Is it really just a user agent change? Could a patched libmusicbrainz 3 really fix it?

Philip Kovac (pkovac) wrote :

Sorry, shouldn't have opened my mouth before I read more in-depth. Nontrivial change indeed :( Has anything been looked at for resolving the bureacratic concerns with adding dependencies, moving things in main, etc?

Still broken as of 2012-08-19 on my just-updated copy of Ubuntu (12.04 LTS Precise Pangolin).

karlos001 (kdt411) wrote :

I'm having the same problem and I have a 32 bit version of ubuntu 12.04. Usually the first cd's meta data is found fine, after ripping and ejecting this cd I then have problems. Sometimes it works if I hit reload sometimes it doesn't and, usually, if it doesn't then rhythmbox completely shuts itself down. Very frustrating.

The other thing I've noticed is that the little progress/search bar that is on when I put the first cd in doesn't appear when I hit reload for the second cd.

Adolfo Jayme (fitoschido) wrote :

(Untargetting old, EOLd releases)

no longer affects: rhythmbox (Ubuntu Lucid)
no longer affects: rhythmbox (Ubuntu Maverick)
no longer affects: rhythmbox (Ubuntu Natty)
TonyR (rooneyo) wrote :

Hello

This is basic and essential functionality so how on earth can his be left for so long unfixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.