Bacula fails to install correctly if mysql wasn't installed before

Bug #321091 reported by Phil on 2009-01-25
612
This bug affects 99 people
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Medium
Unassigned
bacula (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: bacula

Préconfiguration des paquets...
Sélection du paquet bacula-common précédemment désélectionné.
(Lecture de la base de données... 293299 fichiers et répertoires déjà installés.)
Dépaquetage de bacula-common (à partir de .../bacula-common_2.4.2-1ubuntu6_i386.deb) ...
Adding user 'bacula'... Ok.
Sélection du paquet bacula-console précédemment désélectionné.
Dépaquetage de bacula-console (à partir de .../bacula-console_2.4.2-1ubuntu6_i386.deb) ...
Traitement des « déclenchements (triggers) » pour « man-db »...
Paramétrage de bacula-common (2.4.2-1ubuntu6) ...

Sélection du paquet bacula-director-common précédemment désélectionné.
(Lecture de la base de données... 293423 fichiers et répertoires déjà installés.)
Dépaquetage de bacula-director-common (à partir de .../bacula-director-common_2.4.2-1ubuntu6_i386.deb) ...
Sélection du paquet libnet-daemon-perl précédemment désélectionné.
Dépaquetage de libnet-daemon-perl (à partir de .../libnet-daemon-perl_0.38-1.1_all.deb) ...
Sélection du paquet libplrpc-perl précédemment désélectionné.
Dépaquetage de libplrpc-perl (à partir de .../libplrpc-perl_0.2017-1.1_all.deb) ...
Sélection du paquet libdbi-perl précédemment désélectionné.
Dépaquetage de libdbi-perl (à partir de .../libdbi-perl_1.605-1_i386.deb) ...
Sélection du paquet libdbd-mysql-perl précédemment désélectionné.
Dépaquetage de libdbd-mysql-perl (à partir de .../libdbd-mysql-perl_4.007-1build1_i386.deb) ...
Sélection du paquet mysql-client-5.0 précédemment désélectionné.
Dépaquetage de mysql-client-5.0 (à partir de .../mysql-client-5.0_5.0.67-0ubuntu6_i386.deb) ...
Sélection du paquet mysql-client précédemment désélectionné.
Dépaquetage de mysql-client (à partir de .../mysql-client_5.0.67-0ubuntu6_all.deb) ...
Sélection du paquet bacula-director-mysql précédemment désélectionné.
Dépaquetage de bacula-director-mysql (à partir de .../bacula-director-mysql_2.4.2-1ubuntu6_i386.deb) ...
Sélection du paquet bacula-sd précédemment désélectionné.
Dépaquetage de bacula-sd (à partir de .../bacula-sd_2.4.2-1ubuntu6_i386.deb) ...
Sélection du paquet mysql-server-5.0 précédemment désélectionné.
Dépaquetage de mysql-server-5.0 (à partir de .../mysql-server-5.0_5.0.67-0ubuntu6_i386.deb) ...
Sélection du paquet libhtml-template-perl précédemment désélectionné.
Dépaquetage de libhtml-template-perl (à partir de .../libhtml-template-perl_2.9-1_all.deb) ...
Sélection du paquet bacula-sd-mysql précédemment désélectionné.
Dépaquetage de bacula-sd-mysql (à partir de .../bacula-sd-mysql_2.4.2-1ubuntu6_i386.deb) ...
Sélection du paquet bacula-server précédemment désélectionné.
Dépaquetage de bacula-server (à partir de .../bacula-server_2.4.2-1ubuntu6_all.deb) ...
Sélection du paquet bacula-fd précédemment désélectionné.
Dépaquetage de bacula-fd (à partir de .../bacula-fd_2.4.2-1ubuntu6_i386.deb) ...
Sélection du paquet bacula-client précédemment désélectionné.
Dépaquetage de bacula-client (à partir de .../bacula-client_2.4.2-1ubuntu6_all.deb) ...
Sélection du paquet bacula précédemment désélectionné.
Dépaquetage de bacula (à partir de .../bacula_2.4.2-1ubuntu6_all.deb) ...
Sélection du paquet bacula-traymonitor précédemment désélectionné.
Dépaquetage de bacula-traymonitor (à partir de .../bacula-traymonitor_2.4.2-1ubuntu6_i386.deb) ...
Sélection du paquet mysql-server précédemment désélectionné.
Dépaquetage de mysql-server (à partir de .../mysql-server_5.0.67-0ubuntu6_all.deb) ...
Traitement des « déclenchements (triggers) » pour « man-db »...
Paramétrage de bacula-console (2.4.2-1ubuntu6) ...

Paramétrage de bacula-director-common (2.4.2-1ubuntu6) ...

Paramétrage de libnet-daemon-perl (0.38-1.1) ...
Paramétrage de libplrpc-perl (0.2017-1.1) ...
Paramétrage de libdbi-perl (1.605-1) ...
Paramétrage de libdbd-mysql-perl (4.007-1build1) ...
Paramétrage de mysql-client-5.0 (5.0.67-0ubuntu6) ...
Paramétrage de mysql-client (5.0.67-0ubuntu6) ...
Paramétrage de bacula-director-mysql (2.4.2-1ubuntu6) ...
 * Stopping Bacula Director:
   ...done.
 * Starting Bacula Director:
25-jan 11:11 bacula-dir: ERROR TERMINATION at parse_conf.c:829
Erreur de config : Impossible d'ouvrir le fichier de configuration « /etc/bacula/bacula-dir.conf » : Aucun fichier ou dossier de ce type

   ...fail!
dpkg : erreur de traitement de bacula-director-mysql (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de bacula-sd (2.4.2-1ubuntu6) ...

Paramétrage de mysql-server-5.0 (5.0.67-0ubuntu6) ...
 * Stopping MySQL database server mysqld
   ...done.
Reloading AppArmor profiles : done.
 * Starting MySQL database server mysqld
   ...done.
 * Checking for corrupt, not cleanly closed and upgrade needing tables.

Paramétrage de libhtml-template-perl (2.9-1) ...
Paramétrage de bacula-sd-mysql (2.4.2-1ubuntu6) ...
dpkg : des problèmes de dépendances empêchent la configuration de bacula-server :
 bacula-server dépend de bacula-director-mysql (>= 2.4.2-1ubuntu6) | bacula-director ; cependant :
 Le paquet bacula-director-mysql n'est pas encore configuré.
  Le paquet bacula-director n'est pas installé.
  Le paquet bacula-director-sqlite qui fournit bacula-director n'est pas installé.
  Le paquet bacula-director-mysql qui fournit bacula-director n'est pas encore configuré.
dpkg : erreur de traitement de bacula-server (--configure) :
 problèmes de dépendances - laissé non configuré
No apport report written because the error message indicates its a followup error from a previous failure.
                          Paramétrage de bacula-fd (2.4.2-1ubuntu6) ...

Paramétrage de bacula-client (2.4.2-1ubuntu6) ...
dpkg : des problèmes de dépendances empêchent la configuration de bacula :
 bacula dépend de bacula-server ; cependant :
 Le paquet bacula-server n'est pas encore configuré.
dpkg : erreur de traitement de bacula (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de bacula-traymonitor (2.4.2-1ubuntu6) ...
No apport report written because the error message indicates its a followup error from a previous failure.

Paramétrage de mysql-server (5.0.67-0ubuntu6) ...
Des erreurs ont été rencontrées pendant l'exécution :
 bacula-director-mysql
 bacula-server
 bacula
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquet n'a pas pu être installé. Tentative de récupération :
Paramétrage de bacula-director-mysql (2.4.2-1ubuntu6) ...
 * Stopping Bacula Director:
   ...done.
 * Starting Bacula Director:
25-jan 11:12 bacula-dir: ERROR TERMINATION at parse_conf.c:829
Erreur de config : Impossible d'ouvrir le fichier de configuration « /etc/bacula/bacula-dir.conf » : Aucun fichier ou dossier de ce type

   ...fail!
dpkg : erreur de traitement de bacula-director-mysql (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de bacula-server :
 bacula-server dépend de bacula-director-mysql (>= 2.4.2-1ubuntu6) | bacula-director ; cependant :
 Le paquet bacula-director-mysql n'est pas encore configuré.
  Le paquet bacula-director n'est pas installé.
  Le paquet bacula-director-sqlite qui fournit bacula-director n'est pas installé.
  Le paquet bacula-director-mysql qui fournit bacula-director n'est pas encore configuré.
dpkg : erreur de traitement de bacula-server (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de bacula :
 bacula dépend de bacula-server ; cependant :
 Le paquet bacula-server n'est pas encore configuré.
dpkg : erreur de traitement de bacula (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 bacula-director-mysql
 bacula-server
 bacula

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: le sous-processus post-installation script a retourné une erreur de sortie d'état 1
NonfreeKernelModules: nvidia
Package: bacula-director-mysql 2.4.2-1ubuntu6
SourcePackage: bacula
Title: package bacula-director-mysql 2.4.2-1ubuntu6 failed to install/upgrade: le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Uname: Linux 2.6.27-9-generic i686

Phil (exo188) wrote :
Andreas Olsson (andol) wrote :

I can confirm this.

It happens when you install bacula without having a previously installed mysql server. The problem is that bacula-director-mysql tries its run its configuration before the new mysql server has been started.

Workarounds:
pre-install) Make sure you have a mysql installed before you install bacula
post-install) purge and reinstall the packages becula and bacula-director-mysql

Changed in bacula:
status: New → Confirmed
Ante Karamatić (ivoks) wrote :

As with bug #325109, this can be fixed by simply running 'dpkg --configure -a', after mysql is started.

Changed in bacula:
importance: Undecided → Medium
status: Confirmed → Triaged
Ante Karamatić (ivoks) wrote :

Actually, no... After having a better look at this one, problem is in /usr/share/bacula-director/postinst-common:

if [ -f $DSTDIR/$CONFIG.dpkg-tmp ]; then
    SOURCE=$DSTDIR/$CONFIG.dpkg-tmp
else
    SOURCE=$DSTDIR/$CONFIG
fi

This should be:

if [ -f $DSTDIR/$CONFIG.dpkg-tmp ]; then
    SOURCE=$DSTDIR/$CONFIG.dpkg-tmp
else
    SOURCE=$DEFCONFIGDIR/$CONFIG
fi

This is fixed in jaunty.

Ante Karamatić (ivoks) wrote :

I believe this bug is fixed in ubuntu-bacula PPA for intrepid and hardy:

https://edge.launchpad.net/~ubuntu-bacula/+archive/ppa

and for those that would like to have bacula packages for hardy backported from intrepid, they are at my personal PPA:

https://edge.launchpad.net/~ivoks/+archive/ppa

Please test those packages and report results. Thank you

Thierry Carrez (ttx) on 2010-02-18
Changed in server-papercuts:
importance: Undecided → Medium
status: New → Confirmed
Thierry Carrez (ttx) on 2010-03-02
Changed in server-papercuts:
milestone: none → lucid-beta-1
Thierry Carrez (ttx) on 2010-03-10
summary: - Probleme de dependance
+ Bacula fails to install correctly if mysql wasn't installed before
Thierry Carrez (ttx) on 2010-03-17
Changed in server-papercuts:
milestone: lucid-beta-1 → lucid-beta-2
Thierry Carrez (ttx) on 2010-04-01
Changed in server-papercuts:
status: Confirmed → Won't Fix
Thierry Carrez (ttx) on 2010-04-22
Changed in server-papercuts:
milestone: lucid-beta-2 → none
status: Won't Fix → New
importance: Medium → Undecided
Thierry Carrez (ttx) on 2010-06-02
Changed in server-papercuts:
importance: Undecided → Medium
milestone: none → maverick-alpha-2
status: New → Triaged
Thierry Carrez (ttx) wrote :

Assigning to ivoks for evaluation/guidance/fix

Changed in server-papercuts:
assignee: nobody → Ante Karamatić (ivoks)
Thierry Carrez (ttx) on 2010-06-29
Changed in server-papercuts:
milestone: maverick-alpha-2 → maverick-alpha-3
Thierry Carrez (ttx) on 2010-08-03
Changed in server-papercuts:
assignee: Ante Karamatić (ivoks) → nobody
milestone: maverick-alpha-3 → maverick-beta
Thierry Carrez (ttx) wrote :

Non-obvious solution, unmarking as papercut

Changed in server-papercuts:
milestone: maverick-beta → none
status: Triaged → Invalid
Changed in bacula (Ubuntu):
status: Triaged → Confirmed
Changed in server-papercuts:
status: Invalid → Confirmed
Thierry Carrez (ttx) on 2010-08-10
Changed in server-papercuts:
status: Confirmed → Invalid
Thomas Schweikle (tps) wrote :

Same for other databases (postgresql). If not installed bacula is installed first, failing to initialize the database, because the server isn't there.
This is for maverick, lucid. A fix is afaik not available.

The "quick fix", "dpkg --configure -a" given just doesn't work. Not with postgres, not with mysql.

The commands to create the database by hand are missing. For mysql and postgres.

Thomas Schweikle (tps) wrote :

PS: this bug is for natty too!!!!

Scott Moser (smoser) wrote :

This is easily reproduced on 12.04 (still) by running the following from a fresh install (without mysql installed already).
Just run:
 sudo apt-get install bacula-director-mysql

Then you'll see a series of debconf questions:

- [Configuring mysql-server-5.5]
  fill in a new mysql root password for
- [Configuring mysql-server-5.5]
  repeat for confirmation of password
- [Configuring bacula-director-mysql]
  Configure database for bacula-director-mysql with dbconfig-common: Yes
- [Configuring bacula-director-mysql]
  Provide mysql root password
- [Configuring bacula-director-mysql]
  MySQL application password for bacula-director-mysql: passw0rd
  Password Confirmation: passw0rd
- [Configuring bacula-director-mysql]
   An error occurred while installing the database:

   ERROR 2002 (HY000): Can't connect to local MySQL server through socket
   '/var/run/mysqld/mysqld.sock' (2)

   If at this point you choose "retry", you will be prompted with all the
   configuration questions once more and another attempt will be made at performing
   the operation. "retry (skip questions)" will immediately attempt the operation
   again, skipping all questions. If you choose "abort", the operation will fail
   and you will need to downgrade, reinstall, reconfigure this package, or
   otherwise manually intervene to continue using it. If you choose "ignore", the
   operation will continue, ignoring further errors from dbconfig-common.

   Next step for database installation:

      abort
      retry
      retry (skip questions)
      ignore

The easy work around is to simply do:
 sudo apt-get install mysql
 sudo apt-get install bacula-director-mysql

To post a comment you must log in.