Ubuntu

Azureus hangs or crashes showing splash screen at start

Reported by Martin Gustafsson on 2006-08-27
506
Affects Status Importance Assigned to Milestone
azureus (Ubuntu)
High
John Dong
Feisty
Undecided
Unassigned
Gutsy
High
Martin Pitt

Bug Description

Binary package hint: azureus

Azureus fails to start on Edgy x86.
The splash shows "Loading images" and the console prints this message:
$ azureus
changeLocale: *Default Language* != English (United States). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
DEBUG::Sun Aug 27 14:25:17 CEST 2006::org.gudy.azureus2.ui.swt.mainwindow.Initializer::run::304:
  java.lang.NoClassDefFoundError: org/gnu/gtk/IconTheme
        at org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:71)
        at org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:128)
        at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run(Initializer.java:210)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport(SWTThread.java:107)
        at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
        at java.lang.Thread.run(Thread.java:534)

Gary Coady (garycoady) wrote :

Confirmed, I think. There's more than one problem to fix before azureus will run.

Firstly, in /usr/bin/azureus, two of the JAR file references are wrong - there should be references to glib0.4.jar and gtk2.10.jar in $CP.

Secondly, once that is changed, I get the backtrace
  java.lang.UnsatisfiedLinkError: gtk_icon_theme_get_default
        at org.gnu.gtk.IconTheme.gtk_icon_theme_get_default(Native Method)
        at org.gnu.gtk.IconTheme.getDefault(IconTheme.java:42)
        at org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:71)
        at org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:128)
        at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run(Initializer.java:210)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport(SWTThread.java:107)
        at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
        at java.lang.Thread.run(Unknown Source)

Not sure what's happening here - /usr/lib/jni/libgtk-2.10.so has a DT_NEEDED entry for libgtk-x11-2.0.so.0 - so I think that SHOULD cause the GTK library to be linked in? Unsure if this is a problem with libgtk-java, or...

note: using SUN Java 1.5.0+update05

If using gij/gcj, azureus WILL start if LD_PRELOAD is set to /usr/lib/jni/libgtkjni-2.10.so:/usr/lib/jni/libglibjni-0.4.so

Changed in azureus:
status: Unconfirmed → Confirmed
Gary Coady (garycoady) wrote :

With gcj-4.1 (4.1.1-11ubuntu7), azureus works without any LD_PRELOAD set (but with the other changes to /usr/bin/azureus mentioned above).

I also see different behaviour with SUN java:
  java.lang.UnsatisfiedLinkError: /usr/lib/jni/libglibjni-0.4.so: /usr/lib/jni/libglibjni-0.4.so: undefined symbol: g_type_depth
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(Unknown Source)
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at org.gnu.glib.Struct.<clinit>(Struct.java:85)
        at org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:71)
        at org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:128)
        at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run(Initializer.java:210)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport(SWTThread.java:107)
        at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
        at java.lang.Thread.run(Unknown Source)

The DT_NEEDED information from libglibjni is:
$ objdump -x /usr/lib/jni/libglibjni-0.4.so | grep NEEDED
  NEEDED libglib-2.0.so.0
  NEEDED libc.so.6

But g_type_depth is not defined there... setting LD_PRELOAD to /usr/lib/libgobject-2.0.so works in this case. Is there an --as-needed in a linking step somewhere?

Another confirmation, using sun java 1.5.0-08-0ubuntu1:

rikai@sonic:~$ azureus
changeLocale: *Default Language* != English (United States). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
DEBUG::Fri Sep 01 18:55:00 EDT 2006::org.gudy.azureus2.ui.swt.mainwindow.Initializer::run::304:
  java.lang.NoClassDefFoundError: org/gnu/gtk/IconTheme
        at org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:71)
        at org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:128)
        at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run(Initializer.java:210)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport(SWTThread.java:107)
        at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
        at java.lang.Thread.run(Thread.java:595)

Scott Robinson (scott-ubuntu) wrote :

+1 here too. Broken with the same exception.

Blaz Vrtacnik (blaz-vrtacnik) wrote :

+1 here...

Michał Sawicz (saviq) wrote :

Same here. Changes to /usr/bin/azureus and setting LD_PRELOAD according to the first solution here got me up.

Updating now, will see how it goes.

Michał Sawicz (saviq) wrote :

Yeah well... It does not start with Sun Java...
With gcj, on the other hand, transfers stop after less than an hour.

discord (colin.williams) wrote :

on the other hand you can download azureus from sourceforge and run the jar file. It works fine with sun java. Personally dont use the other javas...

discord (colin.williams) wrote :

on the other hand you can download azureus from sourceforge and run the shell script. It works fine with sun-java5-jdk . Personally I dont use the other javas and removed them...

Randakar (randakar) wrote :

+1

All the same symptoms.

Changed in azureus:
importance: Undecided → High
Exclamation (reubend) wrote :

Same problem o edgy amd64.
With gcj downloads stop after a while.

VF (vfiend) wrote :

Azureus also doesn't load for me, using gcj on edgy amd64

I'm on Ubuntu Edgy - Latest ( Beta ).
The splash screen show *loading images* and keeps displaying that until I force-quit it.
Here's what my console displays:

kristof@Edgy:~$ azureus
DEBUG::Sat Oct 07 15:21:41 GMT+02:00 2006::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::137:
  No SSL provider available
    SESecurityManager::initialise::52,ConfigurationChecker::setSystemProperties::141,ConfigurationManager::initialise::138,ConfigurationManager::getInstance::71,LoggerImpl::init::90,Logger::<clinit>::48,Class::initializeClass::-1,StartServer::<init>::69,Main::<init>::56,Main::main::162
changeLocale: *Default Language* != en (AU). Searching without country..
changeLocale: Searching for language en in *any* country..
changeLocale: no message properties for Locale 'en (AU)' (en_AU), using 'English (default)'
DEBUG::Sat Oct 07 15:21:42 GMT+02:00 2006::org.gudy.azureus2.ui.swt.mainwindow.Initializer::run::304:
  java.lang.NoClassDefFoundError: org.gnu.gtk.IconTheme
   at org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:71)
   at org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:128)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run(Initializer.java:210)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport(SWTThread.java:107)
   at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
   at java.lang.Thread.run(libgcj.so.70)

Oliver Maunder (ollym) wrote :

I'm getting the same error on AMD64 Edgy Beta.

I've also tried Azureus 2.5 downloaded from Sourceforge rather than the 2.4 version in the repositories, and I got the same error.

Changed in azureus:
assignee: nobody → motu
Gary Coady (garycoady) wrote :

Updated list of things required to get the azureus package to work:
1. In debian/azureus.sh, change "glib0.2.jar" to "glib0.4.jar".
2. In debian/azureus.sh, change "gtk2.8.jar" to "gtk2.10.jar".
3. In debian/azureus.sh, add "export LD_LIBRARY_PATH=/usr/lib/jni:/usr/lib".
4. Add a call to org.gtk.Gtk.init before org.gudy.azureus2.ui.swt.ImageRepository.loadImages is called. The problem here is that the GTK library has not yet been loaded, so none of the GTK calls can be resolved. In my testing, I edited azureus/org/gudy/azureus2/ui/swt/mainwindow/Initializer.java, and added the following lines to the run() method:
        String gtk_args[] = new String[1];
        gtk_args[0] = "azureus";
        org.gnu.gtk.Gtk.init(gtk_args);

The call can actually go anywhere as long as it happens before any GTK calls are made.

Oliver Maunder (ollym) wrote :

Thanks Gary - that's working for me.

I got the 2.5.0.0 source from Azureus CVS, made the change to Initializer.java and built with Ant. Then copied Azureus2.jar to /usr/share/java/ (where the apt installed one lives).

Made the changes you suggested to /usr/bin/azureus, ran it and it works.

Juho Lehto (keeperb5) wrote :

I have this same problem on Kubuntu 6.10. I solved the problem by replacing /usr/share/java/Azureus.jar with Azureus2.5.0.0.jar (rename to Azureus.jar) which can be downloaded from http://prdownloads.sourceforge.net/azureus/Azureus2.5.0.0.jar?download

When Azureus 2.5.0.0 is started the first time, it gives a warning notice about old Eclipse but it does not come up afterwards and as far as I can tell, works just fine.

Gary Coady (garycoady) wrote :

I would expect the upstream version to work.

The core of the problem with the Ubuntu package is that one of the branding patches (it tries make certain UI icons fit the current GTK+ theme) makes calls into GTK before the Java GTK libraries have been fully initialized. It does not appear to be in use upstream.

An alternative to the above change to Initializer.java is to remove the patch "azureus-themed.patch" from the Ubuntu package.

Lance Poore (lp-7413) wrote :

Confirming that azureus does not work properly when installed from the ubuntu repo. I installed 2.5.0.0 from the source, and put it in /usr/share/azureus and it works fine as long as a I run it with the full path. The script in /usr/bin needs to be replaced, and azureus should be upgraded from 2.4 to 2.5. Anyway, thats how I worked around this issue, hopefully we'll see it fixed before Edgy is deemed stable.

You would think these types of bugs can never hit the repos. They have this patch. They apply it. They upload it. They never ever try to run it.

I'm not expecting any advanced regression test suite or anything. But at least try to run it once.

PS. Its now 23/10. Is the fix proposed above going to get in on time before the release?

The status and purpose of this package may be questionable, but the movie-downloading Azureus types are one of Ubuntu's strong backers. They're the ones setting linux up for friends and family and are their first line of support.

Getting a nice working Azureus by default is more important and noticeable to the 'general-public' than we might at first hand expect. Although I don't think we'll see any reviews complaining about this though ;-)

Erik Andrén (erik-andren) wrote :

+1

Matthias Klose (doko) wrote :

fixed in azureus_2.5.0.0-0ubuntu2

Changed in azureus:
assignee: motu → doko
status: Confirmed → Fix Released
Erick Moreno (erickmoreno) wrote :

Really fixed? I have updated to azureus_2.5.0.0-0ubuntu2. The problem is still occurring with sun hotspot 1.5.09. I've tried with azureus-gcj and all dependencies, but the error

Exception in thread "main" java.lang.UnsatisfiedLinkError: memmove
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:67)
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
   at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main(Azureus2.jar.so)

insists in occur.

Matthias Klose (doko) wrote :

yes, that's amd64 specific, see #68053

Alan (mrintegrity) wrote :

Nope, still does not start here.

variant@craptop:~$ azureus
changeLocale: *Default Language* != English (Ireland). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (Ireland)' (en_IE), using 'English (default)'
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# SIGSEGV (0xb) at pc=0xb0561d02, pid=15371, tid=3084916400
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# Problematic frame:
# C [libglibjni-0.4.so+0x8d02]
#
# An error report file with more information is saved as hs_err_pid15371.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
Aborted (core dumped)

this is celeron cpu, happens with official sun jdk or gcj

Jimmy Angelakos (vyruss) wrote :

I report that Azureus version 2.5.0.0-0ubuntu2 works perfectly in my 32-bit Edgy (upgraded from Dapper).

Kien Tran (kienvtran) wrote :

Azureus crash on Edgy (AMD Athlon):

user:~/download$ java -version
java version "1.5.0_09"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_09-b03)
Java HotSpot(TM) Client VM (build 1.5.0_09-b03, mixed mode, sharing)
user:~/download$ azureus
changeLocale: *Default Language* != English (Canada). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (Canada)' (en_CA), using 'English (default)'
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# SIGSEGV (0xb) at pc=0xb096ed02, pid=17232, tid=3085346480
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_09-b03 mixed mode, sharing)
# Problematic frame:
# C [libglibjni-0.4.so+0x8d02]
#
# An error report file with more information is saved as hs_err_pid17232.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
Aborted (core dumped)

Erik Andrén (erik-andren) wrote :

Kien Tran, I get this error too. Additionally I experience it on both on my machines at home (both running dapper).
The only way I found to temporarily resolve it is to rm -r the .azureus directory in my /home/user directory.

Kien Tran (kienvtran) wrote :

Erik, thank you for the tip. I did rm -r on .azureus in my home directory. and azureus started, and worked for a while, then POOF, it SEGV'ed again, at the same place. Seems like the culprit is libglibjni-0.4.so, but I don't know how to fix it. Here are the beginning of 2 crash logs. In retrospect, upgrading from Dapper to Edgy has brought me nothing but headaches.
First log:
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# SIGSEGV (0xb) at pc=0xb0945d02, pid=2845, tid=3084777136
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_09-b03 mixed mode, sharing)
# Problematic frame:
# C [libglibjni-0.4.so+0x8d02]
#
Second log:
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# Internal Error (53484152454432554E54494D450E43505001A3), pid=4814, tid=3085354672
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_09-b03 mixed mode, sharing)

--------------- T H R E A D ---------------

Current thread (0x0805cc50): JavaThread "main" [_thread_in_Java, id=4814]

Stack: [0xbf742000,0xbf942000), sp=0xbf93bcc0, free space=2023k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V [libjvm.so+0x3251c3]
V [libjvm.so+0x12442c]
V [libjvm.so+0x2c257e]
V [libjvm.so+0x28ce24]
V [libjvm.so+0x28a034]
C [+0x440] __kernel_rt_sigreturn+0x0
V [libjvm.so+0x18629a]
C [libglibjni-0.4.so+0x8d51]
C [libglib-2.0.so.0+0x33f87] g_logv+0x327
C [libglib-2.0.so.0+0x34159] g_log+0x29
C [libgtk-x11-2.0.so.0+0x25590b] gtk_widget_size_allocate+0x2ab
C

felipeal (launchpad-felipeal) wrote :

Just a comment: I've installed Edgy and Azureus was working fine (even with a .azureus that I copied from a FC 3 machine) initially. But one I've installed Sun's JRE, it got broken with the aforementioned JVM crash.

From the stack trace, it's kind of obvious that the Java setup is messed up - the JVM being called is Sun's, but some GCJ libs are getting in the way. So, my first reaction was to uninstall Sun's or the GJC stuff, but ended up finding an easier solution: I've installed azureus-gcj, and everything works fine now..

IbeeX (ibrkanac) wrote :

Hello I have Edgy on amd64 clean install and I get this error

alo have installed azureus-gcj
________________________________

azureus
DEBUG::Wed Nov 08 18:11:00 GMT+01:00 2006::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
    SESecurityManager::initialise::-1,ConfigurationChecker::setSystemProperties::-1,ConfigurationManager::initialise::-1,ConfigurationManager::getInstance::-1,LoggerImpl::init::-1,Logger::<clinit>::-1,Class::initializeClass::-1,Logger::isEnabled::-1,StartServer::<init>::-1,Main::<init>::-1,Main::main::-1
changeLocale: *Default Language* != en (US). Searching without country..
changeLocale: Searching for language en in *any* country..
changeLocale: no message properties for Locale 'en (US)' (en_US), using 'English default)'
DEBUG::Wed Nov 08 18:11:01 GMT+01:00 2006::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
    SESecurityManager::initialise::-1,CryptoManagerImpl::<init>::-1,CryptoManagerImpl::getSingleton::-1,CryptoManagerFactory::getSingleton::-1,AzureusCoreImpl::<init>::-1,AzureusCoreImpl::create::-1,AzureusCoreFactory::create::-1,Main::<init>::-1,Main::main::-1
Exception in thread "main" java.lang.UnsatisfiedLinkError: memmove
   at org.eclipse.swt.internal.gtk.OS.memmove(org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar.so)
   at org.eclipse.swt.internal.Converter.wcsToMbcs(org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar.so)
   at org.eclipse.swt.internal.Converter.wcsToMbcs(org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar.so)
   at org.eclipse.swt.widgets.Display.<clinit>(org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar.so)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at org.eclipse.swt.widgets.Display.getCurrent(org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main(Azureus2.jar.so)

Bob Blanchard (blabj) wrote :

Azureus crashed with JRE 1.5 update 9 as well.

Installed azureus-gcj (x86).. works if I do "sudo update-alternatives --config java" and select java-gcj

Problem is, this breaks Frostwire...

So, altered /usr/bin/frostwire to be:

#!/bin/bash
cd /usr/lib/frostwire
export JAVA_PROGRAM_DIR=/usr/lib/jvm/java-1.5.0-sun/bin/
sh runFrost.sh

So for now - both work.... ah.. the joys of java

Lumír Jasiok (lumir-jasiok) wrote :

Sorry, but i have azureus_2.5.0.0-0ubuntu2 (edgy x86) and this bug is still present. After upgrade from Dapper i have problem described in posts. With gcj azureus working for a while and than stop. With sun java azureus crashing very often

Changed in azureus:
assignee: doko → nobody
Kien Tran (kienvtran) wrote :

Follow up to my previous posts:
Running with Sun Java 5: core dumps
Running with gjc: stops working after a few hours

Downloaded Azureus_2.5.0.0_linux.tar.bz2 from sourceforge.net, installed in home directory, ran it with Sun Java 5. No problems since.

Gothi[c] (gothic) wrote :

Confirmed, still broken with Sun Java 5.

-It will run for a while, then crash
- Then next time you restart it, it won't even start anymore
- If you delete your ~/.azureus folder, it will run for a few hours, and crash again.
- Repeat.

This is really starting to become annoying, somebody should fix this completely and once and for all as soon as possible.

Console log from the crashes:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# Internal Error (53484152454432554E54494D450E43505001A3), pid=13462, tid=3084568240
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# An error report file with more information is saved as hs_err_pid13462.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
Aborted (core dumped)

Vassilis Pandis (pandisv) wrote :

reopening as it appears to still be an issue

Changed in azureus:
status: Fix Released → Confirmed
Iwan (iwan-pieterse) wrote :

DEBUG::Fri Jan 05 02:12:56 GMT+02:00 2007::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
    SESecurityManager::initialise::-1,ConfigurationChecker::setSystemProperties::-1,ConfigurationManager::initialise::-1,ConfigurationManager::getInstance::-1,LoggerImpl::init::-1,Logger::<clinit>::-1,Class::initializeClass::-1,Logger::isEnabled::-1,StartServer::<init>::-1,Main::<init>::-1,Main::main::-1
changeLocale: *Default Language* != en (ZA). Searching without country..
changeLocale: Searching for language en in *any* country..
changeLocale: no message properties for Locale 'en (ZA)' (en_ZA), using 'English (default)'
DEBUG::Fri Jan 05 02:12:57 GMT+02:00 2007::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
    SESecurityManager::initialise::-1,CryptoManagerImpl::<init>::-1,CryptoManagerImpl::getSingleton::-1,CryptoManagerFactory::getSingleton::-1,AzureusCoreImpl::<init>::-1,AzureusCoreImpl::create::-1,AzureusCoreFactory::create::-1,Main::<init>::-1,Main::main::-1
Exception in thread "main" java.lang.UnsatisfiedLinkError: memmove
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:67)
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
   at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main(Azureus2.jar.so)

AMD64 3200+ Ubuntu edgy for AMD64, updated to latest packages. I tried the fixes above, did not work. java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-14ubuntu7)

Leigh Honeywell (hypatia) wrote :

Same bug, nearly same debug info:

DEBUG::Fri Jan 12 12:53:33 EST 2007::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
    SESecurityManager::initialise::-1,ConfigurationChecker::setSystemProperties::-1,ConfigurationManager::initialise::-1,ConfigurationManager::getInstance::-1,LoggerImpl::init::-1,Logger::<clinit>::-1,Class::initializeClass::-1,Logger::isEnabled::-1,StartServer::<init>::-1,Main::<init>::-1,Main::main::-1
changeLocale: *Default Language* != en (US). Searching without country..
changeLocale: Searching for language en in *any* country..
changeLocale: no message properties for Locale 'en (US)' (en_US), using 'English (default)'
DEBUG::Fri Jan 12 12:53:34 EST 2007::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
    SESecurityManager::initialise::-1,CryptoManagerImpl::<init>::-1,CryptoManagerImpl::getSingleton::-1,CryptoManagerFactory::getSingleton::-1,AzureusCoreImpl::<init>::-1,AzureusCoreImpl::create::-1,AzureusCoreFactory::create::-1,Main::<init>::-1,Main::main::-1
Exception in thread "main" java.lang.UnsatisfiedLinkError: memmove
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:67)
   at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
   at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main(Azureus2.jar.so)

Nowlin (nowlin82) wrote :

more info about the log problem can be found here https://launchpad.net/ubuntu/+source/azureus/+bug/68020

doclist (dclist) wrote :

Am also waiting for this

Daniel T Chen (crimsun) on 2007-04-29
Changed in azureus:
assignee: nobody → crimsun
status: Confirmed → In Progress
Martin Pitt (pitti) on 2007-05-02
Changed in azureus:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2007-06-15
Changed in azureus:
assignee: nobody → crimsun
status: Unconfirmed → Fix Committed
Changed in azureus:
status: Fix Committed → Confirmed
Martin Pitt (pitti) on 2007-08-03
Changed in azureus:
status: Fix Committed → Incomplete
John Dong (jdong) on 2007-10-21
Changed in azureus:
assignee: crimsun → jdong
John Dong (jdong) on 2007-10-21
Changed in azureus:
status: Confirmed → In Progress
assignee: crimsun → nobody
John Dong (jdong) on 2007-10-21
Changed in azureus:
assignee: crimsun → jdong
John Dong (jdong) on 2007-10-24
Changed in azureus:
status: In Progress → Fix Released
117 comments hidden view all 197 comments
Jim Braux-Zin (j-brauxzin) wrote :

It worked for me on Gutsy, thank you!

Luke Faraone (lfaraone) wrote :

+1. Seems to work on Gutsy x86 for me too.
Thanks again!

Federico (81joe81) wrote :

I'm using it since yesterday in my Gutsy x86 and it works fine!
thanks!! :)

Thom Pischke (thom-pischke) wrote :

Works great for me on Gutsy, +1

John Dong (jdong) wrote :

ACK from backporters. I know the package for 1ubuntu2 hasn't built in Hardy yet, but I've built it in pbuilder and had multiple success and not a single failure report on the testing backport. 1ubuntu1 built perfectly in Hardy and 1ubuntu2 just introduces some bash scripting changes in the shellscript launcher, no Java code changes, so I have no reason to believe there would be any build-related regressions.

Changed in gutsy-backports:
status: New → In Progress
px (px) wrote :

John, Thanks for the updated deb it works great for me on Gutsy x86.

Francisco Reverbel (reverbel) wrote :

I still see an issue with azureus_2.5.0.4-1ubuntu2~7.10prevu1_all.deb on Gutsy: double-clicking in a torrent file gives you an error from Azureus, which is being passed an URL argument when it expects a plain file argument. The following line in /usr/share/applications/azureus.desktop needs to be fixed:

--- /usr/share/applications/azureus.desktop.original-and-buggy 2007-10-27 17:49:14.000000000 -0200
+++ /usr/share/applications/azureus.desktop 2007-11-04 22:16:43.000000000 -0200
@@ -2,7 +2,7 @@
 Encoding=UTF-8
 Categories=Java;Application;Network;FileTransfer;P2P
 Comment=peer-to-peer file distribution tool
-Exec=azureus %U
+Exec=azureus %f
 GenericName=BitTorrent client
 Icon=Azureus
 MimeType=application/x-bittorrent

works great for me too on gutsy.

John Dong (jdong) wrote :

1ubuntu3 uploaded to Hardy with the above .desktop file change; I figure there's not much point to making a test .deb of it (I've already spammed so many onto here :D)

Fortunately the backport hasn't been processed yet so we are still on track :)

Thom Pischke (thom-pischke) wrote :

One issue with the current candidate, though probably not unique to this version, is that it leaks memory in ways I would have thought impossible in a java app. Even if I strangle it with -Xmx32m, it will instantly gobble 50+ MB on startup, and usually bloat out to over 100 within a few minutes. I don't understand how it can use more space than is allotted to the entire JVM, but it does. Since this renders it nearly unusable on my bittorrent laptop, I've been forced to ditch Azureus. I find deluge has now improved to the point where it's better than Azureus for gnome now anyway. A pity really, since Azureus would be wonderful if it worked properly.

John Dong (jdong) wrote :

I cannot reproduce this happening with the standard settings on Azureus with a torrent with 100 connections. It uses about 35MB resident - shared memory on startup, and uses about 50MB with a torrent running.

Comparing with Deluge, it's roughly the same overall memory usage with active torrents, Deluge is slightly more friendly at RAM but uses more CPU power for some reason.

With that said, Azureus was not designed with extreme lightness in mind, it does use RAM to optimize performance of torrenting, and modern PC's should have more than ample resources to handle it.

Thom Pischke (thom-pischke) wrote :

I do have the SafePeer plugin installed with the bluetack blocklist, and had three active torrents, but my settings are pretty modest. It usually takes a few minutes to really start gobbling memory, but I find even 50 MB to be 18 MB too many when I've explicitly set -Xmx32m in /usr/bin/azureus. A java program that ignores jvm parameters makes me wary. That said, if I could keep it at 50 MB, I would probably still use it, but it pretty rapidly gets over that. Since the laptop I'm using only has 196MB, azureus is usually using a lot of swap if I let it run overnight. That's why I call it a memory leak. It seems to be using memory that it shouldn't even have access to, or even a possible use for. Why could it possibly need 100MB? I even followed the azureus FAQ for reducing memory usage -- didn't help at all. It eats and eats.

This is a separate bug and should be filed as such.

On Nov 5, 2007 1:23 PM, Thom Pischke <email address hidden> wrote:

> I do have the SafePeer plugin installed with the bluetack blocklist, and
> had three active torrents, but my settings are pretty modest. It
> usually takes a few minutes to really start gobbling memory, but I find
> even 50 MB to be 18 MB too many when I've explicitly set -Xmx32m in
> /usr/bin/azureus. A java program that ignores jvm parameters makes me
> wary. That said, if I could keep it at 50 MB, I would probably still
> use it, but it pretty rapidly gets over that. Since the laptop I'm
> using only has 196MB, azureus is usually using a lot of swap if I let it
> run overnight. That's why I call it a memory leak. It seems to be
> using memory that it shouldn't even have access to, or even a possible
> use for. Why could it possibly need 100MB? I even followed the azureus
> FAQ for reducing memory usage -- didn't help at all. It eats and eats.
>
> --
> Azureus hangs or crashes showing splash screen at start
> https://bugs.launchpad.net/bugs/57875
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Mario Limonciello
<email address hidden>

Thom Pischke (thom-pischke) wrote :

Of course it is. Just thought it was worth mentioning, since a completely new package is being introduced and tested.

Thom

This is a matter for another bug report, this one is focused on
addressing the crash-on-startup behavior. I cannot readily reproduce the
behavior you describe on a stock Azureus install on my system.

Helge (helgesdk) wrote :

I'm using a custom-installed Azureus (not from apt).

I recently had to remove GCJ completely and a few depending programs I wasn't using anyway because Azureus refused to start.
Azureus was unable to automatically locate Sun Java and found the GCJ one instead.

Canonical cannot support custom installs.

On 11/9/07, Helge <email address hidden> wrote:
>
> I'm using a custom-installed Azureus (not from apt).
>
> I recently had to remove GCJ completely and a few depending programs I
> wasn't using anyway because Azureus refused to start.
> Azureus was unable to automatically locate Sun Java and found the GCJ one
> instead.
>
> --
> Azureus hangs or crashes showing splash screen at start
> https://bugs.launchpad.net/bugs/57875
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

fre 2007-11-09 klockan 13:03 +0000 skrev Helge:
> I'm using a custom-installed Azureus (not from apt).
>
> I recently had to remove GCJ completely and a few depending programs I wasn't using anyway because Azureus refused to start.
> Azureus was unable to automatically locate Sun Java and found the GCJ one instead.

sudo update-java-alternatives --list
sudo update-java-alternatives --set java-6-sun # <-- insert right java

might work.

>
--
<email address hidden>

Plus ça change, plus c'est la même chose

davidc (scienceinthegreen) wrote :

New deb package works on my Gutsy amd64 pc after I recompiled icedtea-java according to bug #152362:

sudo apt-get build-dep icedtea-java7-plugin
sudo apt-get -b source icedtea-java7-plugin icedtea-java7-bin icedtea-java7-jre icedtea-java7-jdk
sudo dpkg -i icedtea-java7-*deb

Warning: this takes hours! Left .azureus folder in place along with old error files - no crashes, and downloads are no longer crawling. Thanks a lot.

Sebastien Bacher (seb128) wrote :

has this backport request being approved?

Changed in azureus:
status: Confirmed → Incomplete
John Dong (jdong) wrote :

On Sat, Nov 10, 2007 at 07:28:36PM -0000, Sebastien Bacher wrote:
> has this backport request being approved?
Yeah, it's approved. Please backport it at your convenience,

Thanks, John

geefour (marcfinnwilson) wrote :

I don't really know what happened since I was having the same problems with Azureus but, I just downloaded the latest version of Azureus and installed it over the version that seems to be on the Ubuntu repositories and it works just like it was intended to! For some reason, it seems to be using my Java 5 RE and not Java 6 RE but I'm happy that it's not showing me the start up screen and then hanging when it shows me part of the Azureus display!

John Dong (jdong) wrote :

Please do not report information that does not pertain to either the Hardy or Gutsy proposed deb posted here. It does not help with testing these packages to state that a package obtained from another source packaged using completely different techniques worked for you. This bug report is already nearing 200 posts and is enough of a mess to tangle through ;-)

Thanks.

Martin Pitt (pitti) wrote :

For the record, I removed azureus 2.5.0.0repack1-0ubuntu1.1~proposed1 from feisty-proposed. The SRU has never been completed, and I don't see a reason to start caring about Feisty universe now.

Martin Pitt (pitti) wrote :

 * Trying to backport azureus...
  - <azureus_2.5.0.4.orig.tar.gz: downloading from librarian>
  - <azureus_2.5.0.4-1ubuntu3.diff.gz: downloading from librarian>
  - <azureus_2.5.0.4-1ubuntu3.dsc: downloading from librarian>
I: Extracting azureus_2.5.0.4-1ubuntu3.dsc ... done.
I: Building backport of azureus-2.5.0.4 as 2.5.0.4-1ubuntu3~gutsy1 ... done.

Changed in gutsy-backports:
status: In Progress → Fix Released
John Dong (jdong) wrote :

Ok, the 2.5.0.4-1ubuntu3~gutsy1 seems to have propagated to most mirrors, so I'll need everyone's help again for the last step of this update. Please report whether or not this version, found in gutsy-backports, works as well as the candidates you guys so generously tested before. I expect it to be identical, as it came from the same sources, but let's test just to make sure.

After this, it will be a simple copy to gutsy-updates then everyone will have working Azureus and we can move on to more exciting things with our lives.

Cheers,
John

Joseph Price (pricechild) wrote :

The version 2.5.0.4-1ubuntu3~gutsy1 is working perfectly for me on both sun java and iced tea.

John Dong (jdong) wrote :

I can also personally verify that the backports built package works as well as my personally pbuildered candidates.

Federico (81joe81) wrote :

Today I tried version 2.5.0.4-1ubuntu3~gutsy1 from the gutsy-backports and sadly it didn't work: every time I tried to download a torrent (in both cases with azureus already opened and not) azureus started to freeze. I'm using sun java 6 on my kubuntu x86.
Then, I downgraded the package to version 2.5.0.4-1ubuntu2~7.10prevu1 that was posted here and it started to work fine again.
If you need more information, just let me know

Thom Pischke (thom-pischke) wrote :

Version in backports working fine for me

Luke Faraone (lfaraone) wrote :

backported

Changed in azureus:
status: Incomplete → Fix Released
Emmet Hikory (persia) wrote :

Reverting last status change, as the package is not available in gutsy-updates.

Changed in azureus:
status: Fix Released → Incomplete
John Dong (jdong) wrote :

Hi Frederico,

The only difference between 0ubuntu2 and 0ubuntu3 releases is that the
.torrent file association was updated. Can you please confirm that
indeed it breaks between the 0ubuntu2 and 0ubuntu3 packages?

Federico (81joe81) wrote :

Hi John, I retried several times again, and the behavior seems quite unpredictable.
Sometimes Azureus freezes when opening a new torrent file (from a firefox link or directly from Azureus) and sometimes it doesn't. And this for both the 0ubuntu2 and the 0ubuntu3 releases.
I will try to delete again to delete my ~/.azureus directory, and look if with a clean environment the behavior becomes more stable.
I will let you know if I will discover something else.
Thank you for your work.

Saivann Carignan (oxmosys) wrote :

2.5.0.4-1ubuntu3~gutsy1 works flawlessly for me since 3 hours. I got multiples little normal messages in the right-bottom corner of my screen about my connection, my downloads, no problems. I can kill azureus and start it again without experiencing problems, I just get a little normal warning about the fact that I killed azureus.

Sam Brightman (sambrightman) wrote :

We'll see what he says, but I think it's worth arguing the case. Whilst I appreciate the effort you're putting in here, I remember there were two really common bugs and possibly one or two less common ones that were already marked as duplicates where appropriate - and I think it should stay that way. Fair enough, mark them "fixed by bug 57875 solution" - but I think more information (underlying causes) is better than less information.

Martin Pitt (pitti) wrote :

I copied the gutsy-backports version to gutsy-updates. Thanks to all who provided testing feedback!

Changed in azureus:
assignee: jdong → pitti
status: Incomplete → Fix Released

mozart@network:~$ azureus
changeLocale: *Default Language* != English (United States). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
#
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x8f4fb172, pid=26076, tid=3084712848
#
# Java VM: Java HotSpot(TM) Server VM (1.6.0-b105 mixed mode)
# Problematic frame:
# C [libglibjni-0.4.so+0x9172]
#
# An error report file with more information is saved as hs_err_pid26076.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
Aborted (core dumped)
mozart@network:~$

Sean Hunt (coppro) wrote :

I still experience this problem, but it's solved by removing the log directory in .azureus.

Saivann Carignan (oxmosys) wrote :

coppro : Do you use the latest release of azureus on ubuntu Gutsy ver. 2.5.0.4-1ubuntu3~gutsy1? If not, you should prefer that version of azureus which fixes this issue.

Displaying first 40 and last 40 comments. View all 197 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers