ark crashes while loading a big archive

Bug #635384 reported by Muhammad Annaqeeb on 2010-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Utilities
Fix Released
High
Nominated for Trunk by Muhammad Annaqeeb
ark (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdeutils

Application: ark (2.14)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
while loading a big archive ( an aptoncd dvd 1.4 GB) , ark crashes
dolphin was open . using GNOME .no other kde application or qt dependent was
running .

 -- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78cb710 (LWP 4193))]

Thread 2 (Thread 0xb6026b70 (LWP 4195)):
[KCrash Handler]
#6 0x006098bb in ?? () from /lib/tls/i686/cmov/libc.so.6
#7 0x0060bafd in ?? () from /lib/tls/i686/cmov/libc.so.6
#8 0x0060ea6c in ?? () from /lib/tls/i686/cmov/libc.so.6
#9 0x0060ef9d in realloc () from /lib/tls/i686/cmov/libc.so.6
#10 0x05326a94 in qRealloc (ptr=0x94c16d0, size=2048) at global/qmalloc.cpp:65
#11 0x0534c035 in QListData::realloc (this=0x91c4568, alloc=507) at
tools/qlist.cpp:158
#12 0x0534c2e4 in QListData::append (this=0x91c4568) at tools/qlist.cpp:179
#13 0x05432cd9 in QList<QPostEvent>::append (this=0x91c4568, t=...) at
../../include/QtCore/../../src/corelib/tools/qlist.h:470
#14 0x0542e757 in QCoreApplication::postEvent (receiver=0x938e220,
event=0xb561e130, priority=0) at kernel/qcoreapplication.cpp:1149
#15 0x0542e9ac in QCoreApplication::postEvent (receiver=0x938e220,
event=0xb561e130) at kernel/qcoreapplication.cpp:1066
#16 0x05440236 in queued_activate (sender=<value optimized out>, signal=<value
optimized out>, c=0x94c8038, argv=0xb6025708, semaphore=0x0) at
kernel/qobject.cpp:3173
#17 0x054422b1 in QMetaObject::activate (sender=0x94c8080, m=0x81c12c,
local_signal_index=2, argv=0xb6025708) at kernel/qobject.cpp:3266
#18 0x00801ca3 in Kerfuffle::Job::newEntry (this=0x94c8080, _t1=...) at
./jobs.moc:113
#19 0x00801ce4 in Kerfuffle::Job::onEntry (this=0x94c8080, archiveEntry=...) at
../../../ark/kerfuffle/jobs.cpp:77
#20 0x008018eb in Kerfuffle::ReadOnlyArchiveInterface::entry (this=0x94ce190,
archiveEntry=...) at ../../../ark/kerfuffle/archiveinterface.cpp:83
#21 0x08c23c4b in LibArchiveInterface::emitEntryFromArchiveEntry
(this=0x94ce190, aentry=0x9218430) at
../../../../ark/plugins/libarchive/libarchivehandler.cpp:594
#22 0x08c26357 in LibArchiveInterface::list (this=0x94ce190) at
../../../../ark/plugins/libarchive/libarchivehandler.cpp:86
#23 0x00802d75 in Kerfuffle::ListJob::doWork (this=0x94c8080) at
../../../ark/kerfuffle/jobs.cpp:133
#24 0x00801e33 in Kerfuffle::Job::qt_metacall (this=0x94c8080,
_c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xb6025aec) at ./jobs.moc:87
#25 0x0080451a in Kerfuffle::ListJob::qt_metacall (this=0x94c8080,
_c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xb6025aec) at ./jobs.moc:169
#26 0x05433c9a in QMetaObject::metacall (object=0x94c8080, cl=536870912,
idx=30, argv=0xb6025aec) at kernel/qmetaobject.cpp:237
#27 0x054423d5 in QMetaObject::activate (sender=0xb60262e8, m=0x55425a4,
local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#28 0x05493aa7 in QTimer::timeout (this=0xb60262e8) at
.moc/release-shared/moc_qtimer.cpp:134
#29 0x0544a60e in QTimer::timerEvent (this=0xb60262e8, e=0xb6026020) at
kernel/qtimer.cpp:271
#30 0x0543f254 in QObject::event (this=0xb60262e8, e=0xc8094dc7) at
kernel/qobject.cpp:1212
#31 0x00f664dc in QApplicationPrivate::notify_helper (this=0x91d9da8,
receiver=0xb60262e8, e=0xb6026020) at kernel/qapplication.cpp:4300
#32 0x00f6d05e in QApplication::notify (this=0xbfaff65c, receiver=0xb60262e8,
e=0xb6026020) at kernel/qapplication.cpp:3704
#33 0x009fdf2a in KApplication::notify (this=0xbfaff65c, receiver=0xb60262e8,
event=0xb6026020) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x0542ea3b in QCoreApplication::notifyInternal (this=0xbfaff65c,
receiver=0xb60262e8, event=0xb6026020) at kernel/qcoreapplication.cpp:704
#35 0x0545dd66 in QCoreApplication::sendEvent (this=0x9215cbc) at
../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QTimerInfoList::activateTimers (this=0x9215cbc) at
kernel/qeventdispatcher_unix.cpp:603
#37 0x0545a8e4 in timerSourceDispatch (source=0x9215c88) at
kernel/qeventdispatcher_glib.cpp:184
#38 0x051705e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#39 0x051742d8 in ?? () from /lib/libglib-2.0.so.0
#40 0x051744b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#41 0x0545a5d5 in QEventDispatcherGlib::processEvents (this=0x9316f28,
flags=...) at kernel/qeventdispatcher_glib.cpp:412
#42 0x0542d059 in QEventLoop::processEvents (this=0xb6026290, flags=) at
kernel/qeventloop.cpp:149
#43 0x0542d4aa in QEventLoop::exec (this=0xb6026290, flags=...) at
kernel/qeventloop.cpp:201
#44 0x053295a8 in QThread::exec (this=0x9214e20) at thread/qthread.cpp:487
#45 0x00804f42 in Kerfuffle::ThreadExecution::run (this=0x9214e20) at
../../../ark/kerfuffle/threading.cpp:47
#46 0x0532c32e in QThreadPrivate::start (arg=0x9214e20) at
thread/qthread_unix.cpp:248
#47 0x004ba96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#48 0x0066ba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78cb710 (LWP 4193)):
#0 0x00233422 in __kernel_vsyscall ()
#1 0x004bf015 in pthread_cond_wait@@GLIBC_2.3.2 () from
/lib/tls/i686/cmov/libpthread.so.0
#2 0x006789dd in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3 0x0532d287 in QWaitConditionPrivate::wait (this=0x921560c, mutex=0x92155f8,
time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4 QWaitCondition::wait (this=0x921560c, mutex=0x92155f8, time=4294967295) at
thread/qwaitcondition_unix.cpp:159
#5 0x0532c3c9 in QThread::wait (this=0x9214e20, time=4294967295) at
thread/qthread_unix.cpp:619
#6 0x008023fa in ~Job (this=0x94c8080, __in_chrg=<value optimized out>) at
../../../ark/kerfuffle/jobs.cpp:56
#7 0x00804b4f in ~ListJob (this=0x94c8080, __in_chrg=<value optimized out>) at
../../../ark/kerfuffle/jobs.h:83
#8 0x0543e18f in QObjectPrivate::deleteChildren (this=0x94dc798) at
kernel/qobject.cpp:1986
#9 0x0544529d in ~QObject (this=0x94c8010, __in_chrg=<value optimized out>) at
kernel/qobject.cpp:975
#10 0x008057c7 in ~ArchiveBase (this=0x94c8010, __in_chrg=<value optimized
out>) at ../../../ark/kerfuffle/archivebase.cpp:53
#11 0x03294ccd in ~ArchiveModel (this=0x938e220, __in_chrg=<value optimized
out>) at ../../../ark/part/archivemodel.cpp:199
#12 0x0543e18f in QObjectPrivate::deleteChildren (this=0x934cc00) at
kernel/qobject.cpp:1986
#13 0x0544529d in ~QObject (this=0x93568a8, __in_chrg=<value optimized out>) at
kernel/qobject.cpp:975
#14 0x00578a7f in ~Part (this=0x93568a8, __vtt_parm=0x32a23ec, __in_chrg=<value
optimized out>) at ../../kparts/part.cpp:212
#15 0x0057920a in ~ReadOnlyPart (this=0x93568a8, __vtt_parm=0x32a23e8,
__in_chrg=<value optimized out>) at ../../kparts/part.cpp:459
#16 0x0057937f in ~ReadWritePart (this=0x93568a8, __vtt_parm=0x32a23e4,
__in_chrg=<value optimized out>) at ../../kparts/part.cpp:721
#17 0x0328694c in ~Part (this=0x93568a8, __in_chrg=<value optimized out>,
__vtt_parm=<value optimized out>) at ../../../ark/part/part.cpp:132
#18 0x080513f1 in ~MainWindow (this=0x932ac00, __in_chrg=<value optimized out>,
__vtt_parm=<value optimized out>) at ../../../ark/app/mainwindow.cpp:74
#19 0x0543dd65 in qDeleteInEventHandler (o=0xfffffe00) at
kernel/qobject.cpp:3998
#20 0x0543f428 in QObject::event (this=0x932ac00, e=0x1) at
kernel/qobject.cpp:1231
#21 0x00fc4326 in QWidget::event (this=0x932ac00, event=0x954eb50) at
kernel/qwidget.cpp:8455
#22 0x013dfbc7 in QMainWindow::event (this=0x932ac00, event=0x954eb50) at
widgets/qmainwindow.cpp:1433
#23 0x00aefb04 in KMainWindow::event (this=0x932ac00, ev=0x954eb50) at
../../kdeui/widgets/kmainwindow.cpp:1103
#24 0x00b3788f in KXmlGuiWindow::event (this=0x932ac00, ev=0x954eb50) at
../../kdeui/xmlgui/kxmlguiwindow.cpp:131
#25 0x00f664dc in QApplicationPrivate::notify_helper (this=0x91d9da8,
receiver=0x932ac00, e=0x954eb50) at kernel/qapplication.cpp:4300
#26 0x00f6d0f9 in QApplication::notify (this=0xbfaff65c, receiver=0x932ac00,
e=0x954eb50) at kernel/qapplication.cpp:4265
#27 0x009fdf2a in KApplication::notify (this=0xbfaff65c, receiver=0x932ac00,
event=0x954eb50) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x0542ea3b in QCoreApplication::notifyInternal (this=0xbfaff65c,
receiver=0x932ac00, event=0x954eb50) at kernel/qcoreapplication.cpp:704
#29 0x05431473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0,
data=0x91c4550) at
../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0,
data=0x91c4550) at kernel/qcoreapplication.cpp:1345
#31 0x054315dd in QCoreApplication::sendPostedEvents (receiver=0x0,
event_type=0) at kernel/qcoreapplication.cpp:1238
#32 0x0545aadf in QCoreApplication::sendPostedEvents (s=0x91dc110) at
../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x91dc110) at
kernel/qeventdispatcher_glib.cpp:276
#34 0x051705e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x051742d8 in ?? () from /lib/libglib-2.0.so.0
#36 0x051744b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x0545a5d5 in QEventDispatcherGlib::processEvents (this=0x91c4090,
flags=...) at kernel/qeventdispatcher_glib.cpp:412
#38 0x01026135 in QGuiEventDispatcherGlib::processEvents (this=0x91c4090,
flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x0542d059 in QEventLoop::processEvents (this=0xbfaff5b4, flags=) at
kernel/qeventloop.cpp:149
#40 0x0542d4aa in QEventLoop::exec (this=0xbfaff5b4, flags=...) at
kernel/qeventloop.cpp:201
#41 0x0543169f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#42 0x00f66577 in QApplication::exec () at kernel/qapplication.cpp:3579
#43 0x08050499 in main (argc=4, argv=0xbfaff9f4) at
../../../ark/app/main.cpp:210

Download full text (6.2 KiB)

Application that crashed: ark
Version of the application: 2.13
KDE Version: 4.2.87 (KDE 4.2.87 (KDE 4.3 >= 20090519))
Qt Version: 4.5.1
Operating System: Linux 2.6.30-rc6 i686

What I was doing when the application crashed:
Similar to the duplicate bug. Open *huge* .tar.bz2 archive and close ark before it is loaded (I did it with a full system backup, about 1.1 gigabytes). Got kde-4.2.87 on Gentoo with debug enabled.

Hope the magic bug-report-thing will work. (:

 -- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[Current thread is 0 (LWP 6174)]

Thread 2 (Thread 0xb4955b90 (LWP 6181)):
[KCrash Handler]
#6 Kerfuffle::ReadOnlyArchiveInterface::entry (this=0x9297188, archiveEntry=@0xb49551f8) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/kerfuffle/archiveinterface.cpp:83
#7 0xb4af4635 in LibArchiveInterface::emitEntryFromArchiveEntry (this=0x9297188, aentry=0x927c090)
    at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/plugins/libarchive/libarchivehandler.cpp:82
#8 0xb4af5b49 in LibArchiveInterface::list (this=0x9297188) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/plugins/libarchive/libarchivehandler.cpp:116
#9 0xb7f3717d in Kerfuffle::ListJob::doWork (this=0x92916b8) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/kerfuffle/jobs.cpp:144
#10 0xb7f39d31 in Kerfuffle::ThreadExecution::run (this=0x9293140) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/kerfuffle/threading.cpp:41
#11 0xb6a58a90 in QThreadPrivate::start (arg=0x9293140) at thread/qthread_unix.cpp:189
#12 0xb69e516f in start_thread (arg=0xb4955b90) at pthread_create.c:297
#13 0xb6849dce in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb60c0700 (LWP 6174)):
#0 0xb7f50424 in __kernel_vsyscall ()
#1 0xb69e8bf5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0xb6a5966e in QWaitCondition::wait (this=0x92926c0, mutex=0x92926ac, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3 0xb6a58d24 in QThread::wait (this=0x9293140, time=4294967295) at thread/qthread_unix.cpp:485
#4 0xb7f37d2a in ~Job (this=0x92916b8) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/kerfuffle/jobs.cpp:59
#5 0xb7f39879 in ~ListJob (this=0x92916b8) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/kerfuffle/jobs.h:82
#6 0xb6b599d2 in QObjectPrivate::deleteChildren (this=0x92a13c8) at kernel/qobject.cpp:1845
#7 0xb6b612bb in ~QObject (this=0x92a01e8) at kernel/qobject.cpp:844
#8 0xb7f3a98b in ~ArchiveBase (this=0x92a01e8) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/kerfuffle/archivebase.cpp:55
#9 0xb4c9a630 in ~ArchiveModel (this=0x9226a10) at /var/tmp/portage/kde-base/ark-4.2.87/work/ark-4.2.87/ark/part/archivemodel.cpp:204
#10 0xb6b599d2 in QObjectPrivate::deleteChildren (this=0x922e0f0) at kernel/qobject.cpp:1845
#11 0xb6b612bb in ~QObject (this=0x921c628) at kernel/qobject.cpp:844
#12 0xb7e6946b in ~Part (this=0x921c628, __vtt_parm=0xb4ca63cc) at /var/tmp/portage/kde-base/kdelibs-4.2.87/work/kdelibs-4.2.87/kparts/part.cpp:212
#13 0xb7e696fa in ~ReadOnlyPart (this=0x921c628, __vtt_parm=0xb4ca63c8) at /var/tmp/portage/kde-base/kdelibs-4.2.87/work/kdelibs-4.2.87...

Read more...

*** Bug 166751 has been marked as a duplicate of this bug. ***

Indeed, this is a duplicate of bug 166751, but I'm leaving this one open and marking the other one as a duplicate because this report provides a better and mroe up-to-date backtrace. Thanks.

*** Bug 204621 has been marked as a duplicate of this bug. ***

*** Bug 205436 has been marked as a duplicate of this bug. ***

*** Bug 208262 has been marked as a duplicate of this bug. ***

*** Bug 210472 has been marked as a duplicate of this bug. ***

*** Bug 210766 has been marked as a duplicate of this bug. ***

*** Bug 212721 has been marked as a duplicate of this bug. ***

*** Bug 189419 has been marked as a duplicate of this bug. ***

*** Bug 208104 has been marked as a duplicate of this bug. ***

*** Bug 216415 has been marked as a duplicate of this bug. ***

*** Bug 217528 has been marked as a duplicate of this bug. ***

*** Bug 217893 has been marked as a duplicate of this bug. ***

Created attachment 38984
New crash information added by DrKonqi

*** Bug 215974 has been marked as a duplicate of this bug. ***

*** Bug 218558 has been marked as a duplicate of this bug. ***

*** Bug 220165 has been marked as a duplicate of this bug. ***

Created attachment 41246
New crash information added by DrKonqi

I opened big archive file tar.gz (324.5 MB) and i close ark windows before see files in ark list file.

*** Bug 229734 has been marked as a duplicate of this bug. ***

*** Bug 229847 has been marked as a duplicate of this bug. ***

Created attachment 41491
proposed patch

Tries to close threads on exit. Tested with libarchive and clizipplugin. It could help with similar bugs like 222392 but i didn't test it.

Thanks for the patch.

I was thinking of trying to avoid using QThread::terminate() since it will call pthread_cancel() and just stop everything at the next cancellation point (in case the archive is being modified it could lead to data loss?).

If there's no other option, this may be the only way to cancel things, but I'd like to look for other solutions before (I haven't had much time for that lately).

> in case the archive is being modified it could lead to data loss?
That is good point but i'm not sure that there will be any data loss.

When using command line program it's terminated and killed if it won't close in 3(?) seconds. I don't know how programs react to terminate signal but we can't do any better.

Libarchive modifies files in addFiles() and deleteFiles(). Both functions create new modified archive and later replace orginal file.

*** Bug 233284 has been marked as a duplicate of this bug. ***

*** Bug 234902 has been marked as a duplicate of this bug. ***

*** Bug 235054 has been marked as a duplicate of this bug. ***

Created attachment 43087
proposed patch

It's same as before but now Ark won't exit when orginal file is deleted and new archive isn't renamed (to orginal file name).

I've finally had time to review your patch.

archiveinterface.h is missing a <QMutex> #include.

When I closed Ark while it was loading a 1.1G file, Ark crashed and I got the following warning from Qt:

Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

*** Bug 238210 has been marked as a duplicate of this bug. ***

*** Bug 238356 has been marked as a duplicate of this bug. ***

Created attachment 48037
New crash information added by DrKonqi

I was trying to open Fedora 13 x86_64 DVD iso.

*** Bug 242187 has been marked as a duplicate of this bug. ***

*** Bug 245031 has been marked as a duplicate of this bug. ***

*** Bug 244968 has been marked as a duplicate of this bug. ***

Created attachment 49705
New crash information added by DrKonqi

Updated backtrace. I was trying to open a big archive and closed Ark with it was still populating the list.

Created attachment 50950
New crash information added by DrKonqi

when Opening a tar.gz by clicking on the Desktop ARK starts to prepare the Directory structure for Display.
The crash occures when i close the ARK window by clicking on the top right corner X Button before the file is fully analyzed by ARK.
This is before ARK can display the directory tree.

 The crash does not occure if ARK can finish the analysis of the directory structure and the directorytree is displayed in the ARK window.

*** Bug 249255 has been marked as a duplicate of this bug. ***

37 comments hidden view all 160 comments
Muhammad Annaqeeb (annaqeeb) wrote :
38 comments hidden view all 160 comments

*** Bug 250835 has been marked as a duplicate of this bug. ***

Changed in kdeutils:
importance: Unknown → High
status: Unknown → Invalid
Changed in kdeutils:
importance: High → Unknown
status: Invalid → Unknown
affects: kdeutils (Ubuntu) → ark (Ubuntu)
Changed in ark (Ubuntu):
status: New → Triaged
Changed in kdeutils:
importance: Unknown → High
status: Unknown → Confirmed
Changed in kdeutils:
status: Confirmed → Unknown
80 comments hidden view all 160 comments

Created attachment 78366
New crash information added by DrKonqi

ark (2.19) on KDE Platform 4.10.1 using Qt 4.8.4

- What I was doing when the application crashed:

I guess creating/ operning a 22.7 gb archive is a bad idea.

Attempting instilation of debug symbols fails with non-descriptive error messege.

-- Backtrace (Reduced):
#6 0x000000374fe18965 in Kerfuffle::ReadOnlyArchiveInterface::entry(QHash<int, QVariant> const&) () from /lib64/libkerfuffle.so.4
#7 0x00007f5748f11dcd in LibArchiveInterface::emitEntryFromArchiveEntry(archive_entry*) () from /usr/lib64/kde4/kerfuffle_libarchive.so
#8 0x00007f5748f128ae in LibArchiveInterface::list() () from /usr/lib64/kde4/kerfuffle_libarchive.so
#9 0x000000374fe195a0 in Kerfuffle::ListJob::doWork() () from /lib64/libkerfuffle.so.4
#10 0x000000374fe19301 in Kerfuffle::Job::Private::run() () from /lib64/libkerfuffle.so.4

Created attachment 78374
New crash information added by DrKonqi

ark (2.19) on KDE Platform 4.10.1 "release 545" using Qt 4.8.4

I opened a bigger compressed file(around 150MB) and closed it before it totally loaded. I have kde 4.10 with openSUSE 12.3 64bit

-- Backtrace (Reduced):
#5 isSignalConnected (signal_index=4, this=0x0) at kernel/qobject_p.h:242
[...]
#7 0x00007f196f7dfb55 in Kerfuffle::ReadOnlyArchiveInterface::entry (this=<optimized out>, _t1=...) at /usr/src/debug/ark-4.10.1/build/kerfuffle/archiveinterface.moc:125
#8 0x00007f195bb7138d in LibArchiveInterface::emitEntryFromArchiveEntry (this=this@entry=0xd4eed0, aentry=<optimized out>) at /usr/src/debug/ark-4.10.1/plugins/libarchive/libarchivehandler.cpp:651
#9 0x00007f195bb71e6e in LibArchiveInterface::list (this=0xd4eed0) at /usr/src/debug/ark-4.10.1/plugins/libarchive/libarchivehandler.cpp:115
#10 0x00007f196f7e0790 in Kerfuffle::ListJob::doWork (this=0x110dbd0) at /usr/src/debug/ark-4.10.1/kerfuffle/jobs.cpp:192

*** Bug 317672 has been marked as a duplicate of this bug. ***

*** Bug 317777 has been marked as a duplicate of this bug. ***

Created attachment 79072
New crash information added by DrKonqi

ark (2.19) on KDE Platform 4.10.2 using Qt 4.8.4

- What I was doing when the application crashed:
Try to open tar.bz2 (~33 Gb) and compress 7Gb tar to bz2 as a parallel task.

-- Backtrace (Reduced):
#6 0x0000003440418965 in Kerfuffle::ReadOnlyArchiveInterface::entry(QHash<int, QVariant> const&) () from /lib64/libkerfuffle.so.4
#7 0x00007f9c621d4dcd in LibArchiveInterface::emitEntryFromArchiveEntry(archive_entry*) () from /usr/lib64/kde4/kerfuffle_libarchive.so
#8 0x00007f9c621d58ae in LibArchiveInterface::list() () from /usr/lib64/kde4/kerfuffle_libarchive.so
#9 0x00000034404195a0 in Kerfuffle::ListJob::doWork() () from /lib64/libkerfuffle.so.4
#10 0x0000003440419301 in Kerfuffle::Job::Private::run() () from /lib64/libkerfuffle.so.4

*** Bug 320290 has been marked as a duplicate of this bug. ***

Created attachment 80602
Backtrace

*** Bug 322551 has been marked as a duplicate of this bug. ***

Obviously nothing is being done about this particular bug for the last 2
years at least. Please remove me from the cc list.
On Jul 19, 2013 2:24 AM, "Raphael Kubo da Costa" <email address hidden> wrote:

> https://bugs.kde.org/show_bug.cgi?id=193908
>
> Raphael Kubo da Costa <email address hidden> changed:
>
> What |Removed |Added
>
> ----------------------------------------------------------------------------
> CC| |<email address hidden>
>
> --- Comment #126 from Raphael Kubo da Costa <email address hidden> ---
> *** Bug 322551 has been marked as a duplicate of this bug. ***
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>

Indeed, ether fix this or close as NO-FIX and stop sending updates

In my opinion this bug report shows a major problem of KDE - the not invented here syndrome.
It doesn't make a lot of sence to re-write every existing application out there just to make it QT based and KDE integrated. In a few years new apps will be created but nobody will be there to maintain all the existing apps, like its the case with Ark.
Wouldn't it have been better to ship XArchiver with KDE and make sure it is integrated well within KDE by e.g. writing a few plugins? Same holds true in my opinion for a lot of KDE code like KMail, Amarok, Kopete, ....

I have given up waiting for a fix... What is the point of having a bug tracking system when no-one is actually doing anything to fix things.

(In reply to comment #128)
> Indeed, ether fix this or close as NO-FIX and stop sending updates

3rd option: (you can) remove yourself from the CC list if you feel bothered, just like some others have already done.

 (In reply to comment #129)
> In my opinion this bug report shows a major problem of KDE - the not
> invented here syndrome.

Please keep the discussion on topic. Anyway, you should really realize that many KDE apps exist earlier than similar apps. Ark is one of them. NIH is certainly not applicable to it .

By the way, the last real commit in XArchiver was almost 4 years ago. Does look like a good example to back up your suggestion.

(In reply to comment #130)
> I have given up waiting for a fix... What is the point of having a bug tracking system when no-one is actually doing anything to fix things.

Please do not exaggerate what is happening in Ark(or KDE) just because your pet bug is not dealt with. That makes no help to anything.

*** Bug 324211 has been marked as a duplicate of this bug. ***

Created attachment 82240
New crash information added by DrKonqi

ark (2.19) on KDE Platform 4.10.5 "release 1" using Qt 4.8.4

- What I was doing when the application crashed:
Closing karch while it was busy extracting.
Attachted you find another callstack. I hope it may be usefull. Thanks for your work.

Original KDE from OpenSuSE 12.3.

Kind regards, Markus

-- Backtrace (Reduced):
#6 isSignalConnected (signal_index=4, this=0x0) at kernel/qobject_p.h:242
[...]
#8 0xb76d2ba5 in Kerfuffle::ReadOnlyArchiveInterface::entry (this=0x89ad300, _t1=...) at /usr/src/debug/ark-4.10.5/build/kerfuffle/archiveinterface.moc:125
#9 0xb37e4ee1 in LibArchiveInterface::emitEntryFromArchiveEntry (this=this@entry=0x89ad300, aentry=0xb20027c0) at /usr/src/debug/ark-4.10.5/plugins/libarchive/libarchivehandler.cpp:651
#10 0xb37e5a7c in LibArchiveInterface::list (this=0x89ad300) at /usr/src/debug/ark-4.10.5/plugins/libarchive/libarchivehandler.cpp:115
#11 0xb76d3c4a in Kerfuffle::ListJob::doWork (this=0x8970fb8) at /usr/src/debug/ark-4.10.5/kerfuffle/jobs.cpp:192

*** Bug 325339 has been marked as a duplicate of this bug. ***

*** Bug 327414 has been marked as a duplicate of this bug. ***

Harald Sitter (apachelogger) wrote :

Closing in favor of upstream report.

Changed in ark (Ubuntu):
status: Triaged → Invalid

Created attachment 83748
New crash information added by DrKonqi

ark (2.19) on KDE Platform 4.11.2 using Qt 4.8.5

- What I was doing when the application crashed:
Closed Ark while the archive is still being loaded.

-- Backtrace (Reduced):
#5 0x00007f09f905eaf7 in isSignalConnected (signal_index=4, this=0x0) at kernel/qobject_p.h:240
[...]
#7 0x00007f09fb5627b5 in Kerfuffle::ReadOnlyArchiveInterface::entry (this=this@entry=0x1ab3820, _t1=...) at /usr/src/debug/ark-4.11.2/build/kerfuffle/archiveinterface.moc:124
#8 0x00007f09dd2e13f2 in LibArchiveInterface::emitEntryFromArchiveEntry (this=this@entry=0x1ab3820, aentry=<optimized out>) at /usr/src/debug/ark-4.11.2/plugins/libarchive/libarchivehandler.cpp:651
#9 0x00007f09dd2e223d in LibArchiveInterface::list (this=0x1ab3820) at /usr/src/debug/ark-4.11.2/plugins/libarchive/libarchivehandler.cpp:115
#10 0x00007f09fb563274 in Kerfuffle::ListJob::doWork (this=0x1b1ebd0) at /usr/src/debug/ark-4.11.2/kerfuffle/jobs.cpp:192

*** Bug 329369 has been marked as a duplicate of this bug. ***

*** Bug 330093 has been marked as a duplicate of this bug. ***

It is still an issue with Ark 2.19 on KDE 4.13 (Kubuntu 14.04)

This is a serious crasher-bug, reported almost 5 years ago.

Please remove Ark from the KDE Software Distribution / Compilation as it seems to be completely unmaintained, as this bug report proves.

Created attachment 86539
New crash information added by DrKonqi

ark (2.19) on KDE Platform 4.13.0 using Qt 4.8.6

- What I was doing when the application crashed:

Opening ecplise archive, trying to rename another archive

-- Backtrace (Reduced):
#5 0x00007f8dbda02607 in isSignalConnected (signal_index=4, this=0x0) at kernel/qobject_p.h:237
[...]
#7 0x00007f8dbfeca345 in Kerfuffle::ReadOnlyArchiveInterface::entry (this=this@entry=0x25c9500, _t1=...) at ./archiveinterface.moc:124
#8 0x00007f8daa24fd82 in LibArchiveInterface::emitEntryFromArchiveEntry (this=this@entry=0x25c9500, aentry=<optimized out>) at ../../../plugins/libarchive/libarchivehandler.cpp:651
#9 0x00007f8daa250bed in LibArchiveInterface::list (this=0x25c9500) at ../../../plugins/libarchive/libarchivehandler.cpp:115
#10 0x00007f8dbfecae04 in Kerfuffle::ListJob::doWork (this=0x23ffbc0) at ../../kerfuffle/jobs.cpp:192

*** Bug 334659 has been marked as a duplicate of this bug. ***

Ok, I'm bored with ark. This bug has *huuuuuge* history (even before my backtrace there were bugs about this issue), tons of CC, tons of duplicates [1]. There was someone trying to fix things one way or another (check the comments, if you are brave enough), but just nobody cares…

[1] 166751 204621 205436 208262 210472 210766 212721 189419 208104 216415 217528 217893 215974 218558 220165 229734 229847 233284 234902 235054 238210 238356 242187 245031 244968 249255 250835 251147 251177 251152 251179 253129 256115 261082 262124 268003 268438 269186 269204 272016 272700 273285 274876 278447 279735 279736 280042 282522 286132 283998 287423 290692 291597 292714 294761 296445 297307 281699 300776 305172 305356 305870 305905 305905 308388 308772 308984 311002 314162 315423 315539 317672 317777 320290 322551 322551 324211 325339 327414 329369 330093 334659

Since this bug was reopened (reasons?! why?! WHY???!!! ;) I hope there will be a quick fix for Bug 334679. Anyone unhappy with ark bug feel free to CC in there.
EOT

Have a nice ark.

Stop being an ***** or you'll kill the motivation i had to fix the bug,

Git commit acb455da04c473da39a5d99d4212f1d9c88abee5 by Albert Astals Cid.
Committed on 14/05/2014 at 22:59.
Pushed by aacid into branch 'KDE/4.13'.

Properly stop list jobs on close

Track running jobs in JobTracker. On its destruction (i.e. UI is going down) we kill and delete (which waits for finishing) those jobs.

Tested with very big tar.gz (libarchive plugin) and .zip (cliplugin) and it closes without crashing now

Acked by rakuco
FIXED-IN: 4.13.2
REVIEW: 118108

M +9 -2 kerfuffle/cliinterface.cpp
M +1 -0 kerfuffle/cliinterface.h
M +1 -1 kerfuffle/jobs.cpp
M +10 -0 part/jobtracker.cpp
M +2 -0 part/jobtracker.h
M +9 -1 plugins/libarchive/libarchivehandler.cpp
M +2 -0 plugins/libarchive/libarchivehandler.h

http://commits.kde.org/ark/acb455da04c473da39a5d99d4212f1d9c88abee5

Wow! Thank you!

Changed in kdeutils:
status: Unknown → Fix Released

*** Bug 334957 has been marked as a duplicate of this bug. ***

*** Bug 335391 has been marked as a duplicate of this bug. ***

*** Bug 337776 has been marked as a duplicate of this bug. ***

*** Bug 317538 has been marked as a duplicate of this bug. ***

Git commit 074d52778f68c2b1456ba54633bace8e366667cb by Elvis Angelaccio.
Committed on 30/04/2016 at 11:02.
Pushed by elvisangelaccio into branch 'master'.

Don't block the main thread while running CliInterface jobs

Currently we freeze the GUI thread while running CliInterface jobs,
because there is a nested event loop in runProcess(),
which doesn't run anymore in a separate thread.

We can simply drop this event loop and rework the CliInterface logic,
such that the emit signal is not emitted anymore when runProcess() returns,
but in processFinished() instead.

This exposed a crash when closing the main window while a pending job was
running. The fix is simply to not emit finished() if the m_abortingOperation
flag is set.
Related: bug 222392
FIXED-IN: 16.08.0

Differential Revision: D1510

M +4 -8 kerfuffle/archiveinterface.h
M +116 -86 kerfuffle/cliinterface.cpp
M +13 -3 kerfuffle/cliinterface.h
M +0 -1 part/jobtracker.cpp
M +0 -1 plugins/cliunarchiverplugin/cliplugin.cpp

http://commits.kde.org/ark/074d52778f68c2b1456ba54633bace8e366667cb

Git commit ead7a07ee145d41d3f3c737b93862c6ef0c067be by Elvis Angelaccio.
Committed on 19/07/2016 at 20:43.
Pushed by elvisangelaccio into branch 'Applications/16.08'.

Drop direct connection for finished signal

The direct connection was added in commit acb455da04, but since Ark 16.08 is not
necessary anymore (CliInterface runs on the main thread).

This prevents a possible race condition in our jobs
(see https://git.reviewboard.kde.org/r/128113/)

Differential Revision: D2225

M +1 -1 kerfuffle/jobs.cpp

http://commits.kde.org/ark/ead7a07ee145d41d3f3c737b93862c6ef0c067be

*** Bug 367908 has been marked as a duplicate of this bug. ***

Displaying first 40 and last 40 comments. View all 160 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.