package apport 1.20.1-0ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #767829 reported by adelattre
This bug affects 205 people
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
apport (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: apport

first time I ran update manager after upgrading from 10.10 to 11.04 alpha 3, I got this error

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: apport 1.20.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CrashReports: 600:0:0:112742:2011-04-20 17:55:23.934898000 -0500:2011-04-20 17:55:39.484920136 -0500:/var/crash/apport.0.crash
Date: Wed Apr 20 17:55:24 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
SourcePackage: apport
Title: package apport 1.20.1-0ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-04-20 (0 days ago)

Revision history for this message
adelattre (adelattre-gmail) wrote :
Changed in apport (Ubuntu):
status: New → Confirmed
Revision history for this message
rww (rww) wrote :

This error only occurs for me when enabled=0 in /etc/default/apport. Changing it to enabled=1 allows the package to install correctly.

Revision history for this message
Adnan (awasim) wrote :

Just tried what rww suggested above, and it worked for me.

Revision history for this message
mu3en (mu3en) wrote :

above edit in /etc/default/apport allowed package upgrade.

switched back to enabled=0 after, does that make sense?

Revision history for this message
PaiSand (paisand) wrote :

Confirmed, changing it to enabled=1 solve the problem.

Revision history for this message
Marcelo (marceloramone-gmail) wrote :

Yes, me too, changing it to enabled=1 solve the problem.

Revision history for this message
andres hubert (andreshubert) wrote : Re: [Bug 767829] Re: package apport 1.20.1-0ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2011/4/20 PaiSand <email address hidden>:
> Confirmed, changing it to enabled=1 solve the problem.
>

worked for me too.
Thanks.

Revision history for this message
Juan Carlos (arareka-ha) wrote :

For me too, enabled=1 and solved.

Revision history for this message
andres hubert (andreshubert) wrote :

2011/4/20 Marcelo <email address hidden>:
> Yes, me too,  changing it to enabled=1 solve the problem.
>

should this setting stay enabled or disabled after apport succesfull
installation?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.20.1-0ubuntu5

---------------
apport (1.20.1-0ubuntu5) natty; urgency=low

  [ Kees Cook ]
  * debian/rules: really ignore "start" result at install (LP: #767829).

  [ Brian Murray ]
  * Only prepend linux bug titles with [STAGING] if a title exists
    (LP: #767864).
 -- Kees Cook <email address hidden> Wed, 20 Apr 2011 16:27:06 -0700

Changed in apport (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
jim weaver (lonewitch) wrote :

new to this can you explain the fix i need to do

Revision history for this message
fduppa (fduppa) wrote :

changing enabled to 1 solved it for me too.

i have the same question.. should we put it back to 0 ?

Revision history for this message
Brian Murray (brian-murray) wrote :

Yes, apport should not be enabled any more so please set it back to 0.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Still no luck with 1.20.1-0ubuntu5. I've opened LP: #767995

Revision history for this message
Tony Mugan (tmugan) wrote :

Just had this issue when upgrading 1.20.1-0ubuntu4 in Natty
The fix discussed above worked.

Then I set the value back to zero once the upgrade was complete.

Revision history for this message
tengee0411 (tengee0411) wrote :

i can't use ubuntu one Firefox Bookmark share :(

Revision history for this message
John S. Gruber (jsjgruber) wrote :

tengee0411: I'm sorry you are having trouble with ubuntu one. I'm concerned none of its maintainers would see your comment here, however. Would you mind filing a report against the ubuntuone project.

https://bugs.launchpad.net/ubuntu/+source/ubuntuone-client seems to have bugs of a similar nature and perhaps would be an appropriate place to look for (and possibly file) your bug.

Thanks.

Revision history for this message
Wira Mohamed Salleh (wms7939-gmail) wrote :

Changing it to enabled=1 solve the problem.

Revision history for this message
andrewmiller (asinghmiller) wrote :

Yep editing etc/default/apport and changing the value of enabled to 1 worked for me too! Natty

Revision history for this message
Gareth (gmccumskey) wrote :

changing to 1 worked for me too. Remember to set back to 0 after update folks.

Revision history for this message
danizmax (danizmax) wrote :

Confirming bug as well the workaround.

Revision history for this message
Les Lamb (kernelles) wrote :

Fix worked for me too, thanks.

Revision history for this message
Jaime Pereira (jaimepereira) wrote :

Hello Jim
I'm not a expert on IT, only report the bug to programers analise and
correct.
Have a nice day
Jaime

On Thu, Apr 21, 2011 at 2:49 AM, jim weaver <email address hidden> wrote:

> new to this can you explain the fix i need to do
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (767951).
> https://bugs.launchpad.net/bugs/767829
>
> Title:
> package apport 1.20.1-0ubuntu4 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/apport/+bug/767829/+subscribe
>

--
Jaime Pereira
https://launchpad.net/~jaimepereira
OpenPGP keys: B4813835
«Tenho uma vontade de ferro – a preguiça é que ma enferruja.»
---------------------------------------------------
Não mostre para os outros o endereço electrónico dos seus amigos.
Use "Cco" (ou "Bcc") – cópia oculta – ao enviar ou reenviar as suas
mensagens para vários destinatários.
Retire os endereços dos seus amigos no corpo da mensagem antes de
enviar/reenviar.
Faça como eu: Use o Ubuntu e dificulte a disseminação de Vírus, Spams e
Banners.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

+1 to the bug, and +1 to the workaround.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Fixed for me. Only a message remains but it installs ok without requiring a workaround.

Revision history for this message
Carlos Villota (carlos-villota) wrote :

fixed por me.

Have a nice day

Carlos

Revision history for this message
john gils (john-gils) wrote : Re: [Bug 767829] Re: package apport 1.20.1-0ubuntu4 failed toinstall/upgrade: subprocess installed post-installation scriptreturned error exit status 1

Thanks for the quick reply. I will test when I get home from work.
Sent wirelessly from my BlackBerry device on the Bell network.
Envoyé sans fil par mon terminal mobile BlackBerry sur le réseau de Bell.

-----Original Message-----
From: "John S. Gruber" <email address hidden>
Sender: <email address hidden>
Date: Thu, 21 Apr 2011 13:43:54
To: <email address hidden>
Reply-To: Bug 767829 <email address hidden>
Subject: [Bug 767829] Re: package apport 1.20.1-0ubuntu4 failed to
 install/upgrade: subprocess installed post-installation script
 returned error exit status 1

Fixed for me. Only a message remains but it installs ok without
requiring a workaround.

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (768012).
https://bugs.launchpad.net/bugs/767829

Title:
  package apport 1.20.1-0ubuntu4 failed to install/upgrade: subprocess
  installed post-installation script returned error exit status 1

Status in “apport” package in Ubuntu:
  Fix Released

Bug description:
  Binary package hint: apport

  first time I ran update manager after upgrading from 10.10 to 11.04
  alpha 3, I got this error

  ProblemType: Package
  DistroRelease: Ubuntu 11.04
  Package: apport 1.20.1-0ubuntu4
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic x86_64
  Architecture: amd64
  CrashReports: 600:0:0:112742:2011-04-20 17:55:23.934898000 -0500:2011-04-20 17:55:39.484920136 -0500:/var/crash/apport.0.crash
  Date: Wed Apr 20 17:55:24 2011
  ErrorMessage: subprocess installed post-installation script returned error exit status 1
  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
  PackageArchitecture: all
  SourcePackage: apport
  Title: package apport 1.20.1-0ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
  UpgradeStatus: Upgraded to natty on 2011-04-20 (0 days ago)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/767829/+subscribe

Revision history for this message
Brian Murray (brian-murray) wrote :

This is only a problem with the Ubuntu package not the upstream version of Apport.

Changed in apport:
status: New → Invalid
Revision history for this message
omarly666 (omarly666) wrote :

just after rebooting after latest upgrades. no actual bug what i can find just like Brian Murray wrote

Revision history for this message
joopbraak (joopbraak) wrote :

People, this is a bug report, not a blog. Don't comment just to say that it's fixed for you. Remember, there are like 100 people subscribed to this bug, that means that 100 people will get an email for every comment that's posted here. And especially developers have something better to do, so please don't spam them.
The fix is committed, after that the only comments that should be added are when it's not fixed for you. And only then when you really have something constructive to add, so don't repeat something people before you already said. If you are affected too but have nothing new to say, just add yourself to the "This bug affects X people. Does this bug affect you? " on top if the bug page.
Also it's not necessary to post the whole content of your previously received emails, and I'm not interested in from which device and which network you sent it either.
I realise this is noise too, but I hope this will make some people aware of the purpose of bug reports.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers