Ubuntu

[meta-bug] Inverted Internal microphone (phase inversion)

Reported by David Henningsson on 2012-05-22
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

This is a metabug for all machines that are having phase inverted internal microphones.

If your internal mic is either completely silent (no signal), or you can possibly pick a very small sound, with much background noise, even though you have set gain to maximum, there is something you could try.

Install the pavucontrol application, start it and go to the "Input Devices" tab. Unlock the channels (there is a keylock icon), then mute the right channel while keeping the left channel at the volume you want.
If the internal mic is now working correctly, you have an inverted internal mic, so that your right channel cancels out the left one.

(If you're not running PulseAudio, you can try doing the same through AlsaMixer instead (see https://wiki.ubuntu.com/Audio/Alsamixer ), try changing "Capture" level or "Internal Mic" or "Internal Mic Boost" using the Q,E,Z,C keys.)

If so, please file a separate bug against the alsa-driver for your issue, make sure hardware info gets attached to it (either alsa-info as per https://wiki.ubuntu.com/Audio/AlsaInfo or the standard ones that follows when you do "ubuntu-bug alsa-driver" ), then write a comment in this bug, with your machine name and a pointer to the other bug.

As time permits, I'll try to work on fixing them for the next Ubuntu release. Thanks!
 -- David Henningsson

David Henningsson (diwic) wrote :

Thinkpad U300s - bug 903853

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
David Henningsson (diwic) wrote :

Asus U41SV - bug 997227

Javier P.L. (chilicuil) wrote :

Lenovo Thinkpad SL410 - bug #1004819
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Renzo Bagnati (renbag) wrote :

Acer Aspire 1810TZ - bug 1006089

description: updated
description: updated
Brian Burch (brian-pingtoo) wrote :

Acer Aspire One D260-A has this problem, both with the latest 12.04 pulseaudio, and also with the new version in the proposed repository. The bypass using pavucontrol was successful.

My individual bug 99661 should be marked as a duplicate of this meta-bug.

Alban Browaeys (prahal) wrote :

Just to let you know my findings since two years . There is a closed source kernel (in Linpus for Acer Aspire One) driver to handle this kind of small array microphone from Fortemedia (here on Acer Ferrari One 200).
There are in fact 4 channels ie 2 stereo signals (force channels_max to 4 in hda_intel and patch_realtek). This is done to let fmaudio kernel driver (heavily plugged into hda_intel, infringing on the gpl in various ways) do beam, noise processing and other nifty things.
I started works on this. Please tell me if you are interested in my hacks (I managed to get the 4 streams and record them then work in audacity to try to decipher the noise reduction). I also started work on a pulseaudio module (I do not think the audio postprocessing should be done in kernel) fmaaudiosma which I talked upon on pulseaudio ML but this was sent before I found about the 4 channels trick.

Acer eMachines eM350
Machine 00:1b.0 0403: 8086:27d8 (rev 02)
 Subsystem: 1025:0349
Codec: Realtek ALC272X
Vendor Id: 0x10ec0272
Subsystem Id: 0x10250349
Revision Id: 0x100001

essentially bug#639846 (first raised for 10.04, but still present in 12.04

Note: I confirmed this bug by recording direct from hardware
   pasuspender arecord -Dhw:0 -fcd -d5 mic.wav
Then view waveform in Audacity to confirm that one channel is inverted version of the other

Ivo Anjo (knuckles) wrote :

Lenovo S205 has the same issue - Bug 884652

David Henningsson (diwic) wrote :

Status update:

 * Submitted quirk upstream for Lenovo S205 (this one has a Conexant chip, for which we already have a solution).
 * SL410 seems to be a different problem judging from the latest comment in that bug.
 * @Brian burch, that's not the right bug number...

 * In discussion with upstream about the Realtek ones.

Thank you for your patience. The Conexant ones are trivial to fix now, but we're not sure what to do with the Realtek ones yet.

David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :

Good news! Upstream has written a solution today and wishes for some testing. I've packaged it up in a debian package. Please do the following:
1) Download and install the alsa-hda-dkms package just posted
2) Reboot
3) start Alsamixer (see https://wiki.ubuntu.com/Audio/Alsamixer ), make sure "Inverted Internal Mic" is muted
4) now try recording normally from Internal mic.

The following machines are added in this package:
Asus U41SV
Acer 1810TZ
Acer D260 (from bug 996611 )
Acer eM350
Lenovo S205

Please report back whether it works or not. Thanks!

Ivo Anjo (knuckles) wrote :

Seems to work fine on my Ideapad S205 with alsa-hda-dkms_0.1_all.deb

Javier P.L. (chilicuil) wrote :

In mine too, added a more detailed output in the bug #1004819 , thanks for your work!
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Renzo Bagnati (renbag) wrote :

In my case (Acer Aspire 1810TZ) the alsa-hda-dkms_0.1_all.deb does not solve the problem. I can see the inverted internal mic in alsamixer, but I cannot edit it (see screenshot). I cannot see any microphone activity in the audio settings window (and in skype), unless I mute one channel with pavucontrol.
However when I use gnome-sound-recorder I can register sounds out of the box, but this worked also without alsa-hda-dkms.

Voron_Shinigami (mail4spam) wrote :

Seems a sorta work, Lenovo S205. The internal microphone is now working in Skype, but the output volume control with pavucontrol doesn't work any more, the volume is always at its maximum level, independently from slider position, unless controlled with an application's function. Rebooting didn't help. Maybe, I'm just doing something wrong.

David Henningsson (diwic) wrote :

@Renzo, thanks for testing!

Possibly this is only a bug in alsamixer. If so, you might be able to change it with this command:
amixer -D hw:0 sset 'Inverted Internal Mic Capture Switch' 0

Also, could you give alsa-info output with this configuration?

David Henningsson (diwic) wrote :

@Renzo, sorry, it is probably correct in alsamixer. Just use the "space" key to disable recording of the Inverted Internal Mic in alsamixer.

Renzo Bagnati (renbag) wrote :

David, you was right, I used the space key to disable the Inverted Internal Mic and now the microphone is working well in all applications. Thank you very much for your suggestions!

Joao Merighi (joaomerighi) wrote :

The package alsa-hda-dkms_0.1_all.deb SOLVED my problem.

Ubuntu 12.04
Lenovo g470

Thank you!!!!!!

psamuel (persaudsamuel) wrote :

Possibly this is only a bug in alsamixer.

Does the alsa-hda-dkms_0.1_all.deb work in Ubuntu 11.10?

Alex Wolfson (awolfson) wrote :

Looks like we have the same bug in Lenovo E220s

@diwic - can you please take a look if this is the case and add that Laptop?

David Henningsson (diwic) wrote :

@Alex,
There is nothing I can look at in the alsa-info that would tell if this is the case or not - it has to be checked by someone who has the hardware (i e, you).
Because these bugs have to be fixed once per machine, every machine is a separate bug. Can you please file a separate bug for E220 and point me to it, by adding another comment in this bug with the new bug number in it?

Thanks!

I have a Lenovo G470, and followed the steps to certify that the notebook does not have an inverted microphone. It turns out it doesn't.

Nevertheless, have installed alsa-hda-dkms_0.1_all.deb to give it a try. The microphone started working OK on Skype after that, but the output sound of the speakers were suddenly really noisy and polluted (only on Skype). I decided to uninstall the package, and the microphone obviously is not working anymore. I can provide more information about the machine if needed. I am also following bug 1033011.

Lenovo G570, mic not working at all either

John McHugh (mrmcq2u) wrote :

This also effects Acer Aspire ZG5 on ubuntu 12.04, 12.10 and 13.04.

Raymond (superquad-vortex2) wrote :

> Just to let you know my findings since two years . There is a closed source kernel (in Linpus for Acer Aspire One) driver to handle this kind of small array microphone from Fortemedia (here on Acer Ferrari One 200).
 There are in fact 4 channels ie 2 stereo signals (force channels_max to 4 in hda_intel and patch_realtek).

it is possible to perform multi channel capturing when auto Mic and alt_capture are disabled by implement multi_in_xxx (open prepare and close ) similar to multi_out_xxx functions with the new generic parser

David Henningsson (diwic) wrote :

@John McHugh, thanks, I've tracked this machine in bug 1107477

Dave Burgess (burgessdave00) wrote :

Acer Aspire Timeline X 4830TG affected in 12.04, 12.10 & 13.04. Thanks for the workaround.

Hugo (hugo-miras) wrote :

Hi
Did someone finally manage to solve it on Acer eM350?
I triede to followed the steps from David Henningsson (2012-06-22), but it didn't work although eM350 was considered in the package...
Didn't manage to do anything to mute "Inverted Internal Mic", as does not show up -> would this be the problem? (see screen shot)
Many thanks for your support
Hugo

David Henningsson (diwic) wrote :

 > Didn't manage to do anything to mute "Inverted Internal Mic", as does not show up -> would this be the problem? (see screen shot)

You need to press "F4" to see capture controls. By default, only playback controls are shown.

In case this does not work, please give alsa-info according to https://wiki.ubuntu.com/Audio/AlsaInfo - maybe there is more than one ID for eM350.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers