[900X3G, Realtek ALC282, Mic, Internal] inverted mic not working

Bug #1316518 reported by aerobat on 2014-05-06
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Internal Mic of Samsung Ativ book 9 (NP900X3G) is not supported properly.

Stereo recording in audacity records sound from mic in L channel and only loud noise in R channel (phase inverted?)
Muting R channel, and setting L channel to around 16%, in pavucontrol allows to record audio, but in poor quality.

alsa-info.sh output: http://www.alsa-project.org/db/?f=064f0b536a1b068efd30d58c2641b5ec2348f059

Ubuntu Gnome 14.04

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: sarah 2014 F.... pulseaudio
                      sarah 8509 F.... alsamixer
 /dev/snd/controlC0: sarah 2014 F.... pulseaudio
CurrentDesktop: GNOME
Date: Tue May 6 11:55:36 2014
InstallationDate: Installed on 2014-04-29 (6 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:PCH failed
Symptom_Card: Internes Audio - HDA Intel PCH
Symptom_Jack: Mic, Internal
Symptom_Type: None of the above
Title: [900X3G, Realtek ALC282, Mic, Internal] Recording problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/14/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P04ADU.023.140414.PS
dmi.board.asset.tag: No Asset Tag
dmi.board.name: NP900X3G-K02DE
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SAMSUNG_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP04ADU.023.140414.PS:bd04/14/2014:svnSAMSUNGELECTRONICSCO.,LTD.:pn900X3G:pvrP04ADU:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP900X3G-K02DE:rvrSAMSUNG_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 900X3G
dmi.product.version: P04ADU
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
---
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sarah 2004 F.... pulseaudio
 /dev/snd/controlC1: sarah 2004 F.... pulseaudio
CurrentDesktop: GNOME
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=b4bd3914-d1c4-40f0-ba32-fb19aa9af13c
InstallationDate: Installed on 2014-04-29 (27 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 900X3G
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=92ac4966-692f-4e06-a1dd-da069008e861 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127.2
StagingDrivers: rts5139
Tags: trusty trusty staging
Uname: Linux 3.13.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/14/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P04ADU.023.140414.PS
dmi.board.asset.tag: No Asset Tag
dmi.board.name: NP900X3G-K02DE
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SAMSUNG_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP04ADU.023.140414.PS:bd04/14/2014:svnSAMSUNGELECTRONICSCO.,LTD.:pn900X3G:pvrP04ADU:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP900X3G-K02DE:rvrSAMSUNG_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 900X3G
dmi.product.version: P04ADU
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

aerobat (austrianized) wrote :
aerobat (austrianized) wrote :

Problem still exists in mainline kernel 3.15.0-031500rc2-generic

aerobat (austrianized) on 2014-05-06
description: updated
aerobat (austrianized) on 2014-05-07
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Steffen Röcker (sroecker) wrote :

I can confirm this problem on the same hardware. The problem persists with the lates alsa-daily snapshot. (https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS)

The problem also appears on Lenovo IdeaPad 410P (bug #1308831)

tags: added: kernel-sound

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1316518

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream-3.15-rc2
aerobat (austrianized) wrote :

Problem still exists in mainline kernel 3.16.0-031600-generic

Raymond (superquad-vortex2) wrote :

do you mean dynamic adc switching does not work since you internal mic only connected to node 0x11 but Mic jack connected to node 0x08 ?

Node 0x11 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Amp-In caps: ofs=0x17, nsteps=0x3f, stepsize=0x02, mute=1
  Amp-In vals: [0x23 0x23]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x12
Node 0x12 [Pin Complex] wcaps 0x40040b: Stereo Amp-In
  Control: name="Internal Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Internal Mic Phantom Jack", index=0, device=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
  Amp-In vals: [0x03 0x03]
  Pincap 0x00000020: IN
  Pin Default 0x90a60130: [Fixed] Mic at Int N/A
    Conn = Digital, Color = Unknown
    DefAssociation = 0x3, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0

Raymond (superquad-vortex2) wrote :

Node 0x23 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals: [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
  Connection: 6
     0x18 0x19 0x1a 0x1b 0x1d 0x0b

Node 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Control: name="Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Device: name="ALC282 Analog", type="Audio", device=0
  Amp-In caps: ofs=0x17, nsteps=0x3f, stepsize=0x02, mute=1
  Amp-In vals: [0x11 0x00]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x23

Node 0x18 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
  Control: name="Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Mic Jack", index=0, device=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
  Amp-In vals: [0x00 0x00]
  Pincap 0x00003724: IN Detect
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x03a11040: [Jack] Mic at Ext Left
    Conn = 1/8, Color = Black
    DefAssociation = 0x4, Sequence = 0x0
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=02, enabled=1
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0

Raymond (superquad-vortex2) wrote :

node 0x11 and node 0x08

Converter: stream=0, channel=0

stream of one audio input node should be non zero when recording while the other is zero

Raymond (superquad-vortex2) wrote :

if your internal Mic is inverted, the mute of right channel should be applied to node 0x11 instead of node 0x08

Steffen Röcker (sroecker) wrote :

Thanks Raymond. How can we try this? alsamixer is not very helpful as you do not see the node numbers. Do you know the commands for hda-verb?

Steffen (fragone) wrote :

This bug also affects me and I realized today that the internal mic starts working perfectly when plugging a smartphone headset and the headset mic does not work at all. So the modes might simply be switched somehow. Is there any possibility to configure it in a way so that it is set to the internal mic by default.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.18.0-8.9

---------------
linux (3.18.0-8.9) vivid; urgency=low

  [ Leann Ogasawara ]

  * Release Tracking Bug
    - LP: #1407692
  * rebase to v3.18.1
  * ubuntu: AUFS -- Resolve build failure union has no member named
    'd_child'

  [ Upstream Kernel Changes ]

  * arm64: optimized copy_to_user and copy_from_user assembly code
    - LP: #1400349
  * x86, kvm: Clear paravirt_enabled on KVM guests for espfix32's benefit
    - LP: #1400314
    - CVE-2014-8134
  * rebase to v3.18.1
 -- Leann Ogasawara <email address hidden> Mon, 05 Jan 2015 09:12:32 -0800

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
aerobat (austrianized) wrote :

Problem still exists in trusty with mainline kernel 3.18.1-031801-generic.

aerobat (austrianized) on 2015-01-13
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
aerobat (austrianized) wrote :

performed a fresh install of ubuntu 15.04, still not working.

tags: added: vivid
removed: kernel-bug-exists-upstream-3.15-rc2
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Undecided → Medium
hajtipajti (hajtipajti) wrote :

Hello,

I have a Samsung 740U (from Series 7) and in the internal mic there is a constant noise.

hajtipajti (hajtipajti) wrote :

And I have Ubuntu 15.04

annunaki2k2 (russell-knighton) wrote :

Has anyone managed to come up with a solution yet?

weesnich (weesnich) wrote :

For me neither the internal nor a plugged in microphone work (besides USB ones). When I plug in a headset it activates my internal microphone but in horrible quality so that you can mainly only hear the fan rotating. But this seems to be an issue with pulseaudio as the plugged in microphone works well when I check alsamixer. anybody knows a fix?

cgampert (cgampert) wrote :

Referring to comment #24, using hda-analyzer, I could see that:
- Converter audio stream is set to 1 on node 0x11 when the Mic jack is unplugged
- Converter audio stream is set to 1 on node 0x08 when the Mic jack is plugged in

Having the mic jack plugged-in, it seems to reduce noise but it's still the internal mic which capture sound.

Referring to comment #25, using hda-analyser, I tried to mute right channel of node 0x11 but I couldn't see any difference...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers