pulseaudio segfaults when switching streams

Bug #207796 reported by rexy on 2008-03-27
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
PulseAudio
New
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

pulseaudio reliably segfaults on my machine (hardy)

procedure to recreate
start a pulseaudio server with the default configuration

define a bluetooth device in .asoundrc
pcm.headset_hw {
   type bluetooth
   device 00:00:00:00:00:00
   profile "hifi"
}

ctl.headset {
    type bluetooth
    device 00:00:00:00:00:00
}

pcm.headset {
    type plug
    slave.pcm "headset_hw"
}

pactl load-module module-alsa-sink device=headset
start pavucontrol to set the headset as the default output
start mplayer -ao pulse
go back to pavucontrol and swap the stream to the default hw,0 soundcard
it will give an error because it looses connection and dmesg will show a segfault

history of dmesg, i tried multiple times

[ 1695.056366] pulseaudio[14219]: segfault at b6fb536a eip b6fb536a esp b67b1320 error 4
[ 2087.979040] pulseaudio[15098]: segfault at b6f9336a eip b6f9336a esp b678f320 error 4
[ 2089.971514] pulseaudio[15111]: segfault at b6fc836a eip b6fc836a esp b67c4320 error 4
[ 2441.726862] pulseaudio[16020]: segfault at b7ae536a eip b7ae536a esp b4ffd320 error 4
[ 2545.608121] pulseaudio[16360]: segfault at b7a1e36a eip b7a1e36a esp b553e320 error 4

package Installed: 0.9.9-1ubuntu2
up to date hardy install.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 27 16:38:13 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: pulseaudio 0.9.9-1ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/User Name/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
SourcePackage: pulseaudio
Uname: Linux 2.6.24-8-generic i686

Luke Yelavich (themuso) wrote :

WHile I don't have a bluetooth heaqdset, I do have a USB soundcard, and cannot confirm this bug. I wonder whether it has something to do with the bluetooth stack, or the alsa bluetooth driver.

Ca anybody else reproduce this?

I have not yet been able to generate backtraces of the problem since i havent had time, however the problem does seem to be related to bluetooth. For instance switching the stream from the internal card to bluetooth works fine, switching back makes it crash. If i do not load a bluetooth device the pulseaudio server is much more stable.

Martin Soto (soto255) wrote :

I'm seeing the same problem under Hardy, and tried to make a backtrace but some of the symbols are missing and I have no clue of which package to install to fix them. I'm attaching the current backtrace anyway just in case someone can tell me how to improve it.

By the way, I had to run gdb as root and attach to the pulseaudio process running under my user, because gdb fails if I try to run it directly on pulseaudio:

(gdb) run
Starting program: /usr/bin/pulseaudio
[Thread debugging using libthread_db enabled]
[New process 10539]
Executing new program: /proc/10539/exe
/proc/10539/exe: Permission denied.

Whoopie (whoopie79) wrote :

Hi,

I can reproduce it: " pulseaudio[11073]: segfault at 9 ip b6791648 sp b5aad280 error 4 in libasound_module_pcm_bluetooth.so[b678e000+9000]"
I try to get a backtrace the next days.

Whoopie (whoopie79) wrote :

@Martin Soto: You have to follow https://wiki.ubuntu.com/DebuggingProgramCrash to get the a full backtrace.

Whoopie (whoopie79) wrote :

Hi, attached the backtrace. This happens if the BT headset is off and I run "pactl load-module module-alsa-sink device=headset" and then "pactl load-module module-alsa-source device=headset".

scheich (philipp-mangelow) wrote :

Same problem with bt headset

dmesg:

[ 136.279830] pulseaudio[5965]: segfault at b6765278 eip b784fbf4 esp b66262d0 error 4

Brian Rogers (brian-rogers) wrote :

I can confirm this with the same scenario.

Changed in pulseaudio:
status: New → Confirmed
Alexia Death (alexiade) wrote :

Problem is still there with Jaunty...
Segfaults from my various experiments from trying to use my bt headset.

[ 312.316262] CE: hpet increasing min_delta_ns to 15000 nsec
[ 353.879041] pulseaudio[7024]: segfault at b1dd3258 ip b2eb7d84 sp b143a1f0 error 4 in libasound.so.2.0.0[b2e29000+c3000]
[ 751.204221] CE: hpet increasing min_delta_ns to 22500 nsec
[ 809.796087] CE: hpet increasing min_delta_ns to 33750 nsec
[ 859.195384] CE: hpet increasing min_delta_ns to 50624 nsec
[ 878.572121] pulseaudio[7833]: segfault at 32 ip 00000032 sp b1e321ec error 4 in pulseaudio[8048000+10000]
[ 1103.757545] pulseaudio[8015]: segfault at b2e42258 ip b36d2d84 sp addbc1f0 error 4 in libasound.so.2.0.0[b3644000+c3000]
[ 1490.997789] pulseaudio[8319]: segfault at 8373000 ip b7bcd866 sp b16e5118 error 4<6>pulseaudio[8017]: segfault at fff30032 ip b8029d01 sp bffec2d0 error 4 in libpulsecore.so.8.0.0[b8019000+8b000]
[ 1490.998202] in libc-2.9.so[b7b54000+15c000]
[ 1567.123186] pulseaudio[8517]: segfault at b378b258 ip b372cd84 sp b1cfd1f0 error 4 in libasound.so.2.0.0[b369e000+c3000]
[ 1605.499190] pulseaudio[8527]: segfault at 0 ip 00000000 sp b1e431fc error 4 in pulseaudio[8048000+10000]
[ 1704.201716] pulseaudio[8607]: segfault at b1ccc1f8 ip b36b4d84 sp b1c9f200 error 4 in libasound.so.2.0.0[b3626000+c3000]

vnieto (vnieto) wrote :

for amarok, show this :

amarok: pcm_pulse.c:312: pulse_delay: Afirmación `pcm->stream' fallida.
KCrash: Application 'amarok' crashing...
sock_file=/home/vnieto/.kde/socket-vnieto-laptop/kdeinit4__0
QSocketNotifier: Invalid socket 9 and type 'Read', disabling...
QSocketNotifier: Invalid socket 18 and type 'Read', disabling...
QSocketNotifier: Invalid socket 57 and type 'Read', disabling...
QSocketNotifier: Invalid socket 59 and type 'Read', disabling...
QSocketNotifier: Invalid socket 61 and type 'Read', disabling...
amarok: Fatal IO error: client killed
kdeinit4: preparing to launch /usr/lib/kde4/libexec/drkonqi

vnieto (vnieto) wrote :

for the up to day pulseaudio package on jaunty make this error:
 snd_pcm_avail_update() returned a value that is exceptionally large: 13835058055039827028 bytes (418292142619 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.

bloody (bloodynuker) wrote :

Dec 2 13:25:39 XXXX kernel: [ 5936.938713] pulseaudio[1943]: segfault at 7 ip 004ec583 sp bfca4f6c error 6 in libc-2.10.1.so[47f000+13e000]

Dec 2 13:25:42 XXXX pulseaudio[4925]: pid.c: Stale PID file, overwriting.

Dec 2 13:26:59 XXXX kernel: [ 6017.015104] pulseaudio[4925]: segfault at 7 ip 009c2583 sp bf976b5c error 6 in libc-2.10.1.so[955000+13e000]

Dec 2 13:27:03 XXXX pulseaudio[5028]: pid.c: Stale PID file, overwriting.

by rhythmbox shows sometimes this error. the same error appears while i'm playing game on my ubuntu 9.10 distro.

does exist a fix to this bug?

@bloody
Your symptom is resolved as of 9.04

On Dec 2, 2009 7:41 AM, "bloody" <email address hidden> wrote:

Dec 2 13:25:39 XXXX kernel: [ 5936.938713] pulseaudio[1943]: segfault
at 7 ip 004ec583 sp bfca4f6c error 6 in libc-2.10.1.so[47f000+13e000]

Dec 2 13:25:42 XXXX pulseaudio[4925]: pid.c: Stale PID file,
overwriting.

Dec 2 13:26:59 XXXX kernel: [ 6017.015104] pulseaudio[4925]: segfault
at 7 ip 009c2583 sp bf976b5c error 6 in libc-2.10.1.so[955000+13e000]

Dec 2 13:27:03 XXXX pulseaudio[5028]: pid.c: Stale PID file,
overwriting.

by rhythmbox shows sometimes this error. the same error appears while
i'm playing game on my ubuntu 9.10 distro.

does exist a fix to this bug?

** Also affects: pulseaudio
  Importance: Undecided
      Status: New

-- pulseaudio segfaults when switching streams
https://bugs.launchpad.net/bugs/207796 You received...
Status in PulseAudio sound server: New
Status in “pulseaudio” package in Ubuntu: Confirmed

Bug description:
Binary package hint: pulseaudio

pulseaudio reliably segfaults on my machine (hardy)

procedure to recreate
start a pulseaudio server with the default configuration

define a bluetooth device in .asoundrc
pcm.headset_hw {
  type bluetooth
  device 00:00:00:00:00:00
  profile "hifi"
}

ctl.headset {
   type bluetooth
   device 00:00:00:00:00:00
}

pcm.headset {
   type plug
   slave.pcm "headset_hw"
}

pactl load-module module-alsa-sink device=headset
start pavucontrol to set the headset as the default output
start mplayer -ao pulse
go back to pavucontrol and swap the stream to the default hw,0 soundcard
it will give an error because it looses connection and dmesg will show a
segfault

history of dmesg, i tried multiple times

[ 1695.056366] pulseaudio[14219]: segfault at b6fb536a eip b6fb536a esp
b67b1320 error 4
[ 2087.979040] pulseaudio[15098]: segfault at b6f9336a eip b6f9336a esp
b678f320 error 4
[ 2089.971514] pulseaudio[15111]: segfault at b6fc836a eip b6fc836a esp
b67c4320 error 4
[ 2441.726862] pulseaudio[16020]: segfault at b7ae536a eip b7ae536a esp
b4ffd320 error 4
[ 2545.608121] pulseaudio[16360]: segfault at b7a1e36a eip b7a1e36a esp
b553e320 error 4

package Installed: 0.9.9-1ubuntu2
up to date hardy install.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 27 16:38:13 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: pulseaudio 0.9.9-1ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/User
Name/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
SourcePackage: pulseaudio
Uname: Linux 2.6.24-8-generic i686

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers